NetBeans IDE para o Editor do PHP: Breve Visão Geral

Este documento é uma breve visão geral das principais funcionalidades do NetBeans IDE para o Editor do PHP.

Conteúdo

O conteúdo desta página se aplica ao NetBeans IDE 7.2

Para seguir este tutorial, são necessários os recursos e o software a seguir.

Software ou Recurso Versão Necessária
NetBeans IDE Pacote de download do PHP
Um mecanismo PHP Versão 5
Um servidor web É recomendado o Apache HTTP Server 2.2.
Um depurador PHP XDebug 2.0 ou superior

Preparando-se

Para desenvolver e fazer implantação de aplicações PHP no NetBeans IDE para PHP com êxito, você precisa ter todos os softwares necessários instalados e configurados para desenvolvimento de PHP.

Layout do NetBeans IDE para o Editor do PHP

O editor contém as seguintes janelas:

  • A janela Editor mostra o arquivo que você está editando. O Editor tem uma guia para cada arquivo aberto.
  • A janela Projetos mostra uma lista dos projetos existentes no momento
  • A janela Arquivos mostra os arquivos de cada projeto
  • A janela Serviços mostra listas de serviços externos disponíveis no momento, como bancos de dados.

Você também pode abrir uma janela Navegador no painel esquerdo pressionando Ctrl + 7. O Navegador mostra a estrutura de uma classe PHP se ela estiver aberta no Editor. Os arquivos que não são de classe PHP não são mostrados na janela Navegador.

Para abrir a ajuda para uma dessas janelas, selecione qualquer elemento na janela e pressione F1.

Realce de Sintaxe

O editor fornece realce de sintaxe para blocos de código PHP, HTML, JavaScript e CSS.

Os seguintes elementos de sintaxe são realçados na versão atual:

  • Palavras-chave e variáveis PHP
    Palavras-chave PHP realçadas
  • Constantes e "constantes mágicas"
    constante mágica
  • Tags HTML, incluindo entrada de atributos
    Realce de HTML no arquivo PHP
  • Servidor web Apache .htaccess ou arquivos httpd.conf
    Conteúdo do arquivo httpd.conf realçado
  • Números PHP
  • Tags HTML nos blocos de comentários PHPDoc
    Números PHP realçados e tags HTML no bloco PHPDoc
  • A linha atual é exibida com um segundo plano azul claro.
    Linha atual com realce azul
  • Quando você colocar o cursor dentro de uma variável PHP, uma função ou uma classe, todas as ocorrências da variável serão realçadas. Variável selecionada
  • As linhas onde foram detectados erros são sublinhadas em vermelho.
    Erro realçado

Para alterar as definições de realce, selecione Ferramentas > Opções e alterne para a guia Fontes e Cores. Especifique as definições que desejar.

Ir Para Declaração

Com a função Ir Para Declaração, o usuário navega de uma ocorrência de uma variável ou função para a linha em que a variável ou função é declarada ou inicializada. Para usar essa funcionalidade, posicione o cursor na ocorrência de variável ou função relevante e selecione Navegar > Ir para Declaração no menu de contexto, pressione Ctrl-B/⌘-B ou use Ctrl-clique.

Janela Navegador

A janela Navegador exibe as estruturas do código como elementos de uma lista que mostra as estruturas PHP do arquivo ativo no momento. Se o arquivo contiver quaisquer outras fontes de texto (por exemplo, HTML), a lista também exibirá suas estruturas. Quando você clica duas vezes em uma função ou variável na lista, o cursor aponta para a declaração do elemento clicado.

Cuidado: a janela Navegador mostra somente o código PHP para as classes PHP. Ela não pode mostrar código PHP fora de uma classe.

A lista Navegador normalmente não contém nenhuma lista incorporada, mas para instruções complexas ela pode conter estruturas incorporadas. Por exemplo, uma instrução de declaração de classe PHP pode ser apresentada como uma árvore de membros de classe declarada.

A lista é atualizada dinamicamente enquanto o usuário digita o código.

A janela Navegador é mostrada na parte inferior do painel esquerdo.

  1. Para abrir a janela Navegador, pressione Ctrl + 7 ou vá para Janela > Navegando > Navegador. A árvore que exibe a hierarquia das estruturas HTML e PHP será exibida.
  2. Para mover para o elemento desejado, clique duas vezes no nó relevante na lista.
    Usando a janela Navegador para selecionar função

Dobramento de Código

O editor permite que o usuário oculte e exiba de forma seletiva módulos, classes ou funções do arquivo editado atualmente com o código-fonte PHP. Para recolher ou exibir uma parte de código, clique no ícone - ou + à esquerda do código ou pressione Ctrl+ ou Ctrl-.

Dobramento de código a partir do NB 7.2

Recuo Inteligente

O editor formata automaticamente o código enquanto o usuário está digitando.

Formatando

Para formatar uma parte de código para que fique mais compreensível, realize as seguintes etapas:

  1. Selecione a passagem de código relevante.
  2. No menu de contexto exibido ao clicar com o botão direito do mouse, selecione Formatar ou pressione Alt + Shift + F

Fechamento de Colchetes

O editor adiciona e remove automaticamente aspas e colchetes correspondentes enquanto o usuário digita o código.

  • Pares de aspas simples ' ' e aspas duplas "" "", parênteses () e colchetes [] são adicionados quando o usuário tiver digitado o primeiro símbolo.
  • No final de uma linha, é adicionado um ponto e vírgula, além das aspas simples ou duplas de fechamento.
  • A chave de fechamento é adicionada depois que o usuário pressiona Enter, o que também ativa a função Recuo Inteligente.
  • A deleção das aspas simples ou duplas, do parêntese ou do colchete de abertura causa a remoção automática do símbolo de fechamento correspondente, mas não afeta o ponto e vírgula de fim de linha.
  • Quando o cursor aponta para um parêntese de encerramento ), uma chave de encerramento } ou um colchete de encerramento ], o símbolo de abertura correspondente é realçado em amarelo.
    Realce de colchete

Refatoração de Renomeação e Renomeação Instantânea

Você pode renomear um elemento, como um nome de classe, em todos os arquivos de um projeto. A funcionalidade força você a exibir suas alterações antes de poder fazê-las. A janela de visualização mostra cada localização do elemento e permite deletar ocorrências individuais do elemento sendo renomeado.

A Refatoração de Renomeação é comparada com a funcionalidade mais antiga, Renomeação Instantânea. A Renomeação Instantânea ainda está disponível, mas só funciona em contextos "não públicos", como renomear uma variável dentro de um método ou renomear variáveis e pastas privadas. A Renomeação Instantânea permite apenas renomear um elemento dentro de um arquivo e não fornece uma janela de visualização.

Para utilizar Renomeação Instantânea, coloque o cursor em um nome que deseja alterar e pressione Ctrl-R. Se Renomeação Instantânea for aplicada a essa variável, todas as instâncias da variável ou nome da função serão realçadas.

Editor de código PHP depois que Ctrl-R é pressionado

Altere uma instância do nome e todas as outras instâncias do arquivo serão alteradas simultaneamente

Editor de código PHP que mostra um nome de variável refatorado

Para usar Refatoração de Renomeação, selecione o elemento que deseja renomear e pressione Ctrl+R, ou clique com o botão direito do mouse e selecione Refatorar > Renomear. Uma caixa de diálogo será aberta para que você renomeie o elemento.

Caixa de diálogo para renomeação de uma variável

Renomeie o elemento e pressione Visualizar. A janela Refatoração será aberta. Nessa janela, você pode encontrar cada instância do elemento em seu projeto e pode decidir renomeá-lo ou não.

Janela Refatoração

Para obter mais informações sobre Refatoração de Renomeação, consulte o screencast Renomear Refatoração e Outros Aprimoramentos do Editor no NetBeans IDE 7.0 para PHP.

Autocompletar Código

Autocompletar código é um nome comum para um conjunto de funcionalidades que aceleram o processo de codificação.

Os seguintes tipos de funcionalidade autocompletar código estão disponíveis:

Snippets

Os snippets permitem que o usuário gere código para vários elementos automaticamente.

  1. Selecione Ferramentas > Paleta > Fragmentos de Código. Uma paleta que contém vários elementos de interface do usuário será exibida no painel direito.
  2. Arraste o ícone necessário na paleta para a posição relevante no código. Uma caixa de diálogo para especificar os parâmetros dos elementos correspondentes será exibida. Preencha os dados.
  3. O código que exibe o elemento escolhido será gerado e inserido no local escolhido.

Propostas Contextuais

O editor fornece propostas contextuais para completar qualquer número de símbolos iniciais de:

  • Uma palavra-chave de PHP (por exemplo, if, else, elseif, while, switch, function e assim por diante)
  • Uma função incorporada de PHP (por exemplo, substr, count, e assim por diante)
  • Uma variável predefinida ou definida pelo usuário

O editor não só sugere expansões, mas também fornece dicas de parâmetros. Para aplicar Autocompletar Código:

  1. Digite os símbolos iniciais da string de caracteres necessária.
  2. Pressione CTRL + Espaço. Uma lista drop-down mostra as propostas contextuais. Cada proposta é fornecida com uma descrição e dicas de parâmetros. O conteúdo da lista é alterado à medida que você continua digitando.
    Autocompletar código da função
  3. Para obter uma lista das palavras-chave de PHP disponíveis no contexto atual, pressione CTRL + Espaço sem nenhuma digitação anterior.
  4. Para obter uma dica sobre uma variável, basta digitar o símbolo "$". Uma lista de todas as variáveis locais e globais disponíveis atualmente será exibida.
    Autocompletar código de variável

Modelos e Abreviações de Código

No contexto atual, o termo "abreviações" refere-se a um conjunto de strings de caracteres predefinidas que correspondem às palavras-chave utilizadas em uma linguagem de programação. Cada abreviação está associada a um texto expandido que contém a palavra-chave completa e um modelo de código para a palavra-chave com dicas de parâmetros. Para aplicar essa funcionalidade, digite uma abreviação e pressione Tab.

Abreviação do modelo

A abreviação será substituída pela palavra-chave correspondente e o modelo de código da palavra-chave será fornecido.

Modelo cls expandido

No modelo de código, se o cursor estiver em uma caixa azul com borda violeta, ele estará em um campo no modelo. Digite o nome ou valor do campo. Todas as instâncias do campo também têm o valor alterado. Pressione Enter quando tiver finalizado e o cursor irá para o próximo campo (ou para aposição da variável ${cursor} ou fora do modelo, se não houver nenhum campo remanescente).

Modelo com segundo campo selecionado

Para exibir a lista de abreviações definidas com modelos de código:

  1. Selecione Ferramentas > Opções > Editor > Modelos de Código.
  2. Na lista drop-down Linguagem, selecione PHP. A lista de abreviações PHP e o modelo de código definido para elas serão exibidos.
  3. Para adicionar ou remover uma definição da lista, utilize os botões Novo ou Remover respectivamente.
  4. Para editar uma definição, selecione a linha relevante e edite o texto no campo de edição abaixo da lista.
    A lista de abreviações e os modelos de código definidos para elas

Para obter mais informações, consulte Modelos de Código no NetBeans IDE para PHP.

Autocompletar Código para Construtores

Depois da palavra-chave new, a janela de autocompletar código será exibida com construtores e parâmetros de todas as classes disponíveis no projeto.

Dicas da funcionalidade autocompletar código para um construtor

Autocompletar Código SQL

A funcionalidade autocompletar código SQL será exibida quando uma string começar com a palavra-chave do SQL "select". O primeiro passo é selecionar a conexão com banco de dados.

Funcionalidade autocompletar código que oferece conexão com banco de dados

Serão exibidas todas as conexões com banco de dados registradas no IDE.

Todas as conexões com banco de dados registradas no IDE.

Após selecionar a conexão, a funcionalidade autocompletar código SQL oferece todas as tabelas dessa conexão com o banco de dados.

Todas as tabelas na conexão com o banco de dados wishlist

Se a tabela tiver colunas, essas colunas também serão exibidas.

Colunas da tabela exibidas

A funcionalidade autocompletar código SQL também funciona com apelidos de tabela.

Funcionalidade autocompletar código que mostra tabelas em apelido de hotel

Namespaces do PHP 5.3

A funcionalidade autocompletar código oferece suporte a nomes de namespace completamente qualificados, parcialmente qualificados e não qualificados do PHP 5.3. Para obter mais informações, consulte nosso screencast.

O IDE também ajuda a resolver instruções de uso de namespace ausentes. Em um namespace em que você deseja corrigir instruções use, clique com o botão direito do mouse e selecione Usos para Correção... ou pressione Ctrl-Shift-I e vá para Código-Fonte > Usos para Correção... Uma caixa de diálogo será aberta oferecendo nomes completamente qualificados para cada instrução de uso necessária. Para obter mais informações, consulte Como Corrigir Suas Instruções de Uso.

Métodos Substituídos e Implementados

A funcionalidade autocompletar código entre membros de classe oferece a opção de substituir ou implementar métodos.

Funcionalidade autocompletar código que oferece a opção de substituir método

Autocompletar Código Inteligente Tentativa/Captura

A partir do NetBeans IDE 7.1, a função autocompletar código para instruções captura inclui somente as classes herdadas de Exceção.

Editor que mostra a funcionalidade autocompletar código em parâmetros de captura

Anotações

A funcionalidade autocompletar código do NetBeans IDE oferece suporte aos seguintes tipos de anotações PHP:

  • ApiGen (anotações PHPDoc legadas)
  • PHPUnit
  • Doctrine 2 (ORM e ODM)
  • Symfony 2

Toda anotação pode ser associada a um contexto. O NetBeans IDE reconhece quatro contextos:

  • função
  • classe/interface (tipo)
  • método
  • campo

Você pode adicionar mais anotações à funcionalidade autocompletar código em Ferramentas > Opções > PHP > Anotações.

Tratos do PHP 5.4

Os tratos são um mecanismo de reutilização de código introduzido no PHP 5.4.0. (Para obter informações sobre os tratos, consulte a documentação do php.net.) O NetBeans IDE reconhece a sintaxe dos tratos e a funcionalidade autocompletar código inclui métodos, funções e tudo o mais herdado de um trato ou declarado dele.

Funcionalidade autocompletar código do trato

Suporte a PHP 5.4

Editor do NetBeans para PHP oferece várias funcionalidades específicas para desenvolvimento com PHP 5.4.

Seleção Retangular

O NetBeans IDE 7.1 para PHP introduz a ação Seleção Retangular. Essa função de edição é útil em casos como a deleção de números de linhas em código colado.

Para ativar a seleção retangular, pressione o botão Seleção Retangular ou Ctrl+Shift+R para alternar.

Editor que mostra o botão Seleção Retangular.

Quando a Seleção Retangular está ativada, você pode fazer a seleção com o mouse ou com o teclado. Quando você usar o teclado, coloque o cursos em um canto, mantenha a tecla SHIFT pressionada e selecione o que precisa com as teclas de seta.

Editor que mostra uma seleção regular de números de linha colados

Se você escrever um texto enquanto a área estiver selecionada, o texto será colocado em todas as linhas da área selecionada. Isso pode ser útil, por exemplo, para alterar, simultaneamente, os modificadores de acesso de vários campos de uma classe.

Editor com um modificador de acesso adicionado a todas as linhas de uma seleção retangular

Suporte a ApiGen

Suporte incorporado para ApiGen foi adicionado no NetBeans IDE 7.2. Para obter mais informações, consulte o screencast Gerando Documentação PHP Com NetBeans IDE.

Advertência: o PHPDocumentor não oferece suporte completo ao PHP 5.3. Namespaces e algumas outras funcionalidades do 5.3 não são documentadas pelo PHP Documentor.

Geradores de Código

Quando você pressiona a combinação Alt-Insert (Ctrl-I no Mac), um menu é aberto com todos os possíveis geradores de código. A lista de geradores é contextual. Isso depende da posição do cursor no código quando a combinação de teclas é pressionada. Dependendo da sua posição no código, você poderá gerar uma conexão com o banco de dados, tabelas de banco de dados, texto lorum ipsum e vários outros. Esta seção descreve apenas os geradores de código a seguir:

Construtores

Você pode gerar construtores ao pressionar Alt-Insert (Ctrl-I no Mac) quando o cursor estiver dentro de um corpo de classe, mas não dentro de nenhuma função contida nesse corpo. Quando você selecionar Gerar...Construtor, uma caixa de diálogo será aberta, listando os campos que podem ser inicializados pelo construtor. Os nomes de campo são utilizados como parâmetros do construtor.

Caixa de diálogo de campos a serem inicializados com o construtor

Você pode não selecionar nenhum campo. Nesse caso, o IDE gera um construtor vazio, sem parâmetros. Se o campo for uma classe com propriedades, você poderá selecionar propriedades individuais ou a classe, onde todas as propriedades de classe estão selecionadas automaticamente.

Para obter mais informações, consulte o post no blog NetBeans PHP.

Getters e Setters

Você pode gerar getters e setters pressionando Alt-Insert (Ctrl-I no Mac) quando o cursor estiver dentro de um corpo de classe e selecionar Getter, Setter ou Getters e Setters. Apenas as funções possíveis são exibidas. Por exemplo, se já tiver setters para as propriedades disponíveis, apenas a opção getter aparecerá.

Quando você selecionar Gerar... Getter/Setter/Getter e Setter, uma caixa de diálogo aparecerá com as propriedades para as quais você pode gerar um getter ou setter. As propriedades serão exibidas em uma árvore. Se você selecionar uma classe pai, serão selecionadas automaticamente todas as propriedades da classe.

Você pode nomear um getter ou setter de acordo com a convenção getName ou a convenção get_name.

Para obter mais informações, consulte o post no blog NetBeans PHP original e o post em geração de getter e setter aprimorada.

Métodos Substituídos e Implementados

Você pode gerar métodos substituídos ou implementados pressionando Alt-Insert (Ctrl-I no Mac) quando o cursor estiver dentro de uma declaração de classe e existirem vários membros de classe. Uma caixa de diálogo será aberta, mostrando os métodos que podem ser inseridos e indicando se eles estão substituídos ou implementados.

Caixa de diálogo para geração de métodos substituídos

Essa funcionalidade complementa a dica "Implemente todos os métodos abstratos" e a funcionalidade autocompletar código para métodos substituídos e implementados.

Para obter mais informações, consulte o post no blog NetBeans PHP.

Dicas de Parâmetros

O editor solicita ao usuário os parâmetros formais de uma função ou um método no contexto em que a função ou o método é chamado.

  1. Digite os caracteres iniciais da função que deseja chamar.
  2. Pressione CTRL + Espaço. Uma lista drop-down mostra as propostas contextuais com os parâmetros formais de cada proposta.
    Lista de dicas contextuais
  3. selecione a proposta relevante e pressione Enter. O nome da função selecionada será inserido no código e um modelo para inserir os parâmetros será mostrado entre colchetes.
    Dicas de parâmetros para a proposta contextual selecionada.

Definindo o Tipo de Variável em Comentários

Você pode definir uma variável e o seu tipo em um comentário. O comentário deve estar no formato /* @var $variable type */ . Se o comentário estiver escrito corretamente, a tag var estará em negrito.

Variáveis declaradas em comentários

Você pode utilizar o modelo de código vdoc, seguido de Tab, para gerar um comentário que define uma variável. O nome da variável será selecionado e poderá ser alterado. Pressione Tab novamente e o tipo será selecionado.

Variável que declara comentário gerado pelo modelo vdoc

O modelo de código define o nome e o tipo da variável automaticamente. Se a variável for utilizada após o lugar em que você inseriu o modelo, o nome seguinte dessa variável será sugerido por default. Se nenhuma variável for utilizada após o lugar em que você inseriu o modelo, mas uma variável for utilizada acima do modelo, o nome dessa variável será sugerido por default. Se o NetBeans IDE não puder localizar nenhuma variável perto de onde você utilizar o modelo, o nome default será variável.   O tipo de variável é definido automaticamente, de acordo com as mesmas regras.

Variável que declara comentário gerado pelo modelo vdoc, com nomes e tipos de variáveis default

Mensagens de Erro

O editor analisa a sintaxe do código enquanto você digita e marca os erros de sintaxe sublinhando as linhas com erro e colocando um marcador vermelho ao lado delas. Para obter uma explicação do erro, passe o cursor do mouse sobre a linha com erro ou clique no marcador vermelho. Uma dica de ferramenta aparece com uma breve explicação do erro.
Mensagens de erro: uma dica de ferramenta acima da linha com erro.

Testes PHPUnit e Selenium

O NetBeans IDE para PHP suporta os testes automatizados PHPUnit, incluindo a cobertura de código. Você pode utilizar grupos de teste em seu código.

O NetBeans IDE também suporta o framework de teste portátil Selenium, em combinação com o PHPUnit. Um plug-in Selenium está disponível na Central de Atualização. A instalação deste plug-in adiciona um servidor Selenium aos servidores registrados do IDE e adiciona opções de teste Selenium aos menus PHP.

Consulte Testando com PHPUnit e Selenium para obter mais informações.

Corretor Ortográfico

Um corretor ortográfico está disponível. Na caixa de diálogo Opções, você pode alternar entre ativar e desativar o corretor ortográfico para diferentes idiomas.

Caixa de diálogo Opções do corretor ortográfico

Na caixa de diálogo Opções, você pode adicionar e remover novos dicionários e definir a configuração regional.   Quando desejar adicionar um novo dicionário, você terá que ter um arquivo com as palavras. O formato do arquivo do dicionário é uma lista de palavras com cada palavra em uma nova linha. Você terá que informar ao NetBeans a codificação do arquivo do dicionário e para qual configuração regional o arquivo deverá ser usado.

Adicionando um novo dicionário ao corretor ortográfico

Quando o corretor ortográfico encontra uma palavra que não está em seu dicionário, ele sublinha a palavra em vermelho. O corretor ortográfico também adiciona uma dica de ferramenta àquela palavra que diz "Erro de ortografia". Observe que o texto HTML está marcado nos arquivos PHP.

Foram encontrados erros no texto HTML no arquivo PHP

Suporte a Symfony, Symfony2 e Zend Framework

Suporte a Symfony, symfony2 e Zend Framework são incorporados no editor PHP. Ele reconhece Symfony e frameworks Zend existentes e é você pode adicionar o framework a novos projetos no último painel do assistente para novo projeto PHP.

Em um projeto PHP com suporte a Symfony, Symfony2 ou Zend, você pode executar os comandos do Symfony ou do Zend no menu de contexto do projeto.

Menu de contexto que mostra comandos do Symfony

Use a IU dos comandos para:

  • Filtrar os comandos do Symfony/Zend (1)
  • Especificar os parâmetros do comando (2)
  • Selecionar um comando (3)
  • Ver a ajuda contextual do comando (4)
  • Visualizar todo o comando que será executado (5)
Caixa de diálogo do comando do Symfony anotado

A lista de comandos é específica do projeto. Isso significa que, por exemplo, se for utilizado Doctrine em vez de Propel, nenhum comando do Propel será listado, apenas os comandos do Doctrine serão listados. Além disso, todos os comandos dos plug-ins Symfony do projeto estão disponíveis.

A funcionalidade autocompletar código inclui variáveis do Symfony em views do Symfony, variáveis do Symfony2 em views do Symfony2 e variáveis do Zend em views do Zend.

Variáveis do Symfony na funcionalidade autocompletar código

O IDE também oferece atalhos de navegação entre views e ações do Symfony ou do Zend. Esses atalhos foram melhorados no NetBeans 6.9. Além disso, a funcionalidade autocompletar código em exibir modelos/arquivos agora inclui variáveis que estão declaradas em arquivos do controlador/ação. Consulte o post no blog do NetBeans PHP para obter detalhes.

Para saber mais sobre o suporte a Zend framework, assista ao screencast do Zend.

Suporte ao Smarty

O NetBeans IDE inclui um plug-in para o suporte ao framework Smarty. Esse suporte inclui as funcionalidades básicas do Smarty 3, ou seja, funcionalidade autocompletar código e delimitadores do Smarty 3.

Editores que mostra suporte básico ao Smarty 3

Alterne entre o comportamento de Smarty 3 e Smarty 2 na janela Opções. Vá para Ferramentas > Opções (Preferências do NetBeans no MacOS), selecione PHP e, em seguida, abra a guia Smarty. O plug-in do framework Smarty precisa estar instalado.

Opções do Smarty

Suporte a Doctrine2

Se tiver o Doctrine2 ORM e seus pacotes de requisito instalados, você poderá usar a funcionalidade autocompletar código do IDE com funções do Doctrine2 e poderá executar comandos do Doctrine2 a partir do IDE. Você precisa definir o caminho para o script de execução do Doctrine 2 nas Opções do IDE e o seu projeto PHP terá que ter o Doctrine2 ativado. Consulte Suprote ao Doctrine2 Adicionado no blog NetBeans PHP para obter detalhes.

Enviar Feedback neste Tutorial


Para enviar comentários e sugestões, obter suporte e manter-se informado sobre os desenvolvimentos mais recentes das funcionalidades de desenvolvimento PHP do NetBeans IDE, junte-se à lista de correspondência .

Voltar à Trilha do Aprendizado PHP

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2018, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo