将 Eclipse 项目导入 NetBeans IDE

目录

此页上的内容适用于 NetBeans IDE 6.9、7.0、7.1、7.2、7.3 和 7.4

要学完本教程,您需要具备以下软件和资源。

软件或资源 要求的版本
NetBeans IDE 版本 6.9、7.0、7.1、7.2、7.3 或 7.4
Java 开发工具包 (JDK) 版本 6 或 7

导入 Eclipse 项目向导

在 NetBeans IDE 中,增强了对导入 Eclipse 项目的支持。导入 Eclipse 项目向导可帮助您使用 NetBeans 处理在 Eclipse 和 MyEclipse 中创建的 Java 桌面和 Web 应用程序项目。

从 Eclipse 项目创建 NetBeans 项目之后,您可以采用以下工作方式:

  • 使用 NetBeans 操作团队项目,而其他开发人员使用的是 Eclipse。
  • 交互使用 NetBeans 和 Eclipse 操作项目。
  • 使用 NetBeans 操作在 Eclipse 中建立的现有项目。

返回页首

导入向导的运行原理

当导入项目时,IDE 会分析 Eclipse 项目元数据,然后根据这些元数据来创建 NetBeans 项目。项目导入不会对 Eclipse 项目结构进行更改,因此它不会干扰项目在 Eclipse 中的运行方式。

导入项目之后,您可以使用 NetBeans 或 Eclipse IDE 来编辑、构建、运行、调试和分析项目。如果您对 Eclipse 项目的配置进行了更改,那么可以重新同步 NetBeans 项目。这允许您在其他团队成员使用 Eclipse 的情况下使用 NetBeans 来操作项目。您在 Eclipse 中设置的构建路径仍然是项目的主构建路径。

返回页首

导入和配置项目

将 Eclipse 项目导入 IDE:

  1. 确保您希望导入到系统中的项目有自己的副本。

    通常,该项目应该已经在您系统上的某个 Eclipse 工作区中。

  2. 选择 "File"(文件)> "Import Project"(导入项目)> "Eclipse Project"(Eclipse 项目)。
  3. 在向导的 "Workspace Location"(工作区位置)页上,选择 "Import Projects from Workspace"(从工作区导入项目)单选按钮,然后指定工作区位置。单击 "Next"(下一步)。

    "Import Eclipse Project"(导入 Eclipse 项目)向导的 "Workspace Location"(工作区位置)页

  4. 在 "Projects to Import"(要导入的多个项目)页面中,选择您希望导入的项目。
  5. 选择用于存储 NetBeans 项目文件的以下两个选项之一:
    • Store NetBeans project data inside Eclipse project folders(在 Eclipse 项目文件夹内存储 NetBeans 项目数据)。NetBeans 在原始项目的顶级文件夹中添加文件夹和文件。
    • Create imported NetBeans projects in a separate location(在单独位置创建导入的 NetBeans 项目)。NetBeans 使用原始 Eclipse 项目文件夹中的源和库,但会创建单独的文件夹用于保存 NetBeans 项目元数据和构建输出。

    注:通常,在 Eclipse 项目文件夹中存储 NetBeans 项目数据是更好的选择。在大多数情况下,这意味着 NetBeans 项目元数据将采用与 Eclipse 元数据相同的路径来引用源代码和库。因此,在不同的机器上从版本控制系统中检出项目应该在 NetBeans 和 Eclipse 中产生类似的行为。
    有关 NetBeans IDE 创建的文件和文件夹列表,请参见下面的 NetBeans 项目文件

  6. (仅当导入 Web 应用程序时才适用。)单击 "Next"(下一步)。在 "Servers "(服务器)页面中,注册 NetBeans IDE 项目需要的任何服务器。
  7. 单击 "Finish"(完成)。

完成向导之后,可能会出现以下对话框:

  • Import Issues(导入问题)。此对话框提供有关 Eclipse 与 NetBeans 中项目结构差异的信息,并指出更正这些差异可能需要采取的操作。
    您可以复制此对话框中的信息,并将它粘贴到别处供未来引用。
    在大多数情况下,您可以使用项目的 "Project Properties"(项目属性)对话框来解决这些问题。有关解决大多数常见问题的指南,请参见解决导入问题

    "Import Issues"(导入问题)对话框

  • Resolve Reference Problems(解决引用问题)。此对话框提醒您其中一个项目库中出现了特定引用问题。关闭此对话框后,您可以通过右键单击项目节点并选择 "Resolve Reference Problems"(解决引用问题)来解决此问题。
  • Resolve Missing Server(解决缺少服务器问题)。此对话框提醒您项目找不到必需的服务器。关闭此对话框后,您可以通过右键单击项目节点并选择 "Resolve Missing Server"(解决缺少服务器问题)来解决此问题。

完成向导并关闭上述任何信息对话框之后,各项目的节点将出来在 "Projects"(项目)窗口中。

导入项目后的 "Projects"(项目)窗口。

如果存在 NetBeans 无法解析的项目元数据到服务器或其他资源的引用,则项目节点将变为红色。您可以立即解析这些引用,方法是右键单击项目节点并选择 "Resolve Reference Problems"(解决引用问题)或 "Resolve Missing Server"(解决缺少服务器问题)。

对于其他类型的项目配置调整,您可以使用 "Project Properties"(项目属性)对话框。使用以下方法打开 "Project Properties"(项目属性)对话框:右键单击项目节点,然后选择 "Properties"(属性)。

有关配置项目的更多信息,请参见“创建、导入和配置 Java 项目”指南中的配置类路径和其他项目设置

返回页首

构建和运行项目

将项目导入到 NetBeans 中之后,您可以构建和运行项目。通过 NetBeans 构建和运行命令创建的所有工件都保存在 builddist 文件夹中。NetBeans 不会覆盖由 Eclipse 构建操作创建的输出。如果 Eclipse 项目已经有了 builddist 文件夹,则 NetBeans 项目将创建名称为 nbbuildnbdist 的文件夹,并使用它们保存构建输出。

下面列出了 "Run"(运行)菜单中可用的一些构建和运行命令:

  • Run Project(运行项目)。测试在 IDE 中运行应用程序。
  • Clean and Build Project(清理并构建项目)。删除 build(或 nbbuild)和 dist(或 nbdist)文件夹的内容并重新构建所有项目输出。使用 NetBeans 构建脚本。在 Eclipse 中的清理命令使用类似的方法。
  • Clean(清理)。删除 nbbuildnbdist 文件夹的内容。
  • Build(构建)。重新构建项目的输出。如果启用了 "Compile on Save"(在保存时编译)功能,则将禁用 "Build"(构建)命令。请参见“创建、导入和配置 Java 项目”指南的在保存时编译部分。

有关构建和运行应用程序以及定制构建流程的更多信息,请参见创建、导入和配置 Java 项目

返回页首

NetBeans 项目文件

导入项目之后,您将在您的系统中找到以下文件夹和文件:

  • build.xml 文件或 nb-build.xml 文件。项目的主 NetBeans 构建脚本。您可以根据项目的需要来定制脚本。默认情况下,该文件的名称为 build.xml。如果项目文件夹中已经存在这样的文件,则该脚本的名称为 nb-build.xml
  • nbproject 文件夹。包含大多数 NetBeans 项目元数据,包括由主 NetBeans 构建脚本调用的资源。如果您将此文件夹和 build.xml 文件或 nb-build.xml 检入到您的版本控制系统中,则其他用户将能够在 NetBeans 中打开项目。该文件夹还包含一个 private 文件夹,其中包含特定于您的系统的数据。不应将该文件夹检入到版本控制系统中,因为它的内容会因用户而异。请参见下面的版本控制注意事项
  • nbbuild 文件夹。在 NetBeans 中构建或运行项目时,项目的源代码将被编译到此文件夹中。
  • nbdist 文件夹。在 NetBeans 中构建项目时,将创建项目的可分发输出并保存在此文件夹中。其输出可以是 JAR 文件和 WAR 文件。

返回页首

版本控制注意事项

如果从版本控制系统中检出项目,则不应将 build(或 nbbuild)、dist(或 nbdist)和 nbproject/private 文件夹检入到该版本控制系统中。

如果项目位于 CVS、Subversion 或 Mercurial 版本控制系统中,则恰当的“忽略”文件将在导入项目时创建或更新。

尽管 nbproject/private 应被忽略,但应将 nbproject 检入版本控制系统。nbproject 中包含的元数据支持其他用户在 NetBeans 中打开项目,而不需要首先导入项目。

返回页首

重新同步项目

导入程序具备重新同步功能。如果 Eclipse 中的类路径在您最初导入它时已经变更,那么您可以使用“重新同步 Eclipse 项目”功能更新相应 NetBeans 项目的类路径。

项目重新同步是从 Eclipse 项目到 NetBeans 项目的单向操作。如果您对 NetBeans 中的项目结构进行更改,则这些更改将不会通过重新同步功能传播到 Eclipse 项目。如果您打算同时保存 Eclipse 和 NetBeans 项目,可以使用 Eclipse 项目作为“主”项目。

如果对 Eclipse 配置的更改非常明确且不需要您的输入,则 IDE 还将自动重新同步项目。这种自动重新同步操作发生在您打开项目之后。如果重新同步需要您的输出,那么您需要手动重新同步项目。

手动重新同步 NetBeans 项目与 Eclipse 项目:

  • 选择 "File"(文件)> "Import Project"(导入项目)> "Resynchronize Eclipse Projects"(重新同步 Eclipse 项目)。

注:当您重新同步项目时,将对从工作区中导入的所有项目执行重新同步。

返回页首

解决导入问题

将项目导入 NetBeans 中时,有些问题可能是 NetBeans IDE 无法自动解决的。针对其中一些问题,项目的上下文菜单中有对应的菜单项,例如 "Resolve Missing Server Problem"(解决缺少服务器问题)。其他问题可以在 NetBeans IDE 中已导入项目的 "Project Properties"(项目属性)对话框中解决。

下面是常见导入问题及其解决方案列表。

问题消息 解决方案
解决缺少服务器问题 右键单击项目节点并选择 "Resolve Missing Server"(解决缺少服务器问题)。然后,导航到包含服务器的文件或文件夹。
解决引用问题 右键单击项目节点并选择 "Resolve Reference Problem"(解决引用问题)。然后,导航到包含项目所引用的资源的文件或文件夹。
无法使用项目 ProjectName 的 Eclipse 平台。它是 JRE,而 NetBeans 项目需要的是 JDK。NetBeans 将使用默认平台。 如果要更改 NetBeans 为项目使用的平台,选择 "Tools"(工具)> "Platforms"(平台)并指定一个不同的平台。
Eclipse 项目 ProjectName 声明使用 "{1}" 目录的 JDK。但是此目录不存在。NetBeans 将使用默认平台。 如果要更改 NetBeans 为项目使用的平台,选择 "Tools"(工具)> "Platforms"(平台)并指定一个不同的平台。
与 Eclipse 一样,NetBeans 不支持每个源根目录的源包括/排除。这些内容已合并在一起,建议您在 "Source"(源)面板的项目属性中仔细检查这些内容。 在 NetBeans 中,整个项目的包括和排除都在一处声明。要查看 NetBeans 项目中的包括和排除,右键单击项目节点和 "Projects"(项目)窗口并选择 "Properties"(属性)。在 "Project Properties"(项目属性)对话框中,选择 "Source"(源)标签,然后单击 "Includes/Excludes"(包括/排除)按钮。
导入由于 ... 而失败。有关更多的详细信息,请参见 IDE 的日志文件。 您可以通过选择 "View"(查看)> "IDE Log"(IDE 日志)来打开 IDE 的日志文件。
未知项目类型 - 无法将其导入。 您只能导入以下类型的 Eclipse 项目:Java 项目、基于现有 Ant 文件的 Java 项目、静态 Web、动态 Web 和 JPA 项目。

返回页首


另请参见

返回页首

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2018, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo