EclipseプロジェクトのNetBeans IDEへのインポート

目次

このページの内容は、NetBeans IDE 6.9、7.0、7.1、7.2、7.3および7.4に適用されます

このチュートリアルを完了するには、次のソフトウェアとリソースが必要です。

ソフトウェアまたはリソース 必須バージョン
NetBeans IDE バージョン6.9、7.0、7.1、7.2、7.3または7.4
Java Development Kit (JDK) バージョン6または7

Eclipseプロジェクトのインポート・ウィザード

NetBeans IDEでは、Eclipseプロジェクトをインポートするための拡張サポートが使用できます。Eclipseプロジェクトのインポート・ウィザードを使用すると、NetBeansを使用して、EclipseやMyEclipseで作成されたJavaデスクトップおよびWebアプリケーション・プロジェクトを操作できます。

EclipseプロジェクトからNetBeansプロジェクトを作成したら、次の方法で作業できます。

  • 他の開発者がEclipseを使用しているチーム・プロジェクトで、NetBeansを使用する。
  • プロジェクトで、NetBeansとEclipseを交互に使用する。
  • Eclipseで設定された既存のプロジェクトについてNetBeansを試す。

先頭

インポート・ウィザードの機能

プロジェクトをインポートすると、IDEはEclipseプロジェクトのメタデータを解析してから、そのメタデータに基づいてNetBeansプロジェクトを作成します。プロジェクトをインポートしてもEclipseプロジェクトの構造は変わらないので、Eclipseでのプロジェクトの動作方法に影響はありません。

プロジェクトをインポートしたら、NetBeansまたはEclipse IDEのいずれかあるいはその両方を使用して、プロジェクトを編集、ビルド、実行、デバッグ、およびプロファイルできます。Eclipseプロジェクトの構成を変更する場合は、NetBeansプロジェクトを再同期化できます。これにより、チームの他の誰かがEclipseを操作していても、NetBeansでプロジェクトを操作できます。Eclipseで設定したビルド・パスは、プロジェクトのマスターのビルド・パスになります。

先頭

プロジェクトのインポートと構成

EclipseプロジェクトをIDEにインポートするには:

  1. インポートするプロジェクトのコピーがシステムにあることを必ず確認します。

    通常、このプロジェクトはすでにシステムのEclipseワークスペースにあります。

  2. 「ファイル」>「プロジェクトをインポート」>「Eclipseプロジェクト」を選択します。
  3. ウィザードのワークスペースの場所ページで、「ワークスペースからプロジェクトをインポート」ラジオ・ボタンを選択し、ワークスペースの場所を指定します。「次」をクリックします。

    Eclipseプロジェクトのインポート・ウィザードのワークスペースの場所ページ

  4. インポートするプロジェクト・ページで、インポートするプロジェクトを選択します。
  5. NetBeansプロジェクト・ファイルを格納するための次の2つのオプションのいずれかを選択します。
    • NetBeansプロジェクトのデータをEclipseプロジェクトのフォルダに格納する。NetBeansは、元のプロジェクトの最上位フォルダ内にフォルダとファイルを追加します。
    • インポートするNetBeansプロジェクトを別の場所に作成する。NetBeansは、元のEclipseプロジェクト・フォルダにあるソースとライブラリを使用しますが、NetBeansプロジェクトのメタデータを保持したり出力をビルドするために別のフォルダを作成します。

    注意: 一般的に、NetBeansプロジェクト・データはEclipseプロジェクト・フォルダ内に格納することをお薦めします。ほとんどの場合、これはNetBeansプロジェクトのメタデータが、Eclipseメタデータが使用するのと同じパスを使用してソースとライブラリを参照することを意味します。したがって、別のマシンのバージョン管理システムからプロジェクトをチェックアウトすると、NetBeansとEclipseの両方で同じような動作になるはずです。
    NetBeans IDEが作成するファイルおよびフォルダのリストについては、後述するNetBeansプロジェクト・ファイルを参照してください。

  6. (Webアプリケーションがインポートされる場合にのみ適用可能。)「次」をクリックします。サーバー・ページで、プロジェクトがNetBeans IDEで必要とする任意のサーバーを登録します。
  7. 「終了」をクリックします。

ウィザードを完了したら、次のダイアログ・ボックスが表示される可能性があります。

  • インポートの問題。このダイアログ・ボックスには、EclipseとNetBeansのプロジェクト構造間の問題に関する情報が表示され、その問題の修正に必要となる可能性があるアクションが提示されます。
    将来の参照用に、このダイアログから情報をコピーして他の場所に貼り付けることができます。
    ほとんどの場合、プロジェクトの「プロジェクト・プロパティ」ダイアログ・ボックスを使用して、これらの問題を解決します。最も一般的な問題の解決については、インポートの問題の解決を参照してください。

    「インポートの問題」ダイアログ・ボックス

  • 参照の問題を解決。このダイアログ・ボックスには、いずれかのプロジェクト・ライブラリに関する特定の参照の問題についてアラートが表示されます。このダイアログ・ボックスを閉じた後、プロジェクトのノードを右クリックし、「参照の問題を解決」を選択すると、この問題を解決できます。
  • 不足しているサーバーを解決。このダイアログ・ボックスには、プロジェクトが必要なサーバーを検出できないことを示すアラートが表示されます。このダイアログ・ボックスを閉じた後、プロジェクトのノードを右クリックし、不足しているサーバーを解決を選択すると、この問題を解決できます。

ウィザードを完了し、前述した情報ダイアログ・ボックスのいずれかを閉じると、プロジェクトのノードが「プロジェクト」ウィンドウに表示されます。

プロジェクトがインポートされた後の「プロジェクト」ウィンドウ。

NetBeansが解決できないサーバーまたは他のリソースへの参照がプロジェクトのメタデータにある場合、プロジェクトのノードは赤で表示されます。プロジェクトのノードを右クリックし、「参照の問題を解決」または不足しているサーバーを解決を選択することによって、すぐにこれらの参照を解決できます。

他のタイプのプロジェクト構成の調整については、「プロジェクト・プロパティ」ダイアログ・ボックスを使用します。「プロジェクト・プロパティ」ダイアログ・ボックスを開くには、プロジェクトのノードを右クリックし、「プロパティ」を選択します。

プロジェクトの構成の詳細は、Javaプロジェクトの作成、インポート、および構成ガイドのクラスパスおよびその他のプロジェクトの設定の構成を参照してください。

先頭

プロジェクトのビルドと実行

プロジェクトをNetBeansにインポートしたら、プロジェクトをビルドおよび実行できます。NetBeansのビルド・コマンドおよび実行コマンドから作成されたすべてのアーティファクトは、buildフォルダおよびdistフォルダに作成されます。NetBeansは、Eclipseのビルド・アクションで作成された出力を上書きしません。buildフォルダおよびdistフォルダがすでにEclipseプロジェクトにある場合、NetBeansプロジェクトはnbbuildおよびnbdistというフォルダを作成し、ビルド出力用にそれらのフォルダを使用します。

次は、「実行」メニューから使用できるビルド・コマンドおよび実行コマンドの一部です。

  • プロジェクトの実行。IDEでアプリケーションのテスト実行を行います。
  • プロジェクトを消去してビルド。build (またはnbbuild)およびdist (またはnbdist)フォルダの内容を削除し、プロジェクトの出力をすべて再ビルドします。NetBeansのビルド・スクリプトを使用します。Eclipseの「消去」コマンドに似ています。
  • 消去。nbbuildフォルダおよびnbdistフォルダの内容を削除します。
  • ビルド。プロジェクトの出力を再ビルドします。保存時にコンパイル機能が有効になっている場合、「ビルド」コマンドは無効です。Javaプロジェクトの作成、インポート、および構成ガイドの保存時にコンパイルの項を参照してください。

アプリケーションのビルドと実行、およびビルド・プロセスのカスタマイズの詳細は、Javaプロジェクトの作成、インポート、および構成を参照してください。

先頭

NetBeansプロジェクト・ファイル

プロジェクトをインポートしたら、システム上に次のフォルダとファイルが表示されます。

  • build.xmlファイルまたはnb-build.xmlファイル。プロジェクトのメインのNetBeansビルド・スクリプトです。プロジェクトの必要性に応じて、このスクリプトをカスタマイズできます。デフォルトで、このファイルの名前はbuild.xmlです。そのようなファイルがすでにプロジェクト・フォルダに存在する場合、スクリプトの名前はnb-build.xmlです。
  • nbprojectフォルダ。メインのNetBeansビルド・スクリプトによってコールされるリソースなど、NetBeansプロジェクトのメタデータのほとんどが含まれます。このフォルダとbuild.xmlファイルまたはnb-build.xmlをバージョン管理システムにチェック・インすると、他のユーザーがNetBeansでそのプロジェクトを開くことができます。このフォルダには、システムに特有のデータを含むprivateフォルダも含まれます。その内容はユーザーごとに異なるため、このフォルダはバージョン管理システムにチェック・インしないでください。後述するバージョン管理の考慮事項を参照してください。
  • nbbuildフォルダ。NetBeansでプロジェクトをビルドまたは実行すると、プロジェクトのソースがこのフォルダにコンパイルされます。
  • nbdistフォルダ。NetBeansでプロジェクトをビルドすると、プロジェクトの配布可能な出力が作成され、このフォルダに置かれます。そのような出力は、JARファイルまたはWARファイルである可能性があります。

先頭

バージョン管理の考慮事項

プロジェクトがバージョン管理システムからチェックアウトされている場合、build (またはnbbuild)フォルダ、dist (またはnbdist)フォルダ、およびnbproject/privateフォルダはバージョン管理システムにチェック・インしないでください。

プロジェクトがCVS、Subversion、またはMercurialバージョン管理システムにある場合、プロジェクトがインポートされるときに、これらのディレクトリ用に該当する「無視」ファイルが作成または更新されます。

nbproject/privateは無視しますが、nbprojectはバージョン管理システムにチェック・インする必要があります。nbprojectには、最初にプロジェクトをインポートしなくても、他のユーザーがNetBeansでプロジェクトを開くことができるプロジェクトのメタデータが含まれます。

先頭

プロジェクトの再同期

プロジェクト・インポート機能には、同期機能があります。Eclipseのクラスパスが最初にインポートされてから変更されている場合は、Eclipseプロジェクトを再同期機能を使用して、対応するNetBeansプロジェクトのクラスパスを更新できます。

プロジェクトの再同期は、EclipseプロジェクトからNetBeansプロジェクトへの片方向です。NetBeansでプロジェクト構造を変更する場合、その変更は再同期機能でEclipseプロジェクトに伝播されません。EclipseプロジェクトおよびNetBeansプロジェクトの両方を保持する場合は、「マスター」プロジェクトとしてEclipseプロジェクトを使用します。

また、Eclipseの構成の変更があいまいでなく、入力の必要がない場合、IDEは自動的にプロジェクトを再同期化します。この自動再同期は、プロジェクトを開くとすぐに行われます。再同期で入力の必要がある場合は、手動でプロジェクトを再同期化する必要があります。

手動でNetBeansプロジェクトをEclipseプロジェクトと再同期化するには:

  • 「ファイル」>「プロジェクトをインポート」>「Eclipseプロジェクトを再同期」を選択します。

注意: プロジェクトを再同期化する場合、再同期はワークスペースからインポートされたすべてのプロジェクトに対して実行されます。

先頭

インポートの問題の解決

プロジェクトをNetBeansにインポートするときに、NetBeans IDEで自動的に解決できないことがある場合があります。これらの問題のいくつかについて、「不足しているサーバーの問題を解決」などメニュー項目がプロジェクトのコンテキスト・メニューに表示されます。他の問題は、NetBeans IDEのインポートされたプロジェクトの「プロジェクト・プロパティ」ダイアログ・ボックスで解決できます。

次は、一般的なインポートの問題とその対処法のリストです。

問題メッセージ 解決方法
不足しているサーバーの問題を解決 プロジェクトのノードを右クリックし、「不足しているサーバーの問題を解決」を選択します。次に、サーバーが含まれるファイルまたはフォルダに移動します。
参照の問題を解決 プロジェクトのノードを右クリックし、「参照の問題を解決」を選択します。次に、プロジェクトが参照するリソースが含まれるファイルまたはフォルダに移動します。
プロジェクトProjectNameのEclipseプラットフォームが使用できません。JREとNetBeansプロジェクトにはJDKが必要です。NetBeansはデフォルト・プラットフォームを使用します。 NetBeansがプロジェクトに使用するプラットフォームを変更する場合は、「ツール」>「プラットフォーム」を選択し、別のプラットフォームを指定します。
Eclipseプロジェクト"ProjectName"では"{1}"ディレクトリからJDKを使用する必要があります。しかし、このディレクトリは存在しません。NetBeansはデフォルト・プラットフォームを使用します。 NetBeansがプロジェクトに使用するプラットフォームを変更する場合は、「ツール」>「プラットフォーム」を選択し、別のプラットフォームを指定します。
Eclipseと違い、NetBeansではソース・ルートごとのソースの含める/除外するはサポートされていません。これらはマージされたので、ソース・パネル内のプロジェクトのプロパティで再確認することをお薦めします。 NetBeansでは、全体プロジェクトに対して1箇所で含めると除外するが宣言されます。NetBeansプロジェクトで含めると除外するを確認するには、「プロジェクト」ウィンドウでプロジェクトのノードを右クリックし、「プロパティ」を選択します。「プロジェクト・プロパティ」ダイアログ・ボックスで、「ソース」タブを選択し、「含める/除外する」ボタンをクリックします。
...が原因でインポートに失敗しました。詳細は、IDEのログ・ファイルを参照してください。 IDEのログ・ファイルを開くには、「表示」>「IDEのログ」を選択します。
不明なプロジェクト・タイプ - インポートできません。 インポートできるEclipseプロジェクト・タイプは、Javaプロジェクト、既存のAntファイルからのJavaプロジェクト、静的Web、動的Web、およびJPAプロジェクトのみです。

先頭


関連項目

先頭

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2018, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo