Создание, импорт и настройка проектов Java

Это руководство содержит обзор основных функций IDE NetBeans для настройки и конфигурирования проектов Java. Кроме того, в руководстве приводятся сведения о выполнении пользовательской настройки сценариев построения, созданных в среде IDE.

Содержание

Содержимое на этой странице применимо к IDE NetBeans 7.0, 7.1, 7.2 и 7.3

Для работы с этим учебным курсом требуются программное обеспечение и ресурсы, перечисленные ниже.

Программное обеспечение или материал Требуемая версия
IDE NetBeans версия 7.0, 7.1, 7.2 или 7.3
Комплект для разработчика на языке Java (JDK) версия 6 или 7

Основные понятия проекта

В этом разделе представлен обзор базовых сведений о системе проектов в среде IDE.

Проекты

В среде IDE пользователь всегда работает в рамках какого-либо проекта. Кроме исходных файлов в проекте IDE также содержатся метаданные о компонентах пути к классам, методах построения и выполнения проекта и т.д. В среде IDE данные проекта сохраняются в папке проекта, в которой содержатся сценарий построения Ant и файл свойств, управляющий параметрами построения и выполнения, а также файл project.xml, отображающий целевые элементы Ant относительно команд IDE.

Примечание. Хотя IDE помещает исходные каталоги в папке проекта по умолчанию, исходные каталоги не обязательно должны быть расположены в папке проекта.

Ant

Apache Ant является средством построения на основе технологии Java, используемым для стандартизации и автоматизации сред построения и выполнения для разработки проектов. Система проектов IDE построена непосредственно на базе Ant. Все команды проекта, например "Очистить и построить проект" или "Отладка", вызывают целевые элементы сценария Ant в проекте. Таким образом, возможно одинаковое построение и выполнение проектов как вне среды IDE, так и в ее рамках.

Для работы со средой IDE не требуется наличие знаний о средстве Ant. Можно установить базовые параметры компиляции и выполнения в диалоговом окне "Свойства проекта", и в среде IDE будет выполнено автоматическое обновление сценария проекта Ant. При наличии опыта работы с Ant можно выполнить индивидуальную настройку стандартного сценария проекта Ant или написать собственный сценарий Ant для проекта.

Создание проекта

Создание проекта

  • Выберите Файл > Создать проект (CTRL+SHIFT+N в системе Windows/CMD+SHIFT+N в системе OS X).

При отображении мастера создания проекта выберите необходимый шаблон для проекта и продолжите работу с мастером, выполнив все действия. Значок шаблона проекта будет отображаться серым цветом, если не был активирован тип проекта. Эта функция будет активирована в среде IDE по мере создания проекта.

В среде IDE содержатся следующие стандартные шаблоны проектов для приложений Java и веб-приложений Java.

Кроме того, в среде IDE содержатся шаблоны для модулей EJB, приложений уровня предприятия, приложений Java ME и др.

Для категорий проектов Java и веб-проектов также существуют шаблоны проектов свободного формата. Шаблоны свободного формата позволяют использовать для проекта существующий сценарий Ant, однако требуют ручной настройки. См. ниже раздел Проекты свободной формы.

По завершении создания проекта он откроется в среде IDE, и его логическая структура будет отображена в окне "Проекты", а структура файлов - в окне "Файлы".

  • Окно "Проекты" является основной точкой входа исходных файлов проекта. В окне выводится логическое представление ключевого содержимого проекта, например пакетов Java и веб-страниц. Вы можете щелкните правой кнопкой мыши любой узел проекта для доступа к всплывающему меню команд сборки для создания, запуска и отладки проекта, а также открытия диалогового окна 'Свойства проекта'. Окно "Проекты" можно открыть, выбрав "Окно" > "Проекты" (CTRL+1 в системе Windows/CMD+1 в системе OS X).
  • Окно "Файлы" отображает проекты в виде каталога, включая файлы и папки, не выведенные в окне "Проекты". В окне "Файлы" можно открывать и редактировать файлы настройки проекта, например файл сценария построения и файл свойств проекта. Также можно просматривать результат построения, например скомпилированные классы, файлы JAR, файлы WAR и созданную документацию Javadoc. Окно "Файлы" можно открыть, выбрав "Окно" > "Файлы" (CTRL+2 в системе Windows/CMD+2 в системе OS X).

Окна 'Файлы' и 'Проекты'

Примечание. Если требуется доступ к файлам и каталогам, которые находятся за пределами каталогов проекта, можно воспользоваться окном 'Избранное'. Чтобы открыть диалоговое окно "Избранное", необходимо выбрать "Окно" > "Избранное" (CTRL+3 в системеWindows/CMD+3 в системе OS X). Чтобы добавить папку или файл в окно 'Избранное' щелкните правой кнопкой мыши в окне 'Избранное' и выберите 'Добавить в избранное'.

Импорт проекта

В этом разделе рассматриваются принципы обработки начального импорта проектов в среду IDE.

Импорт рабочей области Eclipse

При работе с проектами Eclipse можно использовать мастер импорта проектов Eclipse для создания проектов NetBeans из проектов рабочей области Eclipse и импорта путей к классам и других параметров проекта. При использовании мастера импорта проектов Eclipse создание и настройка проекта NetBeans вручную не требуется. Откройте мастер импорта, выбрав "Файл" > "Импортировать проект" > "Проект Eclipse". Дополнительные сведения о принципах работы мастера и возможностях одновременной работы с проектами Eclipse и NetBeans см. в разделе Импорт проектов Eclipse в IDE NetBeans.

Настройка проекта Java на основе существующих исходных файлов

Для других проектов Java, разработанных вне среды NetBeans, рекомендуется использовать шаблон "Существующие исходники" в мастере создания проектов для построения проекта NetBeans. В мастере необходимо указать путь к исходным файлам и определить папку для метаданных проекта NetBeans. Для настройки проекта используйте диалоговое окно "Свойства проекта".

Настройка проекта NetBeans для существующего проекта Java

  1. Выберите Файл > Создать проект (CTRL+SHIFT+N в системе Windows/CMD+SHIFT+N в системе OS X).
  2. Выберите Java > "Проекты Java с существующими исходными файлами". Нажмите кнопку "Далее".
  3. На странице мастера "Имя и местоположение" выполните следующие действия.
    • Введите имя проекта.
    • Измените значение местоположения папки проекта (необязательно).
    • Измените имя сценария построения, используемого в IDE (необязательно). Это может потребоваться, если сценарий построения с именем build.xml, используемый для создания исходных файлов, уже существует.
    • Установите флажок "Использовать отдельную папку для хранения библиотек" и укажите местоположение папки библиотек (необязательно). Для получения дополнительных сведений об этой возможности ознакомьтесь с разделом Совместное использование библиотек проекта.
    • Установите флажок "Установить как главный проект" (необязательно). При выборе этого параметра сочетания клавиш для команд, такие как "Очистить и построить главный проект" (SHIFT+F11), будут применимы к этому проекту.
  4. Нажмите кнопку "Далее" для перехода к странице мастера "Существующие исходники".
  5. На панели папки с пакетами исходных файлов нажмите "Добавить папку". Далее откройте путь к исходным файлам и, выбрав корневую папку с исходными файлами, нажмите "Открыть".

    Добавляемая папка с исходным кодом должна содержать папку самого высокого уровня иерархии в дереве пакетов. Например, для пакета com.mycompany.myapp.ui необходимо добавить папку, содержащую папку com.

  6. (Необязательно) На панели "Папки с тестами" нажмите элемент "Добавить папку" для выбора папки, содержащей папки с пакетом JUnit.
  7. Нажмите "Следующий", чтобы перейти к странице мастера "Включить/исключить".
  8. (Необязательно) На странице мастера "Включаемые и исключаемые файлы" введите шаблоны имен файлов для всех исключаемых из проекта и включаемых в него файлов. По умолчанию в корневой каталог исходных файлов включены все файлы.
  9. Нажмите кнопку "Завершить".

Настройка веб-проекта на основе существующих исходных файлов

Для веб-проектов, разработанных вне среды NetBeans, рекомендуется использовать шаблон "Существующие исходники" в мастере создания проектов для построения проекта NetBeans. В мастере необходимо указать путь к исходным файлам и определить папку для метаданных проекта NetBeans. Для настройки проекта используйте диалоговое окно "Свойства проекта".

Примечание. Если проект был первоначально разработан в Eclipse, пользователи могут сэкономить время, воспользовавшись местером импорта проектов Eclipse вместе мастера создания проектов. Мастер импорта проекта Eclipse позволяет импортировать несколько проектов одновременно, включая их параметры настройки. См. раздел Импорт проектов Eclipse в IDE NetBeans.

Настройка проекта NetBeans для существующего веб-приложения

  1. Выберите Файл > Создать проект (CTRL+SHIFT+N в системе Windows/CMD+SHIFT+N в системе OS X).
  2. Выберите Java Web > "Веб-приложения с существующими исходниками". Нажмите кнопку "Далее".
  3. На странице мастера "Имя и местоположение" выполните следующие действия.
    • В поле "Расположение" введите имя папки, содержащей корневые папки исходных файлов веб-приложения и папки веб-страниц.
    • Введите имя проекта.
    • Измените значение местоположения папки проекта (необязательно).
  4. Установите флажок "Использовать отдельную папку для хранения библиотек" и укажите местоположение папки библиотек (необязательно). Дополнительные сведения об этом параметре см. в разделе Совместное использование библиотек проектов в IDE NetBeans.
  5. Установите флажок "Установить как главный проект" (необязательно). При выборе этого параметра сочетания клавиш для команд, такие как "Очистить и построить главный проект" (SHIFT+F11), будут применимы к этому проекту.
  6. Нажмите кнопку "Далее" для перехода к странице мастера "Сервер и настройки".
  7. (Необязательно) Добавьте проект в существующее приложение уровня предприятия.
  8. Выберите сервер для развертывания. Если требуемый сервер не отображается, нажмите элемент "Добавить" для регистрации сервера в среде IDE.
  9. Установите уровень языка на версию Java для выполнения приложения.
  10. (Необязательно) Скорректируйте значение контекстного пути. По умолчанию значение контекстного пути базируется на имени проекта.
  11. Нажмите кнопку "Далее" для перехода к странице мастера "Существующие исходники и библиотеки".
  12. Проверьте все поля страницы, в том числе значения полей "Папка веб-страниц" и "Папки пакета исходных файлов".
  13. Нажмите кнопку "Завершить".

Проекты свободной формы

Для проектов свободного формата также существуют шаблоны. В проектах свободного формата среда IDE использует целевые элементы существующего сценария Ant для построения, выполнения, очистки, тестирования и отладки приложения. Если сценарий Ant не содержит целевых элементов для этих функций, они будут недоступны для проекта. Для реализации этих функций запишите целевые элементы в сценарии Ant или во вторичном сценарии Ant.

При этом рекомендуется использовать стандартные шаблоны проекта "С существующими исходными файлами" для импорта проекта. Для проектов Eclipse предлагается использовать функцию импорта проекта, посредством которой выполняется создание и настройка стандартного проекта. Стандартные проекты удобнее в управлении при расчете на длительный промежуток времени. Тем не менее, шаблоны проектов свободного формата можно использовать для проектов на базе приложения Ant с комплексными или уникальными параметрами настройки, которые невозможно воспроизвести в рамках стандартного проекта. Например, при импорте проекта, содержащего несколько корневых каталогов исходных файлов с разными путями к классам, без возможности распределения корневых каталогов по различным проектам можно использовать шаблон проекта свободного формата.

Это руководство посвящено, в основном, работе со стандартными проектами. Чтобы получить более подробную информацию о настройке проектов свободной формы, см. раздел "Дополнительная настройка проектов свободной формы".

Настройка пути к классам и других параметров проекта

В этом разделе рассматриваются наиболее распространенные задачи настройки проекта, например установка целевой папки JDK проекта, установка пути к классам, создание зависимостей между проектами и совместное использование библиотек для проектов и пользователей.

Настройка основного проекта

При разработке крупномасштабных приложений, содержащих несколько папок с исходными файлами, рекомендуется разделить код на отдельные проекты. Обычно один из таких проектов служит точкой входа для приложения. Для определения в среде IDE, какой из проектов является главной точкой входа для приложения, необходимо установить один из проектов как главный. Среда IDE предоставляет команды, применимые к главному проекту. Например, выполнение команды "Очистить и построить главный проект" приводит к построению главного проекта, а также всех необходимых нижестоящих проектов.

Определение проекта в качестве главного

  • Щелкните правой кнопкой мыши узел проекта в окне "Проекты" и выберите команду "Установить как главный проект".

Только один проект может быть определен как главный.

Установка целевого пакета JDK в проекте

В среде IDE существует возможность регистрации нескольких платформ Java, а также возможность присоединения документации Javadoc и исходного кода к каждой платформе. При переходе к целевому пакету JDK для стандартного проекта открывается доступ к следующим возможностям:

  • предоставление новых классов целевого пакета JDK для автозавершения кода;
  • возможное отображение исходного кода целевого пакета JDK и документации Javadoc;
  • использование исполняемых программ пакета JDK (javac и java) для компиляции и выполнения приложения;
  • компиляция исходного кода с учетом библиотек целевого пакета JDK.

По умолчанию в среде IDE используется версия платформы Java SE (JDK), выполняемая средой как стандартная платформа Java для проектов IDE. Чтобы увидеть версию пакета JDK среды IDE, необходимо выбрать "Справка" > "О программе". Версия пакета JDK выведена в поле "Java".

Выполнение среды IDE при работе с другой версией пакета JDK:

  • Запустите среду IDE из командной строки со следующим переключателем:
    --jdkhome jdk-home-dir

    Также можно определить пакет JDK в файле /etc/netbeans.conf, расположенном в папке установки среды IDE.

Регистрация новой платформы Java

  1. Выберите "Сервис" > "Платформа Java" из главного меню.
  2. Укажите папку, содержащую платформу Java, а также исходные файлы и документацию Javadoc для отладки.

Диспетчер платформ Java

Переход к целевому пакету JDK стандартного проекта

  1. Правой кнопкой мыши щелкните узел проекта и выберите элемент "Свойства".
  2. Выберите панель "Библиотеки".
  3. Измените свойство платформы Java.

Управление путями к классам проекта

Добавление группы файлов с классами в путь к классам проекта предоставляет среде IDE данные о возможности доступа проекта к классам во время компиляции и выполнения. Среда IDE также использует настройки пути к классам для активации автозавершения кода, автоматической подсветки ошибок компиляции и реорганизации кода. Объявления пути к классам существующего проекта можно изменить в диалоговом окне "Свойства проекта".

В стандартных проектах Java среда IDE выполняет ведение отдельных путей к классам для компиляции и выполнения проекта, а также компиляции и выполнения тестов JUnit (для приложений Java SE). В среде IDE выполняется автоматическое добавление всех элементов пути к классам компиляции проекта к текущему пути к классам выполнения.

Путь к классам проекта можно изменить, выполнив действия, описываемые ниже.

  • Щелкните правой кнопкой мыши узел проекта, выберите "Свойства", затем - категорию "Библиотеки" и измените отображаемые записи пути к классам.
  • Щелкните правой кнопкой мыши узел "Библиотеки" в окне "Проекты" и выберите команды "Добавить проект", "Добавить библиотеку" или "Добавить архив JAR/папку".

При присоединении документации Javadoc и исходных файлов к файлу JAR в диспетчере библиотек среда IDE автоматически добавит их в проект в случае регистрации файла JAR в пути к классам проекта. Можно перейти к классам и найти страницы Javadoc для классов, не выполняя настройку.

Диалоговое окно 'Свойства проекта'

Управление зависимостями между проектами

Если приложение состоит из нескольких проектов, необходимо настроить зависимости пути к классам между проектами. Как правило, выполняется одновременная настройка главного проекта, содержащего главный класс (в проектах Java SE) и нескольких обязательных проектов. Под обязательным проектом подразумевается проект, который был добавлен в путь к классам другого проекта. При очистке и построении проекта среда IDE выполняет эти действия и для обязательных проектов. Документация Javadoc и исходные файлы обязательного проекта также доступны для принимающего проекта.

Вы можете добавить любые необходимые проекты в текущий проект, щелкнув правой кнопкой мыши узел 'Библиотеки' в окне 'Проекты', или вы можете добавить их, указав их на вкладке 'Библиотеки' диалогового окна 'Свойства проекта'. Если необходимо добавить обязательный проект, выберите папку проекта, файлы JAR которого необходимо добавить к пути к классу (в средстве выбора файла отображается значок для папок проекта IDE) (Значок 'Папка проекта' ). При добавлении проектов в окне "Свойства проекта" убедитесь в том, что флажок "Собирать проекты по пути к классам" установлен.

Для добавления проекта свободного формата в путь к классам стандартного проекта необходимо добавить файл JAR проекта свободного формата. Для выполнения этого действия необходимо сначала объявить все выходные файлы проекта свободного формата на панели "Вывод" диалогового окна "Свойства проекта".

Совместное использование библиотек проекта

Поскольку система проектов IDE NetBeans основана на Ant, проекты NetBeans обычно уже являются переносимыми между различными пользователями, независимо от того, используют ли они IDE. Тем не менее, по умолчанию способ создания ссылок сценария построения проекта на библиотеки зависит от параметров, определенных для каждого пользователя, в частности, в случае ссылок на библиотеки, определенных в диалоговом окне "Диспетчер библиотек".

Например, можно упаковать проект в файл zip и передать другому пользователю, который сможет распаковать его и запустить. Однако если проект зависит от пользовательской библиотеки, определенной в диалоговом окне "Диспетчер библиотек", у других пользователей могут возникнуть трудности с построением проекта из-за недействительных ссылок на пользовательскую библиотеку.

Другое возможное неудобство заключается в том, что библиотеки в зависимости от происхождения различаются по местоположению. Библиотеки, поставляемые вместе со средой IDE, сохраняются во время установки среды в множестве различных папок. В качестве примера можно привести библиотеки Swing Layout Extensions, привязки компонентов и драйверы базы данных.

Для решения этой проблемы можно сохранять библиотеки проекта в отдельной папке. Кроме того, при создании ссылок на библиотеки можно использовать относительный или абсолютный путь.

Эти возможности способствуют упрощению решения проблем в ситуациях, описываемых ниже.

  • Существует необходимость в открытии доступа к создаваемому проекту и предоставлении возможности построения проекта для других пользователей вне зависимости от того, используют ли они среду IDE. Пользователи должны иметь возможность доступа к проекту посредством выписки из управления версиями или распаковывания полученного архива zip. Построение приложения также должно осуществляться без дополнительных настроек.
  • Существует необходимость работы с существующим проектом и придерживаться строго установленных ограничений, касающихся хранения библиотек проекта (а также доступа к ним сценария построения посредством относительных или абсолютных ссылок).

Для стандартных проектов Java SE, Web и Enterprise можно определить отдельную папку с библиотеками. Папку для библиотек можно установить во время создания проекта (в мастере создания проекта) или по завершении создания на вкладке "Библиотеки" диалогового окна "Свойства проекта".

Для настройки совместного использования библиотек по завершении создания проекта, выполните следующие действия.

  1. Выберите "Файл" > "Создать проект".
  2. В категории "Java" мастера создания проекта выберите один из стандартных шаблонов. Затем нажмите кнопку "Дальше".
  3. На странице мастера "Имя и местоположение" установите флажок "Отдельная папка для совместного использования библиотек".
  4. В поле папки "Библиотеки" выберите путь для хранения библиотек.

    В случае существования библиотек в среде IDE они будут скопированы в указанную папку.

Настройка библиотек веб-проектов или проектов Java EE для совместного использования по завершении создания проекта

  1. Выберите "Файл" > "Создать проект".
  2. В категории мастера "Веб" выберите один из стандартных шаблонов. Затем нажмите кнопку "Дальше".
  3. На странице мастера "Имя и местоположение" установите флажок "Отдельная папка для совместного использования библиотек".
  4. В поле папки "Библиотеки" выберите путь для хранения библиотек.

    В случае существования библиотек в среде IDE они будут скопированы в указанную папку.

Настройка библиотек существующего проекта для совместного использования

  1. Правой кнопкой мыши щелкните узел проекта и выберите элемент "Свойства".
  2. В диалоговом окне "Свойства проекта" выберите узел "Библиотеки".
  3. На панели "Библиотеки" нажмите кнопку "Обзор" для открытия мастера создания папки библиотек.
  4. На странице мастера "Папка библиотек" введите местоположения для библиотек и нажмите кнопку "Далее".
    Путь можно указать как относительную или абсолютную ссылку.
  5. На панели мастера "Действия" проверьте выбранное действие для каждой библиотеки в списке. В большинстве случаев среда IDE обнаруживает наиболее подходящее действие для выбранной библиотеки.

    Доступны следующие действия:

    • Копировать файлы JAR библиотеки в новую папку библиотеки. Используйте этот параметр, если библиотека находится не в папке, которую вы выбрали, и необходимо поместить файлы JAR библиотеки в эту папку.
    • Использовать относительный путь к файлам JAR библиотеки. Используйте этот параметр, если библиотека находится не в папке библиотек, и необходимо получить доступ к библиотеке в его существующем местоположении, используя относительный путь. В файл nblibraries.properties папки библиотек будет добавлена запись с относительной ссылкой.
    • Использовать абсолютный путь к файлам JAR библиотеки. Используйте этот параметр, если библиотека находится не в папке библиотек, и необходимо получить доступ к библиотеке в его существующем местоположении, используя абсолютный путь. В файл nblibraries.properties папки библиотек будет добавлена запись с абсолютной ссылкой.
    • Использовать существующую библиотеку в папке библиотек. Используйте этото параметр, если уже есть копия библиотеки в папке библиотек, и необходимо использовать эту копию библиотеки.
  6. Нажмите кнопку "Готово" для выхода из мастера настройки совместного использования проекта.
  7. Нажмите кнопку "ОК" для выхода из диалогового окна "Свойства проекта".

Примечание. Также можно использовать узел 'Библиотеки' диалогового окна 'Свойства проекта' для изменения местоположения папки библиотек. Если папка для библиотек уже определена, то при нажатии кнопки "Обзор" вместо мастера создания папки библиотек откроется окно выбора файлов.

Обеспечение доступности документации Javadoc в среде IDE

Посмотреть документацию по интерфейсу API Java SE в среде IDE NetBeans можно с помощью команды "Source" (Источник) > "Документация". Посмотреть документацию в отдельном окне можно с помощью пункта главного меню "Окно" > "Другое" > Javadoc.

Однако для некоторых сторонних библиотек документация по API недоступна. В этом случае ресурсы Javadoc необходимо связать со средой IDE вручную.

Обеспечение доступности документации Javadoc по API через команду "Просмотреть Javadoc":

  1. Загрузите источник документации Javadoc по интерфейсу API.
  2. Выберите "Tools" > "Библиотеки".
  3. В списке "Библиотеки" выберите библиотеку, которая используется для проекта.
  4. Выберите вкладку "Javadoc".
  5. Нажмите кнопку "Добавить архив ZIP/папку" и перейдите к файлу ZIP или к папке, содержащей документацию Javadoc по интерфейсу API в системе. Выберите файл с ZIP или папку и нажмите кнопку "Добавить архив ZIP/папку".
  6. Нажмите кнопку "ОК".

Активация Java Web Start для приложения

Существует возможность настройки приложения для его выполнения посредством Java Web Start в среде IDE. Для этого используется категория "Java Web Start" в окне "Свойства проекта". Подробные сведения о включении Java Web Start см. учебный курс Включение Java Web Start в IDE NetBeans.

Настройка Java Web Start для приложения

  1. Правой кнопкой мыши щелкните узел проекта и выберите элемент "Свойства".
  2. В диалоговом окне "Свойства проекта" выберите узел "Приложение" > Web Start.
  3. Установите флажок 'Включить Web Start' и настройте параметры Web Start Java как описано в разделе Включение Web Start Java в IDE NetBeans.

Построение приложений

В этом разделе рассматривается построение стандартных проектов в среде IDE, базовые настройки для построения процесса и обработка ошибок компиляции.

Создание проектов, пакетов и файлов

Среда IDE обеспечивает простое и удобное выполнение компиляции. При условии корректной установки пути к классам компиляции проекта необходимо только выбрать компилируемый проект, пакет или файл и нажать соответствующую команду, "Построить" или "Скомпилировать", в меню "Выполнить". Среда IDE выполнит компиляцию файлов.

В случае включения функции "Компиляция при сохранении" для проекта Java (или функции "Развертывание при сохранении" для проектов Java web или проектов уровня предприятия) среда IDE выполнит автоматическую компиляцию файлов при сохранении. См. следующий раздел Компиляция при сохранениидля получения дополнительных сведений.

Построение приложения для развертывания

  • Выберите "Выполнить" > "Clean and Build Project" (Очистить и собрать проект).

    Все ранее скомпилированные файлы и выходные файлы, например архивы JAR, удаляются. Выполняется новая компиляция файлов и создание новых выходных файлов. Для размещения скомпилированных классов создается папка build. Для распределяемых выходных файлов, например архивов JAR или документации Javadoc создается папка dist. Выходные файлы построения можно просмотреть в окне "Файлы".

При каждом вызове команд компиляции среда IDE отображает выходные данные, в частности, ошибки компиляции, в окне "Вывод", как описывается в следующем разделе Исправление ошибок компиляции.

Компиляция при сохранении

Функция компиляции при сохранении среды IDE позволяет сэкономить время при выполнении и отладке проектов IDE. В случае включения данной функции для проекта при сохранении файлов выполняется их компиляция. Скомпилированные файлы сохраняются в кэше, используемом средой IDE при выполнении, тестировании, отладке и профилировании проекта IDE. В результате появляется возможность тестирования и отладки приложения без необходимости ожидания завершения его построения.

При включении функция "Компиляция при сохранении" предоставляет возможности, рассматриваемые ниже.

  • Среда IDE выполняет компиляцию файлов при их сохранении, так что проект доступен для выполнения и отладки в среде IDE в любой момент времени.
  • Команда "Построить" будет отключена. При необходимости повторного построения архива JAR без использования команды "Очистить и построить" требуется отключить функцию "Компиляция при сохранении".
  • Сценарий Ant проекта не используется при выборе команд "Выполнить", "Отладка", "Профиль" или "Тестировать". Настройка сценария построения для использования этих команд будет проигнорирована.
  • Архив JAR, созданный в результате построения проекта, не обновляется при сохранении изменений в файлах. Для построения или повторного построения архива JAR необходимо использовать команду "Очистить и построить". Команда "Очистить и построить" всегда использует сценарий Ant проекта вне зависимости от состояния включения функции "Компиляция при сохранении".

Данная функция включается по умолчанию для создаваемых проектов. Для существующих проектов функция компиляции при сохранении отключена.

Включение и отключение компиляции при сохранении для проекта Java

  1. Правой кнопкой мыши щелкните узел проекта и выберите элемент "Свойства".
  2. Выберите узел "Компиляция" и установите свойство "Компиляция при сохранении".

Кроме того, в среде IDE существует аналогичная функция "Развертывание при сохранении" для веб-приложений Java и приложений уровня предприятия. При включении функции "Развертывание при сохранении" для проекта, развернутого на сервере посредством среды IDE, немедленно выполняется повторное развертывание измененных файлов на сервере. Для корректной работы данной функции на сервере GlassFish V2 необходимо выбрать параметр "Развертывание каталога включено" для экземпляра Glassfish.

Включение или отключение развертывания при сохранении для веб-проектов Java или проектов уровня предприятия

  1. Правой кнопкой мыши щелкните узел проекта и выберите элемент "Свойства".
  2. Выберите узел "Выполнение" и установите свойство "Развертывание при сохранении".

Включение развертывания каталога на сервере Glassfish V2

  1. Выберите элементы "Сервис" > "Серверы".
  2. Выберите требуемый сервер.
  3. Перейдите на вкладку "Параметры".
  4. Выберите параметр "Развертывание каталога включено".

Исправление ошибок компиляции

В среде IDE в окне "Вывод" отображаются выходные сообщения и ошибки компиляции. Это окно с несколькими вкладками выводится при создании записей об ошибках компиляции, отладке программы, создании документации Javadoc и пр. Окно можно также открыть вручную, выбрав "Окно" > "Вывод" (CTRL+4 в системе Windows/Cmd+4 в системе OS X).

Также ошибки компиляции выводятся в окне "Задачи" и выделены в редакторе исходного кода.

Одной из важнейших функций окна "Вывод" является уведомление об ошибках, найденных во время компиляции программы. Сообщение об ошибке выводится в виде текста с подчеркиванием синего цвета и связано со строкой исходного кода, вызвавшей возникновение ошибки, как показано на рисунке ниже. Окно "Вывод" также предоставляет ссылки на ошибки, найденные во время выполнения сценариев Ant. При нажатии ссылки на ошибку в окне "Вывод" редактор исходного кода автоматически переходит к строке с ошибкой.

Окно вывода, в котором показываются результаты теста

Результат каждого действия, выполняемого посредством сценария Ant, например компиляция, выполнение и отладка файлов, также отображается на вкладке окна "Вывод". Для сохранения сообщений, отображаемых в окне "Вывод", можно скопировать и вставить их в отдельный файл. Также можно настроить сценарий Ant для вывода результата выполнения команды для каждой новой цели в новой вкладке окна "Вывод", нажав элементы "Сервис" > "Параметры", выбрав категорию "Разное", нажав вкладку "Ant" и отменив выбор флажка свойства "Повторное использование вкладок с результатом завершенного процесса".

Фильтрация выходных файлов

При создании архива JAR или файла WAR обычно требуется включить в них скомпилированные файлы .class или другие исходные файлы, расположенные в каталоге исходных файлов, например наборы ресурсов или документы XML. Фильтр по умолчанию выполняет включение всех необходимых файлов и исключает файлы .java, .nbattrs и .form из выходного файла.

Дополнительные фильтры для управления выходными файлами можно создать при помощи регулярных выражений. Чтобы указать, какие файлы следует исключить, щелкните правой кнопкой мыши проект в окне 'Проекты' и выберите 'Свойства', чтобы открыть диалоговое окно 'Свойства проекта'. На левой панели нажмите элемент "Упаковка". В текстовом поле на правой панели введите регулярные выражения для определения исключаемых файлов при упаковке файлов JAR или WAR. Кроме выражений по умолчанию можно использовать дополнительные регулярные выражения, перечисленные ниже.

Регулярное выражение Описание
\.html$ Исключение всех файлов HTML
\.java$ Исключение всех файлов Java
(\.html$)|(\.java$) Исключение всех файлов HTML и Java
(Key)|(\.gif$) Исключение всех файлов GIF и файлов, содержащих в имени компонент Key

Подробные сведения о синтаксисе выражений приведены на сайте jakarta.apache.org.

Выполнение приложений

В этом разделе рассматривается выполнение проектов в среде IDE и настройка главного класса проекта, аргументов выполнения, аргументов VM и рабочего каталога.

Выполнение проектов и файлов

При работе с проектами Java в качестве главного обычно устанавливается проект, содержащий главный класс программы. Для веб-проектов главным является проект, развернутый первым. Для выполнения проекта, пакета или файла выполните одно из действий, перечисленных ниже.

  • В главном меню выберите "Выполнить" > "Выполнить главный проект", чтобы выполнить главный проект. Также можно использовать кнопку "Выполнить главный проект" на панели инструментов.
  • В окне 'Проекты' щелкните правой кнопкой мыши проект и выберите 'Выполнить' для запуска проекта. Обратите внимание, что для проектов Java необходимо наличие главного класса.
  • В окне 'Проекты' щелкните правой кнопкой мыши файл и выберите 'Запустить файл' (Shift+F6), чтобы запустить файл. Или в главном меню выберите "Выполнить" > "Выполнить файл" > "Run filename" (Выполнить имя_файла) , чтобы выполнить работоспособный класс.

При выполнении проекта среда IDE выводит все ошибки компиляции и выходные данные в окне "Вывод". Дополнительные сведения приведены в разделе Исправление ошибок компиляции.

Примечание. Если для проекта включена функция 'Компилировать при сохранении', команда Run Project применяется к файлам классов, созданных при сохранении этих файлов. Сценарий построения Ant не используется. При определении пользовательских действий в сценарии построения вышеописанные действия не выполняются. В случае необходимости выполнения полного процесса построения при использовании команд "Выполнить проект", "Отладка проекта" и "Профилирование проекта" отключите функцию "Компиляция при сохранении".

Настройка параметров выполнения

По умолчанию главный класс, аргументы выполнения и аргументы JVM в среде IDE не определены. Путь к классу выполнения каждого стандартного проекта содержит скомпилированные классы проекта и все элементы пути к классам компиляции проекта. Путь к классам компиляции проекта можно просмотреть, открыв диалоговое окно "Свойства проекта", выбрав узел "Библиотеки" на панели "Категории" и нажав вкладку "Компиляция" на правой панели.

Чтобы изменить параметры среды выполнения проекта, откройте диалоговое окно 'Свойства проекта', щелкнув правой кнопкой мыши узел проекта в окне 'Проекты' и выбрав 'Свойства'. Затем выберите узел "Библиотеки" на панели "Категории" и нажмите вкладку "Выполнение" на правой панели диалогового окна. Обратите внимание, что для доступа к параметрам главного класса, аргументов программы, рабочего каталога для выполнения программы и параметров VM необходимо выбрать узел "Выполнение". В следующем разделе будет представлено подробное описание настройки пути к классам выполнения.

Укажите настройки среды выполнения в диалоговом окне 'Свойства проекта'

Установка пути к классам выполнения

Для добавления проектов, библиотек, архивов JAR и папок в путь к классам выполнения проекта используйте кнопки, расположенные в правой части списка "Библиотеки времени выполнения" в диалоговом окне "Свойства проекта".

При динамическом использовании специальных библиотек в проекте во время выполнения через интерфейс посредника или интерфейс API отражения (например, посредством драйверов JDBC или реализации JAXP) необходимо добавить эти библиотеки в путь к классам выполнения. Также настройка пути к классам выполнения необходима, если зависимости между проектами не соответствуют зависимостям компиляции между проектами. Например, представим, что проект А компилируется с проектом B, и проект B компилируется с проектом C, но проект А не компилируется с проектом C. Это означает, что у проект А имеется только проект B на пути к классу среды выполнения. Если во время выполнения для проекта A требуются как проект B, так и проект C, необходимо добавить проект C в путь к классам выполнения проекта A.

Установка главного класса и аргументов выполнения

Для установки главного класса проекта выберите узел "Выполнить" на панели "Категории" диалогового окна "Свойства проекта" и введите полное имя в поле "Главный класс" (например, org.myCompany.myLib.MyLibClass). Главный класс должен содержаться в проекте, архивах JAR или библиотеках в пути к классам выполнения проекта. Затем введите необходимые аргументы выполнения в поле "Аргументы".

При использовании кнопки "Обзор" для выбора главного класса проекта средство выбора файлов отображает только классы в каталоге исходных файлов проекта. В случае возникновения необходимости в определении класса в одной из библиотек в пути к классам требуется ввести полное имя класса в поле "Главный класс".

Установка аргументов JVM

Аргументы JVM для проекта можно указать в диалоговом окне "Свойства проекта". Откройте диалоговое окно "Свойства проекта" и нажмите элемент "Выполнить" на панели "Категории", а затем введите список аргументов JVM в поле "Параметры VM", разделяя их пробелами.

Свойства системы можно установить, введя следующее значение в поле "Параметры VM":

-Dname=value

Настройка сценария построения

При работе со стандартными проектами среда IDE создает сценарий построения на основе параметров, введенных в мастере создания проекта и диалоговом окне "Свойства проекта". Можно установить базовые параметры компиляции и выполнения в диалоговом окне "Свойства проекта", и в среде IDE будет выполнено автоматическое обновление сценария проекта Ant. При существовании дополнительных требований к процессу построения, обрабатываемые в окне "Свойства проекта", можно выполнить изменения непосредственно в сценарии построения.

Главным сценарием Ant для проекта является файл build.xml. Среда IDE вызывает целевые элементы в build.xml при каждом выполнении команд IDE. Этот файл содержит оператор импорта, импортирующий файл nbproject/build-impl.xml, который содержит целевые элементы построения, созданные в среде IDE. В файле build.xml можно переопределить целевые элементы из файла nbproject/build-impl.xml или записать новые целевые элементы. Не выполняйте редактирование nbproject/build-impl.xml напрямую, поскольку этот файл будет восстановлен на основе изменений, производимых в окне "Свойства проекта".

Кроме того, в сценарии построения используется файл nbproject/project.properties, который можно редактировать вручную.

При работе со стандартными проектами можно настроить процесс построения, выполнив следующие действия:

  • Ввод базовых параметров, например параметров пути к классам и фильтров JAR, в мастере создания проекта или по завершении создания в диалоговом окне "Свойства проекта".
  • Редактирование свойств в файле nbproject/project.properties. В этом файле содержатся свойства Ant с важными сведениями о проекте, например о местоположении исходных и выходных папок. Также в файле можно переопределить свойства. Будьте внимательны при его редактировании. Например, необходимо учитывать, что при каждой чистке проекта удаляется папка с выходными файлами. Поэтому не следует устанавливать папку с выходными файлами в ту же самую папку, что и папку с исходными файлами, не выполнив настройку целевого элемента очистки таким образом, чтобы папка с выходными файлами не удалялась.
  • Настройка существующих или создание новых целевых элементов Ant посредством выполнения действий, описываемых ниже.
    • Добавьте указания для обработки до или после выполнения целевого элемента Ant. Для каждой главной цели в файле nbproject/build-impl.xml существуют целевые элементы -pre и -post, которые можно переопределить в файле build.xml. Например, для обеспечения работы RMI со стандартными проектами введите в файл build.xml следующее:
      <target name="-post-compile">
        <rmic base="${build.classes.dir}" includes="**/Remote*.class"/>
                          </target>
    • Измените указания в целевом элементе Ant. Скопируйте целевой элемент из файла nbproject/build-impl.xml в build.xml и измените его требуемым образом.
    • Создайте новые целевые элементы в файле build.xml. Также можно добавить новые целевые элементы к зависимостям существующих целевых элементов среды IDE. Выполните переопределение существующих целевых элементов в файле build.xml, а затем добавьте новый целевой элемент в свойство depends. Следующий пример кода добавляет целевой элемент new-target к зависимостям целевого элемента:
      <target name="new-target">
          <!-- target body... -->
      </new-target>
       
                              <target name="run" depends="new-target,myprojname-impl.run"/>

      Нет необходимости в копировании тела целевого элемента выполнения в файл build.xml.

В следующей таблице перечислены некоторые общие задачи для переопределения архива JAR, рекомендуемые для использования:

Задача Выполняемые действия
Указание файлов, добавляемых в архив JAR. Щелкните правой кнопкой мыши узел проекта в окне "Проекты" и выберите команду "Свойства". Щелкните подузел "Упаковка" (расположенный под узлом "Построение") и выполните настройку фильтра и параметров сжатия посредством поля "Исключить из архива JAR". Дополнительные сведения приведены в разделе Фильтрация выходных файлов.
Изменение имени и местоположения архива JAR. В окне "Файлы" дважды щелкните кнопкой мыши файл проекта nbproject/project.properties для его открытия в редакторе исходного кода. Введите полный путь к архиву JAR в свойстве dist.jar.
Укажите файл манифестов для архива JAR. В файле project.properties введите имя файла манифеста в свойстве manifest.file. Имя файла должно быть указано относительно файла проекта build.xml. Обратите внимание, что при использовании шаблона приложения на Java среда IDE создает файл манифеста.
Отключение функции создания архива JAR для проекта. В окне "Файлы" откройте папку проекта, а затем откройте файл build.xml. Переопределите целевой элемент jar таким образом, чтобы в нем отсутствовали зависимости и содержимое. Например, можно добавить в файл build.xml следующий код:
<target name="jar" />

Для получения дополнительных сведений о работе с Ant перейдите по ссылке http://ant.apache.org/resources.html. Ant можно также установить вручную в справочной системе IDE при помощи диспетчера подключаемых модулей. Выберите "Сервис" > "Подключаемые модули" и установите модуль Ant Documentation.

Редактирование и выполнение сценариев Ant

IDE автоатически распознает сценрии Ant и отображает их как узлы сценариев Ant (Значок узла сценария Ant ), а не как обычные файлы XML. Можно щелкнуть правой кнопкой мыши сценарии Ant в окне 'Проекты', 'Файлы' или 'Избранное' для получения доступа к всплывающему окну команд. Также можно развернуть узел Ant для просмотра подузлов, отображающих целевые элементы сценария Ant в алфавитном порядке. Для каждого подузла также можно вызвать всплывающее меню с командами.

В окнах "Проекты", "Файлы" и "Избранное" подузлы сценария Ant отмечены следующим образом:

Значок Значение
Выделенный значок целевого элемента Ant

Выделенный целевой элемент Ant. К этим целевым элементам относится атрибут описания, который отображается как подсказка. Атрибут описания целевого элемента можно задать в редакторе исходного кода.

Нормальный значок целевого элемента Ant Нормальный целевой элемент Ant. Целевой элемент без атрибута описания.

Дважды щелкните любой подузел сценария Ant для перехода к строке целевого элемента в редакторе исходного кода. Все стандартные инструменты поиска XML, инструменты выбора и сочетания клавиш доступны при редактировании сценариев Ant, также среда IDE предоставляет функцию автозавершения кода для всех стандартных задач Ant.

При создании целевого элемента, выполняемого из командной строки, задайте для него атрибут описания. При возникновении трудностей с определением имен целевых объектов или их назначения можно выполнить команду -projecthelp <script> из командной строки. При использовании этой команды в Ant будет выведен список всех целевых элементов с атрибутом описания, а также их описание. При наличии нескольких целевых элементов в сценарии построения Ant рекомендуется применять функцию выделения для различия часто используемых элементов от редко используемых.

Стиль шрифта метки подузла в окнах "Проекты", "Файлы" и "Избранное" также указывает на различия целевых элементов.

  • Нормальный. Целевой элемент, определенный в текущем сценарии Ant.
  • Курсив. Целевой элемент, импортированный из другого сценария Ant.
  • Выделен серым. Внутренний целевой элемент, который не может быть запущен напрямую. Внутренним целевым элементам присваиваются имена, начинающиеся с символа "-".
  • Полужирный. Целевой элемент по умолчанию для сценария (если есть). Целевой элемент по умолчанию объявляется как атрибут проекта вместе с другими атрибутами проекта, например именем. Атрибут целевого элемента проекта по умолчанию можно задать в редакторе исходного кода.

Целевые элементы, импортируемые из другого сценария, но переопределенные в сценарии импорта, не отображаются в списке. Выводятся только целевые элементы переопределения.

Целевые элементы сценария Ant можно выполнить посредством узла сценария в окне "Проекты", "Файлы" или "Избранное". Для этого щелкните правой кнопкой мыши узел сценария Ant и выберите целевой элемент в подменю 'Выполнить целевой элемент'. Целевые элементы перечислены в алфавитном порядке. Отображаются только выделенные целевые элементы. Выберите "Другие целевые элементы" для выполнения целевого элемента, не выделенного при помощи атрибута описания. Внутренние целевые элементы исключаются из этих списков в силу невозможности их независимого выполнения.

Вместо запуска целевого элемента с помощью всплывающего меню узла сценария Ant можно просто щелкнуть правой кнопкой мыши целевой узел и выбрать 'Выполнить целевой элемент'.

Выполнение целевого элемента Ant

Запись пользовательских задач Ant

Пользовательские задачи Ant можно использовать для развертывания функций, предоставляемой встроенными задачами Ant. Они часто используются для определения свойств, создания вложенных элементов или записи текста непосредственно между тегами посредством метода addText.

Создание пользовательской задачи Ant в среде IDE

  1. Щелкните правой кнопкой мыши пакет, в который необходимо поместить задачу, и выберите "Создать" > "Другое".
  2. Выберите категорию "Другое" и тип файла "Пользовательская задача Ant".
  3. Завершите работу мастера.

При создании файла пользовательской задачи Ant в редакторе исходного кода будет открыт шаблон. В шаблоне содержится пример кода для многих распространенных операций, выполняемых посредством задач Ant. После каждого раздела кода в шаблоне отображаются способы использования задачи в сценарии Ant.



Дополнительные сведения


get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo