Javaプロジェクトの作成、インポート、および構成

このガイドでは、Javaプロジェクトの設定および構成を行うための、NetBeans IDEの主要な機能について概説します。また、IDEで生成されたビルド・スクリプトの構成をカスタマイズする方法についての情報も提供します。

目次

このページの内容は、NetBeans IDE 7.0、7.1、7.2および7.3に適用されます

このチュートリアルを完了するには、次のソフトウェアとリソースが必要です。

ソフトウェアまたはリソース 必須バージョン
NetBeans IDE バージョン7.0、7.1、7.2または7.3
Java Development Kit (JDK) バージョン6または7

プロジェクトの基本的な概念

この項では、IDEのプロジェクト・システムに関する背景情報の概要を示します。

プロジェクト

IDEでは、常にプロジェクトの内部で作業をします。IDEプロジェクトには、ソース・ファイルに加えて、クラスパスに属するものについてのメタデータや、プロジェクトのビルド方法および実行方法などに関するメタデータが含まれています。IDEでプロジェクト情報が格納されるプロジェクト・フォルダには、ビルドや実行の設定を制御するAntビルド・スクリプトとプロパティ・ファイル、およびAntターゲットをIDEコマンドにマップするproject.xmlファイルが含まれています。

注意: IDEでは、ソース・ディレクトリはデフォルトでプロジェクト・フォルダ内に配置されますが、ソース・ディレクトリをプロジェクト・フォルダ内に配置することは必須ではありません。

Ant

Apache AntはJavaベースのビルド・ツールで、開発用のビルド環境や実行環境を標準化および自動化するために使用します。IDEのプロジェクト・システムは、直接Antに基づいています。「プロジェクトを消去してビルド」や「デバッグ」などのプロジェクト・コマンドはすべて、プロジェクトのAntスクリプト内のターゲットをコールします。このため、IDE内と同じようにIDEの外部でプロジェクトをビルドおよび実行できます。

IDEで作業するためにAntについて理解する必要はありません。基本的なコンパイル・オプションと実行時オプションはすべてプロジェクトの「プロジェクト・プロパティ」ダイアログ・ボックスに設定可能で、IDEによってプロジェクトのAntスクリプトが自動的に更新されます。Antに精通している場合は、標準プロジェクトのAntスクリプトをカスタマイズしたり、プロジェクト用に独自のAntスクリプトを記述したりできます。

プロジェクトの作成

新しいプロジェクトを作成する

  • ファイル」>「新規プロジェクト」(Windowsの場合は[Ctrl]-[Shift]-[N]、OS Xの場合は[Cmd]-[Shift]-[N])を選択します。

新規プロジェクト・ウィザードが表示されたら、プロジェクトに適したテンプレートを選択して、ウィザードの残りの手順を完了します。プロジェクト・テンプレートのアイコンはグレーで表示されることがあり、その場合は、このプロジェクト・タイプがアクティブ化されていないことを示します。プロジェクトの作成を続行すると、IDEでこの機能がアクティブ化されます。

IDEには、JavaおよびJava Webアプリケーション用の次の標準プロジェクト・テンプレートが含まれています。

IDEには、EJBモジュール、エンタープライズ・アプリケーション、Java MEアプリケーションなどのテンプレートも用意されています。

JavaとWebのプロジェクト・カテゴリには、自由形式プロジェクトのテンプレートもあります。自由形式のテンプレートでは、プロジェクトに既存のAntスクリプトを使用できますが、手動による構成が必要です。後述する自由形式プロジェクトを参照してください。

プロジェクトの作成が終了すると、IDEでプロジェクトが開き、「プロジェクト」ウィンドウにプロジェクトの論理構造が表示され、「ファイル」ウィンドウにファイル構造が表示されます。

  • 「プロジェクト」ウィンドウは、プロジェクト・ソースへのメインのエントリ・ポイントです。JavaパッケージやWebページなどの重要なプロジェクトの内容の論理ビューを表示します。プロジェクト・ノードを右クリックすると、プロジェクトをビルド、実行、およびデバッグするためのコマンドや、「プロジェクト・プロパティ」ダイアログ・ボックスを開くためのコマンドが含まれるポップアップ・メニューにアクセスできます。「プロジェクト」ウィンドウは、「ウィンドウ」>「プロジェクト」(Windowsの場合は[Ctrl]-[1]、OS Xの場合は[Cmd]-[1])を選択して開くことができます。
  • 「ファイル」ウィンドウには、「プロジェクト」ウィンドウでは表示されないファイルやフォルダなど、プロジェクトのディレクトリ・ベースの構造が表示されます。「ファイル」ウィンドウから、プロジェクトのビルド・スクリプトやプロパティ・ファイルなど、プロジェクトの構成ファイルを開いて編集できます。また、コンパイル済クラス、JARファイル、WARファイル、および生成されたJavadocドキュメントなどのビルド出力も表示できます。「ファイル」ウィンドウは、「ウィンドウ」>「ファイル」(Windowsの場合は[Ctrl]-[2]、OS Xの場合は[Cmd]-[2])を選択して開くことができます。

「ファイル」ウィンドウと「プロジェクト」ウィンドウ

注意: プロジェクト・ディレクトリ外のファイルやディレクトリにアクセスする必要がある場合は、「お気に入り」ウィンドウを使用します。「お気に入り」は、「ウィンドウ」>「お気に入り」((Windowsの場合は[Ctrl]-[3]、OS Xの場合は[Cmd]-[3])を選択して開きます。「お気に入り」ウィンドウを右クリックし、「お気に入りに追加」を選択すると、「お気に入り」ウィンドウにフォルダやファイルを追加できます。

プロジェクトのインポート

この項では、IDEへのプロジェクトの初期インポートの処理方法について説明します。

Eclipseワークスペースのインポート

Eclipseプロジェクトの場合は、Eclipseプロジェクトのインポート・ウィザードを使用して、Eclipseワークスペース内のプロジェクトからNetBeansプロジェクトを作成し、プロジェクトのクラスパスやその他の設定をインポートできます。Eclipseプロジェクトのインポート・ウィザードを使用すると、NetBeansプロジェクトを手動で作成したり構成する必要がありません。「ファイル」>「プロジェクトをインポート」>「Eclipseプロジェクト」を選択してウィザードを開きます。ウィザードの動作や、EclipseプロジェクトとNetBeansプロジェクトで同時に作業する方法については、EclipseプロジェクトのNetBeans IDEへのインポートを参照してください。

既存のソースに基づいたJavaプロジェクトの設定

NetBeans以外で開発されたその他のJavaプロジェクトについては、新規プロジェクト・ウィザードで「既存のソース」テンプレートを使用して、NetBeansプロジェクトを作成します。ウィザードで、ソースの場所を識別し、NetBeansプロジェクト・メタデータの場所を指定します。その後、「プロジェクト・プロパティ」ダイアログ・ボックスを使用してプロジェクトを構成します。

既存のJavaアプリケーション用にNetBeansプロジェクトを設定するには:

  1. ファイル」>「新規プロジェクト」(Windowsの場合は[Ctrl]-[Shift]-[N]、OS Xの場合は[Cmd]-[Shift]-[N])を選択します。
  2. Java」>「既存のソースを使用するJavaプロジェクト」を選択します。「次」をクリックします。
  3. ウィザードの名前と場所ページで、次の手順を実行します。
    • プロジェクト名を入力します。
    • (オプション)プロジェクト・フォルダの場所を変更します。
    • (オプション) IDEで使用されるビルド・スクリプトの名前を変更します。ソースのビルドに使用されるbuild.xmlという名前のビルド・スクリプトがすでに存在する場合は、これを行うことをお薦めします。
    • (オプション)「ライブラリの格納用に専用フォルダを使用」チェックボックスを選択し、ライブラリ・フォルダの場所を指定します。このオプションの詳細は、プロジェクト・ライブラリの共有を参照してください。
    • (オプション)「メイン・プロジェクトとして設定」チェックボックスを選択します。このオプションを選択すると、メイン・プロジェクトを消去してビルド([Shift]-[F11])などのコマンドのキーボード・ショートカットが、このプロジェクトに適用されます。
  4. 「次」をクリックして、ウィザードの既存のソース・ページに進みます。
  5. 「ソース・パッケージ・フォルダ」ペインで、「フォルダの追加」をクリックします。次に、ソースに移動し、ソース・ルートを選択して「開く」をクリックします。

    ソース・コードが含まれているフォルダを追加するときには、パッケージ・ツリー内で最上位のフォルダを含むフォルダを追加する必要があります。たとえば、com.mycompany.myapp.uiパッケージの場合、comフォルダを含むフォルダを追加します。

  6. (オプション)「テスト・パッケージ・フォルダ」ペインで「フォルダの追加」をクリックして、JUnitパッケージ・フォルダを含むフォルダを選択します。
  7. 「次」をクリックして、ウィザードの含める/除外するページに進みます。
  8. (オプション)ウィザードの含める/除外するページで、プロジェクトに含めるファイル、またはプロジェクトから除外するファイルの、ファイル名パターンを入力します。デフォルトでは、ソース・ルートのすべてのファイルが含まれます。
  9. 「終了」をクリックします。

既存のソースに基づいたWebプロジェクトの設定

NetBeans以外で開発されたWebプロジェクトについては、新規プロジェクト・ウィザードで「既存のソース」テンプレートを使用して、NetBeansプロジェクトを作成します。ウィザードで、ソースの場所を識別し、NetBeansプロジェクト・メタデータの場所を指定します。その後、「プロジェクト・プロパティ」ダイアログ・ボックスを使用してプロジェクトを構成します。

注意: プロジェクトが最初にEclipseで開発された場合は、新規プロジェクト・ウィザードのかわりにEclipseプロジェクトのインポート・ウィザードを使用することで時間を節約できる可能性があります。Eclipseプロジェクトのインポート・ウィザードでは、複数のプロジェクトをそれらの構成も含めて同時にインポートできます。EclipseプロジェクトのNetBeans IDEへのインポートを参照してください。

既存のWebアプリケーション用にNetBeansプロジェクトを設定するには:

  1. ファイル」>「新規プロジェクト」(Windowsの場合は[Ctrl]-[Shift]-[N]、OS Xの場合は[Cmd]-[Shift]-[N])を選択します。
  2. Java Web」>「既存のソースを使用するWebアプリケーション」を選択します。「次」をクリックします。
  3. ウィザードの名前と場所ページで、次の手順を実行します。
    • 「場所」フィールドに、Webアプリケーションのソース・ルート・フォルダおよびWebページ・フォルダを含むフォルダを入力します。
    • プロジェクト名を入力します。
    • (オプション)プロジェクト・フォルダの場所を変更します。
  4. (オプション)「ライブラリの格納用に専用フォルダを使用」チェックボックスを選択し、ライブラリ・フォルダの場所を指定します。このオプションの詳細は、NetBeans IDEでのプロジェクト・ライブラリの共有を参照してください。
  5. (オプション)「メイン・プロジェクトとして設定」チェックボックスを選択します。このオプションを選択すると、メイン・プロジェクトを消去してビルド([Shift]-[F11])などのコマンドのキーボード・ショートカットが、このプロジェクトに適用されます。
  6. 「次」をクリックして、ウィザードのサーバーと設定ページに進みます。
  7. (オプション)プロジェクトを既存のエンタープライズ・アプリケーションに追加します。
  8. デプロイ先のサーバーを選択します。目的のサーバーが表示されない場合は、「追加」をクリックしてそのサーバーをIDEに登録します。
  9. ソース・レベルを、アプリケーションを実行するJavaのバージョンに設定します。
  10. (オプション)コンテキスト・パスを調整します。デフォルトでは、コンテキスト・パスはプロジェクト名に基づいています。
  11. 「次」をクリックして、ウィザードの既存のソースとライブラリ・ページに進みます。
  12. 「Webページ・フォルダ」や「ソース・パッケージ・フォルダ」の値など、ページ上のすべてのフィールドを確認します。
  13. 「終了」をクリックします。

自由形式プロジェクト

自由形式プロジェクト用のプロジェクト・テンプレートもあります。自由形式プロジェクトの場合、IDEは既存のAntスクリプト内のターゲットを使用して、アプリケーションのビルド、実行、消去、テスト、およびデバッグを行います。いずれかの機能に対応するターゲットがAntスクリプトに含まれていない場合、それらの機能をプロジェクトで使用することはできません。それらの機能を実装するには、AntスクリプトまたはセカンダリAntスクリプト内にターゲットを記述します。

一般に、プロジェクトのインポートには標準の「既存のソースを使用する」プロジェクト・テンプレートを使用することをお薦めします。Eclipseプロジェクトの場合は、標準のプロジェクトを作成および構成する、「プロジェクトをインポート」機能を使用するのが最適です。標準のプロジェクトのほうが、長期的に見れば管理が容易です。ただし、標準のプロジェクト内では複製できない、複雑または特有な構成を持つAntベースの既存のプロジェクトがある場合は、自由形式プロジェクトのテンプレートが便利です。たとえば、クラスパスがそれぞれ異なる複数のソース・ルートを持つプロジェクトをインポートしており、それらのソース・ルートを別のプロジェクトに分割できないときには、自由形式プロジェクトのテンプレートを使用することが必要な場合があります。

このガイドでは、標準のプロジェクトに重点を置いています。自由形式プロジェクトの設定の詳細は、自由形式プロジェクトの詳細構成を参照してください。

クラスパスおよびその他のプロジェクト設定の構成

この項では、プロジェクトのターゲットJDKの設定、クラスパスの設定、プロジェクト間の依存性の作成、プロジェクトとユーザーとの間のライブラリの共有など、プロジェクト設定の最も一般的なタスクについて説明します。

メイン・プロジェクトの設定

多数のソース・フォルダで構成される大規模なアプリケーションを開発する際には、コードを分割して独立した複数のプロジェクトにまとめることがあります。通常、これらのプロジェクトの1つは、アプリケーションのエントリ・ポイントとして機能します。アプリケーションへのメインのエントリ・ポイントとなるプロジェクトをIDEに対して指定するには、そのプロジェクトをメイン・プロジェクトとして設定します。メイン・プロジェクトに関するコマンドはIDEで提供されています。たとえば、メイン・プロジェクトを消去してビルド・コマンドを実行すると、メイン・プロジェクトと、その必須プロジェクトのすべてがビルドされます。

プロジェクトをメイン・プロジェクトに設定するには:

  • 「プロジェクト」ウィンドウでプロジェクトのノードを右クリックし、「メイン・プロジェクトとして設定」を選択します。

メイン・プロジェクトに指定できるプロジェクトは、一度に1つのみです。

プロジェクトにおけるターゲットJDKの設定

IDEでは、複数のJavaプラットフォームを登録でき、各プラットフォームに対してJavadocやソース・コードを添付できます。標準プロジェクト用のターゲットJDKを切り換えると、処理は次のように変更されます。

  • コード補完の実行時には、新規JDKのクラスが優先して使用されます。
  • ターゲットのJDKのソース・コードとJavadocドキュメントがある場合は、それらが表示されます。
  • アプリケーションのコンパイルおよび実行に、ターゲットJDKの実行可能ファイル(javacおよびjava)が使用されます。
  • ターゲットJDKのライブラリを使用してソース・コードをコンパイルします。

デフォルトでは、IDEは、IDEプロジェクト用のデフォルトのJavaプラットフォームとしてIDEそのものの実行に使用されているJava SEプラットフォーム(JDK)のバージョンを使用します。「ヘルプ」>「製品について」を選択することによって、IDEのJDKバージョンを表示できます。「Java」フィールドにJDKのバージョンが表示されます。

別のバージョンのJDKでIDEを実行するには:

  • 次のスイッチを使用して、コマンド行からIDEを起動します。
    --jdkhome jdk-home-dir

    または、IDEのインストール・フォルダ内にある/etc/netbeans.confファイルでJDKを設定します。

新規Javaプラットフォームを登録するには:

  1. メイン・メニューから「ツール」>「Javaプラットフォーム」を選択します。
  2. Javaプラットフォームが含まれているフォルダと、デバッグに必要なソースおよびJavadocを指定します。

Javaプラットフォーム・マネージャ

標準プロジェクトのターゲットJDKを切り替えるには:

  1. プロジェクト・ノードを右クリックし、「プロパティ」を選択します。
  2. 「ライブラリ」パネルを選択します。
  3. Javaプラットフォーム・プロパティを変更します。

プロジェクトのクラスパスの管理

プロジェクトのクラスパスにクラス・ファイルのグループを追加すると、コンパイルおよび実行中にプロジェクトがアクセスする必要があるクラスをIDEに指示できます。また、IDEはクラスパス設定を使用して、コード補完、コンパイル・エラーの自動強調表示、およびリファクタリングを有効にします。既存のプロジェクトのクラスパス宣言は、「プロジェクト・プロパティ」ダイアログ・ボックスで編集できます。

標準のJavaプロジェクトでは、IDEが、プロジェクトのコンパイルと実行用のクラスパスと、Java SEアプリケーションの場合のJUnitテストのコンパイルと実行用のクラスパスを、個別に維持します。IDEでは、プロジェクトのコンパイル・クラスパスのすべてがプロジェクトの実行時クラスパスに自動的に追加されます。

プロジェクトのクラスパスは、次のいずれかの方法で変更できます。

  • プロジェクトのノードを右クリックして「プロパティ」を選択し、「ライブラリ」カテゴリを選択して、表示されているクラスパス・エントリを変更します。
  • 「プロジェクト」ウィンドウで「ライブラリ」ノードを右クリックし、「プロジェクトの追加」、「ライブラリの追加」または「JAR/フォルダの追加」を選択します。

ライブラリ・マネージャでJavadocおよびソース・ファイルをJARファイルに添付した場合、プロジェクトのクラスパスにJARファイルを登録すると、IDEではJavadocおよびソース・ファイルがプロジェクトに自動的に追加されます。この構成のみで、クラスを表示してそのクラスのJavadocページを参照することもできます。

「プロジェクト・プロパティ」ダイアログ・ボックス

プロジェクト間の依存性の管理

アプリケーションが複数のプロジェクトで構成されている場合は、プロジェクト間のクラスパス依存性を設定する必要があります。通常は、プロジェクトのメイン・クラスを含む1つのメイン・プロジェクトをJava SEプロジェクトに設定し、さらにいくつかの必須プロジェクトを設定します。必須プロジェクトとは、別のプロジェクトのクラスパスに追加されているプロジェクトです。プロジェクトを消去してビルドすると、IDEではその必須プロジェクトも消去してビルドされます。必須プロジェクトのJavadocとソースは、受け側のプロジェクトからも利用できるようになります。

必須プロジェクトは、「プロジェクト」ウィンドウで「ライブラリ」ノードを右クリックするか、「プロジェクト・プロパティ」ダイアログ・ボックスの「ライブラリ」タブで指定することによって、プロジェクトに追加できます。必須プロジェクトを追加するときは、クラスパスに追加するJARファイルを含むプロジェクト・フォルダを選択します(ファイル・チューザには、IDEプロジェクト・フォルダのアイコン(プロジェクト・フォルダ・アイコン)が表示されます)。「プロジェクト・プロパティ」ダイアログ・ボックスでプロジェクトを追加するときは、「クラスパス上のプロジェクトをビルド」チェックボックスが選択されていることを確認します。

自由形式プロジェクトを標準プロジェクトのクラスパスに追加する場合は、自由形式プロジェクトのJARファイルを標準プロジェクトのクラスパスに追加する必要があります。これを行うには、まず自由形式プロジェクトのすべての出力ファイルを、自由形式プロジェクトの「プロジェクト・プロパティ」ダイアログ・ボックスの「出力」パネルで宣言する必要があります。

プロジェクト・ライブラリの共有

NetBeans IDEのプロジェクト・システムはAntベースのため、NetBeansプロジェクトはIDEを使用しているかどうかにかかわらず、異なるユーザー間ですでに一般的に移植できます。ただし、デフォルトでは、プロジェクトのビルド・スクリプトがライブラリを参照する方法は、特に「ライブラリ・マネージャ」ダイアログ・ボックスで定義されたライブラリの場合、各ユーザーに固有の要素に依存します。

たとえば、通常は、プロジェクトをzipファイルにして別のユーザーに渡し、そのユーザーがプロジェクトを展開して実行できます。しかし、「ライブラリ・マネージャ」ダイアログ・ボックスで指定したカスタム・ライブラリにプロジェクトが依存する場合は、カスタム・ライブラリへの参照が未解決のため、他のユーザーがプロジェクトをビルドする際、最初に問題が発生する可能性があります。

その他に不都合を引き起こす可能性があるのは、どこが元になっているかによって、そのライブラリが様々な場所に保存されていることです。IDEに付属するライブラリはIDEのインストール場所内の様々なフォルダに保存されています。これらの例には、Swingレイアウト拡張、Beans Binding、およびデータベース・ドライバが含まれます。

これらの問題を解決するには、プロジェクト・ライブラリ用に専用フォルダを指定します。また、これらのライブラリを参照する場合に相対パスを使用するか絶対パスを使用するかを管理できます。

この柔軟性によって、次のような状況を簡単に処理できます。

  • プロジェクトを作成して、そのプロジェクトを他のユーザーが使用したりビルドできるようにする場合(他のユーザーがIDEを使用しているかどうかに関係なく)。他のユーザーは、バージョン管理のチェックアウト、または提供されるzipファイルの展開によって、プロジェクトにアクセスできる必要があります。また、追加の構成を行わずにアプリケーションをビルドできる必要があります。
  • 既存のプロジェクトで作業を開始し、プロジェクト・ライブラリの保存場所(およびビルド・スクリプトがライブラリを相対パスで参照するか、絶対パスで参照するか)について厳しい規則に従う必要がある場合。

標準のJava SEプロジェクト、Webプロジェクト、およびエンタープライズ・プロジェクト用に、専用のライブラリ・フォルダを設定できます。新規プロジェクト・ウィザードでプロジェクトを作成したとき、またはその後「プロジェクト・プロパティ」ダイアログ・ボックスの「ライブラリ」タブで、ライブラリ・フォルダを設定できます。

プロジェクトの作成時に一般的なJavaプロジェクトのライブラリを共有可能にする

  1. ファイル」>「新規プロジェクト」を選択します。
  2. ウィザードの「Java」カテゴリで、標準テンプレートを1つ選択します。「次」をクリックします。
  3. ウィザードの名前と場所ページで、「ライブラリの共有用に専用フォルダを使用」チェックボックスを選択します。
  4. 「ライブラリ・フォルダ」フィールドで、ライブラリを格納する場所を選択します。

    ライブラリがすでにIDEに含まれる場合、これらのライブラリは指定したフォルダにコピーされます。

プロジェクト作成時にWebプロジェクトまたはJava EEプロジェクトのライブラリを共有可能にする

  1. ファイル」>「新規プロジェクト」を選択します。
  2. ウィザードの「Web」カテゴリで、標準テンプレートを1つ選択します。「次」をクリックします。
  3. ウィザードの名前と場所ページで、「ライブラリの共有用に専用フォルダを使用」チェックボックスを選択します。
  4. 「ライブラリ・フォルダ」フィールドで、ライブラリを格納する場所を選択します。

    ライブラリがすでにIDEに含まれる場合、これらのライブラリは指定したフォルダにコピーされます。

既存のプロジェクトのライブラリを共有可能にする

  1. プロジェクト・ノードを右クリックし、「プロパティ」を選択します。
  2. 「プロジェクト・プロパティ」ダイアログ・ボックスで「ライブラリ」ノードを選択します。
  3. 「ライブラリ」パネルで「参照」をクリックして、新規ライブラリ・フォルダ・ウィザードを開きます。
  4. ウィザードのライブラリ・フォルダ・ページでライブラリの場所を入力し、「次」をクリックします。
    場所は、相対パスまたは絶対パスとして入力できます。
  5. ウィザードの「アクション」パネルで、リストされた各ライブラリに選択されているアクションを確認します。ほとんどの場合、各ライブラリに最適なアクションがIDEによって検出されます。

    次のアクションがあります。

    • ライブラリJARファイルを新規ライブラリ・フォルダにコピー。このオプションは、選択したフォルダ内にライブラリがなく、ライブラリJARファイルをここに配置する場合に使用します。
    • ライブラリJARファイルの相対パスを使用。このオプションは、ライブラリがライブラリ・フォルダ内になく、相対パスを使用して既存の場所にあるライブラリにアクセスする場合に使用します。ライブラリ・フォルダのnblibraries.propertiesファイルに、ライブラリへの相対参照のエントリが追加されます。
    • ライブラリJARファイルの絶対パスを使用。このオプションは、ライブラリがライブラリ・フォルダ内になく、絶対パスを使用して既存の場所にあるライブラリにアクセスする場合に使用します。ライブラリ・フォルダのnblibraries.propertiesファイルに、ライブラリへの絶対参照のエントリが追加されます。
    • ライブラリ・フォルダ内の既存のライブラリを使用。このオプションは、ライブラリ・フォルダにライブラリのコピーがすでに存在し、ライブラリのそのコピーを使用する場合に使用します。
  6. 「終了」をクリックして、プロジェクトを共有可能にするウィザードを終了します。
  7. 「OK」をクリックして、「プロジェクト・プロパティ」ダイアログ・ボックスを終了します。

注意: 「プロジェクト・プロパティ」ダイアログ・ボックスの「ライブラリ」ノードを使用して、ライブラリ・フォルダの場所を変更することもできます。ライブラリ・フォルダをすでに指定してある場合は、「参照」をクリックしたときに新規ライブラリ・フォルダ・ウィザードではなくファイル・チューザが表示されます。

IDEで使用可能なJavadocの作成

NetBeans IDEでJava SE APIのドキュメントを表示するには、「ソース」>「ドキュメントを表示」コマンドを使用するか、またはメイン・メニューから「ウィンドウ」>「その他」>「Javadoc」を選択して、別のウィンドウでAPIのドキュメントを表示します。

ただし、いくつかの他社製のライブラリには、APIドキュメントを使用できません。その場合、Javadocリソースを手動でIDEに関連付ける必要があります。

Javadocを表示コマンドで使用可能なJavadoc APIドキュメントを作成する

  1. Javadoc APIドキュメントのソースをダウンロードします。
  2. ツール」>「ライブラリ」を選択します。
  3. ライブラリ・リストで、プロジェクトが使用しているライブラリを選択します。
  4. 「Javadoc」タブをクリックします。
  5. 「ZIP/フォルダを追加」ボタンをクリックし、システム上のJavadoc APIドキュメントを含むZIPファイルまたはフォルダに移動します。ZIPファイルまたはフォルダを選択し、「ZIP/フォルダを追加」ボタンをクリックします。
  6. 「OK」をクリックします。

アプリケーションのJava Web Startの有効化

IDEでJava Web Startをステップ実行するように、アプリケーションを構成できます。これを行うには、「プロジェクト・プロパティ」ウィンドウの「Java Web Start」カテゴリを使用します。Java Web Startを有効化する方法の詳細は、NetBeans IDEでのJava Web Startの有効化のチュートリアルを参照してください。

アプリケーションのJava Web Startを構成するには:

  1. プロジェクト・ノードを右クリックし、「プロパティ」を選択します。
  2. 「プロジェクト・プロパティ」ダイアログ・ボックスで、「アプリケーション」>「Web Start」ノードを選択します。
  3. 「Web Startを有効化」チェックボックスを選択し、NetBeans IDEでのJava Web Startの有効化の説明に従ってJava Web Start設定を構成します。

アプリケーションのビルド

この項では、IDEでの標準プロジェクトのビルド方法、ビルド・プロセスの基本的なカスタマイズ方法、およびコンパイル・エラーの処理方法について説明します。

プロジェクト、パッケージ、およびファイルのビルド

IDEでのコンパイルは単純です。プロジェクトのコンパイル時クラスパスが正しく設定されている場合は、コンパイルするプロジェクト、パッケージ、またはファイルを選択し、「実行」メニューから適切なビルド・コマンドまたはコンパイル・コマンドを選択するのみです。これにより、IDEでファイルがコンパイルされます。

Javaプロジェクト用に「保存時にコンパイル」機能が有効化されている場合や、Java Webプロジェクトやエンタープライズ・プロジェクト用に「保存時にデプロイ」機能が有効化されている場合は、IDEによって保存時にファイルが自動的にコンパイルされます。詳細は、後述する保存時にコンパイルを参照してください。

デプロイメント用にアプリケーションをビルドするには:

  • 実行」>「プロジェクトを消去してビルド」を選択します。

    以前にコンパイルされたファイルや、JARファイルなどの配布可能な出力がすべて削除されます。次に、ファイルが再コンパイルされ、新しい出力が生成されます。コンパイルされたクラスを保持するためのbuildフォルダが作成されます。JARファイルやJavadocドキュメントなどの配布可能な出力を格納するためのdistが生成されます。「ファイル」ウィンドウを開いて、ビルド出力を確認できます。

コンパイル・コマンドを呼び出すたびに、後述するコンパイル・エラーの修正で説明するように、発生したコンパイル・エラーを含む出力が「出力」ウィンドウに表示されます。

保存時にコンパイル

IDEの「保存時にコンパイル」機能を使用すると、IDEでプロジェクトを実行およびデバッグする際の時間が短縮されます。プロジェクト用に「保存時にコンパイル」機能が有効化されている場合は、ファイルの保存時にそれらのファイルがコンパイルされます。コンパイルされたファイルは、IDEでプロジェクトを実行、テスト、デバッグ、およびプロファイルするときに使用されるキャッシュに格納されます。このため、アプリケーションのテストおよびデバッグを行うとき、最初にアプリケーションがビルドされるまで待つ必要がありません。

「保存時にコンパイル」機能を有効にすると、次のような効果があります。

  • IDEでは保存時にファイルがコンパイルされるため、プロジェクトは常にIDEで実行可能またはデバッグ可能な状態になります。
  • ビルド・コマンドが無効になります。「消去してビルド」コマンドを使用せずにJARファイルを再ビルドする場合は、「保存時にコンパイル」機能を無効にする必要があります。
  • 実行、デバッグ、プロファイル、またはテストのコマンドを使用する際に、プロジェクトのAntスクリプトは使用されません。これらのいずれかのコマンド用にビルド・スクリプトをカスタマイズした場合、そのカスタマイズ内容は無視されます。
  • ファイルに加えた変更を保存するときに、プロジェクトからビルドされたJARファイルは最新の状態に変更されません。JARファイルをビルドまたは再ビルドするには、「消去してビルド」コマンドを使用する必要があります。「保存時にコンパイル」が有効になっているかどうかに関係なく、「消去してビルド」コマンドでは、常にプロジェクトのAntスクリプトが使用されます。

デフォルトでは、プロジェクトを新たに作成する場合は「保存時にコンパイル」機能が有効化されます。既存のプロジェクトの場合は、「保存時にコンパイル」機能が無効になります。

Javaプロジェクトで「保存時にコンパイル」機能を有効または無効にするには:

  1. プロジェクト・ノードを右クリックし、「プロパティ」を選択します。
  2. 「コンパイル」ノードを選択し、「保存時にコンパイル」プロパティを設定します。

同様に、IDEには、Java Webアプリケーションおよびエンタープライズ・アプリケーション用に「保存時にデプロイ」機能も用意されています。プロジェクトで「保存時にデプロイ」機能が有効化されていて、そのプロジェクトがIDEを介してサーバーにデプロイされている場合、変更されたファイルはすぐにそのサーバーに再デプロイされます。「保存時にデプロイ」がGlassFish V2で機能するには、Glassfishインスタンスで、ディレクトリ・デプロイメント有効オプションが選択されている必要があります。

Java Webまたはエンタープライズ・プロジェクトで「保存時にデプロイ」機能を有効または無効にするには:

  1. プロジェクト・ノードを右クリックし、「プロパティ」を選択します。
  2. 「実行」ノードを選択し、「保存時にデプロイ」プロパティを設定します。

ディレクトリ・デプロイメントGlassfish V2を有効化するには:

  1. ツール」>「サーバー」を選択します。
  2. サーバーを選択します。
  3. 「オプション」タブを選択します。
  4. ディレクトリ・デプロイメント有効オプションを選択します。

コンパイル・エラーの修正

IDEでは、出力メッセージとコンパイル・エラーが「出力」ウィンドウに表示されます。複数のタブを持つこのウィンドウは、コンパイル・エラーの生成時、プログラムのデバッグ時、Javadocドキュメントの生成時などに自動的に表示されます。また、このウィンドウは、「ウィンドウ」>「出力」(Windowsの場合は[Ctrl]-[4]、OS Xの場合は[Cmd]-[4])を選択して手動で開くことができます。

また、コンパイル・エラーは、「タスク」ウィンドウにも表示され、ソース・エディタでマークされます。

「出力」ウィンドウの重要な機能の1つは、プログラムのコンパイル中に見つかったエラーを通知することです。次のイメージに示すように、エラー・メッセージは青い下線付きのテキストで表示され、ソース・コード内のエラーが発生した行にリンクされています。「出力」ウィンドウには、Antビルド・スクリプトを実行したときに見つかったエラーへのリンクもあります。「出力」ウィンドウでエラー・リンクをクリックすると、ソース・エディタは、そのエラーが含まれている行に自動的に移動します。

コンパイル・エラーが表示された「出力」ウィンドウ

ファイルのコンパイルや実行、デバッグなどの、Antスクリプトが実行するすべてのアクションの出力は、同じ「出力」ウィンドウのタブに送信されます。「出力」ウィンドウに表示されたメッセージを保存する必要がある場合は、そのメッセージを別のファイルにコピーして貼り付けることができます。新しいターゲットそれぞれのコマンド出力を新しい「出力」ウィンドウ・タブに出力するようにAntを設定することもできます。これを行うには、「ツール」>「オプション」を選択し、「その他」カテゴリを選択し、「Ant」タブをクリックし、「終了したプロセスの出力タブを再利用」プロパティのチェックボックスを選択解除します。

出力ファイルのフィルタリング

JARファイルやWARファイルを作成するときには、通常、コンパイルされた.classファイルと、リソース・バンドルやXMLドキュメントなど、ソース・ディレクトリに置かれているその他のリソース・ファイルのみを含めます。デフォルトのフィルタは、出力ファイルからすべての.javaファイル、.nbattrsファイル、および.formファイルを除外することで、自動的にこの処理を行います。

正規表現を使用して追加のフィルタを作成し、出力ファイルを制御できます。除外するファイルを指定するには、「プロジェクト」ウィンドウでプロジェクトを右クリックし、「プロパティ」を選択して「プロジェクト・プロパティ」ダイアログ・ボックスを表示します。左側ペインで、「パッケージング」をクリックします。右ペインでテキスト・ボックスに正規表現を入力して、JARファイルまたはWARファイルのパッケージング時に除外するファイルを指定します。デフォルトの式に加えて、使用可能な正規表現がいくつかあります。

正規表現 説明
\.html$ すべてのHTMLファイルを除外
\.java$ すべてのJavaファイルを除外
(\.html$)|(\.java$) すべてのHTMLファイルおよびJavaファイルを除外
(Key)|(\.gif$) すべてのGIFファイルと、名前にKeyが含まれるすべてのファイルを除外

正規表現の構文については、jakarta.apache.orgを参照してください。

アプリケーションの実行

この項では、IDEでのプロジェクトの実行方法と、プロジェクトのメイン・クラス、実行時引数、VM引数、および作業ディレクトリの構成方法について説明します。

プロジェクトおよびファイルの実行

Javaプロジェクトの場合は、通常、プログラムのメイン・クラスを含むプロジェクトをメイン・プロジェクトとして設定します。Webプロジェクトの場合、メイン・プロジェクトは最初にデプロイされたプロジェクトです。プロジェクト、パッケージ、またはファイルを実行するには、次のいずれかを選択します。

  • メイン・メニューで、「実行」>「メイン・プロジェクトの実行」([F6])を選択して、メイン・プロジェクトを実行します。また、ツールバーの「メイン・プロジェクトの実行」ボタンを使用することもできます。
  • 「プロジェクト」ウィンドウで、プロジェクトを右クリックし、「実行」を選択してプロジェクトを実行します。Javaプロジェクトの場合は、プロジェクトにメイン・クラスが必要です。
  • 「プロジェクト」ウィンドウでファイルを右クリックし、「ファイルを実行」([Shift]+[F6])を選択してファイルを実行します。または、メイン・メニューで「実行」>「ファイルを実行」>「filenameを実行」([Shift]+[F6])を選択して、実行可能なクラスを実行します。

プロジェクトを実行すると、IDEでコンパイル・エラーと出力が「出力」ウィンドウに表示されます。詳細は、コンパイル・エラーの修正を参照してください。

注意: プロジェクトで「保存時にコンパイル」が有効化されている場合、「プロジェクトの実行」コマンドは、これらのファイルを保存したときに作成されたクラス・ファイルに対して作用します。Antビルド・スクリプトは使用されません。ビルド・スクリプトでカスタム手順を定義した場合、それらの手順には従いません。「プロジェクトの実行」、「プロジェクトをデバッグ」、または「プロジェクトをプロファイル」を使用するときに、すべてのビルド・プロセスを実行するには、「保存時にコンパイル」を無効にします。

実行時オプションのカスタマイズ

デフォルトでは、IDEでメイン・クラス、実行時引数、またはJVM引数は指定されません。各標準プロジェクトの実行時クラスパスには、プロジェクトのコンパイル済クラスと、プロジェクトのコンパイル時クラスパスにあるすべての生成物が含まれます。プロジェクトのコンパイル時クラスパスを表示するには、「プロジェクト・プロパティ」ダイアログ・ボックスを表示し、「カテゴリ」ペインで「ライブラリ」ノードを選択してから、右ペインで「コンパイル」タブをクリックします。

プロジェクト実行時オプションを変更するには、「プロジェクト」ウィンドウでプロジェクトのノードを右クリックして「プロパティ」を選択し、「プロジェクト・プロパティ」ダイアログ・ボックスを表示します。次に、「カテゴリ」ペインで「ライブラリ」ノードを選択し、ダイアログ・ボックスの右ペインで「実行」タブをクリックします。メイン・クラスの設定、プログラム引数、プログラム実行用の作業ディレクトリ、およびVMオプションにアクセスするには、「実行」ノードを選択する必要があります。次の項では、実行時クラスパスの構成方法について詳しく見て行きます。

「プロジェクト・プロパティ」ダイアログ・ボックスでの実行時設定の指定

実行時クラスパスの設定

プロジェクト、ライブラリ、JARファイル、およびフォルダをプロジェクトの実行時クラスパスに追加するには、「プロジェクト・プロパティ」ダイアログ・ボックス内の「実行時ライブラリ」リストの右側にあるボタンを使用します。

プロジェクトが、間接インタフェースまたはリフレクションを使用して、実行時に動的に特殊なライブラリ(JDBCドライバあるいはJAXP実装など)を使用する場合は、それらのライブラリを実行時クラスパスに追加してください。また、プロジェクト間の実行時の依存性が、コンパイル時の依存性と異なる場合も、実行時クラスパスを調整する必要があります。たとえば、プロジェクトAがプロジェクトBに対してコンパイルされ、プロジェクトBがプロジェクトCに対してコンパイルされるが、プロジェクトAはプロジェクトCに対してコンパイルされないとします。このことは、プロジェクトAの実行時クラスパスには、プロジェクトBのみ存在することを意味します。実行中のプロジェクトAがプロジェクトBとCの両方を必要とする場合は、プロジェクトAの実行時クラスパスにプロジェクトCを追加する必要があります。

メイン・クラスと実行時引数の設定

プロジェクトのメイン・クラスを設定するには、「プロジェクト・プロパティ」ダイアログ・ボックスの「カテゴリ」ペインで「実行」ノードを選択し、完全修飾名を「メイン・クラス」フィールドに入力します(例: org.myCompany.myLib.MyLibClass)。メイン・クラスは、プロジェクト内か、プロジェクトの実行時クラスパスにあるJARファイルまたはライブラリのいずれかに存在する必要があります。その後、必要な実行時引数を「引数」フィールドに入力します。

「参照」ボタンを使用してプロジェクトのメイン・クラスを選択すると、ファイル・チューザにプロジェクトのソース・ディレクトリ内のクラスのみ表示されます。クラスパス上にあるライブラリにあるクラスを指定する場合は、「メイン・クラス」フィールドにそのクラスの完全修飾名を入力する必要があります。

JVM引数の設定

プロジェクトのJVM引数は、「プロジェクト・プロパティ」ダイアログ・ボックスで指定できます。「プロジェクト・プロパティ」ダイアログ・ボックスを表示し、「カテゴリ」ペインで「実行」をクリックしてから、「VMオプション」フィールドにスペースで区切られたJVM引数のリストを入力します。

「VMオプション」フィールドで次を入力することによって、システム・プロパティを設定することができます。

-Dname=value

ビルド・スクリプトのカスタマイズ

標準プロジェクトでは、IDEにより、新規プロジェクト・ウィザードおよびプロジェクトの「プロジェクト・プロパティ」ダイアログ・ボックスに入力したオプションに基づいて、ビルド・スクリプトが生成されます。基本的なコンパイル・オプションと実行時オプションはすべてプロジェクトの「プロジェクト・プロパティ」ダイアログ・ボックスに設定可能で、IDEによってプロジェクトのAntスクリプトが自動的に更新されます。ビルド・プロセスの追加要件に、「プロジェクト・プロパティ」ダイアログ・ボックスでは処理できないものがある場合は、ビルド・スクリプトを直接変更できます。

標準プロジェクトのメインのAntスクリプトは、build.xmlです。IDEコマンドを実行すると、IDEによってbuild.xml内のターゲットがコールされます。このファイルには、IDEによって生成されたビルド・ターゲットを含むnbproject/build-impl.xmlをインポートする、インポート文が含まれています。build.xmlでは、nbproject/build-impl.xmlからのターゲットをオーバーライドしたり、新しいターゲットを作成したりできます。nbproject/build-impl.xmlファイルは「プロジェクト・プロパティ」ダイアログ・ボックスで加えた変更に基づいて再生成されるため、直接編集しないでください

また、ビルド・スクリプトでは、手動で編集できるnbproject/project.propertiesが使用されます。

標準プロジェクトの場合は、次のいずれかを実行してビルド・プロセスをカスタマイズできます。

  • クラスパス設定やJARフィルタなどの基本的なオプションを、プロジェクトを作成するときに新規プロジェクト・ウィザードで、または後で「プロジェクト・プロパティ」ダイアログ・ボックスに入力します。
  • nbproject/project.properties内のプロパティを編集します。このファイルには、ソース・フォルダや出力フォルダの場所などの、プロジェクトに関する重要な情報とともにAntプロパティが格納されます。このファイルのプロパティはオーバーライドできます。このファイルを編集するときには注意してください。たとえば、プロジェクトを消去すると、出力フォルダも削除されます。したがって、出力フォルダとソース・フォルダを同じディレクトリに保存する場合は、最初に必ずcleanターゲットを構成して出力フォルダを削除しないようにしてください。
  • 既存のAntターゲットをカスタマイズするか、または新しいAntターゲットを作成するには、次のいずれかを実行します。
    • Antターゲットの実行前または実行後に処理される命令を追加します。nbproject/build-impl.xml内の各メイン・ターゲットには、build.xmlでオーバーライドできる-preおよび-postターゲットもあります。たとえば、RMIを通常のプロジェクトで動作させるには、build.xmlに次の内容を入力します。
      <target name="-post-compile">
        <rmic base="${build.classes.dir}" includes="**/Remote*.class"/>
                          </target>
    • Antターゲットで命令を変更します。nbproject/build-impl.xmlからbuild.xmlにターゲットをコピーし、ターゲットに変更を加えます。
    • build.xmlに新しいターゲットを作成します。新しいターゲットをIDEの既存のターゲットの依存性に追加することもできます。build.xmlで既存のターゲットをオーバーライドしてから、既存のターゲットのdependsプロパティに新しいターゲットを追加します。たとえば、runターゲットの依存性にnew-targetターゲットを追加するには、次のように指定します。
      <target name="new-target">
          <!-- target body... -->
      </new-target>
       
                              <target name="run" depends="new-target,myprojname-impl.run"/>

      build.xmlにrunターゲットの本体をコピーする必要はありません。

次の表は、JARファイルを再定義するのに役立つ、いくつかの一般的なタスクをまとめたものです。

行う作業 手順
JARファイルに追加するファイルを指定する。 「プロジェクト」ウィンドウでプロジェクトのノードを右クリックし、「プロパティ」を選択します。「ビルド」の下の「パッケージング」サブノードをクリックし、「JARファイルから除外」フィールドを使用して、フィルタ設定と圧縮設定を構成します。詳細は、出力ファイルのフィルタリングを参照してください。
JARファイルの名前と場所を変更する。 「ファイル」ウィンドウでプロジェクトのnbproject/project.propertiesファイルをダブルクリックして、このファイルをソース・エディタで開きます。dist.jarプロパティにJARファイルのフル・パスを入力します。
JARファイルのマニフェスト・ファイルを指定する。 project.properties内のmanifest.fileプロパティにマニフェスト・ファイルの名前を入力します。このファイル名は、プロジェクトのbuild.xmlファイルを基準にした相対パスで指定する必要があります。Javaアプリケーション・テンプレートを使用している場合は、IDEによってマニフェスト・ファイルが自動的に作成されます。
プロジェクトのJARファイルの生成を無効にする。 「ファイル」ウィンドウでプロジェクト・フォルダを開き、build.xmlを開きます。jarターゲットをオーバーライドし、コンテンツなし、依存性なしに設定します。たとえばbuild.xmlに次の行を追加します。
<target name="jar" />

Antに関する学習リソースについては、http://ant.apache.org/resources.htmlを参照してください。プラグイン・マネージャを使用して、AntのマニュアルをIDEのヘルプ・システムにインストールすることもできます。「ツール」>「プラグイン」を選択し、Ant Documentationモジュールをインストールします。

Antスクリプトの編集および実行

IDEはAntスクリプトを自動的に認識し、それらのスクリプトを、通常のXMLファイルではなくAntスクリプト・ノード(Antスプリクト・ノード・アイコン)として表示します。「プロジェクト」ウィンドウ、「ファイル」ウィンドウ、または「お気に入り」ウィンドウでAntスクリプトを右クリックして、コマンドのポップアップ・メニューにアクセスできます。また、Antスクリプト・ノードを展開して、Antスクリプトのターゲットを表すサブノードのアルファベット順のリストを表示することもできます。これらのサブノードのそれぞれには、コマンドのポップアップ・メニューもあります。

「プロジェクト」ウィンドウ、「ファイル」ウィンドウ、および「お気に入り」ウィンドウでは、Antスクリプトのサブノードが次のように表示されます。

アイコン 意味
強調されたAntターゲット・アイコン

強調されたAntターゲット。これらのターゲットには、ツールチップとして表示される説明属性が含まれています。ターゲットの説明属性は、ソース・エディタで定義します。

通常のAntターゲット・アイコン 通常のAntターゲット。説明属性を持たないターゲットです。

Antスクリプトのサブノードをダブルクリックすることにより、ソース・エディタ内のそのターゲットの場所まで移動できます。すべての通常のXML検索ツール、選択ツール、およびキーボード・ショートカットを使用してAntスクリプトを編集でき、IDEでは、すべての標準的Antタスクについてコード補完機能が動作します。

コマンド行から実行するターゲットを作成するときには、そのターゲットに説明属性を設定してください。ターゲットの名前や機能を忘れた場合は、ant-projecthelp <script>コマンドをコマンド行から実行できます。このコマンドを実行すると、Antは、説明属性を持つターゲットのみを、それらの説明とともにリストします。特に、Antビルド・スクリプト内に多数のターゲットがある場合、一部のターゲットを強調し、その他のターゲットは強調しないことによって、頻繁に使用するターゲットとそうでないターゲットを簡単に区別できます。

「プロジェクト」、「ファイル」、および「お気に入り」の各ウィンドウに表示されるサブノードのラベルのフォント・スタイルは、次の状態を示します。

  • 通常。現在のAntスクリプト内で定義されているターゲット。
  • イタリック。別のAntスクリプトからインポートされたターゲット。
  • グレー表示。直接には実行できない内部ターゲット。内部ターゲットには、「-」で始まる名前が付けられています。
  • 太字。スクリプトのデフォルト・ターゲット(存在する場合)。デフォルト・ターゲットは、プロジェクトの属性として、プロジェクト名など、プロジェクトのその他の属性とともに宣言されます。プロジェクトのデフォルト属性は、ソース・エディタで定義します。

別のスクリプトからインポートされたが、インポート・スクリプトでオーバーライドされたターゲットは、リストされません。オーバーライドしたターゲットのみがリストされます。

Antスクリプト内のターゲットは、「プロジェクト」ウィンドウ、「ファイル」ウィンドウ、または「お気に入り」ウィンドウでAntスクリプトのノードから実行できます。これを行うには、Antスクリプト・ノードを右クリックし、「ターゲット実行」サブメニューからターゲットを選択します。ターゲットはアルファベット順にソートされます。強調されたターゲットのみがリストされます。説明属性で強調されていないターゲットを実行するには、「その他のターゲット」を選択します。内部ターゲットは別個に実行することができないため、リストから除外されます。

Antスクリプト・ノードのポップアップ・メニューを使用してターゲットを実行するかわりに、そのターゲットのノードを右クリックし、「ターゲット実行」を選択して実行することもできます。

Antターゲットの実行

カスタムAntタスクの書込み

カスタムAntタスクを使用して、Antの組込みタスクで提供される機能を拡張できます。カスタム・タスクは、プロパティの定義、入れ子にされた要素の作成、またはaddTextメソッドを使用したタグ間でのテキストの直接書込みにしばしば使用されます。

IDEでカスタムAntタスクを作成するには:

  1. タスクを配置するパッケージを右クリックし、「新規」>「その他」を選択します。
  2. 「その他」カテゴリと、「カスタムAntタスク」ファイル・タイプを選択します。
  3. ウィザードを完了します。

カスタムAntタスクのファイルを作成するときには、ソース・エディタでテンプレートが開きます。このテンプレートには、Antタスクで実行される多くの一般的な操作のためのサンプル・コードが含まれています。テンプレートでは、コードの各セクションの後に、そのタスクをAntスクリプトで使用する方法も示されています。



関連項目


get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo