NetBeans IDE Java 编辑器中的代码帮助:参考指南

任何集成开发环境 (IDE) 都旨在最大限度提高工作效率,并支持通过单个工具进行无缝开发。本参考文档介绍了 NetBeans IDE 的 Java 编辑器中非常有用的代码帮助功能、定制选项和导航功能。

观看在 NetBeans IDE 中编辑 Java 代码截屏视频,了解如何使用编辑器的工作效率功能。

目录

此页上的内容适用于 NetBeans IDE 6.9 和更高版本

要学完本教程,您需要具备下表所列的软件和资源。

软件或资源 要求的版本
NetBeans IDE 版本 6.9 或更高版本
Java 开发工具包 (JDK) 版本 6 或 7

智能代码完成

NetBeans IDE 的 Java 编辑器中的“智能”代码完成功能可帮助您快速完成和生成代码。通常,如果希望填充缺少的代码,查看在应用程序上下文中提供的选项以及在需要时生成代码块,代码完成是非常有用的。有关如何使用代码完成的示例,请参见以下部分。

调用代码完成

代码完成框

Ctrl-空格键(或者从主菜单中选择 "Source"(源)> "Complete Code"(完成代码))以打开代码完成框。在键入内容时,建议列表将会缩短。列出的建议包括在源文件中导入的建议以及 java.lang 包中的符号。

要定制代码完成设置,请选择 "Tools"(工具)> "Options"(选项)> "Editor"(编辑器)> "Code Completion"(代码完成)。

例如,可以将代码完成窗口设置为自动弹出或仅在需要时弹出。如果在 "Code Completion"(完成代码)标签中选中 "Auto Popup Completion Window"(自动弹出完成窗口)复选框,则可以在键入某些字符时自动调用代码完成窗口。默认字符为 .,但您可以添加自己的字符。

要添加字符以调用代码完成窗口,请从 "Language"(语言)下拉列表中选择 "Java",然后在 "Auto Popup Triggers for Java"(Java 自动弹出式触发器)字段中键入字符。每次键入指定的字符时,将会弹出代码完成窗口。

如果禁用了 "Auto Popup Completion Window"(自动弹出完成窗口)复选框,则需要在每次使用代码完成时按 Ctrl-空格键

顶部的智能建议

带有智能建议的代码完成框

在 NetBeans IDE 中,Java 代码完成是“智能的”,这意味着代码上下文的最相关建议显示在代码完成窗口顶部(黑线上方)。

在左侧的示例中,编辑器建议插入 java.util 包中的 LinkedHashMap 构造函数。

如果“智能”建议并不是要使用的建议,请再次按 Ctrl-空格键以查看完整列表。

完成关键字

完成关键字

可以使用代码完成(Ctrl-空格键)完成代码中的关键字。编辑器将分析上下文,并建议最相关的关键字。

在左侧的示例中,ColorChooserDemo 类扩展 JPanel 类。可以通过建议的项目快速添加 extends 关键字。

为变量和字段建议名称

完成名称和字段

在添加新字段或变量时,可以使用代码完成(Ctrl-空格键)选择与键入内容匹配的名称。

键入新名称的前缀,按 Ctrl-空格键,然后从建议列表中选择要使用的名称。

建议参数

参数格式的建议

编辑器猜测变量、方法或字段的参数,并在弹出框中显示建议。

例如,从代码完成窗口中选择具有一个或多个参数的方法时,编辑器将突出显示第一个参数,并显示建议该参数格式的工具提示。要移到下一个参数,请按 Tab 键或 Enter 键。

可以随时按 Ctrl-P 组合键(或者选择 "Source"(源)> "Show Method Parameters"(显示方法参数))以调用包含方法参数的工具提示。

通用前缀完成

完成前缀

可以使用 Tab 键快速填充最常用的前缀和单个建议。

要了解此功能的工作方式,请尝试键入以下内容:

  1. 键入 System.out.p 并等待代码完成功能显示以 "p." 开头的所有字段和方法。所有建议将与 "print." 相关。
  2. Tab 键,编辑器将自动填充 "print"。
    您可以继续键入 "l" 并按 Tab 键,将添加 "println"。

在代码完成窗口中,将使用图标区分 Java 语言的不同成员。请参见文档结尾的附录 A 以了解这些图标的含义。

返回页首

管理 import 语句

可以通过几种方式使用 import 语句。IDE 的 Java 编辑器持续检查代码是否正确使用了 import 语句,并在检测到非导入的类或未使用的语句时立即向您发出警告。

导入语句的建议

 

找到非导入的类时,IDE 左侧旁注中显示 灯泡错误图标 错误标记(此旁注也称为图标旁注)。单击该错误标记,然后选择是添加缺少的 import 语句,还是在当前包中创建该类。

在键入内容时,按 Ctrl-Shift-I 组合键(或者从菜单中选择 "Source"(源)> "Fix Imports"(修复导入))可同时添加所有缺少的 import 语句。

Alt-Shift-I 组合键仅在光标所在位置为键入内容添加 import 语句。

 

自动添加导入语句

从代码完成窗口中选择类时,编辑器自动为其添加 import 语句,因此您无需执行此操作。

自动删除未使用的导入

如果代码中有未使用的导入语句,请按编辑器左侧旁注中的 灯泡警告图标 警告标记,然后选择删除一个未使用的导入或所有未使用的导入。在编辑器中,未使用的 import 语句带有下划线(请参见语义突出显示部分以了解详细信息)。

要快速查看代码是否包含未使用或缺少的 import 语句,请查看右旁注中的错误带区:橙色带区标记了缺少或未使用的 import 语句。

返回页首

生成代码

在使用 Java 编辑器时,可以通过以下两种方法之一生成代码片段:使用代码完成或通过 "Code Generation"(代码生成)对话框。让我们详细了解几个简单的自动代码生成示例。

使用 "Code Generation"(代码生成)对话框

"Code Generation"(代码生成)对话框中的代码生成

 

在编辑器中的任意位置按 Alt-Insert 组合键(或者选择 "Source"(源)> "Insert Code"(插入代码)),从 "Code Generation"(代码生成)框中插入一个结构。将根据当前上下文调整建议的列表。

在左侧的示例中,我们将为 Sample 类生成一个构造函数。按 Alt-Insert 组合键,从 "Code Generation"(代码生成)框中选择 "Constructor"(构造函数),然后指定该构造函数初始化的字段。编辑器将使用指定参数生成构造函数。

在 IDE 的 Java 编辑器中,您可以自动生成各种不同的结构和整个方法,覆盖和委托方法以及添加属性等。

使用代码完成功能

"Code Completion"(代码完成)窗口中的代码生成

也可以从代码完成窗口中生成代码。在此示例中,我们使用与上面相同的代码片段说明如何从代码完成窗口中生成代码。

按 Ctrl-空格键以打开代码完成窗口,然后选择以下项目:Sample(String name, int number) - generate。编辑器将使用指定参数生成构造函数。

在代码完成窗口中,使用 "Generate"(生成)图标 图标和 generate(生成)注释可以标记自动生成的构造函数。有关这些图标及其含义的更多说明,请参见附录 A

返回页首

代码模板

代码模板是一个预定义的代码片段,它具有关联的缩写。请参见下面的示例,其中说明了如何使用代码模板。

使用代码模板

从 "Code Completion"(代码完成)窗口插入模板

代码模板在代码完成窗口中使用 实时模板图标 图标标记。

可以执行以下任一操作:

  • 从代码完成窗口中选择一个模板,然后按 Enter 键;或者
  • 键入该模板的缩写,然后按展开该模板的键(默认为 Tab 键)。

在展开的模板中,可编辑的部分将显示为蓝色框。可以使用 Tab 键浏览到需要编辑的部分。

添加或编辑代码模板

定制实时模板

定制代码模板:

  1. 选择 "Tools"(工具)> "Options"(选项)> "Editor"(编辑器)> "Code Templates"(代码模板)。
  2. 从 "Language"(语言)下拉列表中,选择 "Java"(或要创建代码模板的语言)。将显示缩写和关联模板的列表。
  3. 可以使用 "New"(新建)和 "Remove"(删除)按钮添加或删除列表中的模板。要编辑现有模板,请选择该模板,然后在列表下面的 "Expanded Text"(展开的文本)字段中编辑代码。
  4. 选择将用于展开模板的键。默认为 Tab 键。

请参见本文档以详细了解用于编写新代码模板的语法。

另请参见适用于 PHP 的 NetBeansIDE 中的代码模板

返回页首

使用 Javadoc

可通过以下功能帮助使用代码的 Javadoc。

显示 Javadoc

Javadoc 窗口。

将光标放在某个元素上,然后按 Ctrl-Shift-空格键(或者选择 "Source"(源)> "Show Documentation"(显示文档))。将在弹出式窗口中显示该元素的 Javadoc。

在 IDE 主菜单中,单击 "Window"(窗口)> "Other"(其他)> "Javadoc" 以打开 "Javadoc" 窗口,将自动刷新光标位置的文档。

 

 

 

创建 Javadoc 桩模块

创建 Javadoc 桩模块

将光标放在没有 Javadoc 的方法或类的上方,键入 /**,然后按 Enter 键。

IDE 将为 Javadoc 注释创建框架结构并填充一些内容。如果打开了 Javadoc 窗口,则会在键入内容时立即看到更改。

 

使用 Javadoc 提示

使用 Javadoc 提示

在缺少 Javadoc 或需要 Javadoc 标记时,IDE 将显示提示。

单击编辑器左旁注中的灯泡图标以修复 Javadoc 错误。

如果不想查看与 Javadoc 有关的提示,请选择 "Tools"(工具)> "Options"(选项)> "Editor"(编辑器)> "Hints"(提示),然后在显示的提示列表中清除 "Javadoc" 复选框。

使用代码完成处理 Javadoc 标记

Javadoc 的代码完成

可以使用代码完成处理 Javadoc 标记。

请键入 "@" 符号并一直等到打开了代码完成窗口(根据设置情况,您可能需要按 Ctrl-空格键)。

生成 Javadoc

生成的 Javadoc 输出

要为项目生成 Javadoc,请选择 "Run"(运行)> "Generate Javadoc"(生成 Javadoc)菜单项(或者在 "Projects"(项目)窗口中右键单击该项目,然后选择 "Generate Javadoc"(生成 Javadoc))。IDE 将生成 Javadoc,并在单独浏览器窗口中打开它。

在左侧的示例中,您可以看到 "Generate Javadoc"(生成 Javadoc)命令的样例输出。如果有一些警告或错误,则还会在此窗口中显示它们。

要定制 Javadoc 格式设置选项,请右键单击项目,选择 "Properties"(属性),然后在 "Build"(构建)类别(仅在 Java 项目上可用)下面打开 "Documenting"(构建文档)面板。有关该面板中的选项的信息,请在此窗口中单击 "Help"(帮助)按钮。

分析 Javadoc

"Javadoc Analyzer"(Javadoc 分析器)窗口

要确定代码中需要 Javadoc 注释的位置并快速插入这些注释,您可以使用 Java 编辑器中提供的 Javadoc 分析器工具。

要分析和修复 Javadoc 注释,请执行以下操作:

  1. 选择一个项目、包、或单个文件,然后从主菜单中选择 "Tools"(工具)> "Analyze Javadoc"(分析 Javadoc)。
    分析器窗口将显示添加或修复 Javadoc 注释的建议,具体取决于选择范围。
  2. 选中一个或多个要修复 Javadoc 的复选框,然后单击 "Fix Selected"(修复选定的问题)按钮。
  3. 单击 "Go Over Fixed Problems"(查看修复的问题),然后使用向上和向下方向键实际添加注释。如果选择同时修复几个实例并希望立即重新访问桩模块,这可能是非常有用的。

返回页首

使用提示

在键入内容时,Java 编辑器将检查代码,并建议如何修复错误和浏览代码。下面的示例说明了编辑器中提供的提示类型以及如何对其进行定制。

使用提示修复代码

使用提示来修复代码

对于最常见的编码错误,您可以在编辑器左旁注中查看提示。将为很多类型的错误显示提示,如缺少字段和变量定义、import 语句和花括号问题等。请单击提示图标,然后选择要添加的修复。

默认情况下,将自动显示提示。不过,如果要查看所有提示,请选择 "Source"(源)> "Fix Code"(修复代码),或者按 Alt-Enter 组合键。

例如,尝试键入 "myBoolean=true"。编辑器将检测到未定义该变量。单击提示图标,然后会看到编辑器建议创建一个字段、方法参数或局部变量。选择

定制提示

定制提示的选项

您可能需要限制显示提示的类别数。为此,请执行以下操作:

  1. 选择 "Tools"(工具)> "Options"(选项)> "Editor"(编辑器)> "Hints"(提示)。
  2. 从 "Language"(语言)下拉列表中,选择 "Java" 并查看显示提示的元素列表(选中了其复选框)。
  3. 要禁用某些类别的提示,请清除相应的复选框。

注:在 "Hints"(提示)标签中,还可以禁用或限制依赖关系扫描范围("Dependency Scanning"(依赖关系扫描)选项)。这些步骤可大大提高 IDE 的性能。

IDE 通过查找和重新编译依赖于所修改的文件的类,检测 Java 源代码中的编译错误(即使没有在编辑器中打开包含这些依赖关系的文件)。如果发现编译错误,则在源文件、包或项目节点会中添加红色标记。项目中的依赖关系扫描可能会消耗大量资源并降低性能,尤其是处理较大的项目时。

要提高 IDE 的性能,您可以执行以下操作之一:

  • 将依赖关系扫描范围限制为源根目录(仅在修改的类所在的源根目录中搜索依赖关系)或当前项目。
  • 禁用依赖关系扫描(选择 "Project Properties"(项目属性)> "Build"(构建)> "Compiling"(编译),并取消选择 "Track Java Dependencies"(跟踪 Java 依赖关系)选项)。在这种情况下,在修改文件时,IDE 不会扫描依赖关系或更新错误标记。

包含方式...

包含在选项中

可以方便地将代码片段包含在各种语句中,如 forwhileiftry/catch 等。

选择要包含在语句中的代码块,然后单击左旁注中的灯泡图标(或者按 Alt-Enter 组合键)。编辑器将显示一个建议列表,您可以从中选择所需的语句。

常规编辑器功能

代码格式设置

格式定制选项

选择 "Source"(源)> "Format"(格式)或按 Alt-Shift-F 组合键,以设置整个文件或所选代码的格式。IDE 将按照指定的格式设置设定代码格式。

要定制 Java 代码的格式设置,请执行以下操作:

  1. 选择 "Tools"(工具)> "Options"(选项)> "Editor"(编辑器)> "Formatting"(格式设置)。
  2. 从 "Language"(语言)下拉列表中选择 "Java"。
  3. 从 "Category"(类别)下拉列表中,选择要定制的类别。例如,您可以定制空行数、制表符和缩进大小和自动换行样式等。
  4. 修改选定类别的规则并预览结果。

插入和突出显示圆括号、方括号和引号

方括号的定制选项

默认情况下,IDE 自动插入匹配的圆括号、方括号和引号对。在键入左花括号并按 Enter 键时,将自动添加右花括号。对于 (["',编辑器立即插入一个匹配对。

如果由于某种原因禁用了此功能,请按如下方式将其启用:

  1. 选择 "Tools"(工具)> "Options"(选项)> "Editor"(编辑器)> "Code Completion"(代码完成)。
  2. 选中 "Insert Closing Brackets Automatically"(自动插入右括号)复选框。

编辑器还会突出显示匹配的圆括号、方括号和引号对。例如,将光标放在任何圆括号或方括号前面;如果有匹配的对,则会以黄色突出显示两个括号。任何类型的单个方括号将以红色突出显示,并在左旁注中显示错误标记。

要定制突出显示颜色,请选择 "Tools"(工具)> "Options"(选项)> "Fonts & Colors"(字体和颜色)> "Highlighting"(突出显示)。

代码折叠

代码折叠示例

在 Java 编辑器中,您可以快速折叠和展开代码块,如方法声明、Javadoc 注释和 import 语句等。可折叠的块以灰色行显示,并在编辑器的左旁注附近显示加/减号。

  • 要折叠代码块,最简单的方法是单击左旁注中带有减号字符的灰色行。
  • 要折叠文件中的所有可折叠块,请在编辑器中单击鼠标右键,然后从弹出式菜单中选择 "Code Folds"(代码折叠)> "Collapse All"(全部折叠)。
  • 从 "Code Folds"(代码折叠)> "Collapse All"(全部折叠)弹出式菜单中,您可以选择折叠文件中的所有 Javadoc 注释或所有 Java 代码。
  • 可以将鼠标放在折叠的元素上以快速查看隐藏的部分。

要定制代码折叠选项,请执行以下操作:

  1. 选择 "Tools"(工具)> "Options"(选项)> "Editor"(编辑器)> "General"(常规)。
  2. 要禁用代码折叠,请清除 "Use Code Folding"(使用代码折叠)。请注意,将默认启用代码折叠。
  3. 选择在打开文件时默认折叠的代码块。

定制快捷键

键盘定制选项

在 NetBeans IDE 中,选择 "Tools"(工具)> "Options"(选项)> "Keymap"(快捷键映射)以定制快捷键。可以使用几种方法执行此操作:

  • 选择一组预定义的快捷键(称为配置文件)。
  • 编辑特定快捷键。

您可以将定制的快捷键集合保存为配置文件。然后,可以切换配置文件以快速更改多个设置。例如,要创建快捷键的定制配置文件,请执行以下操作:

  1. 在 "Options"(选项)> "Keymap"(快捷键映射)窗口中,单击 "Manage profiles"(管理配置文件)。
  2. 选择要作为新配置文件基础的配置文件,然后单击 "Duplicate"(复制)。
  3. 输入新配置文件名称,然后单击 "OK"(确定)。
  4. 确保选择新配置文件,然后根据需要修改快捷键。
    要编辑快捷键,请双击 "Shortcut"(快捷键)字段,或者单击省略号按钮 (...)。在按键序列时,将为其添加语法。
    如果要添加特殊字符(如 TabEscEnter),请再次单击省略号按钮 (...),然后从弹出式窗口中选择该键。
  5. 完成编辑后,在 "Options"(选项)窗口中单击 "OK"(确定)。

要查找特定命令的快捷键,请在 "Search"(搜索)字段中键入命令名称。要按组合键查找命令,请在 "Search in Shortcuts"(在快捷键中搜索)字段中插入光标,然后按快捷键组合。

 

语义突出显示

根据代码的语义,IDE 的 Java 编辑器将使用不同颜色显示代码元素。通过使用语义突出显示,您可以轻松确定代码中的各种元素。除了突出显示以外,Java 编辑器还使用特定背景色突出显示类似的元素。因此,您可以将突出显示功能视为 "Search"(搜索)命令的替代方法,因为在与错误带区组合使用时,您可以快速了解突出显示的部分在文件中的位置。

定制颜色

突出显示的定制选项

要为 Java 编辑器定制语义突出显示设置,请选择 "Tools"(工具)> "Options"(选项)> "Fonts and Colors"(字体和颜色)。

IDE 提供了几个预设突出显示方案(称为配置文件)。可以使用定制颜色创建新的配置文件,并快速在配置文件之间进行切换。

可以非常方便地在新配置文件中保存定制颜色。例如,执行以下操作:

  1. 在 "Options"(选项)> "Fonts and Colors"(字体和颜色)窗口中,单击 "Profile"(配置文件)下拉列表旁边的 "Duplicate"(复制)。
  2. 输入新配置文件名称,然后单击 "OK"(确定)。
  3. 确保当前选择了新配置文件,然后从 "Language"(语言)下拉列表中选择 "Java"。
  4. 选择一个类别,然后更改该类别的字体、字体颜色(前景)、背景色和效果。
    可以使用 "Preview"(预览)窗口查看结果。
  5. 单击 "OK"(确定)。

注:所有 NetBeans IDE 设置和配置文件存储在 NetBeans userdir 中(有关在操作系统中如何查找 userdir 的信息,请参见常见问题解答)。在升级到较新版本的 NetBeans 时,您可以导出旧设置,并将其导入到较新版本中。

要导出 IDE 设置,请执行以下操作:

  1. 在 "Options"(选项)窗口("Tools"(工具)> "Options"(选项))中,单击 "Export"(导出)。
  2. 指定将创建的 ZIP 文件的位置和名称。
  3. 选择要导出的设置,然后单击 "OK"(确定)。

要导入 IDE 设置,请执行以下操作:

  1. 在 "Options"(选项)窗口("Tools"(工具)> "Options"(选项))中,单击 "Import"(导入)。
  2. 指定包含以前版本的 IDE 设置的 ZIP 文件或 userdir 路径。
  3. 选择要导入的设置,然后单击 "OK"(确定)。

 

突出显示示例

显示突出显示示例的图像

可以在左侧看到突出显示方案的示例。根据您的定制设置,颜色可能不同于屏幕快照中显示的颜色。

将使用不同颜色表示关键字(蓝色)、变量和字段(绿色)和参数(橙色)。

对过时方法或类的引用以删除线表示。如果编写的代码依赖于过时成员,将会向您发出警告。

未使用的成员以带有灰色波浪线的下划线表示。注释以灰色显示。

 

使用突出显示

显示突出显示用法的图像

IDE 突出显示使用的相同元素、匹配花括号、方法退出点以及异常错误抛出点。

如果将光标放在元素(如字段或变量)中,则会突出显示该元素的所有使用实例。请注意,编辑器右旁注中的错误带区指示了该元素在整个源文件中的使用实例(请参见错误带区)。可以单击错误带区以快速导航到所需的使用实例位置。

如果决定重命名所有突出显示的实例,请使用 "Instant Rename"(即时重命名)命令(Ctrl-R 组合键或选择 "Refactor"(重构)> "Rename"(重命名))。

 

导航

Java 编辑器提供了多种如何导航代码的方法。有关说明 Java 编辑器导航功能的一些示例,请参见以下部分。

错误带区

通过使用编辑器右旁注中的错误带区,可以快速了解当前文件中的所有标记位置:错误、警告、提示、突出显示实例和标注。请注意,错误带区旁注表示整个文件,而不仅仅是编辑器中当前显示的部分。通过使用错误带区,您可以立即确定文件是否包含任何错误或警告,而无需滚动查看文件。

单击错误带区可跳转至标记所引用的行。

从编辑器中导航:转至...

显示 "Go To"(转至)命令的图像

可以使用以下 "Go To.."(转至...)命令(位于 "Navigate"(导航)菜单项下面)快速跳转至目标位置:

  • 转至声明(默认情况下,按 Ctrl-B 组合键)。按住 Ctrl 键,然后单击某个类、方法或字段使用实例以跳转至其声明。也可以将光标放在成员(类、方法或字段)上并选择 "Navigate"(导航)> "Go To Declaration"(转至声明),或者单击鼠标右键,然后从弹出式菜单中选择 "Navigate"(导航)> "Go To Declaration"(转至声明)。
  • 转至源(默认情况下,按 Ctrl-Shift-B 组合键)。按住 Ctrl 键,然后单击某个类、方法或字段以跳转至源代码(如果可用)。也可以将光标放在成员(类、方法或字段)上,然后按 Ctrl-Shift-B 组合键,或者在主菜单中选择 "Navigate"(导航)> "Go To Source"(转至源)。

显示 "Go To Type"(转至类型)对话框的图像

  • 转至类型(Ctrl-O 组合键)转至文件(Alt-Shift-O 组合键)转至符号(Ctrl-Alt-Shift-O 组合键)。如果知道要跳转至的类型(类、接口、标注或枚举)、文件或符号的名称,请使用这些命令并在新窗口中键入名称。请注意,您可以使用前缀、驼峰匹配和通配符。

显示 "Go To Line"(转至行)对话框的图像

  • 转至行(Ctrl-G 组合键)。输入要跳转至的行号。

跳转至上一个编辑位置

显示 "Jumping to Last Edit"(跳转至上一个编辑位置)按钮的图像

要快速返回到上一个编辑位置,请按 Ctrl-Q 组合键或使用 Java 编辑器工具栏左上角的按钮,即使编辑位置位于另一个文件或项目中。将打开上次编辑的文档,并将光标放在上次编辑的位置。

在文件之间切换

显示用于在打开文件之间切换的按钮的图像

 

可以使用两个非常方便的功能切换打开的文件:

  • 返回(Alt-向左方向键)前进(Alt-向右方向键)。要转至上一个编辑过的文件或前进,请选择 "Navigate"(导航)< "Back"(后退)或 "Navigate"(导航)< "Forward"(前进),或者在编辑器工具栏上按对应的按钮(如图所示)。将打开文件,并将光标放在上次编辑的位置。在单击其中的一个按钮时,您可以展开最新的文件列表,然后单击以导航到任何文件。

显示用于在文件之间切换的弹出菜单的图像

  • 在文件之间切换(Ctrl-Tab 组合键)。在按 Ctrl-Tab 组合键后,将在弹出式窗口中显示所有打开的文件。按住 Ctrl 键,然后按几次 Tab 键以选择要打开的文件。

使用书签

显示书签示例的图像

您可以使用书签快速导航到代码中的某些位置。

按 Ctrl-Shift-M 组合键(或者右键单击左旁注,然后选择 "Bookmark"(书签)> "Toggle Bookmark"(开启/关闭书签))为当前行添加书签。带有书签的行将在左旁注中显示一个小蓝色图标(如图所示)。

要删除书签,请再次按 Ctrl-Shift-M 组合键。

要转至下一个书签,请按 Ctrl-Shift-句点;要转至上一个书签,请按 Ctrl-Shift-逗号。

使用 "Navigator"(导航器)

"Navigator"(导航器)窗口示例

"Navigator"(导航器)窗口提供了所使用的文件的结构化视图,您可以快速在文件的不同部分之间进行导航。

要打开 "Navigator"(导航器)窗口,请选择 "Window"(窗口)> "Navigating"(导航)> "Navigator"(导航器),或者按 Ctrl-7 组合键。

在 "Navigator"(导航器)窗口中,可以执行以下操作:

  • 在不同视图之间进行选择:成员、Bean 模式、树和元素等。
  • 双击某个元素以跳转至定义它的行。
  • 右键单击某个元素并应用命令,如 "Go to Source"(转至源)、"Find Usages"(查找使用实例)和 "Refactor"(重构)。
  • 将过滤器应用于 "Navigator"(导航器)中显示的元素(使用底部的按钮)。
  • 键入要查找的元素的名称("Navigator"(导航器)窗口必须处于活动状态)。

 


另请参见

返回页首

附录 A:"Code Completion"(代码完成)窗口中的图标

图标 含义 变体(如果有)

含义

"Annotation type"(标注类型)图标 标注类型    
"Class"(类)图标    
"Package"(包)图标    
"Enum type"(枚举类型)图标 枚举类型    
"Code Template"(代码模板)图标 代码模板    
"Constructor"(构造函数)图标 构造函数 "New constructor"(新构造函数)图标 新构造函数(生成)
    "Protected constructor"(受保护的构造函数)图标 受保护的构造函数
    "Private constructor"(私有构造函数)图标 私有构造函数
    "Package private constructor"(包私有构造函数)图标 包私有构造函数
"Field"(字段)图标 字段 "Protected field"(受保护的字段)图标 受保护的字段
    "Private field"(私有字段)图标 私有字段
    包私有字段的图标 包私有字段
静态字段的图标 静态字段 受保护的静态字段的图标 受保护的静态字段
    私有静态字段的图标 私有静态字段
    包私有静态字段的图标 包私有静态字段
"Interface"(接口)图标 接口    
"Java keyword"(Java 关键字)图标 Java 关键字    
"Method"(方法)图标 方法 受保护的方法的图标 受保护的方法
    私有方法的图标 私有方法
    包私有方法的图标 包私有方法
静态方法的图标 静态方法 受保护静态方法的图标 受保护的静态方法
    私有静态方法的图标 私有静态方法
    包私有静态方法的图标 包私有静态方法
"Local variable"(局部变量)图标 局部变量    
"Attribute"(属性)图标 属性    
get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2015, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo