Работа с кодом в редакторе Java IDE NetBeans: справочник

Назначение любой интегрированной среды разработки (Integrated Development Environment, IDE) состоит в максимальном повышении производительности и поддержке плавной разработки в едином инструменте. В этом справочном документе описываются полезные функции по работе с кодом, параметры настройки и функции навигации редактора Java IDE NetBeans.

Просмотрите экранную демонстрацию Редатирование кода Java в IDE NetBeans, чтобы ознакомиться со способами работы с полезными функциями редактора.

Содержание

Содержимое на этой странице применимо к IDE NetBeans 6.9 или более поздней версии

Для работы с этим учебным курсом требуются программное обеспечение и материалы, перечисленные в таблице ниже.

Программное обеспечение или материал Требуемая версия
IDE NetBeans Версия 6.9 или более поздняя
Комплект для разработчика на языке Java (JDK) версия 6 или 7

Интеллектуальное автозавершение кода

Редактор Java IDE NetBeans позволяет быстро завершать и создавать код с помощью функции "интеллектуального" завершения кода. В общем случае использование автозавершения кода целесообразно в случаях, когда требуется вписать недостающий код, найти параметры, соответствующие контексту создаваемого приложения, и создать блоки кода при необходимости. Далее приводятся примеры использования автозавершения кода.

Вызов автозавершения кода

Поле автозавершения кода

Нажмите Ctrl+Space (или выберите в главном меню "Исходный код" > "Автозавершение кода") для открытия окна автозавершения кода. При вводе дополнительных символов с клавиатуры список предлагаемых вариантов сокращается. Этот список вариантов включает в себя записи, импортированные в исходный файл, а также символы из пакета java.lang.

Для настройки автозавершения кода выберите "Сервис" > "Параметры" > "Редактор" > "Автозавершение кода".

Например, можно определить необходимость автоматического вывода окна автозавершения кода или его вывода только по необходимости. На вкладке "Автозавершение кода" установите флажок "Автоматический вывод окна автозавершения кода" для автоматического вызова окна автозавершения при каждом случае набора определенных символов. По умолчанию задан символ "."; однако можно добавить собственные символы.

Для добавления символов, при вводе которых будет выводиться окно автозавершения кода, в раскрывающемся списке "Язык" выберите "Java" и введите требуемые символы в поле "Условия автоматического вывода окна для Java". Окно автозавершения кода будет выводиться в каждом случае набора указанных символов.

Если флажок "Автоматический вывод окна автозавершения кода" не установлен, то для вызова автозавершения кода потребуется нажать комбинацию клавиш Ctrl+Space.

Интеллектуальные подсказки в верхней части списка

Поле автозавершения кода с интеллектуальными подсказками

В IDE NetBeans функция завершения кода является "интеллектуальной," что означает, что наиболее полезные для контекста кода рекомендации отображаются в верхней части, над черной линией в окне завершения кода.

В примере слева редактор предлагает вставить конструктор LinkedHashMap из пакета java.util.

Если "интеллектуальные" подстановки не соответствуют требуемым, нажмите Ctr+Space еще раз для вывода полного списка.

Завершение ключевых слов

Завершение ключевых слов

Автозавершение кода (Ctr+Space) можно использовать для завершения ключевых слов кода. Редактор анализирует контекст и предлагает наиболее подходящие ключевые слова.

В примере слева класс ColorChooserDemo используется для расширения класса JPanel. Из набора предлагаемых вариантов можно быстро добавить ключевое слово extends.

Предложение имен переменных и полей

Завершение имен и полей

При добавлении нового поля или переменной можно вызвать функцию автозавершения кода (Ctr+Space) для выбора имени, соответствующего типу объекта.

Введите начало нового имени, нажмите Ctr+Space и выберите требуемое имя из списка предложенных вариантов.

Предложение параметров

Рекомендации по форматам параметров

Редактор предлагает параметры переменных, методов и полей и выводит доступные варианты во всплывающем окне.

Например, при выборе в окне автозавершения кода метода с одним или несколькими аргументами редактором подсвечивается первый аргумент, и отображается подсказка с предложением формата этого аргумента. Для перехода к следующему аргументу можно нажать клавишу Tab или Enter.

Подсказку с параметрами метода можно вызвать в любой момент нажатием комбинации клавиш Ctr+P (или путем выбора в меню "Исходный код" > "Показать параметры метода").

Завершение часто используемых префиксов

Завершение префиксов

Нажатием клавиши Tab можно быстро подставить наиболее часто используемые префиксы и одиночные предлагаемые варианты.

Для знакомства с работой этой функции введите следующий текст.

  1. Введите System.out.p и дождитесь автозавершения кода, чтобы отобразить все поля и метода, имена которых начинаются с "p". Все рекомендации будут связаны с "print."
  2. Нажмите клавишу Tab; редактор автоматически подставит значение "print".
    Можно продолжить набор и ввести "l", тогда после нажатия клавиши Tab будет добавлена запись "println".

В окне автозавершения кода имеются значки, служащие для обозначения различных элементов языка Java. Описание этих обозначений приведено в Приложении A в конце этого документа.

В начало

Управление импортом

Имеется несколько способов работы с операторами импорта. Редактором Java среды IDE осуществляется интерактивная проверка правильности использования операторов импорта в коде, и в случае обнаружения неимпортированных классов или неиспользуемых операторов импорта выводится соответствующее сообщение.

Рекомендации по оператору импорта

 

Если найден не импортированный класс, метка ошибки Значок ошибки в виде лампочки отображается на левой границе IDE (эта граница также называется специальной границей). Щелкните значок ошибки и выберите либо параметр добавления недостающего импорта, либо параметр создания класса в текущем пакете.

Во время набора символов можно нажать комбинацию клавиш Ctrl+Shift+I (или выбрать в меню "Исходный код" > "Исправить выражения импорта"); при этом будут добавлены сразу все отсутствующие операторы импорта.

При нажатии комбинации клавиш Alt+Shift+I будет добавлен только оператор импорта, соответствующий типу, на котором в данный момент установлен курсор.

 

Автоматическое добавление операторов импорта

При выборе класса в окне автозавершения кода редактор автоматически добавит соответствующий оператор импорта, так что выполнять это действие вручную не требуется.

Автоматическое удаление неиспользованных операторов импорта

Если имеются не использованные операторы импорта в коде, щелкните метку предупреждения Значок предупреждения в виде лампочки на левом поле редактора и либо удалите один не использованный оператор импорта или все не использованный оператор импорта. В редакторе неиспользуемые операторы импорта подчеркиваются (для получения подробных сведений см. раздел Семантическая подсветка).

Для быстрой проверки наличия неиспользуемых или отсутствующих операторов импорта в коде следите за полосами ошибок в правом поле: неиспользуемые или отсутствующие операторы импорта обозначаются оранжевым цветом.

В начало

Создание кода

При работе в редакторе Java фрагменты кода можно создавать одним из двух способов: с использованием функции автозавершения кода или с помощью диалогового окна "Создание кода". Рассмотрим автоматическую генерацию кода подробнее на нескольких простых примерах.

Использование диалогового окна "Создание кода"

Создание кода в диалоговом окне "Создание кода"

 

В любой области редактора можно нажать Alt+Insert (или выбрать в меню "Исходный код" > "Добавить код") для вставки конструкции из окна "Создание кода". Список предлагаемых вариантов корректируется в соответствии с текущим контекстом.

В примере слева требуется создать конструктор для класса Sample. Нажмите Alt+Insert, в окне "Создание кода" выберите "Конструктор" и укажите поля, которые будут инициализированы этим конструктором. В редакторе будет создан конструктор с указанными параметрами.

В редакторе Java среды IDE можно автоматически создавать различные конструкции и целые методы, переопределять и делегировать методы, добавлять свойства и т.д.

Использование автозавершения кода

Создание кода в диалоговом окне "Автозавершение кода"

Кроме того, код можно создавать с помощью окна автозавершения кода. В данном примере используется тот же фрагмент кода, что и в предыдущем случае, но на этот раз код создается с помощью окна автозавершения кода.

Для открытия окна автозавершения кода нажмите комбинацию клавиш Ctrl+Space" и выберите в нем следующий элемент: Sample(String name, int number) - generate. В редакторе будет создан конструктор с указанными параметрами.

В окне автозавершения кода, конструкторы, которые могут быть автоматически созданы, помечаются значком Значок 'Создать' и пометкой "создать". Более подробное описание значков и их значений приведено вПриложении A.

В начало

Шаблоны кода

Шаблон кода — это предварительно определенная часть кода, имеющая соответствующую ей аббревиатуру. В приведённых ниже примерах показано использование шаблонов кода.

Использование шаблонов кода

Вставка шаблона из диалогового окна "Автозавершение кода"

Шаблоны кода помечены значком Значок динамического шаблона в окне автозавершения кода.

Можно выполнить одно из следующих действий:

  • выберите компонент в окне автозавершения кода и нажмите клавишу Enter:
  • введите сокращение, относящееся к этому шаблону и нажмите кнопку для развертывания этого шаблона (по умолчанию - Tab).

Компоненты в развернутом шаблоне, в которые можно вносить изменения, отображаются в синих прямоугольниках. Для перехода по компонентам, которые требуется изменить, используется клавиша Tab.

Добавление или изменение шаблонов кода

Настройка динамических шаблонов

Для настройки шаблонов кода выполните следующее.

  1. Выберите путь "Сервис" > "Параметры" > "Редактор" > "Шаблоны кода".
  2. В раскрывающемся списке "Язык" выберите "Java" (или другой язык, для которого необходимо создать шаблон кода). Появится список сокращений и соответствующих шаблонов.
  3. Для добавления шаблонов в список и их удаления используются кнопки "Создать" и "Удалить", соответственно. Для изменения существующего шаблона выберите его и внесите изменения в код в поле "Расширенный текст" под списком.
  4. Выберите клавишу для развертывания шаблонов. По умолчанию используется клавиша Tab.

См. данный документ для получения дополнительных сведений о создании новых шаблонов кода.

См. также Шаблоны кода в среде NetBeansIDE для PHP.

В начало

Работа с документацией Javadoc

Следующие функции позволяют упростить работу с документацией Javadoc для кода.

Просмотр документации Javadoc

Окно Javadoc

Установите курсор на каком-либо элементе и нажмите комбинацию клавиш Ctr+Shift+Space (или выберите в меню "Исходный код" > "Показать документацию"). Во всплывающем окне появится документация Javadoc по этому элементу.

В главном меню среды IDE перейдите по пути "Окно" > "Прочее" > "Документация Javadoc" для открытия окна с документацией Javadoc; документация в этом окне автоматически изменяется в зависимости от местоположения курсора.

 

 

 

Создание заглушек документации Javadoc

Создание заглушек Javadoc

Установите курсор на методе или классе, для которых отсутствует документация Javadoc, введите "/**" и нажмите Enter.

В среде IDE будет создана скелетная структура для комментария документации Javadoc с определенным содержимым. Если окно документации Javadoc открыто, то непосредственно в процессе ввода в нем можно будет наблюдать изменения.

 

Использование подсказок документации Javadoc

Использование подсказок Javadoc

Если какой-либо документ Javadoc отсутствует, или требуются теги документации Javadoc, то в среде IDE отображаются подсказки.

Для исправления ошибок документации Javadoc щелкните значок в виде лампочки в левом поле.

Если выводить связанные с документацией Javadoc подсказки не требуется, выберите "Сервис" > "Параметры" > "Редактор" > "Подсказки" и снимите флажок "Документация Javadoc" в списке отображаемых подсказок.

Использование автозавершения кода для тегов документации Javadoc

Автозавершение кода для Javadoc

При работе с тегами документации Javadoc можно использовать автозавершение кода.

Введите символ "@" и дождитесь вывода окна автозавершения кода (в зависимости от установленных параметров может потребоваться нажать Ctr+Space).

Создание документации Javadoc

Созданные выходные данные Javadoc

Для создания Javadoc выберите 'Выполнить' > 'Создать элемент меню Javadoc' (или щелкните правой кнопкой мыши проект в окне 'Проекты' и выберите Javadoc'). В системе IDE будет создана документация Javadoc, который откроется в отдельном окне просмотра.

В примере слева можно увидеть пример вывода команды "Создать документацию Javadoc". Если появились предупреждения или ошибки, они также отображаются в этом окне.

Для настройки параметров форматирования Javadoc, щелкните правой кнопкой мыши проект, выберите команду 'Свойства' и откройте панель 'Документирование' в категории 'Сборка' (доступно только для проектов Java). Для получения сведений об элементах этой панели нажмите кнопку "Справка" в этом окне.

Анализ документации Javadoc

Окно 'Анализатор Javadoc'

Для определения фрагментов кода, для которых требуются комментарии документации Javadoc, и быстрого добавления этих комментариев можно использовать средство "Анализатор документации Javadoc" редактора Java.

Для анализа и исправления комментариев документации Javadoc выполните следующее:

  1. Выберите проект, пакет или отдельный файл, затем выберите в главном меню "Сервис" > "Анализ документации Javadoc".
    В окне "Анализатор" появятся предлагаемые варианты для добавления или исправления комментариев документации Javadoc, в зависимости от размера выбранного фрагмента.
  2. Установите один или несколько флажков напротив элементов, для которых требуется внести исправления в документацию Javadoc, и нажмите кнопку "Исправить выделенное".
  3. Выберите "Перейти к исправленным проблемам" и добавьте требуемые комментарии с помощью стрелок "вверх" и "вниз". Это может быть целесообразно в том случае, если выбран параметр одновременного исправления по нескольким экземплярам, и теперь требуется просмотреть заглушки заново.

В начало

Использование подсказок

Во время ввода символов редактором Java выполняется проверка кода, и предлагаются варианты исправления ошибок и перемещения по коду. В нижеприведенных примерах представлены типы подсказок, предусмотренных в редакторе, и способы их настройки.

Использование подсказок для исправления кода

Использование подсказок для исправления кода

В левом поле редактора отображаются подсказки по большинству типичных ошибок в написании кода. Подсказки отображаются для большинства типов ошибок, таких как отсутствующие определения полей и переменных, проблемы с операторами импорта, скобками и т.д. Щелкните значок подсказки и выберите вариант исправления.

По умолчанию подсказки отображаются автоматически. Для просмотра всех подсказок выберите "Исходный код" > "Исправить код" (или нажмите комбинацию клавиш Alt+Enter).

Например, введите "myBoolean=true". Редактор обнаружит, что эта переменная не определена. Щелкните значок подсказки и обратите внимание на то, что редактором предлагается выбрать один из вариантов - создание поля, параметра метода или локальной переменной. Выберите компонент

Настройка подсказок

Настройка параметров подсказок

Может потребоваться ограничить количество категорий, для которых будут выводиться подсказки. Для этого выполните следующее:

  1. Выберите путь "Сервис" > "Параметры" > "Редактор" > "Подсказки".
  2. В раскрывающемся списке "Язык" выберите "Java" и просмотрите список элементов, для которых отображаются подсказки (с установленными флажками).
  3. Для отключения подсказок для каких-либо категорий снимите соответствующие флажки.

Примечание. На вкладке 'Подсказки', также можно отключить или ограничить область зависимости сканирования (параметр 'Сканирование зависимостей'). Следующие действия позволяют повысить эффективность среды IDE.

В среде IDE предусмотрена возможность обнаружения ошибок компиляции в исходных кодах Java путем поиска и повторной компиляции классов, зависящих от файла, в который вносятся изменения (даже в том случае, если эти зависимости находятся в файлах, не открытых в редакторе). При обнаружении ошибки компиляции к узлам исходных файлов, пакетов или проектов добавляются красные метки. Как правило, при сканировании зависимостей в проектах потребляется много ресурсов, и снижается производительность, особенно в случае работы с большими проектами.

Для повышения производительности среды IDE можно выполнить одно из следующих действий:

  • ограничьте объем сканирования зависимостей корнем исходных файлов (т.е. выполняйте поиск зависимостей только в том корне исходных файлов, в котором находится требуемый класс) или текущим проектом;
  • отключите поиск зависимостей (выберите "Свойства проекта > Сборка > Компиляция" и снимите флажок "Отслеживать зависимости Java"). В этом случае сканирование зависимостей или обновление меток ошибок при правке файла средой IDE выполняться не будет.

Окружение...

Окружение параметрами

Предусмотрена возможность быстрой расстановки различных операторов, таких как for, while, if, try/catch и т.д., вокруг фрагментов кода.

Выберите фрагмент кода, который требуется заключить в операторные скобки, и щелкните значок лампочки в левом поле (или нажмите комбинацию клавиш Alt+Enter). В редакторе появится список предложений, в котором можно выбрать необходимый оператор.

Основные функции редактора

Форматирование кода

Форматирование параметров настройки

Выберите "Исходный код" > "Формат" или нажмите комбинацию клавиш Alt+Shift+F для форматирования всего файла или выделенного фрагмента кода. Код будет отформатирован средой IDE в соответствии с выбранными настройками форматирования.

Для настройки форматирования кода Java:

  1. Выберите путь "Сервис" > "Параметры" > "Редактор" > "Форматирование".
  2. В раскрывающемся списке "Язык" выберите "Java".
  3. В раскрывающемся списке "Категория" выберите категорию, настройки которой требуется изменить. Например, можно изменить количество пустых строк, величину отступов и сдвигов, тип переноса и т.д.
  4. Измените правила для выбранной категории и просмотрите предварительный результат.

Вставка и подсветка скобок, квадратных скобок и кавычек

Настройка параметров скобок

По умолчанию средой IDE автоматически подставляются соответствующие пары круглых скобок, квадратных скобок и кавычек. Если ввести открывающую фигурную скобку и нажать Enter, то закрывающая скобка добавится автоматически. Для символов (, [, " и ' редактор также подставляет соответствующий парный символ.

Если эта функция по какой-либо причине отключена, включить ее можно следующим образом:

  1. Перейдите в меню по пути "Сервис" > "Параметры" > "Редактор" > "Создание кода".
  2. Установите флажок "Автоматически вставлять закрывающие скобки".

Кроме того, парные скобки, квадратные скобки и кавычки в редакторе подсвечиваются. Например, поместите курсор перед любой скобкой или квадратной скобкой; если ей соответствует парный символ, то оба они будут выделены желтым цветом. Одиночные скобки любого типа выделяются красным цветом, при этом в левом поле отображается значок ошибки.

Для настройки цветовой подсветки выберите в меню "Сервис" > "Параметры" > "Шрифты и цвета" > "Подсветка".

Свертывание кода

Пример свертывания кода

В редакторе Java можно быстро свернуть и развернуть различные блоки кода, например, объявление метода, комментарии документации Javadoc, операторы импорта и т.д. Блоки с возможностью сворачивания отмечены серыми линиями и значками "+/-" у левого поля редактора.

  • Наиболее удобный способ свертывания блока кода - щелкнуть серую линию со знаком "-" в левом поле.
  • Чтобы свернуть все блоки (для которых поддерживается сворачивание) в файл, щелкните правой кнопкой мыши в редакторе и выберите 'Свернуть код' > 'Свернуть все' во всплывающем меню.
  • В меню "Свертывание кода" > "Свернуть все" можно выбрать либо параметр сворачивания всех комментариев документации Javadoc или всего кода Java в файле.
  • Для быстрого просмотра скрытой области можно навести курсор мыши на скрытый элемент.

Для настройки свертывания кода:

  1. Выберите путь "Сервис" > "Параметры" > "Редактор" > "Общее".
  2. Для отключения функции свертывания кода снимите флажок "Использовать свертывание кода". Обратите внимание, что по умолчанию свертывание кода включено.
  3. Выберите блоки кода, сворачиваемые по умолчанию при открытии файла.

Настройка горячих клавиш

Параметры настройки клавиатуры

В IDE NetBeans выберите 'Сервис' > 'Параметры' > 'Сочетание клавиш', чтобы настроить сочетания клавиш клавиатуры. Это действие можно выполнить несколькими способами:

  • выберите предварительно определенный набор горячих клавиш, называемый профилем;
  • измените требуемые горячие клавиши по одной.

Настроенные наборы горячих клавиш можно сохранять в виде профилей. После этого можно быстро переходить от одного набора настроек к другому путем смены профилей. Например, для создания пользовательского профиля горячих клавиш:

  1. В окне, вызываемом по пути "Параметры" > "Сочетание клавиш" щелкните "Настроить профиль".
  2. Выберите профиль, который требуется использовать как шаблон для нового профиля, и нажмите "Дублировать".
  3. Введите имя нового профиля и нажмите "ОК".
  4. Выберите новый профиль и измените требуемые горячие клавиши.
    Для изменения сочетания дважды щелкните поле "Комбинация клавиш" или нажмите кнопку в виде эллипса (...). При нажатии данной комбинации клавиш в поле вставляется соответствующая ей синтаксическая конструкция.
    Если требуется добавить специальные символы, такие как Tab, Escape или Enter, нажмите кнопку в виде эллипса (...) еще раз и выберите требуемую клавишу во всплывающем окне.
  5. По окончании редактирования нажмите кнопку "OK" в меню "Параметры".

Для поиска комбинации клавиш, соответствующих определенной команде, введите имя этой команды в поле "Поиск". Для поиска команды по комбинации установите курсор в поле "Поиск по комбинации" и нажмите комбинацию клавиш.

 

Цветовое выделение и семантическая подсветка

Элементы кода в редакторе Java среды IDE отображаются различными цветами в зависимости от семантики кода. Цветовая подсветка семантики повышает наглядность расположения различных элементов в коде. Помимо цветовой подсветки, одинаковые элементы в редакторе Java выделяются цветом фона. Таким образом, функцию подсветки можно рассматривать как некоторую альтернативу команде поиска, поскольку в сочетании с полосами ошибок она позволяет быстро получить представление о расположении подсвеченных фрагментов в файле.

Настройка цветов

Настройка параметров цветовой схемы

Для настройки семантической подсветки в редакторе Java выберите "Сервис" > "Параметры" > "Шрифты и цвета".

В среде IDE имеется несколько предопределенных схем цветового выделения, называемых профилями. Можно создать новые профили с пользовательскими цветами и быстро менять их.

Пользовательские цвета удобно сохранять в новых профилях. Например, выполните следующие действия:

  1. В окне "Параметры" > "Шрифты и цвета" нажмите кнопку "Дублировать" рядом с раскрывающимся списком "Профиль".
  2. Введите имя нового профиля и нажмите "ОК".
  3. Убедитесь в том, что новый профиль выделен, и выберите "Java" в раскрывающемся списке "Язык".
  4. Выберите категорию, затем измените шрифт, цвет шрифта ("Цвет"), цвет фона и эффекты для этой категории.
    Предварительный результат отображается в окне "Предварительный просмотр".
  5. Нажмите кнопку "ОК".

Примечание. Все настройки и профили IDE NetBeans хранятся в userdir NetBeans (см. в разделе Часто задаваемые вопросы описание поиска userdir для используемой операционной системы). При обновлении NetBeans до новых версий можно экспортировать старые настройки и импортировать их в новую версию.

Для экспорта настроек среды IDE:

  1. В окне "Параметры" ("Сервис" > "Параметры") нажмите кнопку "Экспорт".
  2. Укажите местоположение и имя создаваемого файла ZIP.
  3. Выберите настройки, которые требуется экспортировать, и нажмите "OK".

Для импорта настроек среды IDE:

  1. В окне "Параметры" ("Сервис" > "Параметры") нажмите кнопку "Импорт".
  2. Укажите файл ZIP с настройками IDE или путь к каталогу пользователя из предыдущей версии.
  3. Выберите настройки, которые требуется импортировать, и нажмите "OK".

 

Пример цветовой подсветки

Изображение, показывающее пример использования цветовой схемы

Слева представлен пример схемы цветовой подсветки. В зависимости от настроек цветовой подсветки, цвета могут отличаться от отображаемых на этом снимке экрана.

Различные элементы выделяются различными цветами: ключевые слова - синим, переменные и поля - зеленым, параметры - оранжевым.

Ссылки на устаревшие методы и классы отображаются зачеркнутыми. Таким образом пользователю выдается предупреждение о том, что в коде используются устаревшие элементы.

Неиспользуемые элементы подчеркиваются серой волнистой линией. Комментарии отображаются серым цветом.

 

Использование подсветки

Изображение, показывающее пример использования выделений

В среде IDE используется подсветка сходных элементов, парных скобок, точек выхода методов и точек передачи исключений.

Если установить курсор на каком-либо элементе, например, поле или переменной, то все случаи вхождения этого элемента будут подсвечены. Обратите внимание на то, что полосы ошибок на правом поле редактора обозначают случаи вхождения данного элемента во всем исходном файле (см. Полосы ошибок). Щелкните полосу ошибки для быстрого перехода к требуемому экземпляру использования.

Если требуется переименовать все подсвеченные случаи вхождения, используйте команду "Быстрое переименование" (нажмите комбинацию клавиш Ctrl+R или выберите в меню "Реорганизация кода" > "Переименовать").

 

Переходы

В редакторе Java предусмотрено множество способов перехода по коду. Ниже приводится ряд примеров функций переходов по редактору Java.

Полосы ошибок

Полосы ошибок в правом поле обеспечивают удобный обзор всех отмеченных областей в текущем файле, в том числе ошибок, предупреждений, подсказок, подсвеченных экземпляров и аннотаций. Следует отметить, что поле полос ошибок относится ко всему файлу, а не только к той его части, которая отображается в редакторе. Использование полос ошибок позволяет быстро обнаруживать наличие ошибок или предупреждений в файле без необходимости его прокрутки.

Щелкните полосу ошибки для перехода к соответствующей ей строке

Навигация в редакторе: "Перейти к..."

Изображение, показывающее команду 'Перейти к'

Команды "Перейти к...", вызываемые из меню "Переход" используются для быстрого перехода к требуемым областям:

  • Переход к объявлению (по умолчанию Ctrl+B). Нажмите и удерживайте клавишу Ctrl и щелкните случай вхождения класса, метода или поля для быстрого перехода к его объявлению. Вы также можете поместить курсор на член (класс, метод или поле) и выбрать 'Переход' > 'Перейти к объявлению' или щелкните правой кнопкой мыши и выберите 'Переход > 'Перейти к объявлению' во всплывающем меню.
  • Переход к исходному тексту (по умолчанию Ctrl+Shift+B). Нажмите и удерживайте клавишу Ctrl и щелкните класс, метод или поле для быстрого перехода к исходному коду, если он доступен. Кроме того, можно установить курсор на каком-либо элементе (классе, методе или поле) и нажать комбинацию клавиш Ctrl+Shift+B или выбрать "" > "Перейти к исходному тексту".

Изображение, показывающее диалоговое окно 'Перейти к типу'

  • Перейти к типу (Ctrl+O), Перейти к файлу (Alt+Shift+O), и Перейти к символу (Ctrl+Alt+Shift+O). Если известно имя типа (класс, интерфейс, аннотация, перечисление), файл или символ, к которому требуется перейти, используйте эти команды и введите требуемое имя в новом окне. При этом можно использовать префиксы, CamelCase и групповые символы.

Изображение, показывающее диалоговое окно 'Перейти к строке'

  • Перейти к строке (Ctrl+G). Введите номер строки, к которой требуется перейти.

Быстрый переход к последнему редактируемому элементу

Изображение, показывающее кнопку 'Быстрый переход к последнему элементу правки'

Для быстрого возврата к месту последней правки (в том числе в другом файле или проекте) нажмите комбинацию клавиш Ctrl+Q или соответствующую кнопку в левом верхнем углу панели инструментов редактора Java. Откроется последний измененный документ, и курсор при этом будет установлен в месте последней правки.

Переход между файлами

Изображение, показывающее кнопки, использованные для переключения между открытыми файлами

 

Предусмотрено две удобных функции перехода между файлами:

  • Назад (Alt-Left) и Вперед (Alt-Right). Чтобы перейти к ранее измененному файлу или переместиться вперед, выберите 'Перейти<назад' или 'Перейти<вперед' или нажмите соответствующую кнопку на панели инструментов редактора (показано на рисунке). Файл откроется, и курсор при этом будет установлен в месте последней правки. При нажатии какой-либо из этих кнопок можно развернуть список последних открытых файлов и щелкнуть любой из них для перехода к этому файлу.

Изображение, показывающее всплывающее меню для переключения между файлами

  • Переход по файлам (Ctrl+Tab). При нажатии комбинации клавиш Ctrl+Tab во всплывающем окне появится список всех открытых файлов. Удерживая нажатой клавишу Ctrl, несколько раз нажмите клавишу Tab, чтобы выбрать файл, который необходимо открыть.

Использование закладок

Изображение, показывающее пример закладки

Для быстрого перехода к определенным областям кода можно использовать закладки.

Нажмите сочетание клавиш Ctrl-Shift-M (или щелкните правой кнопкой мыши левое поле и выберите 'Закладки' > 'Переключить закладки'), чтобы добавить в закладки текущую строку. Строка с закладкой отмечается маленьким синим значком в левом поле (см. рисунок).

Для удаления закладки нажмите Ctrl+Shift+M еще раз.

Для перехода к следующей закладке нажмите Ctrl+Shift+точка, для перехода к предыдущей закладке нажмите Ctrl+Shift+запятая.

Использование навигатора

Пример окна 'Навигатор'

В окне "Навигатор" отображаются структуры файла, с которым вы работаете, которые позволяют быстро переходить от одной части файла к другой.

Для вызова окна "Навигатор" выберите "Окно" > "Навигация" > "Навигатор" или нажмите комбинацию клавиш Ctrl+7.

В окне "Навигатор" можно выполнять следующие действия:

  • выбор между различными вариантами просмотра: "Члены", "Шаблоны компонентов", "Деревья", "Элементы" и т.д.
  • Дважды щелкните элемент для перехода к строке с его определением.
  • По щелчку элемента правой кнопкой можно выполнить различные команды: "Перейти к исходному тексту", "Поиск использований" и "Реорганизация кода".
  • С помощью кнопок в нижней части окна "Навигатор" можно применять к элементам фильтры.
  • Для поиска требуемого элемента ведите его имя (окно "Навигатор" должно быть активным).

 


Дополнительные сведения

В начало

Приложение A: значки в окне автозавершения кода

Значок Значение Варианты (при наличии)

Значение

Значок 'Тип аннотаций' Тип аннотаций    
Значок 'Класс' Класс    
Значок 'Пакет' Пакет    
Значок 'Тип перечисления' Тип перечисления    
Значок 'Шаблон кода' Шаблон кода    
Значок 'Конструктор' Конструктор Значок 'Новый конструктор' Новый конструктор (создание)
    Значок 'Защищенный конструктор' Защищенный конструктор
    Значок 'Закрытый конструктор' Закрытый конструктор
    Значок 'Закрытый конструктор пакета' Закрытый конструктор пакета
Значок 'Поле' Поле Значок 'Защищенное поле' Защищенное поле
    Значок 'Закрытое поле' Закрытое поле
    Значок 'Закрытое поле пакета' Закрытое поле пакета
Значок 'Статические поля' Статическое поле Значок 'Защищенные статические поля' Защищенное статическое поле
    Значок 'Закрытые статические поля' Закрытое статическое поле
    Значок 'Закрытые статические поля пакета' Закрытое статическое поле пакета
Значок 'Интерфейс' Интерфейс    
Значок 'Ключевое слово Java' Ключевое слово Java    
Значок 'Метод' Метод Значок 'Защищенные методы' Защищенный метод
    Значок 'Закрытые методы' Закрытый метод
    Значок 'Закрытое поле пакета' Закрытый метод пакета
Значок 'Статические методы' Статический метод Значок 'Защищенные статические методы' Защищенный статический метод
    Значок 'Закрытые статические методы' Закрытый статический метод
    Значок 'Закрытые статические методы пакета' Закрытый статический метод пакета
Значок 'Локальная переменная' Локальная переменная    
Значок 'Атрибут' Атрибут    
get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2015, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo