NetBeans IDE Javaエディタでのコード支援: リファレンス・ガイド

統合開発環境(IDE)の目的は、生産性を最大限にすることと、単一のツールからのシームレスな開発をサポートすることです。このリファレンス・ドキュメントでは、NetBeans IDEのJavaエディタに備わった、便利なコード支援機能、カスタマイズ・オプション、およびナビゲーション機能を説明します。

エディタの生産性を向上させる機能の使用方法を表示するには、NetBeans IDEでのJavaコードの編集スクリーンキャストを視聴してください。

内容

このページの内容は、NetBeans IDE 6.9以降に適用されます

このチュートリアルを完了するには、次の表に示すソフトウェアとリソースが必要です。

ソフトウェアまたはリソース 必須バージョン
NetBeans IDE バージョン6.9以降
Java Development Kit (JDK) バージョン6または7

スマート・コード補完

NetBeans IDEのJavaエディタは、スマート・コード補完機能を使用してコードをすばやく記述および生成できます。一般に、コード補完機能は、不足しているコードを追加する場合、アプリケーションとの関連で使用できるオプションを探す場合、必要に応じてコード・ブロックを生成する場合にとても便利です。コード補完の使用方法の例を次に示します。

コード補完の呼出し

コード補完ボックス

[Ctrl]-[Space]を押すか、またはメイン・メニューから「ソース」>「コードを補完」を選択して、コード補完ボックスを表示します。入力するに従って、候補の一覧は短くなります。一覧表示される候補には、java.langパッケージからソース・ファイルにインポートされた候補と記号が含まれます。

コード補完設定をカスタマイズするには、「ツール」>「オプション」>「エディタ」>「コード補完」を選択します。

たとえば、「コード補完」ウィンドウを自動的にポップアップするように設定したり、必要な場合にのみポップアップするように設定することもできます。「コード補完」タブで、「補完ウィンドウを自動ポップアップ」チェックボックスを選択すると、特定の文字の入力時に「コード補完」ウィンドウが自動的に呼び出されます。デフォルトの文字は「.」ですが、独自の文字を追加してもかまいません。

「コード補完」ウィンドウを呼び出す文字を追加するには、「言語」ドロップダウン・リストから「Java」選択し、「Java用自動ポップアップのトリガー」フィールドに目的の文字を入力します。指定した文字を入力すると常に「コード補完」ウィンドウがポップアップするようになります。

「補完ウィンドウを自動ポップアップ」チェックボックスが無効になっている場合、コード補完を使用するには毎回[Ctrl]-[Space]を押す必要があります。

最上部に表示されるスマート候補

スマート候補が表示されたコード補完ボックス

NetBeans IDEのJavaコード補完は「スマート」であるため、コードの文脈に最も関連のある候補が、「コード補完」ウィンドウの最上位の黒い線より上に表示されます。

左の例では、エディタはjava.utilパッケージからLinkedHashMapコンストラクタを挿入することを候補にあげています。

「スマート」候補に使用するものがない場合、再度[Ctrl]-[Space]を押してリスト全体を表示します。

キーワード補完

キーワードの補完

コード補完([Ctrl]-[Space])を使用して、コード内のキーワードを補完できます。エディタが文脈を分析し、最も関連のあるキーワードが候補として表示されます。

左の例では、ColorChooserDemoクラスがJPanelクラスを拡張します。候補の項目から、extendsキーワードをすばやく追加できます。

変数とフィールドに対する名前候補の表示

名前とフィールドの補完

新しいフィールドまたは変数を追加するときに、コード補完([Ctrl]-[Space])を使用して、その型に一致する名前を選択できます。

新しい名前の接頭辞を入力して[Ctrl]-[Space]を押し、使用する名前を候補の一覧から選択します。

パラメータ候補の表示

パラメータ書式の候補

エディタは、変数、メソッド、またはフィールドのパラメータを推測し、候補をポップアップ・ボックスに表示します。

たとえば、1つ以上の引数を持つメソッドを「コード補完」ウィンドウから選択した場合、最初の引数がエディタで強調表示され、この引数の書式の候補を示すツールチップが表示されます。次の変数に移動するには、[Tab]キーまたは[Enter]キーを押します。

[Ctrl]-[P](または「ソース」>「メソッドのパラメータを表示」)を押すと、メソッド・パラメータのツールチップをいつでも呼び出すことができます。

一般的な接頭辞補完

接頭辞の補完

[Tab]キーを押すと、最も広く使用される接頭辞と単一の候補をすばやく補完できます。

この機能の動作を確認するには、次のように入力します。

  1. System.out.p」と入力し、コード補完で「p」から始まるすべてのフィールドとメソッドが表示されるのを待ちます。表示される候補はすべて「print」関連です。
  2. [Tab]キーを押すと、エディタで「print」が自動的に補完されます。
    次に「l」と入力して[Tab]を押すと、「println」が追加されます。

「コード補完」ウィンドウでは、Java言語の異なるメンバーを識別するためにアイコンが使用されます。これらのアイコンの意味を確認するには、このドキュメントの最後の付録Aを参照してください。

先頭

インポートの管理

インポート文を使用する方法はいくつかあります。IDEのJavaエディタでは、コードでインポート文が正しく使用されているかどうかが常に確認され、インポートされていないクラスまたは使用されていないインポート文が検出されるとすぐに警告が表示されます。

インポート文の候補

 

インポートされていないクラスが見つかった場合、電球エラー・アイコンエラー・マークがIDEの左マージンに表示されます(このマージンは、グリフ・マージンとも呼ばれます)。エラー・マークをクリックし、見つからないインポートを追加するか、またはこのクラスを現在のパッケージ内に作成するかを選択します。

見つからないすべてのインポート文を一度に追加するには、入力中に[Ctrl]-[Shift]-[I]を押します(またはメニューから「ソース」>「インポートを修正」を選択します)。

カーソルがある場所の型のインポートのみを追加するには、[Alt]-[Shift]-[I]を押します。

 

インポート文の自動追加

「コード補完」ウィンドウからクラスを選択すると、エディタによってクラスにインポート文が自動的に追加されるため、これについて考慮する必要はありません。

使用されていないインポートの自動除去

使用されていないインポート文がコード内にある場合、エディタの左マージンにある電球警告アイコン警告マークを押し、使用されていないインポートを1つ除去するか、すべて除去するかを選択します。エディタでは、使用されていないインポートには下線が表示されます(詳細は、意味解釈の色分けの項を参照)。

コードに、使用されていないインポートや見つからないインポートがあるかどうかをすばやく確認するには、右マージンのエラー・ストライプを見ます。オレンジ色のストライプは、見つからないインポートまたは使用されていないインポートを示します。

先頭

コードの生成

Javaエディタでの作業中、コード補完を使用するか、または「コード生成」ダイアログ・ボックスから、コードの部分を生成できます。自動コード生成の単純な例を次に示します。

「コード生成」ダイアログ・ボックスの使用

「コード生成」ダイアログ・ボックスからのコード生成

 

エディタ内の任意の場所で[Alt]-[Insert]を押し(または「ソース」>「コードを挿入」を選択)、「コード生成」ボックスからコンストラクタを挿入します。候補の一覧は、現在の文脈にあわせて調整されます。

左の例では、Sampleクラスにコンストラクタを生成しようとしています。[Alt]-[Insert]を押して「コード生成」ボックスから「コンストラクタ」を選択し、コンストラクタによって初期化されるフィールドを指定します。エディタで、指定したパラメータを使用してコンストラクタが生成されます。

IDEのJavaエディタでは、様々なコンストラクタとメソッド全体の生成、メソッドのオーバーライドと委譲、プロパティの追加などを自動的に行えます。

コード補完の使用

「コード補完」ウィンドウからのコード生成

コードは、「コード補完」ウィンドウから生成することもできます。この例では、前述と同じコード部分を使用して、「コード補完」ウィンドウからコードを生成する方法を示します。

[Ctrl]-[Space]を押して「コード補完」ウィンドウを開き、「Sample(String name, int number) - generate」を選択します。エディタで、指定したパラメータを使用してコンストラクタが生成されます。

「コード補完」ウィンドウでは、自動的に生成できるコンストラクタに「生成」アイコンアイコンと「generate」というノートがマークされます。アイコンとその意味の説明については、付録Aを参照してください。

先頭

コード・テンプレート

コード・テンプレートとは、関連付けられた省略名を持つ、定義済のコードです。コード・テンプレートの使用方法を次の例に示します。

コード・テンプレートの使用方法

「コード補完」ウィンドウからのテンプレートの挿入

コード・テンプレートは、「コード補完」ウィンドウ内でライブ・テンプレート・アイコンアイコンがマークされます。

次のいずれかの操作を実行できます。

  • テンプレートを「コード補完」ウィンドウから選択し、[Enter]を押します。
  • このテンプレートの省略名を入力し、このテンプレートを展開するキーを押します(デフォルトでは[Tab])。

展開されたテンプレートで、編集できる部分は青いボックスで表示されます。[Tab]キーを使用し、編集する必要がある部分を移動します。

コード・テンプレートの追加または編集

ライブ・テンプレートのカスタマイズ

コード・テンプレートをカスタマイズするには:

  1. 「ツール」>「オプション」>「エディタ」>「コード・テンプレート」を選択します。
  2. 「言語」ドロップダウン・リストから、「Java」(またはコード・テンプレートの作成に使用する任意の言語)を選択します。省略名の一覧と、それに関連付けられたテンプレートが表示されます。
  3. 「新規」ボタンと「除去」ボタンを使用し、一覧のテンプレートを追加または除去します。既存のテンプレートを編集するには、テンプレートを選択し、一覧の下にある「展開されるテキスト」フィールド内でコードを編集します。
  4. テンプレートの展開に使用するキーを選択します。デフォルトのキーは[Tab]です。

新しいコード・テンプレートを記述するための構文の詳細は、このドキュメントを参照してください。

PHP向けのNetBeans IDEのコード・テンプレートも参照してください。

先頭

Javadocの操作

コードでJavadocを使用しやすくする次の機能を使用します。

Javadocの表示

Javadocウィンドウ。

カーソルを要素の上に置き、[Ctrl]-[Shift]-[Space](または「ソース」>「ドキュメントを表示」を選択)を押します。この要素のJavadocがポップアップ・ウィンドウに表示されます。

IDEのメイン・メニューで、「ウィンドウ」>「その他」>「Javadoc」をクリックしてJavadocウィンドウを開きます。このウィンドウでは、カーソル位置についてのドキュメントが自動的にリフレッシュされます。

 

 

 

Javadocスタブの作成

Javadocスタブの作成

カーソルをJavadocのないメソッドまたはクラスの上に置き、「/**」と入力し、[Enter]を押します。

IDEでは、内容を補足するJavadocコメントの骨格構造が作成されます。Javadocウィンドウを開いている場合は、入力中に変更内容が即時に表示されます。

 

Javadocヒントの使用

Javadocヒントの使用

IDEでは、Javadocが見つからない場合、またはJavadocタグが必要な場合にヒントが表示されます。

Javadocエラーを修正するには、エディタの左マージンの電球アイコンをクリックします。

Javadocに関連するヒントを表示しない場合は、「ツール」>「オプション」>「エディタ」>「ヒント」を選択し、表示されるヒントの一覧で「Javadoc」チェックボックスを選択解除します。

Javadocタグに対するコード補完の使用

Javadocに対するコード補完

Javadocタグにはコード補完を使用できます。

「@」記号を入力して、「コード補完」ウィンドウが開くまで待ちます(設定によっては、[Ctrl]-[Space]を押す必要があります)。

Javadocの生成

生成されたJavadocの出力

プロジェクトにJavadocを生成するには、「実行」>「Javadocを生成」メニュー項目を選択(または「プロジェクト」ウィンドウ内のプロジェクトを右クリックして「Javadocを生成」を選択)します。IDEでJavadocが生成され、個別のブラウザ・ウィンドウに表示されます。

左の例に、「Javadocを生成」コマンドの出力サンプルを示します。警告またはエラーがある場合は、それらもこのウィンドウに表示されます。

Javadocフォーマット・オプションをカスタマイズするには、プロジェクトを右クリックして「プロパティ」を選択し、「ビルド」カテゴリの下にある「ドキュメント化」パネル(Javaプロジェクトでのみ使用可能)を開きます。このパネルのオプションについては、このウィンドウの「ヘルプ」ボタンをクリックします。

Javadocの解析

「Javadocアナライザ」ウィンドウ

Javadocコメントが必要なコード内の場所を特定し、それらのコメントをすばやく挿入するには、Javaエディタで使用できるJavadocアナライザ・ツールを使用します。

Javadocコメントを解析して修正するには:

  1. プロジェクト、パッケージ、または個別のファイルを選択し、メイン・メニューから「ツール」>「Javadocを解析」を選択します。
    選択範囲に応じて、Javadocコメントを追加または修正するための候補が「アナライザ」ウィンドウに表示されます。
  2. Javadocを修正する箇所の1つまたは複数のチェックボックスを選択し、「選択項目を修正」ボタンをクリックします。
  3. 「修正した問題を見直し」をクリックし、[↑]または[↓]を使用して実際にコメントを追加します。この機能は、修正するいくつかのインスタンスを一度に選択し、再度スタブに移動する場合に便利なことがあります。

先頭

ヒントの使用

入力中に、Javaエディタでコードが確認され、エラーを修正してコードを移動する方法の候補が提供されます。次の例に、このエディタで使用できるヒントのタイプと、それらをカスタマイズする方法を示します。

コード修正のためのヒントの使用

コード修正のためのヒントの使用

一般的なコーディングの間違いについて、エディタの左マージンにヒントが表示されます。フィールドの不足、変数の定義、インポートや括弧の問題など、様々なタイプのエラーに関するヒントが表示されます。ヒント・アイコンをクリックし、追加する修正を選択します。

ヒントは、デフォルトで自動的に表示されます。すべてのヒントを表示する場合、「ソース」>「コードを修正」を選択します(または[Alt]-[Enter]を押します)。

たとえば、「myBoolean=true」と入力してみます。この変数が定義されていないことがエディタで検出されます。ヒント・アイコンをクリックすると、フィールド、メソッド・パラメータ、またはローカル変数の作成が提案されることがエディタに表示されます。選択

ヒントのカスタマイズ

ヒントのオプションのカスタマイズ

表示するヒントのカテゴリ数は制限できます。これを行うには、次の手順に従ってください。

  1. 「ツール」>「オプション」>「エディタ」>「ヒント」を選択します。
  2. 「言語」ドロップダウン・リストから「Java」を選択し、ヒントを表示する要素の一覧を表示します(チェックボックスは選択された状態)。
  3. 一部のカテゴリのヒントを無効にするには、該当するチェックボックスを選択解除します。

注意: 「ヒント」タブで、依存性のスキャンのスコープ(「依存性のスキャン」オプション)を無効にしたり、制限したりすることもできます。これらの手順を実行すると、IDEのパフォーマンスが大幅に向上することがあります。

IDEは、変更中のファイルに依存するクラスを特定して再コンパイルすることで、Javaソースのコンパイル・エラーを検出します(これは、エディタで開いていないファイル内に依存性がある場合でも実施されます)。コンパイル・エラーが見つかった場合、赤いバッジがソース・ファイル、パッケージ、またはプロジェクト・ノードに追加されます。プロジェクト内での依存性のスキャンは、リソース消費を増やすことがあり、特に大規模プロジェクトを操作している場合にパフォーマンスが低下することがあります。

IDEのパフォーマンスを改善するため、次のいずれかを実行できます。

  • 依存性のスキャンのスコープをソース・ルートに制限する(変更されたクラスがあるソース・ルート内でのみ依存性を検索する)か、または現在のプロジェクトに制限します。
  • 依存性のスキャンを無効にします(「プロジェクト・プロパティ」>「ビルド」>「コンパイル」を選択し、「Javaの依存性をトラック」オプションを選択解除します)。この場合、ファイルの変更時に、IDEで依存性またはエラー・バッジの更新がスキャンされません。

囲む...

「囲む」オプション

コードの一部をforwhileiftry/catchなどの様々な文で簡単に囲むことができます。

文で囲むコード内のブロックを選択し、左マージンの電球アイコンをクリックします(または[Alt]-[Enter]を押す)。候補の一覧が表示され、ここから必要な文を選択できます。

一般的なエディタ機能

コードのフォーマット

フォーマットのカスタマイズ・オプション

「ソース」>「フォーマット」を選択するか、または[Alt]-[Shift]-[F]を押し、ファイル全体またはコードの選択部分をフォーマットします。指定したフォーマット設定に従って、IDEでコードがフォーマットされます。

Javaコードのフォーマット設定をカスタマイズするには:

  1. 「ツール」>「オプション」>「エディタ」>「フォーマット」を選択します。
  2. 「言語」ドロップダウン・リストから「Java」を選択します。
  3. 「カテゴリ」ドロップダウン・リストから、カスタマイズするカテゴリを選択します。たとえば、空白行の数、タブとインデントのサイズ、折返しスタイルなどをカスタマイズできます。
  4. 選択したカテゴリのルールを変更し、結果をプレビューします。

中括弧、括弧、および引用符の挿入と強調表示

括弧のカスタマイズ・オプション

IDEでは、デフォルトで、対応する中括弧、括弧、および引用符のペアが自動的に挿入されます。開始中括弧を入力し、[Enter]を押すと、閉じ中括弧が自動的に追加されます。(["、および'に対し、対応するペアがすぐに挿入されます。

なんらかの理由でこの機能が無効にされている場合は、次のようにして有効にします。

  1. 「ツール」>「オプション」>「エディタ」>「コード補完」を選択します。
  2. 「閉じ括弧を自動的に挿入」チェックボックスを選択します。

また、対応する中括弧、括弧、および引用符のペアも、エディタで強調表示されます。たとえば、任意の中括弧または括弧の前にカーソルを置き、それに対応するペアがある場合、両方が黄色で強調表示されます。どの種類でも、括弧が単独の場合には赤で強調表示され、エラー・マークが左マージンに表示されます。

強調表示の色をカスタマイズするには、「ツール」>「オプション」>「フォントと色」>「強調表示」を選択します。

コード折りたたみ

コード折りたたみの例

Javaエディタでは、メソッドの宣言、Javadocコメント、インポート文などのコード・ブロックをすばやく縮小したり、展開したりできます。縮小可能なブロックはグレーの線で示され、エディタの左マージン付近にプラス記号またはマイナス記号が表示されます。

  • コード・ブロックを縮小する最も簡単な方法は、左マージンにマイナス記号があるグレーの行をクリックすることです。
  • ファイル内の縮小可能なブロックをすべて折りたたむには、エディタ内で右クリックし、ポップアップ・メニューから「コード折りたたみ」>「すべてを縮小」を選択します。
  • 「コード折りたたみ」>「すべてを縮小」のポップアップ・メニューで、ファイル内のJavadocコメントをすべて縮小するか、またはJavaコードをすべて縮小するかを選択できます。
  • 折りたたまれた要素の上にマウスを移動すると、非表示の部分を簡単に確認できます。

コード折りたたみオプションをカスタマイズするには:

  1. 「ツール」>「オプション」>「エディタ」>「一般」を選択します。
  2. コード折りたたみを無効にするには、「コード折りたたみの使用」を選択解除します。コード折りたたみは、デフォルトで有効になっています。
  3. ファイルを開いたときにデフォルトで縮小されるコード・ブロックを選択します。

キーボード・ショートカットのカスタマイズ

キーボードのカスタマイズ・オプション

NetBeans IDEで、「ツール」>「オプション」>「キーマップ」を選択し、キーボード・ショートカットをカスタマイズします。この処理は、次のいくつかの方法で実行できます。

  • 定義済のキーボード・ショートカットのセット(プロファイルと呼ばれます)を選択します。
  • 特定のキーボード・ショートカットを編集します。

カスタマイズしたショートカットのセットは、プロファイルとして保存できます。これにより、あるプロファイルから別のプロファイルに切り替えることができるようになり、複数の設定をすばやく変更できます。たとえば、キーボード・ショートカットのカスタム・プロファイルを作成するには:

  1. 「オプション」>「キーマップ」ウィンドウで、「プロファイルの管理」をクリックします。
  2. 新しいプロファイルのベースに使用するプロファイルを選択し、「複製」をクリックします。
  3. 新規プロファイル名を入力し、「OK」をクリックします。
  4. 新規プロファイルが選択されていることを確認し、必要なショートカットを変更します。
    ショートカットを編集するには、「ショートカット」フィールドをダブルクリックするか、または省略符号ボタン(...)をクリックします。一連のキーを押すと、それらの構文が追加されます。
    TabESC、またはEnterなどの特殊文字を追加する場合、省略符号ボタン(...)を再度クリックし、ポップアップ・ウィンドウからキーを選択します。
  5. 編集が終了したら、「オプション」ウィンドウの「OK」をクリックします。

特定のコマンド用のショートカットを検索するには、コマンド名を「検索」フィールドに入力します。コマンドを組合せで検索するには、カーソルを「ショートカットを検索」フィールドに挿入し、ショートカット・キーの組合せを押します。

 

意味解釈の色分けと強調表示

IDEのJavaエディタでは、コードの意味解釈に基づいて、コード要素が異なる色で表示されます。意味解釈の色分けにより、コード内の様々な要素が識別しやすくなります。色分けに加え、Javaエディタでは類似要素が特定の背景色で強調表示されます。したがって、エラー・ストライプの組合せによって、強調表示された場所がファイル内のどこにあるかをひと目で確認できるため、強調表示機能は「検索」コマンドにかわるものとして考えることができます。

配色のカスタマイズ

配色のカスタマイズ・オプション

Javaエディタの意味解釈の配色設定をカスタマイズするには、「ツール」>「オプション」>「フォントと色」を選択します。

IDEには、プロファイルと呼ばれる事前設定されたいくつかの色スキームが用意されています。カスタムの色を使用した新規プロファイルを作成でき、作成したプロファイルを簡単に切り替えることができます。

新規プロファイルにカスタムの色を保存すると、とても便利です。たとえば、次のように操作します。

  1. 「オプション」>「フォントと色」ウィンドウで、「プロファイル」ドロップダウン・リストの横にある「複製」をクリックします。
  2. 新規プロファイル名を入力し、「OK」をクリックします。
  3. 新規プロファイルが現在選択されていることを確認し、「言語」ドロップダウン・リストから「Java」を選択します。
  4. カテゴリを選択し、そのカテゴリに対し、フォント、フォントの色(前景)、背景色、および効果を変更します。
    「プレビュー」ウィンドウを使用して、結果を表示します。
  5. 「OK」をクリックします。

注意: すべてのNetBeans IDE設定とプロファイルは、NetBeansのユーザー・ディレクトリに格納されます(使用しているオペレーティング・システムのuserdirの場所を探す方法については、FAQを参照)。新しいバージョンのNetBeansにアップグレードする場合、古い設定をエクスポートし、それらを新しいバージョンにインポートできます。

IDEの設定をエクスポートするには:

  1. 「オプション」ウィンドウ(「ツール」>「オプション」)で「エクスポート」をクリックします。
  2. 作成するZIPファイルの場所と名前を指定します。
  3. エクスポートする設定を選択し、「OK」をクリックします。

IDEの設定をインポートするには:

  1. 「オプション」ウィンドウ(「ツール」>「オプション」)で「インポート」をクリックします。
  2. IDEの設定があるZIPファイルを指定するか、以前のバージョンからのuserdirのパスを指定します。
  3. インポートする設定を選択し、「OK」をクリックします。

 

色分けの例

色分けの例を示すイメージ

左側で、配色スキームの例を参照できます。カスタム設定によっては、このスクリーンショットの表示と色が異なる場合があります。

キーワード(青)、変数とフィールド(緑)、およびパラメータ(オレンジ)には、それぞれ異なる色が使用されます。

非推奨のメソッドまたはクラスへの参照には、取消し線が表示されます。これは、非推奨のメンバーに依存するコードを記述しようとしていることを警告します。

使用されないメンバーには、下線にグレーの波線が表示されます。コメントはグレーで表示されます。

 

強調表示の使用

強調表示の使用を示すイメージ

IDEでは、同じ要素、一致した括弧、メソッドの終了ポイント、および例外のスロー・ポイントの使用状況が強調表示されます。

カーソルをフィールドや変数などの要素の上に置くと、この要素のすべての使用状況が強調表示されます。エディタの右マージンにあるエラー・ストライプは、ソース・ファイル全体でのこの要素の使用状況を示しています(エラー・ストライプを参照)。エラー・ストライプをクリックすると、目的の使用状況の場所にすばやく移動できます。

強調表示されているすべてのインスタンスを名前変更する場合、「名前の即時変更」コマンド([Ctrl]-[R]、または「リファクタリング」>「名前変更」を選択)を使用します。

 

ナビゲーション

Javaエディタには、コード内を移動するための様々な方法が用意されています。Javaエディタのナビゲーション機能を示すいくつかの例を次に示します。

エラー・ストライプ

エディタの右マージンに表示されるエラー・ストライプには、現在のファイル内にあるマークされたすべての場所(エラー、警告、ヒント、強調表示、および注釈)の概要が示されます。エラー・ストライプ・マージンは、現在エディタに表示されている部分のみでなく、ファイル全体を表します。エラー・ストライプを使用することで、ファイルにエラーまたは警告があるかどうかが、ファイル内をスクロールしなくてもすばやく特定できます。

マークで参照されている行にジャンプするには、エラー・ストライプをクリックします。

エディタからのナビゲート: 「移動」

「移動」コメンドを示すイメージ

ターゲットの場所にすばやくジャンプするには、「ナビゲート」メニュー項目の下にある次の「移動..」コマンドを使用します。

  • 「宣言へ移動」(デフォルトでは[Ctrl]-[B])。[Ctrl]キーを押しながら、クラス、メソッド、またはフィールドの使用状況をクリックすると、その宣言にジャンプできます。また、カーソルをメンバー(クラス、メソッド、またはフィールド)の上に置き、「ナビゲート」>「宣言へ移動」を選択するか、右クリックしてポップアップ・メニューから「ナビゲート」>「宣言へ移動」を選択します。
  • 「ソースへ移動」(デフォルトでは[Ctrl]-[Shift]-[B])。[Ctrl]キーを押しながら、クラス、メソッド、またはフィールドをクリックすると、ソースが使用できる場合には、そのソース・コードにジャンプできます。また、カーソルをメンバー(クラス、メソッド、またはフィールド)の上に置き、[Ctrl]-[Shift]-[B]を押すか、メイン・メニューから「ナビゲート」>「ソースへ移動」を選択することもできます。

「型に移動」ダイアログ・ボックスを示すイメージ

  • 「型に移動」([Ctrl]-[O])「ファイルへ移動」([Alt]-[Shift]-[O])、および「シンボルへ移動」([Ctrl]-[Alt]-[Shift]-[O])。ジャンプ先の型(クラス、インタフェース、注釈、または列挙)、ファイル、またはシンボルの名前がわかっている場合、これらのコマンドを使用し、新規ウィンドウに名前を入力します。接頭辞、キャメル・ケース、およびワイルド・カードを使用できます。

「行へ移動」ダイアログ・ボックスを示すイメージ

  • 「行へ移動」([Ctrl]-[G])。ジャンプする行番号を入力します。

最後の編集に移動

最後の編集に移動ボタンを示すイメージ

最後に編集した箇所にすばやく戻るには、別のファイルやプロジェクトにある場合でも、[Ctrl]-[Q]を押すか、またはJavaエディタ・ツールバーの左上隅のボタンを使用します。最後に編集したドキュメントが開き、カーソルが最後に編集した位置に移動します。

ファイル間の切替え

開いているファイル間の切替えに使用するボタンを示すイメージ

 

開いているファイル間を切り替えるには、次の2種類の便利な機能が使用できます。

  • 戻る([Alt]-[←])進む([Alt]-[→])。前に編集したファイルに移動したり、次に進んだりするには、「ナビゲート」>「戻る」または「ナビゲート」>「進む」を選択するか、またはエディタのツールバーにある対応するボタンを押します(図を参照)。ファイルが開き、最後に編集した場所にカーソルが移動します。これらのボタンのいずれかをクリックすると、最新ファイルの一覧を展開でき、クリックして任意のファイルに移動できます。

ファイル間を切り替えるためのポップアップ・メニューを示すイメージ

  • ファイル間を切り替える([Ctrl]-[Tab])。[Ctrl]-[Tab]を押すと、開いているすべてのファイルがポップアップ・ウィンドウに表示されます。[Ctrl]キーを押したまま、[Tab]キーを何回か押すと、開くファイルを選択できます。

ブックマークの使用

ブックマークの例を示すイメージ

ブックマークを使用すると、コード内の特定の場所にすばやく移動できます。

[Ctrl]-[Shift]-[M]を押すか、または左マージンを右クリックして「ブックマーク」>「ブックマークを切替え」を選択すると、現在の行がブックマークされます。ブックマークされた行には、左マージンに小さな青いアイコンが表示されます(図を参照)。

ブックマークを除去するには、再度[Ctrl]-[Shift]-[M]を押します。

次のブックマークに移動するには[Ctrl]-[Shift]-[.] (ピリオド)を押し、前のブックマークに移動するには[Ctrl]-[Shift]-[,] (カンマ)を押します。

ナビゲータの使用

「ナビゲータ」ウィンドウの例

「ナビゲータ」ウィンドウを使用すると、使用中のファイルの構造化されたビューを表示でき、ファイルの異なる部分の間をすばやく移動できます。

「ナビゲータ」ウィンドウを開くには、「ウィンドウ」>「ナビゲート」>「ナビゲータ」を選択するか、[Ctrl]-[7]を押します。

「ナビゲータ」ウィンドウでは次の操作を実行できます。

  • 「メンバー」、「Beanパターン」、「ツリー」、「要素」などの異なるビュー間で選択します。
  • 要素をダブルクリックすると、その要素が定義されている行にジャンプします。
  • 要素を右クリックし、「ソースへ移動」、「使用状況を検索」、および「リファクタリング」などのコマンドを適用します。
  • 「ナビゲータ」に表示された要素にフィルタを適用します(最下部のボタンを使用)。
  • 検索する要素の名前を入力します(「ナビゲータ」ウィンドウはアクティブである必要があります)。

 


関連項目

先頭

付録A: 「コード補完」ウィンドウのアイコン

アイコン 意味 形状(該当する場合)

意味

注釈型アイコン 注釈型    
クラス・アイコン クラス    
パッケージ・アイコン パッケージ    
列挙型アイコン 列挙型    
コード・テンプレート・アイコン コード・テンプレート    
コンストラクタ・アイコン コンストラクタ 新規コンストラクタ・アイコン 新規コンストラクタ(生成)
    protectedコンストラクタ・アイコン protectedコンストラクタ
    privateコンストラクタ・アイコン privateコンストラクタ
    package privateコンストラクタ・アイコン package privateコンストラクタ
フィールド・アイコン フィールド protectedフィールド・アイコン protectedフィールド
    privateフィールド・アイコン privateフィールド
    package privateフィールドのアイコン package privateフィールド
静的フィールドのアイコン 静的フィールド protected静的フィールド・アイコン protected静的フィールド
    private静的フィールドのアイコン private静的フィールド
    package private静的フィールドのアイコン package private静的フィールド
インタフェース・アイコン インタフェース    
Javaキーワード・アイコン Javaキーワード    
メソッド・アイコン メソッド protectedメソッドのアイコン protectedメソッド
    privateメソッドのアイコン privateメソッド
    package privateメソッドのアイコン package privateメソッド
静的メソッドのアイコン 静的メソッド protected静的メソッドのアイコン protected静的メソッド
    private静的メソッドのアイコン private静的メソッド
    package private静的メソッドのアイコン package private静的メソッド
ローカル変数アイコン ローカル変数    
属性アイコン 属性    
get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2015, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo