Debugging C/C++ Projects Tutorial

The following short tutorial takes you through some of the features for debugging a C or C++ project in NetBeans IDE.

Contents

Content on this page applies to NetBeans IDE 7.2 and 7.3
Requirements
Creating the Sample Project
Creating Breakpoints
Starting a Debugging Session
Inspecting the State of the Application

Requirements

To follow this tutorial, you need the following software and resources.

Software or Resource Version Required
NetBeans IDE version 7.3 with NetBeans C/C++ plugin module
Java Developer Kit (JDK) version 7

See the NetBeans IDE 7.2 Installation Instructions and Configuring the NetBeans IDE for C/C++/Fortran for information on downloading and installing the required software.

Creating the Sample Project

The NetBeans IDE with C/C++ uses the gdb debugger and provides numerous features for debugging your projects. To explore these features, you will use the Quote project. If you have not already created this project, do the following:

  1. Choose File > New Project.
  2. In the project wizard, expand the Samples category and the C/C++ subcategory.
  3. Select the Applications subcategory, then select the Quote project. Click Next, then click Finish.

Creating Breakpoints

You can create and manipulate breakpoints in your code at any time without starting a debugging session.

Creating and Removing a Line Breakpoint

  1. In the Quote_1 project, open the quote.cc file.
  2. Set a line breakpoint by clicking in the left margin of the Source Editor window next to line 171 (response = readChar("Enter disk module type: (S for single disks, R for RAID; Q - exit)", 'S');). The line is highlighted in red to indicate that the breakpoint is set.
    Screenshot of Source Editor window
  3. You could remove the breakpoint by clicking on the icon in the left margin.
  4. Choose Window > Debugging > Breakpoints to open the Breakpoints window. Your line breakpoint is listed in the window.
    Screenshot of Breakpoints window

Creating a Function Breakpoint

  1. Choose Debug > New Breakpoint (Ctrl+Shift+F8) to open the New Breakpoint dialog box.
  2. In the Breakpoint Type drop-down list, set the type to Function.
  3. Type the function name Customer::GetDiscount in the Function Name text field. Click OK.
    Screenshot of New Breakpoint dialog box
  4. Your function breakpoint is set and is added to the list in the Breakpoints window.
    Screenshot of Breakpoints window

Starting a Debugging Session

When you start a debugging session, the IDE starts the gdb debugger, then runs the application inside the debugger. The IDE automatically opens the debugger windows and prints debugger output to the Output window.

  1. Start a debugging session for the Quote_1 project by right-clicking the project node and choosing Debug.
    The debugger starts and the application runs.
  2. Open the Sessions window by choosing Window > Debugging > Sessions.
    The debugging session is shown in this window.

Inspecting the State of the Application

  1. The Quote_1 application prompts you for input.
  2. Enter a customer name after the "Enter customer name:" prompt.

    The application stops at the function breakpoint you set earlier. The Breakpoints window lists the two breakpoints you set earlier. The green program counter arrow appears on top of the breakpoint icon of the function breakpoint.
    Screenshot of Breakpoints tab

  3. Open the Call Stack window by choosing Window > Debugging > Call Stack. The call stack shows three frames.
    Screenshot of Call Stack tab
  4. Open the Variables window and note that one variable is displayed.
  5. Click the Show autos button button in the left column in the Variables tab to show Autos instead of local variables.
  6. Click the expand icons to expand the structure.
    Screenshot of
         Variables tab
  7. Click the Continue button in the toolbar.
    The GetDiscount function is executed, printing the customer discount to the External I/O window. Then you are prompted for input.
  8. Enter the input in response to the prompts.

    The program stops at the next breakpoint, the line breakpoint you set earlier. In the quote.cc file, the green program counter arrow appears on top of the breakpoint icon indicating the line on which the program is stopped.

    Screenshot of the Source
      Editor

  9. Click the Variables tab and note the long list of variables.
    Screenshot of Local Variables tab
  10. Click the Call Stack tab and note that there is now one frame in the stack.
  11. Choose Window > Debugging > Registers.
    The Registers window opens, displaying the current contents of the registers.
    Screenshot of Registers window
  12. Choose Window > Debugging > Disassembly.
    The Disassembly window opens, displaying the assembly instructions for the current source file.
    Screenshot of Disassembler window
  13. Click the Continue button in the toolbar and continue entering input in response to the prompts in the Output window until the program is completed.
  14. When you press Enter to exit the program, your debug session ends. To end the debug session before the execution of the program was complete, you could right-click the session in the Sessions tab, and choose Finish, or choose Debug > Finish Debugger Session.
get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo