Beginning JNI with NetBeans IDE and C/C++ Plugin on Linux

This tutorial takes you through the creation of a simple application that uses JavaTM Native Interface (JNI) code written in the C programming language.

The tutorial is specific to Linux.

Contents

Content on this page applies to NetBeans IDE 7.1, 7.2 and 7.3
Requirements
Setting Up Your Environment for the Tutorial
Setting Up the Java Application Project
Setting Up a New C/C++ Dynamic Library Project
Building and Running the Application
Next Steps

Requirements

To follow this tutorial, you need the following software and resources.

Software or Resource Version Required
NetBeans IDE version 6.9, 7.0, 7.1, 7.2, or 7.3 with NetBeans C/C++ plugin
Java Developer Kit (JDK) version 6 or 7
C and C++ compilers, make, gdb
Configuring the NetBeans IDE for C/C++/Fortran

See the NetBeans IDE 7.3 Installation Instructions and Configuring the NetBeans IDE for C/C++/Fortran for information on downloading and installing the required software.

Setting Up Your Environment for the Tutorial

You need both Java modules and C/C++ modules for this tutorial. If you already have downloaded the NetBeans IDE C/C++ bundle, you can download the additional Java modules separately.

To determine if you have the Java and C/C++ modules, select File > New Project. The project categories should include both Java and C/C++.

To download Java and C/C++ modules that may be missing:

  1. In the NetBeans IDE, select Tools > Plugins.
  2. In the Available Plugins tab, select the checkbox for Java or C/C++, depending on which is missing from your IDE. If you already have the plugins, they will be listed in the Installed tab.
  3. Click Install.
  4. Click Next in the NetBeans IDE Installer dialog box, accept the license terms checkbox, and click Install.
  5. Click Finish when the installation is complete.

Setting Up the Java Application Project

This program requires a Java project and a C project. In this section, you will create and configure the Java project for the JNI application you will be developing. You will create a new Java application project, initialize its main class, and add a native method to this class.

  1. Choose File > New Project. Select the Java category and Java Application project type. Click Next.
    Screenshot
of the New Project Wizard
  2. In the Project Name field, type JNIDemoJava.
  3. You can change the Project Location to any directory on your computer, but here we use the default NetBeansProjects in the user directory.
  4. Leave the Create Main Class checkbox selected and change the Main class name to jnidemojava.Main.

    The IDE creates the NetBeansProjects/JNIDemoJava project folder.


    Screenshot
of the Name and Location page of the New Java Application Wizard

Editing the Main Class Source

  1. To open the Main class source in the editor, right-click the Main.java class node and choose Open.
  2. Replace the line //TODO code application logic here in the main method with the following:
    new Main().nativePrint();
  3. Notice the indicator in the left margin showing an error and lightbulb. Click on the indicator, and you are prompted with a shortcut to create the method nativePrint.
  4. Click on this shortcut and the IDE inserts the following code:
    private void nativePrint() {
          throw new UnsupportedOperationException("Not supported yet");
       }
  5. Modify the body of the nativePrint() method by deleting its contents, and insert the native keyword into the method signature so that it now looks as follows:
    private native void nativePrint();

    The native keyword indicates that the method has an implementation located in an external native library. However, at runtime the library location is not clear.

    The new main method should look as follows:

    public static void main(String[] args) {
           new Main().nativePrint();
       }
    
       private native void nativePrint();
    }
  6. Right-click the project name and select Clean and Build. The project should build successfully.

Creating the Native Library Header File

In this section we use javah, a Java tool that creates a C header from a Java class.
  1. In a terminal window, navigate to the NetBeansProjects directory.
  2. Type the following:
    javah -o JNIDemoJava.h -classpath JNIDemoJava/build/classes jnidemojava.Main
    

    A JNIDemoJava.h C header file is generated in the NetBeansProjects directory. This file is required to provide a correct function declaration for the native implementation of the nativePrint() method. You will need it later when you create the C part of this application.

  3. Switch back to the NetBeans IDE window.

Summary

In this exercise you created a new Java application project, specified its location, and defined the package and name of the main class of the project. You also added a new method to the main class and marked it as a method having a native implementation. As a final step, you created a C header file, which is required later for the native library compilation.

Setting Up a New C/C++ Dynamic Library Project

This section shows you how to create the native part of the application. You will create the C++ Dynamic Library project and configure it to be able to build JNI code.

After you have set up the project, you will create the implementation for the native method you declared earlier in the Java part of the application.

  1. Choose File > New Project. Under Categories, select C/C++. Under Projects, select C/C++ Dynamic Library. Click Next.
    Screenshot of the Choose Project page of the New Project wizard
  2. In the Project Name field, type JNIDemoCdl.
  3. In the Project Location field, use the same location that you used for the Java application project, NetBeansProjects. The location should be shown as the default value.
  4. Accept the defaults for all other fields and click Finish.

    The IDE creates the NetBeansProjects/JNIDemoCdl project folder.

Setting Project Properties

  1. Right-click the JNIDemoCdl project node and choose Properties.
  2. In the Properties dialog box, select the C Compiler node under the Build properties.
  3. Click the Include Directories ... button and click Add in the Include Directories dialog box.
  4. Browse into your JDK directory, and select the include subdirectory.
  5. Select the Store path as Absolute option, then click Select to add this directory to the project's Include Directories.
  6. Add the JDK's include/linux directory in the same way, then click OK.
    Screenshot of the Project Properties dialog
box and the Debug-Include Directories dialog box

    These settings are required to enable references to the Java jni.h library from your C code.

  7. Find the Compilation Line area of the C Compiler options. Click in the text field of the Additional Options property and type -shared -m32. Screenshot of the Debug-Additional Optionstext field being edited

    The -shared option tells the compiler to generate a dynamic library.
    The -m32 option tells the compiler to create a 32-bit binary. By default on 64-bit systems the compiled binaries are 64-bit, which causes a lot of problems with 32-bit JDKs.

  8. Click the Linker category in the left panel.
    Screenshot of the Project Properties dialog box with Linker properties
  9. Click the Output text field, and replace the string
    ${CND_DISTDIR}/${CND_CONF}/${CND_PLATFORM}/libJNIDemoCdl.so
    with the string
    dist/libJNIDemoCdl.so
    to simplify the path of the resulting shared object file. This will make the file easer to reference from Java.
  10. Click OK. The defined settings are saved.

Adding a Header File

  1. Go to a terminal window and move the JNIDemoJava.h header file that you generated previously from your NetBeansProjects directory to the C/C++ Library project directory, NetBeansProjects/JNIDemoCdl.
  2. In the Projects window, right-click the Source Files node of the JNIDemoCdl project and choose Add Existing Item. Navigate to the NetBeansProjects/JNIDemoCdl directory and select the JNIDemoJava.h file, then click Select.

    The JNIDemoJava.h file appears under Source Files.

    Screenshor of
the Projects window

Implementing a Method

  1. Right-click the Source Files node of the JNIDemoCdl project and choose New > C Source File. Type JNIDemo in the File Name field, and click Finish. The editor opens the JNIDemo.c file.
  2. Edit the JNIDemo.c file by typing the following code:
    #include <jni.h>
    #include <stdio.h>
    #include "JNIDemoJava.h"
    
    JNIEXPORT void JNICALL Java_jnidemojava_Main_nativePrint
            (JNIEnv *env, jobject obj)
    {
    
        printf("\nHello World from C\n");
    
    }
    
  3. Save the JNIDemo.c file.
  4. Right-click the JNIDemoCdl project node and choose Build Project. The Output window displays Build successful. Exit value 0.

Summary

In this exercise you created a new C/C++ Dynamic Library, specified its location, and configured it to be able to build a JNI implementation of your Java method. You added the generated header file for the native method you declared in the Java application, and implemented it.

Building and Running the Application

In this exercise, you will perform some final alterations to the Java part of the application. These changes are required to ensure the Java part properly loads the native library you compiled in the previous exercise. After that you will compile and run the resulting application.

Configuring the Java Project

  1. Open the Main.java file in the editor.
  2. Add the following initialization code for the C++ dynamic library after the public class Main line, using the path to the output file that you shortened in the previous exercise:
    static {
            System.load("full-path-to-NetBeansProjects-dir/JNIDemoCdl/dist/libJNIDemoCdl.so");
           }
    
    Replace full-path-to-NetBeansProjects-dir with the path to your NetBeansProjects directory, which should be something similar to /home/username/NetBeansProjects
  3. Save the Main.java file.

Running the JNIDemoJava Application

  1. Select the JNIDemoJava application in the Projects window.
  2. Press F6 or click the Run button in the toolbar to run the application. The program should execute correctly and the Output window should display output similar to the following:
    Screenshot of the Output window

Summary

In this exercise you made some final configuration steps and ran the application to verify that the implementation of the native method comes from the native C library.

Next Steps

If you want to check your work against a working example, you can download a zip file containing the source code from netbeans.org.

You can use the following documents to get more information:

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo