Java ME MIDP 开发快速入门指南

本教程将指导您完成使用 NetBeans IDE 创建 Java(tm) Platform, Micro Edition(Java(tm) ME 平台)移动信息设备配置文件 (MIDP) 应用程序的基本步骤,其目的是帮助您尽快着手开发 Mobile 应用程序。本教程引导您完成使用项目系统的一些基本步骤。我们向您介绍了两种方法来创建名为 "MyHello" 的 Java ME MIDP 项目,此项目在设备仿真器中显示文本 "Make My Day"。本教程可以帮助您做好使用其他 IDE 功能来开发 CLDC/MIDP 应用程序的准备。

注:如果您使用的是 NetBeans IDE 6.9、7.0 或 7.1,请参见《NetBeans IDE 6.9、7.0 或 7.1 Java ME MIDP 开发快速入门指南》。

目录

此页上的内容适用于 NetBeans IDE 7.2

要求

要学完本教程,您需要具备以下软件和资源:

软件或资源 要求的版本
带有 Java ME 的 NetBeans IDE 版本 7.2
Java 开发工具包 (JDK) 版本 6 或 7

:IDE 捆绑的仿真器根据下载的安装程序所适用的操作系统而有所不同。

  • NetBeans 7.1、7.1.1、7.1.2 和 7.2 的 Windows 发行版随 Java ME SDK 3.0.5 捆绑提供。
  • NetBeans IDE 的 Linux 发行版随 Sun Java Wireless Toolkit 2.5.2 捆绑提供。
  • NetBeans IDE 的 OS X 版本随 Java ME SDK 3.0 for CLDC 捆绑提供。

使用源代码编辑器创建 MIDP 应用程序

使用源代码编辑器,可以手动创建 MIDlet 的代码。在源代码编辑器中创建代码会使您在编辑代码时获得更大的灵活性,并且可以插入预处理程序代码块。将使用新建项目向导和新建文件向导创建 MyHello 应用程序,并使用源代码编辑器完成代码。

新建 Java ME MIDP 项目

  1. 选择 File(文件)> New Project(新建项目)(Ctrl-Shift-N 组合键)。在 "Categories"(类别)下,选择 Java ME。在 "Projects"(项目)下,选择 Mobile Application(Mobile 应用程序),然后单击 "Next"(下一步)。
  2. 在 "Project Name"(项目名称)字段中输入 MyHelloMIDlet(请注意,MID 采用的是大写字母)。指定项目位置。在本教程中,我们首选 $PROJECTHOME 目录。
  3. 取消选中 "Create Hello MIDlet"(创建 Hello MIDlet)复选框,然后单击 "Next"(下一步)。
  4. 选择默认仿真器平台,并对其余选项使用默认设置。单击 "Finish"(完成)。
    IDE 将创建 $PROJECTHOME/MyHelloMIDlet 项目文件夹。此项目文件夹包含所有源代码和项目元数据,例如项目的 Ant 脚本。
  5. 在资源管理器窗口中,右键单击 MyHelloMIDlet 节点,然后选择 New(新建)> MIDlet
  6. 输入 HelloMIDlet 作为 MIDlet 名称(请注意,默认情况下 "MID" 使用的不是大写字母)。单击 "Finish"(完成)。
    将创建 HelloMIDlet.java 文件,并在 IDE 的编辑器窗口中显示源代码。
  7. 单击源代码编辑器,然后将 public class HelloMIDlet extends MIDlet 更改为
    public class HelloMIDlet
    extends MIDlet implements javax.microedition.lcdui.CommandListener
    {
  8. startApp() 方法前添加下面的文本:
        private void initialize() {
            javax.microedition.lcdui.Display.getDisplay(this).setCurrent(get_helloTextBox());
        }
    
        public void commandAction(javax.microedition.lcdui.Command command, javax.microedition.lcdui.Displayable displayable) {
            if (displayable == helloTextBox) {
                if (command == exitCommand) {
                    javax.microedition.lcdui.Display.getDisplay(this).setCurrent(null);
                    destroyApp(true);
                    notifyDestroyed();
                }
            }
        }
    
        private javax.microedition.lcdui.TextBox get_helloTextBox() {
            if (helloTextBox == null) {
                helloTextBox = new javax.microedition.lcdui.TextBox(null, "Hello Test Code", 120, 0x0);
                helloTextBox.addCommand(get_exitCommand());
                helloTextBox.setCommandListener(this);
            }
            return helloTextBox;
        }
    
        private javax.microedition.lcdui.Command get_exitCommand() {
            if (exitCommand == null) {
                exitCommand = new javax.microedition.lcdui.Command("Exit", javax.microedition.lcdui.Command.EXIT,
                        1);
            }
            return exitCommand;
        }
        javax.microedition.lcdui.TextBox helloTextBox;
        javax.microedition.lcdui.Command exitCommand;
    
  9. startApp() 方法中添加 initialize(); 代码行,使它如下所示:
      public void startApp() {
    initialize();
    }
    

编辑 Java 源代码

现在添加一些供 MIDlet 显示的文本。

get_helloTextBox() 方法中,将示例代码 Hello Test Code 替换为您选择的文本(例如,Make My Day.)。

注:有关使用 NetBeans IDE Java 编辑器的代码帮助功能、定制选项和导航功能的完整指南,请参见 NetBeans IDE Java 编辑器中的代码帮助

编译并运行项目

从 IDE 主工具栏中选择 Run(运行)> Run Project(运行项目)。在 "Output"(输出)窗口中观察项目编译的进度。注意 HelloMIDlet.java 文件在执行之前会先构建。设备仿真器随即打开以显示所执行的 MIDlet 的结果,其中会显示您在源代码中输入的文本。

Java ME SDK 3.0.5 默认 CLDC 仿真器中的

要关闭 MIDlet 和仿真器窗口,请在仿真器窗口中选择 "Application"(应用程序)> "Exit"(退出)。

使用可视 Mobile 设计器创建 MIDP 应用程序

NetBeans IDE 提供一个使您可以快速创建 MIDP 项目的向导。创建此项目时,可以选择在可视 Mobile 设计器 (VMD) 或源代码编辑器中开发应用程序。使用 VMD,能够以可视方式规划应用程序流并设计应用程序使用的屏幕。在设计画布上保存更改时,设计器会自动创建应用程序的代码。

注:要在 IDE 中运行可视 Mobile 设计器,您需要按如下所示从更新中心安装可视 Mobile 设计器插件:

  1. 从主菜单中选择 "Tools"(工具)> "Plugins"(插件)。
  2. 在 "Plugins"(插件)对话框的 "Available Plugins"(可用插件)标签中,选择 "Visual Mobile Designer"(可视 Mobile 设计器),然后单击 "Install"(安装)。
  3. 在 "Installer"(安装程序)对话框的欢迎页,单击 "Next"(下一步)。
  4. 在 "License Agreement"(许可证协议)页上,阅读与该插件相关的许可证协议。如果您同意所有许可证协议条款,请单击适当的选项,然后单击 "Install"(安装)。
  5. (可选)选择 "Run in the Background"(在后台运行)选项以在后台运行安装。
  6. 在安装过程完成后,单击 "Finish"(完成)。

创建 MIDP/CLDC 应用程序

  1. 选择 File(文件)> New Project(新建项目)(Ctrl+Shift+N 组合键)。在 "Categories"(类别)下,选择 Java ME。在 "Projects"(项目)下,选择 Mobile Application(Mobile 应用程序),然后单击 "Next"(下一步)。
  2. 在 "Project Name"(项目名称)字段中输入 MyHello。使用默认 "Project Location"(项目位置),或者将它改为系统上您要选择的目录。在本教程中,我们首选 $PROJECTHOME 目录。
  3. 选中 Create Hello MIDlet(创建 Hello MIDlet)复选框。单击 "Next"(下一步)。
  4. 选择默认仿真器平台,并对其余选项使用默认设置。单击 "Finish"(完成)。
  5. IDE 将创建 $PROJECTHOME/MyHello 项目文件夹。此项目文件夹包含所有源代码和项目元数据,例如项目的 Ant 脚本。应用程序本身显示在可视 Mobile 设计器的 "Flow"(流)设计窗口中。

    IDE 中 Hello Midlet 的

    注:有关可用组件面板组件的完整描述,请参见可视 Mobile 设计器组件面板参考

编辑 Java 源代码

现在我们编辑 MIDlet 显示的文本。

  1. HelloMIDlet.java 下方,单击 "Screen"(屏幕)以切换至 "Screen"(屏幕)视图,其中显示了 "Device Screen"(设备屏幕),这是应用程序中唯一可用的屏幕。
  2. 在 "Device Screen"(设备屏幕)中单击 Hello World! 消息。在 "Properties"(属性)窗口中,单击 Hello World! 文本以更改欢迎消息文本,然后按 Enter 键。在本示例中,我们键入了 Make my day

    在

  3. "Screen"(屏幕)视图显示您在 "Text"(文本)字段中输入的文本的预览。

    VMD 的

编译并运行项目

  1. 从 IDE 主工具栏中选择 Run(运行)> Run Project(运行项目)(F6 键)。在 "Output"(输出)窗口中观察项目编译的进度。注意 HelloMIDlet.java 文件在执行之前会先构建。设备仿真器打开,显示所执行的 MIDlet 的结果。设备仿真器启动 MIDlet 并显示您在源代码中输入的文本。

    可以指定用于运行 MIDlet 的仿真器,方法是:右键单击项目节点,然后从上下文菜单中选择 Run With...(运行方式...)。下面显示了 Java ME SDK 3.0.5 中提供的 DefaultCldcPhone1

    Java ME SDK 默认电话仿真器中显示的

  2. 在仿真器窗口中,选择 "Application"(应用程序)> "Exit"(退出)以关闭 MIDlet 和仿真器窗口。

后续步骤

有关介绍如何开发 MIDP 和 CLDC 应用程序的更多教程,请访问 Mobile 应用程序学习资源。

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo