Краткое руководство пользователя по разработке приложений на базе MIDP Java ME

В этом учебном курсе описываются основные шаги использования IDE NetBeans для создания приложений на платформе Java(tm), Micro Edition (платформа Java(tm) ME), Mobile Information Device Profile (MIDP) и создано для того, чтобы пользователи смогли приступить к разработке мобильных приложений как можно быстрее. В руководстве продемонстрированы основные этапы работы с системой проектов. Здесь приводится описание двух способов создания проекта MIDP Java ME с именем "MyHello", который отображает текст "Make my day" в эмуляторе устройства. Руководство служит для подготовки к использованию других функций среды IDE, применяемых при разработке приложений для CLDC/MIDP.

Примечание. При использовании среды IDE NetBeans 6.9, 7.0 и 7.1, воспользуйтесь учебным курсом Краткое руководство пользователя по разработке приложений на базе IDE NetBeans 6.9, 7.0 и 7.1 или MIDP Java ME.

Содержание

Содержимое на этой странице применимо к IDE NetBeans 7.2

Требования

Для работы с этим учебным курсом требуются программное обеспечение и ресурсы, перечисленные ниже.

Программное обеспечение или материал Требуемая версия
IDE NetBeans с Java ME Версия 7.2
Комплект для разработки приложений на языке Java (JDK) Версия 6 или 7

Примечание. Эмулятор, поставляемый вместе со средой IDE, зависит от операционной системы, для которой загружается программа установки.

  • Распространение в Windows NetBeans 7.1, 7.1.1, 7.1.2 и 7.2 входит в комплект Java ME SDK 3.0.5.
  • Дистрибутив среды IDE NetBeans для Linux поставляется вместе с Sun Java Wireless Toolkit 2.5.2.
  • Версия OS X NetBeans поставляется с пакетом Java ME SDK 3.0 для CLDC.

Создание приложения MIDP в редакторе исходного кода

Редактор исходного кода позволяет создать код мидлета вручную. Этот вариант отличается большей гибкостью с точки зрения возможности изменения кода, а также позволяет вставить блоки кода для предварительной обработки. Планируется создание приложения MyHello с использованием мастеров создания проектов и мастеров создания файлов и завершение кода в редакторе исходного кода.

Создание нового проекта MIDP Java ME

  1. Выберите File > New Project (Файл > Новый проект) (CTRL+SHIFT+N). В разделе "Категории" выберите "Java ME". В области "Проекты" выберите Мобильное приложение и нажмите кнопку "Далее".
  2. Введите MyHelloMIDlet в поле 'Имя проекта' (обратите вниание, что MID указано в символах верхнего регистра). Укажите местоположение проекта. Далее в тексте этот каталог будет называться каталогом $PROJECTHOME.
  3. Снимите флажок с параметра "Create Hello MIDlet" и щелкните 'Далее'.
  4. Выберите платформу эмулятора по умолчанию, а в остальных полях оставьте значения по умолчанию. Нажмите кнопку "Завершить".
    Среда IDE создаст папку проекта $PROJECTHOME/MyHelloMIDlet. Папка проекта содержит все исходные файлы и метаданные проекта, например, сценарий Ant для этого проекта.
  5. В диалоговом окне проводника щелкните узел MyHelloMIDlet правой кнопкой мыши и выберите Создать > мидлет.
  6. Введите имя мидлета HelloMIDlet (обратите внимание, что "MID" необходимо вводить в верхнем регистре). Нажмите кнопку "Завершить".
    Будет создан файл HelloMIDlet.java, и исходный код будет представлен в окне редактора среды IDE.
  7. Щелкните левой кнопкой мыши в редакторе исходного кода и измените мидлет общедоступного класса HelloMIDlet extends MIDlet на
    public class HelloMIDlet
    extends MIDlet implements javax.microedition.lcdui.CommandListener
    {
  8. Добавьте следующий текст перед методом startApp():
        private void initialize() {
            javax.microedition.lcdui.Display.getDisplay(this).setCurrent(get_helloTextBox());
        }
    
        public void commandAction(javax.microedition.lcdui.Command command, javax.microedition.lcdui.Displayable displayable) {
            if (displayable == helloTextBox) {
                if (command == exitCommand) {
                    javax.microedition.lcdui.Display.getDisplay(this).setCurrent(null);
                    destroyApp(true);
                    notifyDestroyed();
                }
            }
        }
    
        private javax.microedition.lcdui.TextBox get_helloTextBox() {
            if (helloTextBox == null) {
                helloTextBox = new javax.microedition.lcdui.TextBox(null, "Hello Test Code", 120, 0x0);
                helloTextBox.addCommand(get_exitCommand());
                helloTextBox.setCommandListener(this);
            }
            return helloTextBox;
        }
    
        private javax.microedition.lcdui.Command get_exitCommand() {
            if (exitCommand == null) {
                exitCommand = new javax.microedition.lcdui.Command("Exit", javax.microedition.lcdui.Command.EXIT,
                        1);
            }
            return exitCommand;
        }
        javax.microedition.lcdui.TextBox helloTextBox;
        javax.microedition.lcdui.Command exitCommand;
    
  9. Добавьте строку initialize(); к методу startApp() следующим образом:
      public void startApp() {
    initialize();
    }
    

Изменение исходного кода Java

Теперь добавим текст, который будет отображаться мидлетом.

В методе get_helloTextBox() замените код Hello Test Code произвольным текстом (например, Make My Day.)..

Примечаение. Полное руководство по использованию функций для работы с кодом, параметров настройки и функций навигации редактора Java IDE NetBeans см. в Работа с кодом в редакторе Java IDE NetBeans.

Компиляция и выполнение проекта

Выберите Выполнить > Выполнить проект на главной панели инструментов IDE. Процесс компиляции проекта отражается в окне "Вывод". Обратите внимание на то, что перед исполнением файла HelloMIDlet.java выполняется его сборка. Для отображения результатов выполнения мидлета открывается эмулятор устройства и отображается текст, введенный в исходном коде.

Сообщение 'Make my day' в эмуляторе CLDC Java ME SDK 3.0.5, заданному по умолчанию

Чтобы закрыть MIDlet и окно эмулятора, выберите в окне эмулятора 'Приложение' > 'Выход'.

Создание приложения для MIDP с помощью Visual Mobile Designer

The IDE NetBeans provides a wizard that enables you to quickly create a MIDP project. При создании проекта можно выбрать между разработкой приложения в Visual Mobile Designer (VMD) или в редакторе исходного кода. VMD позволяет графически построить блок-схему приложения и спроектировать требуемые экраны. Код приложения при этом создается автоматически, поскольку изменения сохраняются на холсте проекта.

Примечание. Для запуска Visual Mobile Designer в IDE необходимо установить подключаемый модуль Visual Mobile Designer из центра обновлений следующим образом:

  1. Выберите "Сервис" > "Подключаемые модули" в главном меню.
  2. На вкладке 'Доступные подключаемые модули' в диалоговом окне 'Подключаемые модули' выберите Visual Mobile Designer и щелкните 'Установить'.
  3. На странице "Добро пожаловать" диалогового окна программы установки нажмите кнопку "Далее".
  4. На странице "Лицензионное соглашение" ознакомьтесь с лицензионным соглашением, связанным с подключаемым модулем. При принятии всех условий лицензионного соглашения щелкните соответствующий параметр и щелкните 'Установить'.
  5. (Дополнительно) Выберите запуск в фоновом режиме для запуска установки в фоновом режиме.
  6. Когда процесс установки завершится, нажмите кнопку 'Готово'.

Создание приложения для MIDP/CLDC

  1. Выберите Файл > Новый проект (CTRL+SHIFT+N). В разделе "Категории" выберите "Java ME". В области "Проекты" выберите Мобильное приложение и нажмите кнопку "Далее".
  2. Введите MyHello в поле "Имя проекта". Используйте папку проекта (поле "Местоположение проекта") по умолчанию, либо выберите требуемый каталог. Далее в тексте этот каталог будет называться каталогом $PROJECTHOME.
  3. Установите флажок Create Hello MIDlet. Нажмите кнопку "Далее".
  4. В качестве платформы эмулятора выберите "default", а в остальных полях оставьте значения по умолчанию. Нажмите кнопку "Завершить".
  5. Средой IDE будет создана папка проекта $PROJECTHOME/MyHello. Папка проекта содержит все исходные файлы и метаданные проекта, например, сценарий Ant для этого проекта. Само приложение отображается в окне "Flow Design" в Visual Mobile Designer.

    Представление потока Hello Midlet в IDE

    Примечание. Полное описание доступных компонентов палитры см. в разделе Справочные ресурсы по палитре конструктора Visual Mobile.

Изменение исходного кода Java

Рассмотрим способы изменения текста, отображаемого мидлетом.

  1. В мидлете HelloMIDlet.java нажмите кнопку "Экран" для перехода к представлению экрана, показывающему экран устройства, единственный доступный экран в приложении.
  2. Щелкните сообщение Hello World! на экране устройства. Для изменения текста приветствия в окне "Свойства" щелкните сообщениеHello World! и нажмите ENTER. В примере мы ввели текст Make my day.

    Текст 'Make my day' вводится в текстовое поле окна 'Свойства'.

  3. Текст, введенный в этом текстовом поле, отображается в режиме предварительного просмотра на вкладке "Экран".

    Текст 'Make my day' отображается на экране предварительного просмотра устройства в представлении экрана VMD

Компиляция и выполнение проекта

  1. Выберите Выполнить > Выполнить проект (F6) на главной панели инструментов IDE. Процесс компиляции проекта отражается в окне "Вывод". Обратите внимание на то, что перед исполнением файла HelloMIDlet.java выполняется его сборка. На экране появившегося эмулятора устройства будут представлены результаты выполнения мидлета. Эмулятор устройства запускает мидлет и отображает текст, введенный в исходном коде.

    Можно указать эмулятор, на котором будет выполняться мидлет. Для этого щелкните узел проекта правой кнопкой мыши и выберите Выполнить с... в контекстном меню. На рисунке показан эмулятор DefaultCldcPhone1, доступный в пакете Java ME SDK 3.0.5.

    Сообщение 'Make my day' отображается в эмуляторе Java ME SDK , заданному по умолчанию

  2. В окне эмулятора выберите 'Приложение' > 'Выход', чтобы закрыть MIDlet и окно эмулятора.

Что дальше?

Дополнительные учебные курсы по разработке приложений MIDP и CLDC приведены в учебной карте по мобильным приложениям.

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo