Guia de Início Rápido de Desenvolvimento Java ME MIDP

Este tutorial orienta você pelas etapas básicas de utilização do NetBeans IDE para criar uma Plataforma Java(tm), Micro Edition (Plataforma Java(tm) ME), aplicação Perfil do Dispositivo de Informações Móvel (MIDP) e foi projetado para iniciar o desenvolvimento da aplicação móvel o mais rápido possível. O tutorial orienta você por meio de algumas etapas básicas do trabalho com o sistema de projeto. Nós mostramos duas maneiras de criar um projeto Java ME MIDP chamado "MyHello" que exibe o texto "Make My Day" em um emulador de dispositivo. Este tutorial prepara você para usar outras funcionalidades do IDE para o desenvolvimento de aplicações CLDC/MIDP.

Observação: Se você estiver usando o NetBeans IDE 6.9, 7.0 ou 7.1, consulte o Guia de Início Rápido ao Desenvolvimento em NetBeans IDE 6.9, 7.0 ou 7.1 Java ME MIDP.

Conteúdo

O conteúdo desta página se aplica ao NetBeans IDE 7.2

Requisitos

Para concluir este tutorial, são necessários os seguintes recursos e softwares:

Software ou Recurso Versão Necessária
NetBeans IDE com Java ME Versão 7.2
Java Development Kit (JDK) Versão 6 ou 7

Observação: o emulador que vem com o IDE varia dependendo de qual instalador de sistema operacional foi baixado.

  • As distribuições para Windows do NetBeans 7.1,7.1.1 e 7.2 vêm junto com o Java ME SDK 3.0.5.
  • A distribuição para Linux do NetBeans IDE é oferecida com o Sun Java Wireless Toolkit 2.5.2.
  • A versão OS X do NetBeans IDE vem com o Java ME SDK 3.0 para CLDC.

Criando uma Aplicação MIDP Usando o Editor de Código-fonte

Usando o Editor de Código-fonte, crie manualmente o código para os MIDlets. Ao criar o código no Editor de Código-fonte, você tem mais flexibilidade ao editar o código e pode inserir blocos do código do pré-processador. Você irá criar a aplicação MyHello usando os assistentes de Novo Projeto e Novo Arquivo e completar o código usando o Editor de Código-fonte.

Criando um Novo Projeto Java ME MIDP

  1. Selecione Arquivo > Novo Projeto (Ctrl-Shift-N). Em Categorias, selecione Java ME. Em Projetos, selecione Aplicação Móvel e clique em Próximo.
  2. Digite MyHelloMIDlet no campo Nome do Projeto (observe que MID está em maiúsculas). Especifique o Local do Projeto Nomeamos este diretório como $PROJECTHOME neste tutorial.
  3. Desmarque a caixa de seleção Criar Olá MIDlet e clique em Próximo.
  4. Selecione a plataforma do emulador default e utilize os defaults restantes. Clique em Finalizar.
    O IDE cria a pasta do projeto $PROJECTHOME/MyHelloMIDlet. A pasta do projeto contém todos os códigos-fonte e os metadados do projeto, como o script Ant do projeto.
  5. Clique com o botão direito do mouse no nó MyHelloMIDlet na janela do Explorer e selecione Novo > MIDlet.
  6. Insira HelloMIDlet como o nome do MIDlet (observe que "MID" não está em maiúsculas por default). Clique em Finalizar.
    O arquivo HelloMIDlet.java é criado e o código-fonte é exibido na janela Editor do IDE.
  7. Clique no Editor de Código-fonte e altere classe pública HelloMIDlet se estende para MIDlet para
    public class HelloMIDlet
    extends MIDlet implements javax.microedition.lcdui.CommandListener
    {
  8. Adicione o seguinte texto antes do método startApp():
        private void initialize() {
            javax.microedition.lcdui.Display.getDisplay(this).setCurrent(get_helloTextBox());
        }
    
        public void commandAction(javax.microedition.lcdui.Command command, javax.microedition.lcdui.Displayable displayable) {
            if (displayable == helloTextBox) {
                if (command == exitCommand) {
                    javax.microedition.lcdui.Display.getDisplay(this).setCurrent(null);
                    destroyApp(true);
                    notifyDestroyed();
                }
            }
        }
    
        private javax.microedition.lcdui.TextBox get_helloTextBox() {
            if (helloTextBox == null) {
                helloTextBox = new javax.microedition.lcdui.TextBox(null, "Hello Test Code", 120, 0x0);
                helloTextBox.addCommand(get_exitCommand());
                helloTextBox.setCommandListener(this);
            }
            return helloTextBox;
        }
    
        private javax.microedition.lcdui.Command get_exitCommand() {
            if (exitCommand == null) {
                exitCommand = new javax.microedition.lcdui.Command("Exit", javax.microedition.lcdui.Command.EXIT,
                        1);
            }
            return exitCommand;
        }
        javax.microedition.lcdui.TextBox helloTextBox;
        javax.microedition.lcdui.Command exitCommand;
    
  9. Adicione uma linha initialize(); ao método startApp() para que tenha a seguinte aparência:
      public void startApp() {
    initialize();
    }
    

Editando o Código-fonte Java

Agora, vamos adicionar texto ao MIDlet para exibição.

No método get_hellotextbox(), substitua o exemplo Hello Test Code com o texto de sua escolha (por exemplo, Make My Day).

Observação: para obter um guia completo para usar as funcionalidades de assistência de código, opções de personalização e recursos de navegação do Editor Java do NetBeans IDE consulte a Assistência ao Código no Editor Java do NetBeans IDE.

Compilando e Executando o Projeto

Selecione Executar >Executar Projeto na barra de ferramentas principal do IDE. Siga o progresso da compilação do projeto na janela de Saída. Note que o arquivo HelloMIDlet.java é construído antes de ser executado. Um emulador de dispositivo abre para exibir os resultados do MIDlet executado e exibe o texto inserido no código fonte.

Mensagem

Para fechar o MIDlet e a janela do emulador, selecione Aplicação > Sair na janela emulador.

Criando uma Aplicação MIDP Utilizando o Visual Mobile Designer

O NetBeans IDE fornece um assistente que permite que você crie rapidamente um projeto MIDP. Ao criar o projeto, você pode optar por desenvolver a aplicação no Visual Mobile Designer (VMD) ou no Editor de Código-fonte. Utilizar o VMD fornece a habilidade de planejar visualmente o fluxo da aplicação e o design da tela nas utilizações da aplicação. O designer cria automaticamente o código para a aplicação conforme as alterações são salvas na tela de design.

Observação: para executar o Visual Mobile Designer no IDE você precisará instalar o plug-in do Visual Mobile Designer da Central de Atualização da seguinte forma:

  1. Selecione Ferramentas > Plug-ins do menu principal.
  2. Na aba Plug-ins Disponíveis da caixa de diálogo Plug-ins, selecione Visual Mobile Designer e clique em Instalar.
  3. Pelo a página de Boas-vindas da caixa de diálogo do Instalador, clique em Próximo.
  4. Na página Contrato de Licença, leias os contratos associados ao plug-in. Se você concordar com os todos os termos da licença do contrato, clique na opção apropriada e, em seguida, clique em Instalar.
  5. (Opcional) Selecione Executar na opção do Segundo Plano para executar a instalação no segundo plano.
  6. Quando o processo de instalação for concluído, clique em Finalizar.

Criando uma Aplicação MIDP/CLDC

  1. Selecione Arquivo > Novo Projeto (Ctrl+Shift+N). Em Categorias, selecione Java ME. Em Projetos, selecione Aplicação Móvel e clique em Próximo.
  2. Insira MyHello no campo Nome do Projeto. Use o Local de Projeto default ou altere-a para o diretório de sua preferência no sistema. Neste tutorial, esse diretório é definido como $PROJECTHOME.
  3. Selecione a caixa de seleção Criar Hello MIDlet. Clique em Próximo.
  4. Selecione o default como a plataforma do emulador e utilize os defaults restantes. Clique em Finalizar.
  5. O IDE cria a pasta do projeto $PROJECTHOME/MyHello. A pasta do projeto contém todos os códigos-fonte e os metadados do projeto, como o script Ant do projeto. A aplicação é exibida na janela Design de Fluxo do Visual Mobile Designer.

    View do fluxo no Hello MIDlet no IDE

    Observação: para uma descrição completa dos componentes da paleta disponíveis, consulte a Referência da Paleta do Visual Mobile Designer.

Editando o Código-fonte Java

Agora, vamos editar o texto exibido pelo MIDlet.

  1. Em HelloMIDlet.java clique em Tela para mostrar a janela View da Tela exibindo a Tela do Dispositivo, que é a única tela disponível na aplicação.
  2. Clique na mensagem Hello World! na Tela do Dispositivo. Na janela Propriedades, clique no texto Hello World! para modificar a mensagem de boas-vindas e pressione Enter. Neste exemplo, digitamos Make my day.

    O texto 'Make my day' foi digitado no campo de texto da janela Propriedades.

  3. A View da Tela exibe o texto inserido no campo Texto.

    O texto 'Make my day' é visível na exibição da Tela do Dispositivo na view de Tela VMD.

Compilando e Executando o Projeto

  1. Selecione Executar > Executar Projeto (F6) na barra de ferramentas principal do IDE. Siga o progresso da compilação do projeto na janela de Saída. Observe que o arquivo HelloMIDlet.java é construído antes de ser executado. Um emulador de dispositivo é aberto para exibir os resultados do MIDlet executado. O emulador de dispositivo inicia o MIDlet e exibe o texto inserido no código-fonte.

    É possível especificar o emulador para executar o MIDlet ao clicar com o botão direito do mouse no nó do projeto e selecionar Executar Com.. no menu de contexto. O DefaultFXPhone1 disponível no Java ME SDK 3.0.5 é mostrado abaixo.

    Mensagem

  2. Na janela emulador, selecione Aplicação > Sair para fechar o MIDlet e a janela do emulador.

Próximas Etapas

Para mais tutoriais mostrando como desenvolver aplicações MIDP e CLDC visite a Trilha de Aprendizado de Aplicação Móvel.

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo