Java ME MIDP開発のクイック・スタート・ガイド

このチュートリアルでは、NetBeans IDEを使用して、Java(TM) Platform Micro Edition (Java(TM) MEプラットフォーム)のMIDP (Mobile Information Device Profile)アプリケーションを作成する手順を概説します。このチュートリアルは、できるだけすばやくモバイル・アプリケーション開発を始められるように作成されています。このチュートリアルでは、プロジェクト・システムを使用した基本的な作業手順の一部を学ぶことができます。デバイス・エミュレータに「Make My Day」というテキストを表示する、「MyHello」という名前のJava ME MIDPプロジェクトを作成する2通りの方法を示します。このチュートリアルを終了すると、IDEが備えているCLDC/MIDPアプリケーション開発用の他の機能を使用する準備が整います。

注意: NetBeans IDE 6.9、7.0または7.1を使用している場合は、NetBeans IDE 6.9、7.0、または7.1 Java ME MIDP開発のクイック・スタート・ガイドを参照してください。

内容

このページの内容は、NetBeans IDE 7.2に適用されます

要件

このチュートリアルを完了するには、次のソフトウェアとリソースが必要です。

ソフトウェアまたはリソース 必須バージョン
NetBeans IDEとJava ME バージョン7.2
Java Development Kit (JDK) バージョン6または7

注意: IDEにバンドルされているエミュレータは、ダウンロードしたオペレーティング・システム・インストーラによって異なります。

  • NetBeans 7.1、7.1.1、7.1.2および7.2のWindowsディストリビューションには、Java ME SDK 3.0.5がバンドルされています。
  • NetBeans IDEのLinuxディストリビューションには、Sun Java Wireless Toolkit 2.5.2がバンドルされています。
  • NetBeans IDEのOS Xバージョンには、Java ME SDK 3.0 for CLDCがバンドルされています。

ソース・エディタを使用したMIDPアプリケーションの作成

ソース・コード・エディタを使用すると、MIDletのコードを手動で作成できます。ソース・コード・エディタでコードを作成すると、より柔軟にコードを編集したり、プリプロセッサ・コード・ブロックを挿入したりできます。ここでは、新規プロジェクト・ウィザードと新規ファイル・ウィザードを使用してMyHelloアプリケーションを作成し、ソース・エディタを使用してコードを完了します。

Java ME MIDPプロジェクトの新規作成

  1. ファイル」>「新規プロジェクト」(Ctrl-Shift-N)を選択します。「カテゴリ」から「Java ME」を選択します。「プロジェクト」で「モバイル・アプリケーション」を選択して、「次」をクリックします。
  2. 「プロジェクト名」フィールドにMyHelloMIDletと入力します(MIDは大文字であることに注意)。プロジェクトの場所を指定します。このチュートリアルでは、このディレクトリを$PROJECTHOMEと表記します。
  3. 「Hello MIDletの作成」チェックボックスを選択解除し、「次」をクリックします。
  4. デフォルトのエミュレータ・プラットフォームを選択し、残りもデフォルト設定を使用します。「終了」をクリックします。
    IDEによって、$PROJECTHOME/MyHelloMIDletプロジェクト・フォルダが作成されます。このプロジェクト・フォルダには、ソースおよび、プロジェクトのAntスクリプトなどのプロジェクト・メタデータのすべてが含まれます。
  5. エクスプローラ・ウィンドウで「MyHelloMIDlet」ノードを右クリックし、「新規」>「MIDlet」を選択します。
  6. MIDlet名として「HelloMIDlet」と入力します(「MID」はデフォルトでは大文字でないことに注意)。「終了」をクリックします。
    HelloMIDlet.javaファイルが作成され、ソース・コードがIDEのエディタ・ウィンドウに表示されます。
  7. ソース・エディタ内をクリックし、public class HelloMIDlet extends MIDletを次のように変更します
    public class HelloMIDlet
    extends MIDlet implements javax.microedition.lcdui.CommandListener
    {
  8. startApp() メソッドの前に次のテキストを追加します。
        private void initialize() {
            javax.microedition.lcdui.Display.getDisplay(this).setCurrent(get_helloTextBox());
        }
    
        public void commandAction(javax.microedition.lcdui.Command command, javax.microedition.lcdui.Displayable displayable) {
            if (displayable == helloTextBox) {
                if (command == exitCommand) {
                    javax.microedition.lcdui.Display.getDisplay(this).setCurrent(null);
                    destroyApp(true);
                    notifyDestroyed();
                }
            }
        }
    
        private javax.microedition.lcdui.TextBox get_helloTextBox() {
            if (helloTextBox == null) {
                helloTextBox = new javax.microedition.lcdui.TextBox(null, "Hello Test Code", 120, 0x0);
                helloTextBox.addCommand(get_exitCommand());
                helloTextBox.setCommandListener(this);
            }
            return helloTextBox;
        }
    
        private javax.microedition.lcdui.Command get_exitCommand() {
            if (exitCommand == null) {
                exitCommand = new javax.microedition.lcdui.Command("Exit", javax.microedition.lcdui.Command.EXIT,
                        1);
            }
            return exitCommand;
        }
        javax.microedition.lcdui.TextBox helloTextBox;
        javax.microedition.lcdui.Command exitCommand;
    
  9. 次のようにstartApp()メソッドにinitialize();行を追加します。
      public void startApp() {
    initialize();
    }
    

Javaソース・コードの編集

MIDletで表示するテキストを追加してみます。

get_helloTextBox()メソッドで、例にあるコードHello Test Codeを任意のテキスト(たとえば、Make My Day.など)に置き換えます。

注意: NetBeans IDEのJavaエディタのコード支援機能、カスタマイズ・オプションおよびナビゲーション機能を使用するための完全ガイドは、NetBeans IDE Javaエディタでのコード支援を参照してください。

プロジェクトのコンパイルと実行

IDEのメイン・ツールバーから「実行」>「プロジェクトの実行」を選択します。「出力」ウィンドウで、プロジェクトのコンパイルの進行状況を確認します。HelloMIDlet.javaファイルは実行前にビルドされることに注意してください。デバイス・エミュレータが開いてMIDletの実行結果が表示され、ソース・コードに入力したテキストが表示されます。

Java ME SDK 3.0.5のデフォルトCLDCエミュレータの「Make my day」メッセージ

MIDletとエミュレータ・ウィンドウを閉じるには、エミュレータ・ウィンドウで「アプリケーション」>「終了」を選択します。

ビジュアル・モバイル・デザイナを使用したMIDPアプリケーションの作成

NetBeans IDEには、MIDPプロジェクトを簡単に作成できるウィザードがあります。プロジェクトの作成時に、アプリケーションの開発にビジュアル・モバイル・デザイナ(VMD)を使用するか、またはソース・コード・エディタを使用するかを、選択できます。VMDを使用すると、視覚的にアプリケーションのフローを計画し、そのアプリケーションで使用する画面をデザインできます。このデザイナでは、アプリケーションのコードが自動的に作成され、変更がデザイン・キャンバス上に保存されます。

注意: IDEでビジュアル・モバイル・デザイナを実行するには、次のように、更新センターからビジュアル・モバイル・デザイナ・プラグインをインストールする必要があります。

  1. メイン・メニューから「ツール」>「プラグイン」を選択します。
  2. 「プラグイン」ダイアログ・ボックスの「使用可能なプラグイン」タブで、「ビジュアル・モバイル・デザイナ」を選択して「インストール」をクリックします。
  3. 「インストーラ」ダイアログ・ボックスのようこそページで「次」をクリックします。
  4. ライセンス契約ページで、プラグインに関連するライセンス契約を読みます。ライセンス契約のすべての条件に同意する場合は、該当するオプションをクリックしてから「インストール」をクリックします。
  5. (オプション)バックグラウンドでインストールを実行するには、「バックグラウンドで実行」オプションを選択します。
  6. インストール・プロセスが完了したら、「終了」をクリックします。

MIDP/CLDCアプリケーションの作成

  1. ファイル」>「新規プロジェクト」(Ctrl+Shift+N)を選択します。「カテゴリ」から「Java ME」を選択します。「プロジェクト」で「モバイル・アプリケーション」を選択して、「次」をクリックします。
  2. 「プロジェクト名」フィールドにMyHelloと入力します。デフォルトのプロジェクトの場所を使用するか、システム上の任意のディレクトリに変更します。このチュートリアルでは、このディレクトリを$PROJECTHOMEと表記します。
  3. 「Create Hello MIDlet」チェックボックスを選択します。「次」をクリックします。
  4. エミュレータ・プラットフォームはデフォルト設定を選択し、残りもデフォルト設定を使用します。「終了」をクリックします。
  5. IDEによって、$PROJECTHOME/MyHelloプロジェクト・フォルダが作成されます。このプロジェクト・フォルダには、ソースおよび、プロジェクトのAntスクリプトなどのプロジェクト・メタデータのすべてが含まれます。アプリケーション自体はビジュアル・モバイル・デザイナの「フロー・デザイン」ウィンドウに表示されます。

    IDEでのHello Midletの「フロー」ビュー

    注意: 使用可能なパレット・コンポーネントの詳細は、ビジュアル・モバイル・デザイナのパレットのリファレンスを参照してください。

Javaソース・コードの編集

ここで、MIDletによって表示されるテキストを編集します。

  1. HelloMIDlet.javaの下の「画面」をクリックして「画面」ビューに切り替え、アプリケーションで利用できる唯一の画面である「デバイス画面」を表示します。
  2. 「デバイス画面」の「Hello World!」メッセージをクリックします。「プロパティ」ウィンドウで、「Hello World!」テキストをクリックしてウェルカム・メッセージ・テキストを変更し、Enterを押します。この例では「Make my day」と入力しました。

    テキスト「Make my day」が「プロパティ」ウィンドウのテキスト・フィールドに入力されています。

  3. 「画面」ビューに、テキスト・フィールドに入力したテキストのプレビューが表示されます。

    テキスト「Make my day」が、VMDの「画面」ビューにあるデバイス画面プレビューに表示されています。

プロジェクトのコンパイルと実行

  1. IDEのメイン・ツールバーから「実行」>「プロジェクトの実行」(F6)を選択します。「出力」ウィンドウで、プロジェクトのコンパイルの進行状況を確認します。HelloMIDlet.javaファイルは実行前にビルドされることに注意してください。デバイス・エミュレータが開いて、MIDletの実行結果が表示されます。デバイス・エミュレータがMIDletを起動し、ソース・コードに入力されたテキストを表示します。

    MIDletを実行するエミュレータは、プロジェクト・ノードを右クリックし、コンテキスト・メニューから「指定して実行...」を選択して指定できます。次に、Java ME SDK 3.0.5で使用可能なDefaultCldcPhone1を示します。

    Java ME SDKのデフォルトの電話エミュレータに表示される「Make my day」

  2. エミュレータ・ウィンドウで「アプリケーション」>「終了」を選択して、MIDletとエミュレータ・ウィンドウを閉じます。

次の手順

MIDPおよびCLDCアプリケーションの開発方法を紹介する追加のチュートリアルについては、モバイル・アプリケーションの学習を参照してください。

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo