在 NetBeans IDE 中对 Java 应用程序进行性能分析的简介

NetBeans IDE 中包含一款功能强大的性能分析工具,可提供与应用程序的运行时行为有关的重要信息。通过 NetBeans 性能分析工具,可以从 IDE 中轻松监视线程状态、CPU 性能以及应用程序的内存使用情况,而且其开销相对较低。

本介绍性文档概述了包含在 IDE 中的性能分析工具,并将指导和帮助您快速启动对 NetBeans 项目的性能分析。本文档旨在介绍 IDE 中提供的各种性能分析任务,以及在进行项目性能分析时可以获取的性能分析结果。其中既没有涵盖 IDE 中的所有性能分析功能,也未介绍如何解释性能分析结果以解决应用程序中可能存在的特定性能问题。

在本文档中,将使用性能分析工具获取与 Anagram Game 样例应用程序(包含在 IDE 中的简单 Java 应用程序)有关的性能分析数据。虽然 Anagram Game 是一个非常简单的 Java 应用程序项目,但仍可按照同样的步骤,对更大型、更复杂的 Java 应用程序以及 Web 和企业应用程序项目进行性能分析。

本文档介绍了如何使用 IDE 对应用程序进行性能分析并获取以下性能分析结果:

  • 应用程序的运行时行为
  • 应用程序的方法使用的 CPU 时间
  • 创建对象

此外,本文档还介绍了如何生成并比较性能分析结果的快照。

此页上的内容适用于 NetBeans IDE 6.9、7.0、7.1 和 7.2

目录

入门指南

先决条件

本文档假定您具备以下技术的一些基本知识或编程经验:

  • Java 编程
  • NetBeans IDE

本教程所需要的软件

在学习本教程之前,您需要在计算机上安装以下软件:

软件或资源 要求的版本
NetBeans IDE 6.9、7.0、7.1、7.2
Java 开发工具包 (JDK) 版本 6 或 7

注:

  • 性能分析工具与 NetBeans IDE 捆绑在一起,无需进行特定的设置,即可开始对应用程序进行性能分析。

首次执行性能分析

首次使用性能分析工具时,IDE 需要执行一些初始操作以确保获取准确的性能分析结果,并将该工具与项目进行集成。为演示此情况,首先将创建 AnagramGame 项目,然后再执行校准。首次对 AnagramGame 项目进行性能分析时,IDE 将自动执行集成操作。

创建样例项目

在本文档中,将对 Anagram Game 样例应用程序进行性能分析。为此,首先要使用新建项目向导来创建样例应用程序并将项目设置为主项目。

要创建 Anagram Game 应用程序,请执行以下步骤。

  1. 从主菜单中,选择 "File"(文件)> "New Project"(新建项目)(Ctrl-Shift-N 组合键;在 Mac 上为 ⌘-Shift-N 组合键)。
  2. 在新建项目向导中,选择 "Samples"(样例)> "Java" 类别。
  3. 选择 Anagram Game 项目。单击 "Next"(下一步)。
  4. 指定项目的位置。单击 "Finish"(完成)。

    单击 "Finish"(完成),此时 IDE 将创建 Anagram Game 样例项目。

  5. 从主菜单中选择 "Run"(运行)> "Set Main Project"(设置为主项目)> "AnagramGame"。

在将项目设置为主项目后,您可以看到 Anagram Game 项目的名称在 "Projects"(项目)窗口中显示为粗体。默认情况下,使用 IDE 对项目进行性能分析时,IDE 也将对主项目进行性能分析。如果未将项目设置为主项目,则 IDE 将会对在 "Projects"(项目)窗口中选择的项目进行分析。

首次使用分析器

要获得准确的性能分析结果,必须拥有每个要用于性能分析的 Java 平台的校准数据。如果是首次运行性能分析工具,或没有可用于 Java 平台的有效校准数据,则 IDE 将提示您为平台运行校准过程。

校准只需执行一次即可。不过,如果对计算机配置进行任何可能会影响其性能的重大更改,则应重新运行校准过程。您可以通过执行以下步骤随时运行校准过程。

  1. 从 "Profile"(性能分析)菜单中,选择 "Advanced Commands"(高级命令)> "Run Profiler Calibration"(运行分析器校准)。
  2. 选择 Java 平台。单击 "OK"(确定)。

完成校准操作之后,将会显示一个对话框。您可以单击 "Show Details"(显示详细信息),以查看一个对话框,其中包含与校准结果有关的信息。每个 Java 平台的校准数据都保存在主目录的 .nbprofile 目录中。

注:如果您使用的是 NetBeans IDE 6.9 或更低版本,则首次对项目进行分析时,将会显示一个对话框,指出 IDE 需要将性能分析工具与目标项目进行集成。

要与项目进行集成,IDE 将修改项目的构建脚本 (build.xml) 来添加以下行,以导入所需性能分析库的其他构建脚本。

<import file="nbproject/profiler-build-impl.xml"/>

修改构建脚本之前,IDE 将会创建原始构建脚本 (build-before-profiler.xml) 的备份。您可以通过从 "Profile"(性能分析)菜单中选择 "Advanced Commands"(高级命令)> "Unintegrate"(取消集成)随时恢复原始构建脚本。

选择性能分析任务

IDE 提供了各种内部设置,用于优化性能分析,以满足您的需要。例如,可以降低性能分析开销,但代价是生成的信息量会有所减少。不过,要了解各种可用设置的含义和用法,可能需要花些时间。对很多应用程序而言,为性能分析任务指定的默认设置足以应对大多数情况。

对项目进行性能分析时,可以使用 "Select Profiling Task"(选择性能分析任务)对话框,根据要获取的性能分析信息类型选择所需的任务。下表描述了性能分析任务以及通过运行任务获取的性能分析结果。

性能分析任务 结果
监视应用程序 选择此任务可获取有关目标 JVM 属性的高级信息,其中包括线程活动和内存分配。
分析 CPU 性能 选择此任务可获取有关应用程序性能的详细数据,其中包括方法的执行时间和调用次数。
分析内存使用情况 选择此任务可获取有关对象分配和垃圾回收的详细数据。

"Select Profiling Task"(选择性能分析任务)对话框是用于运行性能分析任务的主界面。选择任务后,可以修改任务设置,以优化要获取的结果。对于每个性能分析任务,还可以根据任务创建并保存定制性能分析任务。创建定制性能分析任务时,将在 "Select Profiling Task"(选择性能分析任务)对话框中列出定制任务,以便于您稍后可以轻松找到并运行定制设置。创建定制性能分析任务时,可以修改更高级的性能分析设置,方法是单击 "Select Profiling Task"(选择性能分析任务)对话框中的 Advanced settings(高级设置)。

监视应用程序

选择 "Monitor"(监视)任务时,将启动目标应用程序,而不进行任何分析。监视应用程序时,可以获取有关目标 JVM 的几个重要属性的高级信息。监视应用程序产生的开销非常低,因此,应用程序可以在长时间内以这种模式运行。

要监视 Anagram Game 应用程序,请执行以下步骤。

  1. 确认将 AnagramGame 项目设置为主项目。
  2. 从主菜单中选择 "Profile"(性能分析)> "Profile Main Project"(分析主项目)。

    此外,也可以在 "Projects"(项目)窗口中右键单击项目节点,然后选择 "Profile"(性能分析)。

  3. 在 "Select Profiling Task"(选择性能分析任务)对话框中选择 "Monitor"(监视)。
  4. 根据需要,选择其他监视选项。单击 "Run"(运行)。

    将光标悬停在某一选项上即可查看包含有关该选项详细信息的工具提示。

单击 "Run"(运行)后,IDE 将启动应用程序,此时 "Profiler"(分析器)窗口将在 IDE 的左窗格中打开。"Profiler"(分析器)窗口中包含用于执行以下操作的控件:

  • 控制性能分析任务
  • 查看当前性能分析任务的状态
  • 显示性能分析结果
  • 管理性能分析结果快照
  • 查看基本遥测统计信息

使用 "Profiler"(分析器)窗口或主菜单中的控件,可以打开相关窗口在其中查看监视数据。使用 "Telemetry Overview"(遥测概览)窗口,可以快速实时地概览监视数据。如果将光标放在图形上,则可以查看与该图形中显示的数据相关的更详细统计信息。在 "Telemetry Overview"(遥测概览)窗口中,可以双击任何图形,以打开该图形更大、更详细的版本。

如果该概览未自动打开,则可选择 "Window"(窗口)> "Profiling"(性能分析)> "VM Telemetry Overview"(VM 遥测概览),以便在 "Output"(输出)窗口中打开该概览。您可以打开 "VM Telemetry Overview"(VM 遥测概览)窗口,并在任意性能分析会话期间随时查看监视数据。

分析 CPU 性能

选择 "CPU" 任务时,IDE 会对应用程序的方法级 CPU 性能(执行时间)进行分析并实时处理结果。您可以选择通过以下方法来分析性能:定期进行堆栈跟踪,或分析应用程序中的方法。您也可以选择分析所有方法,或只分析部分应用程序代码,甚至可以只分析特定代码片段。

要分析 CPU 性能,可通过选择以下一个选项,选择应用程序的性能分析方式。

  • Quick (Sampled)(快速(采样))。在此模式中,IDE 对应用程序进行采样并定期执行堆栈跟踪。此选项不如分析方法精确,但是开销较低。借助此选项,可以找到可能需要分析的方法。
  • Advanced (Instrumented)(高级(分析))。在此模式中,将对所分析的应用程序的方法进行分析。IDE 会记录线程进入和退出项目方法的时间,方便您查看在每个方法中花费的时间。在进入某个方法时,线程将生成“方法进入”事件。在退出该方法时,线程将生成相应的“方法退出”事件。系统将记录这两个事件的时间戳。该数据是实时处理的。

    您可以选择分析应用程序中的所有方法,也可以通过指定一个或多个根方法只分析部分应用程序代码。要指定根方法,可以在源代码中使用弹出式菜单,也可以单击 customize(定制),打开 "Edit Profiling Roots"(编辑性能分析根目录)对话框。

    根方法是源代码中可指定为分析根的方法、类或包。当应用程序的某个线程进入和离开分析根时,系统将会收集性能分析数据。在应用程序的某个线程进入根方法之前,系统不会收集任何性能分析数据。指定根方法可以大大减少性能分析开销。对于某些应用程序,指定根方法可能是获取所有详细和/或实际性能数据的唯一方式,因为对整个应用程序进行性能分析时,可能会生成大量的性能分析数据,使应用程序无法使用,甚至可能导致其崩溃。

注:快速分析模式不适用于 NetBeans IDE 7.0 及更低版本。您只能通过分析获取性能分析结果,但是,您可以选择分析整个应用程序,也可以通过指定一个或多个根方法,只分析部分应用程序。

您可以进一步优化所分析的代码量,方法是使用过滤器限制所分析的源。

现在,您将使用 IDE 分析 Anagram Game 应用程序的 CPU 性能。此外,您还将选择 "Part of Application"(部分应用程序)选项,然后选择 WordLibrary.java 作为性能分析根。通过选择此类作为性能分析根,可以只对此类中的方法进行分析。

  1. 在 "Profiler"(分析器)窗口中单击 "Stop"(停止)按钮,以停止前一个性能分析会话(如果仍在运行)。
  2. 从主菜单中选择 "Profile"(性能分析)> "Profile Main Project"(分析主项目)。
  3. 在 "Select Profiling Task"(选择性能分析任务)对话框中选择 "CPU"。
  4. 选择 Advanced (Instrumented)(高级(分析))。

    要使用此选项,还需要指定性能分析根方法。

  5. 单击 Customize(定制),打开 "Edit Profiling Roots"(编辑性能分析根目录)对话框。
  6. 在 "Edit Profiling Roots"(编辑性能分析根目录)对话框中,展开 "AnagramGame" 节点,然后选择 Sources/com.toy.anagrams.lib/WordLibrary。对项目进行性能分析时,可以指定多个根方法。
    用于选择根方法的对话框
  7. 单击 "Advanced"(高级)按钮,以打开 "Edit Profiling Roots (Advanced)"(编辑性能分析根目录(高级))对话框,该对话框提供了更高级的选项,用于添加、编辑和删除根方法。
    用于指定根方法的对话框

    您可以看到 WordLibrary 被列为根方法。单击 "OK"(确定)以关闭 "Edit Profiling Roots (Advanced)"(编辑性能分析根目录(高级))对话框。

  8. 单击 "OK"(确定),以关闭 "Edit Profiling Roots"(编辑性能分析根目录)对话框。

    在选择性能分析根目录后,在 "Select Profiling Task"(选择性能分析任务)对话框中单击 edit(编辑)即可修改所选的根方法。

  9. 选择 Profile only project classes(只分析项目类)作为过滤器值。

    使用此过滤器可以限制所分析的类。您可以从 IDE 的预定义性能分析过滤器中选择,也可以创建自己的定制过滤器。单击 Show filter value(显示过滤器值)即可查看在应用所选过滤器时进行分析的类列表。

  10. 在 "Select Profiling Task"(选择性能分析任务)对话框中单击 "Run"(运行)以启动性能分析会话。

单击 "Run"(运行)后,IDE 将启动应用程序,并开始性能分析会话。要查看性能分析结果,请在 "Profiler"(分析器)窗口中单击 "Live Results"(实时结果)以打开 "Live Results"(实时结果)窗口。"Live Results"(实时结果)窗口将显示迄今为止收集的性能分析数据。默认情况下,每几秒钟就刷新一次显示的数据。分析 CPU 性能时,"Live Results"(实时结果)窗口会显示与每个方法所花费时间相关的信息,以及与每个方法的调用次数相关的信息。您可以看到,在 Anagram Game 应用程序中,最初只调用选定的根方法。

您可以快速导航至包含任何列出方法的源代码,方法是:右键单击方法的名称,然后选择 "Go To Source"(转至源)。单击 "Go To Source"(转至源)后,将在源代码编辑器中打开类。

分析内存使用情况

"Analyze Memory Usage"(分析内存使用情况)任务提供了与目标应用程序中已分配对象有关的数据,如已分配对象的数量、类型和位置。

要分析内存性能,可以选择下列一个选项,以选择要获取的数据量:

  • Record object creation only(仅记录对象创建)。如果选中此选项,则将对当前由目标 JVM 加载的所有类(以及加载时生成的每个新类)进行分析以生成有关对象分配的信息。
  • Record both object creation and garbage collection(同时记录对象创建和垃圾回收)。如果选中此选项,则对应用程序进行性能分析时将提供有关对象活动的信息,例如每种类型中有多少对象仍处于活动状态,这些对象的大小和平均生存期以及分配数据。

从功能方面来讲,第一个选项是第二个选项的子集,使用它所产生的性能和内存开销较少。在 "Select Profiling Task"(选择性能分析任务)窗口中,"Overhead"(开销)计数器将根据所选的性能分析选项粗略地估计性能分析开销的增减量。

在本练习中,将使用 IDE 分析 Anagram Game 应用程序的内存性能。您将选择 Record both object creation and garbage collection(同时记录对象创建和垃圾回收)选项,并选择 Record stack traces for allocation(记录分配的堆栈跟踪),以便于 IDE 记录完整调用堆栈。选择此选项后,在生成内存快照时,您可以在反向调用树中查看分配了对象的方法。

  1. 在 "Profiler"(分析器)窗口中单击 "Stop"(停止)按钮,以停止前一个性能分析会话(如果仍在运行),并停止 Anagram Game 应用程序。
  2. 从主菜单中选择 "Profile"(性能分析)> "Profile Main Project"(分析主项目)。
  3. 在 "Select Profiling Task"(选择性能分析任务)对话框中选择 "Memory"(内存)。
  4. 选择 Record both object creation and garbage collection(同时记录对象创建和垃圾回收)。
  5. 使 "Track every N object allocations"(跟踪每第 N 个对象分配)保持为默认值 10。

    此选项可用于设置堆栈采样的间隔/比例。如果将值设置为 10,则意味着,对于每个类,每执行 10 个对象分配时,将只完整记录第 10 个对象分配。要记录每个对象的所有信息,可以将值设置为 1。不过,这会大大增加性能分析开销。

  6. 选择 Record stack traces for allocation(记录分配的堆栈跟踪)。单击 "Run"(运行)以启动性能分析会话。

    请注意,选择此选项时,"Overhead"(开销)计数器将大大增加,但应用程序非常小,因此性能影响应该可控。

单击 "Run"(运行)后,IDE 将启动应用程序,并开始性能分析会话。要查看性能分析结果,请在 "Profiler"(分析器)窗口中单击 "Live Results"(实时结果)以打开 "Live Results"(实时结果)窗口。"Live Results"(实时结果)窗口将显示与项目中所分配对象的大小和数量相关的信息。

默认情况下,将按 "Live Bytes"(活动字节)数对结果进行排序和显示,但是,您可以单击列标题,以更改结果的显示方式。此外,还可以在列表下方的过滤器框中键入类名,对结果进行过滤。

生成快照

性能分析会话正在运行时,可通过生成快照捕获性能分析结果。生成快照时,快照可捕获性能分析数据。不过,快照在以下方面不同于实时性能分析结果:

  • 可以在性能分析会话没有运行时检查快照。
  • 与实时结果相比,快照包含更详细的性能分析数据记录。
  • 可以很方便地比较快照(内存快照)。

无需运行性能分析会话即可打开项目的快照,因此,通过以下方式可以随时打开项目的快照:在 "Profiler"(分析器)窗口中,从已保存快照的列表中选择所需快照,然后单击 "Open"(打开)。

生成和比较内存快照

对于 Anagram Game 应用程序,可以生成结果的快照,以查看类型为 String 的对象的分配堆栈跟踪。然后,可以生成另一个快照,并对二者进行比较。通过比较内存快照,可以查看在生成两个快照的时间间隔内从堆释放或创建的对象。快照必须可以进行比较,这意味着,性能分析类型(例如 "Allocations"(分配)与 "Liveness"(活动))和已跟踪的对象数必须匹配。

在本练习中,将生成快照并将其保存到项目中。然后,将生成第二个快照,并将该快照与已保存的快照进行比较。

  1. 确保性能分析会话仍在运行中。
    (如果停止了性能分析会话,则重复执行相应步骤以分析内存性能并打开 "Live Results"(实时结果)窗口。)
  2. 在 "Live Results"(实时结果)窗口中,右键单击 java.lang.String 所在行,然后选择 "Take Snapshot and Show Allocation Stack Traces"(生成快照并显示分配堆栈跟踪)。

    IDE 将会生成内存快照,并在 "Allocation Stack Traces"(分配堆栈跟踪)标签中打开快照。在 "Allocation Stack Traces"(分配堆栈跟踪)标签中,可以在反向调用树中浏览实例化了选定对象的方法。

    内存性能分析结果的屏幕快照
  3. 单击快照工具栏中的 "Save Snapshot to Project"(将快照保存到项目中)按钮(Ctrl-S 组合键;在 Mac 上为 ⌘-S 组合键),将内存快照保存到项目中。将快照保存到项目中时,会在 "Profiler"(分析器)窗口中将该快照添加到 Anagram Game 的已保存快照的列表中。默认情况下,快照实际上保存在项目的 nbproject/private/profiler 目录中。已保存的快照会附加 .nps 后缀。

    注:您可以将快照保存到文件系统上的任何位置,但只有保存在项目中默认位置的快照才会列在 "Profiler"(分析器)窗口中。此外,还可以单击快照工具栏中的 "Save current view to image"(将当前视图另存为图像)按钮,将快照保存为可以在 IDE 外部查看的图像文件 (.png)。

  4. 生成另一个快照,方法是:单击 "Live Results"(实时结果)工具栏中的 "Take Snapshot of Collected Results"(生成收集结果的快照)按钮(或者,也可以在 "Profiler"(分析器)窗口中单击 "Take Snapshot"(生成快照)按钮)。保存该快照。
  5. 在某一内存快照的窗口中,单击快照工具栏中的 "Compute Difference"(计算差异)按钮 ()。此外,也可以从主菜单中选择 "Profile"(性能分析)> "Compare Memory Snapshots"(比较内存快照)。
  6. 在 "Select Snapshot to Compare"(选择要比较的快照)中,从列表中选择其中一个打开的快照。单击 "OK"(确定)。
    用于选择要比较的快照的对话框的屏幕快照

    内存快照处于打开状态时,可以将其与其他可比较的内存快照进行比较。您可以将该快照与当前打开的未保存快照进行比较,也可以将其与保存到项目或系统中其他位置的快照进行比较。

    单击 "OK"(确定)后,将会打开 "Liveness Comparison"(活动比较)窗口,其中会显示两个内存快照之间的差异。

    活动比较结果的屏幕快照

快照比较类似于内存快照,但只显示两个比较快照之间的差异。通过 "Live Bytes"(活动字节)列中的图形栏,可以轻松查看分配的字节的差异。如果该列中单元格的左半部分为绿色,则表示生成第二个快照时为该对象分配的字节数小于生成第一个快照时为其分配的字节数。如果该单元格的右半部分为红色,则表示第二个快照中分配的字节数大于第一个快照中分配的字节数。在其他列中,可以看到加号 (+) 表示值增加,而减号 (-) 表示该值减小。

注:您还可以设置生成快照性能分析点,以便更精确地控制生成快照的时间。有关如何使用性能分析点生成快照的详细信息,请参见在 NetBeans IDE 中使用性能分析点


另请参见

使用 NetBeans IDE 对应用程序进行性能分析的简介到此结束。本文档介绍了如何使用 IDE 对简单的 NetBeans 项目进行性能分析并查看性能分析结果的基本知识。对大多数项目进行性能分析时,上述步骤可能都适用。如果对企业应用程序和自由格式项目等更复杂的项目进行性能分析,则可能需要执行额外的配置步骤。

有关本文档中未介绍的性能分析设置和功能的更详细信息,请查阅相关文档,后者是该产品附带的,可从 "Help"(帮助)菜单项获得。

有关相关文档,请参见以下资源:

返回页首

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo