Введение в профилирование приложений Java в IDE NetBeans

IDE NetBeans включает многофункциональный инструмент профилирования, который позволят получить важные сведения о режиме работы приложения во время выполнения. Средство профилирования NetBeans позволяет просто отслеживать состояния потоков, производительность ЦП и использование памяти приложением в среде IDE; оно потребляет сравнительно немного ресурсов.

Этот вводный документ — обзор средства профилирования, входящего в состав среды IDE, и руководство, позволяющее быстро приступить к профилированию проектов NetBeans. Этот документ предназначен продемонстрировать различные задачи профилирования, доступные в среде IDE, и результаты профилирования, которые можно получить при профилировании проекта. В ней не рассматриваются все функции профилирования среды IDE, также не освещена интерпретация результатов профилирования для разрешения определенных проблем производительности, которые могут возникнуть в приложении.

В этом документе будет демонстрироваться использование средства профилирования для получения данных профилирования о примере приложения Anagram Game, простого приложения Java, входящего в состав среды IDE. Хотя Anagram Game — это очень простой проект приложения Java, при профилировании больших и более сложных приложений Java, а также проектов корпоративных и веб-приложений желательно выполнять те же действия.

В этом документе показано использование среды IDE для профилирования приложения и получения следующих результатов профилирования:

  • Поведение приложения при выполнении
  • Время ЦП, используемое методами приложения
  • Создание объекта

Кроме того, в этом документе показано получение и сравнение снимков результатов профилирования.

Содержимое на этой странице применимо к IDE NetBeans 6.9, 7.0, 7.1 и 7.2

Содержание

Начало работы

Предпосылки

Предполагается, что читатель обладает базовыми знаниями по следующим технологиям или опытом программирования с их использованием:

  • Программирование на Java
  • IDE NetBeans

Программное обеспечение, требуемое для работы с данным учебным курсом.

Для работы с этим учебным курсом на компьютере должно быть установлено следующее программное обеспечение.

Программное обеспечение или материал Требуемая версия
IDE NetBeans 6.9, 7.0, 7.1, 7.2
Комплект для разработчика на языке Java (JDK) Версия 6 или 7

Примечания.

  • Инструмент профилирования включен в комплект с IDE NetBeans и для начала профилирования приложения не требуется дополнительная настройка.

Первое профилирование

При первом использовании средства профилирования среде IDE необходимо выполнить некоторые начальные операции для обеспечения получения точных результатов профилирования и интеграции средства с проектом. Чтобы продемонстрировать это, создадим проект AnagramGame, а затем выполним калибровку. Среда IDE автоматически выполнит интеграцию при первом профилировании проекта AnagramGame.

Создание примера проекта

В этом документе будет выполнено профилирование примера проекта Anagram Game. Для этого вам сначала необходимо использовать мастер создания проектов для создания примера приложения и настроить проект, как главный проект.

Для создания приложения Anagram Game выполните следующие действия.

  1. Выберите "Файл > Новый проект" (CTRL+SHIFT+N; &#8984+SHIFT+N в Mac ОС) в главном меню.
  2. В мастере создания проекта выберите категорию "Примеры > Java".
  3. Выберите проект "Anagram Game". Нажмите кнопку "Далее".
  4. Укажите местоположение проекта. Нажмите кнопку "Завершить".

    При нажатии кнопки "Готово" среда IDE создает пример проекта Anagram Game.

  5. Выберите 'Выполнить' > 'Настроить основной проект' > AnagramGame в главном меню.

После настройки проекта как основного имя проекта Anagram Game будет выделено полужирным в окне 'Проекты'. По умолчанию при использовании среды IDE для профилирования проекта среда IDE профилирует главный проект. Если ни один проект не выбран в качестве главного, среда IDE выполнит профилирование проекта, который выбран в окне 'Проекты'.

Первое использование средства профилирования

Для получения точных результатов профилирования требуются данные калибровки для каждой платформы Java, которая будет использоваться для профилирования. При первом запуске средства профилирования, или если допустимые данные калибровки недоступны для данной платформы Java, среда IDE запросит выполнить процесс калибровки для вашей платформы.

Калибровка должны быть выполнена только один раз. Однако при внесении значительных изменений в комплектацию компьютера, которая может повлиять на его производительность, необходимо снова выполнить калибровку. Калибровку можно выполнить в любое время, выполнив следующие действия.

  1. Выберите "Дополнительные команды > Выполнить калибровку средства профилирования" в меню "Профиль".
  2. Выберите платформу Java. Нажмите кнопку "ОК".
Диалоговое окно "Выбор платформы Java".

По завершении операции калибровки появится диалоговое окно. Можно нажать кнопку "Показать подробные сведения", чтобы просмотреть диалоговое окно с информацией о результатах калибровки. Данные калибровки для каждой платформы Java сохраняются в каталоге .nbprofile в домашнем каталоге.

снимок диалогового окна 'Сведения о калибровке'

Примечание. При использовании IDE NetBeans 6.9 или более ранней версии при первом профилировании проекта отображается диалоговое окно, в котором указывается, что среде IDE требуется интеграция инструмента профилирования с целевым проектом.

Диалоговое окно 'Включить поддержку профилирования'

Для интеграции с проектом среда IDE добавляет к сценарию сборки (build.xml) проекта следующую строку для импорта дополнительного сценария сборки для необходимых библиотек профилирования.

<import file="nbproject/profiler-build-impl.xml"/>

Перед изменением сценария сборки среда IDE создает резервную копию исходного сценария сборки (build-before-profiler.xml). Можно восстановить исходный сценарий сборки в любое время, выбрав "Дополнительные команды > Удалить профилирование" в меню "Профилировать".

Выбор задачи профилирования

Среда IDE предоставляет ряд внутренних параметров, позволяющих настраивать профилирования в соответствии с вашими требованиями. Например, можно уменьшить дополнительный расход ресурсов на профилирование за счет уменьшения объема созданной информации. Однако ознакомление со множеством доступных параметров может занять некоторое время. Для большинства приложений параметров по умолчанию, указанных для задач профилирования, достаточно для большинства ситуаций.

При профилировании проекта используется диалоговое окно "Выбор задачи профилирования" для выбора задачи в соответствии с необходимо информацией профилирования. В следующей таблице описываются задачи профилирования и результаты, получаемые в результате выполнения задачи.

Задача профилирования Результаты
Наблюдение за приложением Выберите для получения высокоуровневой информации о свойствах целевой JVM, включая активность потоков и распределение памяти.
Анализ производительности ЦП Выберите для получения подробных данных о производительности приложения, включая время выполнения методов и число вызовов метода.
Анализ использования памяти Выберите для получения подробной информации о выделении объектов и сборке мусора.

Диалоговое окно "Выбор задачи профилирования" — основной интерфейс для выполнения задач профилирования. После выбора задачи можно изменить ее параметры для точной настройки получаемых результатов. Для каждой задачи профилирования также можно создать и сохранить пользовательские задачи профилирования на основе данной задачи. При создании пользовательской задачи профилирования она будет указана в диалоговом окне "Выбрать задачу профилирования", что позволяет позже просто найти и выполнить пользовательские параметры. При создании пользовательской задачи профилирования можно изменить дополнительные параметры профилирования, нажав кнопку Дополнительные параметры в диалоговом окне "Выбрать задачу профилирования".

Наблюдение за приложением

При выборе задачи наблюдения целевое приложение запускается без каких-либо инструментов. При наблюдении за приложением вы получаете высокоуровневую информацию о нескольких важных свойствах целевой JVM. Поскольку наблюдение за приложением не требует большого дополнительного расхода ресурсов, можно запускать приложение в этом режиме в течение длительного времени.

Для наблюдения за приложением Anagram Game выполните следующие действия.

  1. Убедитесь, что проект AnagramGame установлен как главный проект.
  2. Выберите "Профиль > Профилировать главный проект" в главном меню.

    Также можно щелкнуть правой кнопкой мыши узел проекта в окне 'Проекты' и выбрать 'Профиль'.

  3. Выберите "Наблюдение" в диалоговом окне "Выбор задачи профилирования".
  4. При необходимости выберите дополнительные параметры монитора. Нажмите кнопку "Выполнить".
    Диалоговое окно 'Выбор задачи профилирования' - приложение монитора

    Можно подвести курсор к параметру для просмотра всплывающей подсказки со сведениями о параметре.

При нажатии кнопки "Выполнить" среда IDE запускает приложение, и открывается окно "Средство профилирования" в левой панели среды IDE. В окне "Средство профилирования" содержатся элементы управления, позволяющие выполнять следующие действия.

  • Контроль за задачей профилирования
  • Просмотр состояния текущей задачи профилирования
  • Отображение результатов профилирования
  • Управление моментальными снимками результатов профилирования
  • Просмотр статистики основной телеметрии

Можно использовать элементы управления в окне "Средство профилирования" или главном меню для открытия окон, в которых можно просматривать данные наблюдения. Окно "Обзор телеметрии" можно использовать для быстрого получения обзора данных наблюдения в реальном времени. Если поместить курсор на график, можно просмотреть более подробную статистику отображающихся в графике данных. Можно дважды щелкнуть любой график в окне "Обзор телеметрии" для открытия более крупной и подробной версии графика.

снимок окна 'Обзор телеметрии'

Если обзор не открывается автоматически, можно выбрать "Окно > Профилирование > Обзор телеметрии", чтобы открыть окно вывода. Можно открыть окно "Обзор телеметрии VM" и просмотреть данные наблюдения в любое время во время сеанса профилирования.

Анализ производительности ЦП

При выборе задачи ЦП среда IDE профилирует производительность ЦП уровня метода (время выполнения) приложения и обрабатывает результаты в реальном времени. Можно выбрать анализ производительности путем периодического выполнения трассировки стека или инструментирования методов в приложении. Можно выбрать инструментирование всех методов или ограничить инструментирование частью кода приложения, даже определенным фрагментом кода.

Для анализа производительности ЦП можно выбрать способ профилирования приложения, выбрав один из следующих вариантов.

  • Быстрый (образец). В этом режиме IDE создает образец приложения и периодически создает трассировку стека. Этот вариант менее точен, чем методы инструментирования, но вызывает меньший дополнительный расход ресурсов. Этот вариант может помочь выбрать методы для инструментирования.
  • Расширенный (инструментация). В этом режиме методы профилируемого приложения инструментируются. Среда IDE регистрирует вход и выход потоков в методы проекта, позволяя отслеживать время, затрачиваемое на каждый метод. При входе в метод потоки создают событие "вход в метод". При выходе из метода потоки создают соответствующее событие "выход из метода". Записываются метки времени обоих событий. Эти данные обрабатываются в реальном времени.

    Можно выбрать инструментирование всех методов приложения или ограничить инструментирование поднабором кода приложения, указав один или несколько корневых методов. Корневой метод можно указать, используя всплывающее меню в исходном коде, или щелкнув настроить, чтобы открыть диалоговое окно "Изменить корневые методы профилирования".

    Корневой метод — это метод, класс или пакет в исходном коде, который можно указать как корень обработки. Данные профилирования собираются при входе и выходе одного из потоков приложения из корня обработки. До входа одного из потоков приложения в корневой метод данные профилирования не собираются. Указание корневого метода может значительно снизить дополнительный расход ресурсов на профилирование. Для некоторых приложений указание корневого метода может быть единственным способом получения подробных и/или реалистичных данных производительности, поскольку профилирование всего приложения может создать так много данных профилирования, что приложение станет непригодным к использованию, или даже произойдет отказ приложения.

Примечание. Режим профиля Quick недоступен в IDE NetBeans 7.0 и более ранних версиях. Можно использовать только инструментирование для получения результатов профилирования, но можно выбрать инструментирование всего приложения или ограничить инструментирование частью приложения, указав один или несколько корневых методов.

Можно еще больше уточнить код для профилирования, используя фильтр для ограничения исходного кода для инструментирования.

Теперь среда IDE будет использоваться для анализа производительности ЦП приложения Anagram Game. Необходимо выбрать вариант "Часть приложения", а затем WordLibrary.java в качестве корневого метода профилирования. При выборе этого класса в качестве корневого метода профилирования последнее ограничивается методами в этом классе.

  1. Нажмите кнопку "Остановить" в окне "Средство профилирования", чтобы остановить предыдущий сеанс профилирования (если он еще запущен).
  2. Выберите "Профиль > Профилировать главный проект" в главном меню.
  3. Выберите "ЦП" в диалоговом окне "Выбор задачи профилирования".
  4. Выберите Расширенный (инструментарий).

    Для использования этого варианта также необходимо указать корневой метод профилирования.

  5. Нажмите кнопку настроить, чтобы открыть диалоговое окно "Изменение корневых методов профилирования".
    Диалоговое окно 'Выбор задачи профилирования' - ЦП
  6. В диалоговом окне 'Изменение корневых методов профилирования' разверните узел AnagramGame и выберите Sources/com.toy.anagrams.lib/WordLibrary. При профилировании проекта можно указать несколько корневых методов профилирования.
    диалоговое окно для выбора корневых методов
  7. Нажмите кнопку "Дополнительно", чтобы открыть диалоговое окно "Изменение корневых методов профилирования (Дополнительно)", в котором доступны дополнительные параметры для добавления, изменения и удаления корневых методов.
    Диалоговое окно для указания корневых методов

    Можно видеть, что WordLibrary указан как корневой метод. Нажмите "ОК", чтобы закрыть диалоговое окно "Изменение корневых методов профилирования (Расширенное)".

  8. Нажмите "ОК", чтобы закрыть диалоговое окно "Изменение корневых методов профилирования".

    После выбора корневых методов профилирования можно щелкнуть правка в диалоговом окне 'Выбор задачи профилирования' дл изменения выбранного корневого метода.

  9. Выберите Профилировать только классы проекта для значения "Фильтр".

    Фильтр позволяет ограничить инструментируемые классы. Можно выбрать один из предварительно определенных фильтров профилирования IDE или создать собственные пользовательские фильтры. Щелкните Показать значение фильтра для просмотра списка классов, которые будут профилированы при применении выбранного фильтра.

    Диалоговое окно 'Показать значени фильтра'
  10. Нажмите кнопку "Выполнить" в диалоговом окне "Выбрать задачу профилирования" для начала сеанса профилирования.

При нажатии кнопки "Выполнить" среда IDE запускает приложение Anagram Game и запускает сеанс профилирования. Чтобы просмотреть результаты профилирования, нажмите кнопку "Текущие результаты" в окне "Средство профилирования", при этом откроется окно "Текущие результаты". В окне "Текущие результаты" отображаются собранные на этот момент данные профилирования. По умолчанию отображаемые данные обновляются каждые несколько секунд. При анализе производительности ЦП в окне "Текущие результаты" отображаются сведения о времени, затраченным для каждого метода, и число вызовов каждого метода. Можно видеть, что в приложении Anagram Game изначально вызываются только выбранные корневые методы.

снимок текущих результатов ЦП

Вы можете быстро перейти к исходному коду, содержащему любой из перечисленных методов, щелкнув правой кнопкой мыши имя метода и выбрав 'Перейти к источнику'. При щелчке 'Перейти к исходному коду' класс открывается в редакторе исходного кода.

Анализ использования памяти

Задач "Анализ использования памяти" предоставляет данные об объектах, выделенных в целевом приложении, таких как число, тип и расположение выделенных объектов.

Для анализа производительности памяти необходимо выбрать объем данных для получения, выбрав один из следующих вариантов.

  • Регистрировать только создание проектов. Если выбран этот параметр, все классы, которые в настоящее время загружены целевой JVM (и каждый новый класс по мере его загрузки) инструментируются для создания данных о распределении объектов.
  • Регистрировать создание объектов и сборку мусора. Если выбрано, профилирование приложений позволяет получить сведения о жизнеспособности объектов, включая сведения о том, сколько объектов каждого типа все еще жизнеспособны, каков их размер и средний возраст, а также распределение данных.

Первый вариант — это функциональное подмножество второго, имеющее меньший дополнительный расход ресурсов по производительности и памяти. Показатель "Накладные расходы" в окне "Выбрать задачу профилирования" предоставляет примерное увеличение или уменьшение дополнительного расхода ресурсов на профилирование в соответствии с выбранными вариантами профилирования.

В этом упражнении среда IDE будет использоваться для анализа производительности памяти приложения Anagram Game. Необходимо выбрать вариант Регистрировать создание объектов и сборку мусора и пункт Регистрировать трассировку стека для операций выделения, чтобы среда IDE регистрировала весь стек вызовов. При выборе этого варианта при получении моментального снимка можно просмотреть обратное дерево вызовов для метода, вызывающего эти выделенные объекты.

  1. Нажмите кнопку "Остановить" в окне "Средство профилирования", чтобы остановить предыдущий сеанс профилирования (если он еще запущен) и приложение Anagram Game.
  2. Выберите "Профиль > Профилировать главный проект" в главном меню.
  3. Выберите "Память" в диалоговом окне "Выбрать задачу профилирования".
  4. Выберите Регистрировать создание объектов и сборку мусора.
  5. Для параметра трассировки размещения каждого из N объектов оставьте значение по умолчанию, 10.

    Этот параметр устанавливает интервал /пропорцию для опроса стека. При установке значения 10 для каждого класса будет полностью зарегистрировано только каждое десятое выделение объекта. Для регистрации всей информации для каждого объекта можно установить значение 1. Однако это значительно увеличит дополнительный расход ресурсов на профилирование.

  6. Выберите Регистрировать трассировку стека для операций выделения. Нажмите кнопку "Выполнить" для начала сеанса профилирования.

    Обратите внимание, что при выборе этого варианта значение показателя "Накладные расходы" значительно увеличивается, но приложение достаточно мало для того, чтобы снижение производительности было приемлемым.

    Диалоговое окно 'Выбор задачи профилирования' - Память

При нажатии кнопки "Выполнить" среда IDE запускает приложение Anagram Game и запускает сеанс профилирования. Чтобы просмотреть результаты профилирования, нажмите кнопку "Текущие результаты" в окне "Средство профилирования", при этом откроется окно "Текущие результаты". В окне "Текущие результаты" отображается информация о размере и числе объектов, выделенных в нашем проекте.

По умолчанию результаты сохраняются и отображаются как число выделенных байтов, но можно щелкнуть заголовок столбца, чтобы изменить способ отображения результатов. Также можно выполнить фильтрацию результатов, введя имя класса в поле фильтра под списком.

Результаты профилирования памяти

Получение моментального снимка

При выполнении сеанса профилирования можно сохранить результаты профилирования, получив моментальный снимок. Моментальный снимок сохраняет данные профилирования на момент получения снимка. Однако моментальные снимки отличаются от текущих результатов профилирования следующим.

  • Моментальные снимки могут быть исследованы, когда сеанс профилирования не запущен.
  • Моментальные снимки содержат более подробную запись данных профилирования, чем текущие результаты.
  • Моментальные снимки просты в сравнении (моментальные снимки памяти).

Поскольку для открытия моментальных снимков проекта сеанс профилирования выполняться не должен, можно открыть моментальный снимок проекта в любое время, выбрав снимок в списке сохраненных моментальных снимков в окне "Средство профилирования" и выбрав "Открыть".

Получение и сравнение моментальных снимков памяти

Для приложения Anagram Game можно получить моментальный снимок результатов, чтобы просмотреть трассировку стека выделения для объектов типа Строка. Можно получить другой моментальный снимок или сравнить два снимка. Путем сравнения моментальных снимков памяти можно просмотреть, какие объекты были созданы или освобождены из кучи в интервале между получения двух моментальных снимков. Моментальные снимки должны быть сравнимыми, что означает, что тип профилирования (например, выделения и жизнеспособность) и число отслеживаемых объектов должны совпадать.

В этом упражнении будет получен и сохранен моментальный снимок в проекте. Затем будет получен второй моментальный снимок и сравнен с первым.

  1. Убедитесь, что сеанс профилирования по-прежнему выполняется.
    (Если сеанс профилирования остановлен, повторите действия для анализа производительности памяти и откройте окно "Текущие результаты".)
  2. Правой кнопкой мыши щелкните строку, содержащую java.lang.String, в окне "Текущие результаты" и выберите "Получить снимок и показать стек операций выделения памяти".

    Среда IDE получает моментальный снимок памяти и открывает его во вкладке "Трассировка стека операций выделения памяти". На вкладке "Трассировка стека операций выделения памяти" можно изучить обратное дерево вызовов для методов, создавших экземпляр выбранного объекта.

    Снимок результатов профилирования памяти
  3. Нажмите кнопку "Сохранить моментальный снимок в проекте" на панели инструментов моментального снимка (Ctrl-S; ⌘-S в Mac), чтобы сохранить моментальный снимок памяти в проекте. При сохранении моментального снимка в проекте он добавляется к списку сохраненных моментальных снимков Anagram Game в окне "Средство профилирования". По умолчанию моментальные снимки физически сохраняются в каталоге nbproject/private/profiler проекта. К сохраненным моментальным снимкам добавляются суффикс .nps.

    Примечание. Вы можете сохранять снимки в любом местоположении файловой системы, но только снимки, сохраненные в папке по умолчанию в проекте, будут указаны в окне средства профилирования. Также можно нажать кнопку "Сохранить текущее представление в изображении" на панели инструментов моментального снимка, чтобы сохранить снимок как файлы изображений (.png), которые можно просмотреть вне среды IDE.

  4. Получите другой моментальный снимок, нажав кнопку "Сделать моментальный снимок собранных результатов" на панели инструментов "Текущие результаты" (или нажмите кнопку "Сделать моментальный снимок" в окне "Средство профилирования"). Сохраните моментальный снимок.
  5. В окне одного из снимков памяти, нажмите кнопку 'Вычислить разницу' ( Кнопка 'Сравнить списки' ) на панели инструментов снимков. Или выберите "Профиль > Сравнить моментальные снимки памяти" в главном меню.
  6. В окне "Выбор моментального снимка для сравнения" выберите один из открытых моментальных снимков в списке. Нажмите кнопку "ОК".
    снимок диалогового окна 'Выбрать снимки для сравнения'

    После открытия моментального снимка памяти можно сравнить его с другими сравнимыми снимками памяти. Снимок экрана можно сравнить с текущими открытыми несохраненными снимками или со снимками, которые сохранены в проекте или где-либо в ином месте системы.

    При нажатии кнопки "ОК" откроется окно "Сравнение жизнеспособности", в котором отображается сравнение двух моментальных снимков памяти.

    снимок результатов сравнения жизнеспособности

Сравнение моментальных снимков сходно с моментальным снимком памяти, но на нем отображается только различия двух моментальных снимков. Графическая полоса в столбце "Выделенные байты" позволяет просто просмотреть различия выделенных байтов. Если левая половина ячейки в этом столбце зеленая, это означает, что число выделенных байтов для этого объекта меньше при получении второго моментального снимка, чем при получении первого. Если правая половина ячейки красная, это означает, что число выделенных байтов выше во втором моментальном снимке, чем в первом. В других столбцах можно видеть, что знак плюс ( + ) означает увеличение значения, а знак минус ( - ) уменьшение значения.

Примечание. Также можно настроить точки профилирования для создания снимков, что позволит добиться более точного контроля над временем создания снимков. Дополнительные сведения о создании моментальных снимков с помощью точек профилирования см. в разделе Использование точек профилирования в IDE NetBeans.


Дополнительные сведения

На этом завершается введение в профилирование приложения с помощью IDE NetBeans. В этом документе были продемонстрированы основы использования среды IDE для профилирования простого проекта NetBeans, а также просмотр результатов профилирования. Описанные выше действия применяются при профилировании большинства проектов. Для профилирования более сложных проектов, таких как приложения J2EE и проекты свободной формы, могут требоваться дополнительные действия по настройке.

Для получения более подробной информации о параметрах и функциях профилирования, не рассмотренных в этом документе, воспользуйтесь документацией, входящей в состав среды IDE и доступной из меню "Справка".

Сопутствующая документация приведена в следующих ресурсах.

В начало

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo