NetBeans IDE para o Editor do PHP: Breve visão geral

Este documento é uma breve visão geral dos principais recursos do NetBeans IDE para o Editor do PHP.

Conteúdo

O conteúdo desta página se aplica ao NetBeans IDE 7.1

Para seguir este tutorial, você precisa dos seguintes recursos e softwares.

Software ou recurso Versão necessária
NetBeans IDE Pacote de download do PHP
Um mecanismo PHP Versão 5
Um servidor Web É recomendado o Apache HTTP Server 2.2.
Um depurador PHP XDebug 2.0 ou posterior

Preparando

Para desenvolver e fazer deployment de aplicativos PHP no NetBeans IDE para PHP, você precisa ter todo o software necessário instalado e configurado para desenvolvimento de PHP.

Layout do NetBeans IDE para o Editor do PHP

O editor contém as seguintes janelas:

  • A janela Editor mostra o arquivo quando você está editando. O Editor tem uma aba para cada arquivo aberto.
  • A janela Projetos mostra uma lista dos projetos existentes no momento
  • A janela Arquivos mostra os arquivos de cada projeto
  • A janela Serviços mostra listas de serviços externos disponíveis atualmente como bancos de dados.

Você também pode abrir uma janela Navegador no painel esquerdo pressionando Ctrl + 7. O Navegador mostra a estrutura de uma classe PHP se ela estiver aberta no Editor. Os arquivos que não sejam de classe PHP não são mostrados na janela Navegador.

Para abrir a ajuda para uma desssas janelas, selecione qualquer elemento na janela e pressione F1.

Realce de sintaxe

O editor fornece realce de sintaxe para blocos de código PHP, HTML, JavaScript e CSS.

Os seguintes elementos de sintaxe são realçados na versão atual:

  • Palavras-chave do PHP
  • Variáveis do PHP
  • Constantes do PHP
  • Marcas HTML
  • Atributos de formulário de entrada de HTML
  • A linha atual é exibida com um segundo plano azul claro.
  • Ao colocar o cursor dentro de uma variável PHP, uma função ou uma classe, todas as ocorrências da variável serão realçadas.
  • As linhas onde tenham sido detectados erros são sublinhadas em vermelho.
A janela do NetBeans para editor do PHP mostra um fragmento de código com os elementos de código PHP e HTML realçados.

Para alterar as configurações de realce, escolha Ferramentas > Opções e alterne para a aba Fontes e cores. Especifique as configurações que desejar.

Ir para declaração

Com a função Ir para declaração, o usuário navega de uma ocorrência de uma variável ou função para a linha onde a variável ou função é declarada ou inicializada. Para usar essa funcionalidade, posicione o cursor na variável ou função relevante e escolha Navegar > Ir para a declaração a partir do menu de contexto, pressione Ctrl-B/⌘-B ou use Ctrl-click.

Janela do Navegador

A janela do Navegador exibe as estruturas do código como elementos de uma lista que mostra as estruturas PHP do arquivo ativo atual. Se o arquivo contiver quaisquer outras fontes de texto (por exemplo, HTML), a lista também exibe suas estruturas. Ao clicar duas vezes em uma função ou uma variável na lista, o cursor aponta para a declaração do elemento clicado.

Cuidado: a janela do Navegador somente mostra o código PHP para as classes PHP. Ela não pode mostrar código PHP fora de uma classe.

A lista Navegador normalmente não contém quaisquer listas incorporadas, mas para comandos complexos ela pode conter estruturas incorporadas. Por exemplo, um comando de declaração de classe PHP pode ser apresentado como uma árvore de membros de classe declarada.

A lista é atualizada dinamicamente enquanto o usuário digita o código.

A janela Navegador é mostrada na parte inferior do painel esquerdo.

  1. Para abrir a janela Navegador, pressione Ctrl + 7 ou vá para Janela > Navegação > Navegador. A árvore que exibe a hierarquia das estruturas de HTML e PHP é exibida.
  2. Para mover para o elemento desejado, clique duas vezes no nó relevante na lista.
    A figura mostra um exemplo da utilização da ferramenta de navegação. A figura também mostra funções e classes dobradas e desdobradas.

Dobramento de código

O editor permite que o usuário oculte e exiba de forma seletiva módulos, classes ou funções do arquivo editado atualmente com o código-fonte PHP. Para recolher ou exibir uma parte de código, clique no ícone - ou + à esquerda do código ou pressione Ctrl+ ou Ctrl-.

Recuo inteligente

O editor formata automaticamente o código enquanto o usuário está digitando.

Formatação

Para formatar uma parte de código para que fique mais compreensível, realize as seguintes etapas:

  1. Selecione a passagem de código relevante.
  2. Do menu de contexto exibido ao clicar com o botão direito do mouse, escolha Formatar ou pressione Alt + Shift + F

Conclusão de colchetes

O editor automaticamente adiciona e remove aspas e colchetes correspondentes enquanto o usuário digita o código.

  • Pares de aspas simples ' ' e aspas duplas "" "", parênteses () e colchetes [] são adicionados quando o usuário tiver digitado o primeiro símbolo.
  • No final de uma linha, um ponto-e-vírgula é adicionado além das aspas simples ou duplas de encerramento.
  • A chave de encerramento é adicionada depois que o usuário pressiona Enter, o que também ativa a função Recuo inteligente.
  • A exclusão das aspas simples ou duplas, do parêntese ou do colchete de abertura causa a remoção automática do símbolo de encerramento correspondente mas não afeta o ponto-e-vírgula do fim da linha.
  • Quando o cursor aponta para um parêntese de encerramento ), uma chave de encerramento } ou um colchete de encerramento ], o símbolo de abertura correspondente é realçado em amarelo.
    Quando o cursor aponta para um parêntese ou colchete de encerramento, o elemento de abertura correspondente é realçado.

Renomear refatoração e Renomear instantâneo

Você pode renomear um elemento, como um nome de classe, em todos os arquivos em um projeto. O recurso força você a visualizar suas alterações antes de poder fazê-las. A janela de visualização mostra cada localização do elemento e permite excluir ocorrências individuais do elemento sendo renomeado.

Renomear refatoração é contrastada com o recurso mais antigo, Renomear instantâneo. Renomear instantâneo ainda está disponível, mas somente funciona em contextos "não públicos", como renomear uma variável dentro de um método ou renomear variáveis e pastas privadas. Renomear instantâneo somente permite renomear um elemento dentro de um arquivo e não fornece uma janela de visualização.

Para usar Renomear instantâneo, coloque o cursor em um nome que deseja alterar e pressione Ctrl+R. Se Renomear instantâneo se aplicar a tal variável, todas as instâncias daquela variável ou função serão realçadas.

Editor de código-fonte PHP após Ctrl-R ser pressionado

Altere uma instância do nome e todas as outras instâncias serão alteradas simultaneamente

Editor código-fonte PHP mostrando um nome de variável refatorado

Para usar Renomear refatoração, selecione o elemento que deseja renomear e pressione Ctrl+R, ou clique com o botão direito do mouse e selecione Refatorar > Renomear. Uma caixa de diálogo é aberta para que você renomeie o elemento.

Caixa de diálogo para renomear uma variável

Renomeie o elemento e pressione Visualizar. A janela Refatoração é aberta. Nessa janela, você pode encontrar cada instância do elemento em seu projeto e pode decidir renomeá-lo ou não.

Janela Refatoração

Para obter mais informações sobre Renomear refatoração, consulte o screencast Renomear refatoração e outros aprimoramentos no editor no NetBeans IDE 7.0 para PHP.

Auto-completar de código

O preenchimento de código é um nome comum para um conjunto de recursos que aceleram o processo de codificação.

Os seguintes tipos de auto-completar de código estão disponíveis:

Trechos

Os trechos permitem que o usuário gere código para vários elementos automaticamente.

  1. Escolha Ferramentas > Paleta > Fragmentos de código. Uma paleta contendo vários elementos de interface do usuário aparece no painel direito.
  2. Arraste o ícone necessário na paleta para a posição relevante no código. Uma caixa de diálogo para especificar os parâmetros dos elementos correspondentes aparece. Preencha os dados.
  3. O código que exibe o elemento escolhido é gerado e inserido no local escolhido.

Propostas sensíveis a contexto

O editor fornece propostas sensíveis a contexto para completar qualquer número de símbolos iniciais de:

  • Uma palavra-chave de PHP (por exemplo, if, else, elseif, while, switch, function e assim por diante)
  • Uma função incorporada de PHP (por exemplo, substr, count, e assim por diante)
  • Uma variável predefinida ou definida pelo usuário

O editor sugere expansões mas também fornece dicas de parâmetros. Para aplicar o Auto-completar de código:

  1. Digite os símbolos iniciais da cadeia de caracteres necessária.
  2. Pressione CTRL + espaço. Uma lista suspensa mostra as propostas sensíveis a contexto. Cada proposta é fornecida com uma descrição e dicas de parâmetro. O conteúdo da lista é alterado à medida que você continua digitando.
  3. Para obter uma lista das palavras-chave de PHP disponíveis no contexto atual, pressione CTRL + espaço sem nenhuma digitação anterior.
    Uma lista de propostas sensíveis a contexto. Cada proposta é fornecida com uma descrição e dicas de parâmetro.
  4. Para obter uma dica sobre uma variável, digite o símbolo "$". Uma lista de todas as variáveis locais e globais disponíveis atualmente é exibida.
    Uma lista de variáveis é aberta depois que o usuário digita $. A lista contém variáveis globais do PHP e variáveis definidas pelo usuário.

Modelos de código e abreviaturas

No contexto atual, o termo "abreviações" refere-se a um conjunto de cadeias de caracteres predefinidas que correspondem às palavras-chave utilizadas em uma linguagem de programação. Cada abreviação está associada a um texto expandido que contém a palavra-chave completa e um modelo de código para a palavra-chave com dicas de parâmetro. Para aplicar esta funcionalidade, digite uma abreviação e pressione Tab.

A abreviação "cls" para a palavra-chave "class" é digitada

A abreviação é substituída pela palavra-chave correspondente e o modelo de código da palavra-chave é fornecido.

O texto completo da abreviação é exibido com um modelo de código para definição de classe

Para exibir a lista de abreviações definidas com modelos de código:

  1. Escolha Ferramentas > Opções > Editor > Modelos de código.
  2. A partir da lista suspensa Linguagem, selecione PHP. A lista de abreviações PHP e o modelo de código definido para elas são exibidos.
  3. Para adicionar ou remover uma definição da lista, utilize os botões Novo ou Remover respectivamente.
  4. Para editar uma definição, selecione a linha relevante e edite o texto no campo de edição abaixo da lista.
    A lista de abreviações e os modelos de código definidos para elas

Para obter mais informações, consulte Modelos de código no NetBeans IDE para PHP.

Preenchimento de código para construtores

Depois da nova palavra-chave, a janela de auto-completar código é exibida com construtores e parâmetros de todas as classes disponíveis no projeto.

Dicas do auto-completar código para um construtor

Preenchimento de código SQL

O autocompletar código SQL é exibido quando uma string começa com a palavra-chave do SQL "select". O primeiro passo é selecionar a conexão do banco de dados.

Auto-completar código oferecendo conexão do banco de dados

São exibidas todas as conexões do banco de dados registradas com o IDE.

Todas as conexões do banco de dados registradas com o IDE

Após selecionar a conexão, o auto-completar código SQL oferece todas as tabelas de tal conexão do banco de dados.

Todas as tabelas da conexão do banco de dados wishlist

Se a tabela tiver colunas, tais colunas também são exibidas.

Colunas exibidas da tabela

o auto-completar código SQL também funciona com aliases de tabela.

Auto-completar código SQL mostrando tabelas no alias hotel

Espaços de nome do PHP 5.3

O autocompletar de código suporta nomes namespace não qualificados, parcialmente qualificados e totalmente qualificados a partir do PHP 5.3. Para mais informações, consulte nosso screencast.

Métodos substituídos e implementados

Autocompletar de código entre membros de classe oferece substituir ou implementar métodos.

Autocompletar código oferecendo substituir o método

Preenchimento de código inteligente tentar/obter

A partir do NetBeans IDE 7.1, o preenchimento de código para declarações catch inclui somente as classes que herdam de Exceção.

Editor mostrando o preenchimento inteligente do código em parâmetros catch

Seleção retangular

O NetBeans IDE 7.1 para PHP introduz a ação Seleção retangular. Essa função de edição é útil em casos como a exclusão de números de linhas em código colado.

Para ativar a seleção retangular, pressione o botão Seleção retangular ou Ctrl+Shift+R para alternar.

Editor mostrando o botão Seleção retangular para alternar

Quando a Seleção retangular está ativada, você pode fazer a seleção com o mouse ou com o teclado. Quando você usa o teclado, coloque o cursor em um canto, mantenha Shift pressionado e selecione o que deseja com as teclas de seta. 

Editor mostrando uma seleção retangular de números de linhas colados

Se você escrever um texto enquanto a área estiver selecionada, o texto será colocado em cada linha na área selecionada. Isso pode ser útil, por exemplo, para alterar simultaneamente os modificadores de acesso de vários campos em uma classe. 

Editor com um modificador de acesso adicionado em todas as linhas em uma seleção retangular

Suporte ao PHPDocumentor

O suporte incorporado ao PHPDocumentor foi incluído no NetBeans IDE 7.0. Para obter mais informações, consulte o screencast Gerando documentação PHP com o NetBeans IDE.

Aviso: o PHPDocumentor não suporta completamente o PHP 5.3. Espaços de nome e alguns outros recursos do 5.3 não são documentados pelo PHP Documentor.

Geradores de código

Ao pressionar a combinação Alt-Insert (Ctrl-I no Mac), um menu abre com todas os possíveis geradores de código. A lista de geradores é sensível ao contexto. Isso depende da posição do cursor no código quando a chave de combinação é pressionada. Dependendo da sua posição no código, é possível gerar uma conexão de banco de dados, tabelas de banco de dados, texto lorum ipsum e vários outros. Esta seção descreve apenas os geradores de código a seguir:

Construtores

É possível gerar construtores ao pressionar Alt-Insert (Ctrl-I no Mac) quando o cursor estiver dentro de um corpo de classe, mas não dentro de nenhuma função contida neste corpo. Ao selecionar Gerar... Construtor, uma caixa de diálogo abre listando os campos que podem ser inicializados pelo construtor. Os nomes de campo são utilizados como parâmetros do construtor.

Caixa de diálogo dos campos pra inicializar com o construtor

Você pode selecionar nenhum campo. Nesse caso, o IDE gera um construtor vazio, sem parâmetros. Se o campo for uma classe com propriedades, é possível selecionar propriedades individuais ou é possível selecionar a classe, já que todas as propriedades de classe estão selecionadas automaticamente.

Para mais informações, consulte a publicação no blog NetBeans PHP.

Getters e setters

É possível gerar getters e setters ao pressionar Alt-Insert (Ctrl-I no Mac) quando o cursor estiver dentro de um corpo de classe e selecionar Getter, Setter ou Getters e setters. Apenas as funções possíveis são exibidas. Por exemplo, se já possuir setters disponíveis para as propriedades, apenas a opção getter aparece.

Ao selecionar Gerar... Getter/Setter/Getter e setter, uma caixa de diálogo aparece com as propriedades para que seja possível gerar um getter ou setter. As propriedades são exibidas em uma árvore. Se você selecionar uma classe principal, são selecionadas automaticamente todas as propriedades da classe.

É possível nomear um getter ou setter de acordo com a convenção getName ou a convenção get_name.

Para mais informações, consulte a publicação no blog NetBeans PHP original e a publicação geração de getter e setter aprimorada.

Métodos substituídos e implementados

É possível gerar métodos substituídos ou implementados ao pressionar Alt-Insert (Ctrl-I no Mac) quando o cursor estiver dentro de uma declaração de classe e existirem vários membros de classe. Uma caixa de diálogo abre mostrando os métodos que podem ser inseridos e indicando se eles estão substituídos ou implementados.

Caixa de diálogo para a geração de métodos substituídos

Esse recurso conclui a dica "Implemente todos os métodos abstratos" e autocompletar de código para métodos substituídos e implementados.

Para mais informações, consulte a publicação no blog NetBeans PHP.

Dicas de parâmetro

O editor solicita ao usuário os parâmetros formais de uma função ou um método no contexto onde a função ou o método é chamado.

  1. Digite os caracteres iniciais da função que deseja chamar.
  2. Pressione CTRL + espaço. Uma lista suspensa mostra as propostas sensíveis a contexto com os parâmetros formais de cada proposta.
    Lista de dicas sensíveis a contexto
  3. Escolha a proposta relevante e pressione Enter. O nome da função escolhida é inserido no código e um modelo para inserir os parâmetros é mostrado entre colchetes.
    Dicas de parâmetro para a proposta sensível a contexto escolhida.

Definindo o tipo de variável em comentários

É possível definir uma variável e o seu tipo em um comentário. O comentário deve estar no formato /* @var $variable type */ . Se o comentário estiver escrito corretamente, a marcação var estará em negrito.

Variáveis declaradas em comentários

É possível utilizar o modelo de código vdoc, seguido de Tabulação, para gerar um comentário que define uma variável. O nome da variável é selecionado e pode ser alterado. Pressione Tab novamente e o tipo é selecionado.

Variável declarando comentário gerado pelo modelo vdoc

O modelo de código define o nome e o tipo da variável automaticamente. Se a variável for utilizada após o lugar no qual você inseriu o modelo, o nome seguinte de tal variável será sugerido por padrão. Se nenhuma variável for utilizada após o lugar no qual você inseriu o modelo, mas houver uma variável utilizada acima do modelo, o nome de tal variável será sugerido por padrão. Se o NetBeans IDE não for capaz de localizar nenhuma variável perto de onde você utilizar o modelo, o nome padrão é variável.  O tipo de variável é definido automaticamente de acordo com as mesmas regras.

Variável declarando comentário gerado pelo modelo vdoc, com nomes e tipos de variável padrão

Mensagens de erro

O editor analisa a sintaxe do código enquanto você digita e marca os erros de sintaxe sublinhando as linhas com erro e colocando um marcador vermelho ao lado delas. Para obter uma explicação do erro, passe o cursor do mouse sobre a linha com erro ou clique no marcador vermelho. Uma dica de ferramenta aparece com uma breve explicação do erro.
Mensagem de erro: uma dica de ferramenta sobre a linha com erro.

Testes PHPUnit e Selenium

O NetBeans IDE para PHP suporta os testes automatizados PHPUnit, incluindo a cobertura de código. A partir do NetBeans IDE 7.1, você pode usar grupos de teste em seu código.

O NetBeans IDE também suporta a estrutura de teste portátil Selenium em combinação com o PHPUnit. Um plug-in Selenium está disponível no Centro de atualizações. A instalação deste plug-in adiciona um servidor Selenium nos servidores registrados do IDE e adiciona opções de teste Selenium aos menus PHP.

Consulte Testando com PHPUnit e Selenium para obter mais informações.

Corretor ortográfico

Um corretor ortográfico está disponível. Na caixa de diálogo Opções, você pode alternar entre ativar e desativar o corretor ortográfico para diferentes idiomas.

Caixa de diálogo Opções para o corretor ortográfico

Na caixa de diálogo Opções, você pode adicionar e remover novos dicionários e definir a localidade.  Quando desejar adicionar um novo dicionário, você terá que ter um arquivo com as palavras. O formato do arquivo do dicionário é uma lista de palavras com cada palavra em uma nova linha. Você terá que informar ao NetBeans a codificação do arquivo do dicionário e para qual localidade o arquivo deverá ser usado.

Adicionando um novo dicionário para o corretor ortográfico

Quando o corretor ortográfico encontra uma palavra que não está em seu dicionário, ele sublinha a palavra em vermelho. O corretor ortográfico também adiciona uma dica de ferramenta àquela palavra que diz "Erro de ortografia". Observe que o texto HTML é verificado em arquivos PHP.

Erros encontrados no texto HTML em um arquivo PHP

Suporte à estrutura Symfony e Zend

Suporte à estrutura Symfony e Zend são embutidos no editor PHP. Ele reconhece as estruturas Symfony existentes e é possível adicionar a estrutura a novos projetos no último painel do assistente para novo projeto PHP.

Em um projeto PHP com suporte ao Symfony ou Zend, é possível executar os comandos do Symfony ou do Zend a partir do menu de contexto do projeto.

Menu de contexto mostrando os comandos do Symfony

Use a IU dos comandos para:

  • Filtrar os comandos do Symfony/Zend (1)
  • Especificar os parâmetros do comando (2)
  • Selecionar um comando (3)
  • Ver a ajuda de contexto do comando (4)
  • Visualizar todo o comando que será executado (5)
Caixa de diálogo do comando do Symfony anotado

A lista de comandos é específica do projeto. Isso significa que, por exemplo, se for utilizado Doctrine em vez de Propel, nenhum comando do Propel será listado, apenas os comandos do Doctrine serão listados. Também, todos os comandos dos plug-ins Symfony do projeto estão disponíveis.

Autocompletar de código inclui variáveis Symfony nas visualizações Symfony e variáveis Zend nas visualizações Zend.

Variáveis do Symfony no auto-completar código

O IDE também oferece atalhos de navegação entre as visualizações e as ações do Symfony e do Zend. Esses atalhos foram aprimorados no NetBeans 6.9. Além disso, o autocompletar de código em visualizar modelos/arquivos inclui variáveis que são declarados nos arquivos controlador/ação. Consulte a publicação no blog do NetBeans PHP para detalhes.

Para saber mais sobre o suporte da estrutura Symfony, assista o screencast do Symfony.

Para saber mais sobre o suporte da estrutura Zend, assista o screencast do Symfony.

Suporte ao Smarty

O NetBeans IDE 7.1 inclui um plug-in para o suporte à estrutura Smarty. Esse suporte inclui os recursos básicos do Smarty 3, ou seja, preenchimento de código e delimitadores do Smarty 3.

Editor mostrando o suporte básico ao Smarty 3

Alterne entre o comportamento de Smarty 3 e Smarty 2 na janela Opções. Vá para Ferramentas > Opções (Preferências do NetBeans no MacOS), selecione PHP e, a seguir, abra a aba Smarty. O plug-in da estrutura Smarty deve estar instalado.

Opções do Smarty

Envie-nos seus comentários


Para enviar comentários e sugestões, obter suporte e manter-se informado sobre os desenvolvimentos mais recentes dos recursos de desenvolvimento em PHP no NetBeans IDE, junte-se à lista de usuários .

Voltar à trilha do aprendizado PHP

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo