NetBeans IDE for PHP Editor: Brief Overview

This document is a brief overview of the main features of the NetBeans IDE PHP Editor.

Contents

Content on this page applies to NetBeans IDE 7.1

To follow this tutorial, you need the following software and resources.

Software or Resource Version Required
NetBeans IDE PHP download bundle
A PHP engine Version 5
A web server Apache HTTP Server 2.2 is recommended.
A PHP debugger XDebug 2.0 or later

Getting Ready

To successfully develop and deploy PHP applications in the NetBeans IDE for PHP, you need to have all the required software installed and configured for PHP development.

The NetBeans IDE for PHP Editor Layout

The editor contains the following windows:

  • The Editor window shows the file you are editing. The Editor has a tab for every open file.
  • The Projects window shows a list of currently existing projects
  • The Files window shows the files for each project
  • The Services window shows lists of currently available external services such as databases.

You can also open a Navigator window in the left-hand panel by pressing Ctrl + 7. The Navigator shows the structure of a PHP class if the class is open in the Editor. Non-class PHP files are not shown in the Navigator window.

To open help for one of these windows, select any element in the window and press F1.

Syntax Highlighting

The editor provides syntax highlighting for PHP, HTML, JavaScript, and CSS code blocks.

The following syntax elements are highlighted in the current version:

  • PHP keywords
  • PHP variables
  • PHP constants
  • HTML tags
  • HTML input form attributes
  • The current line is displayed with a light-blue background.
  • By placing the caret inside a PHP variable, a function, or a class, all the occurrences of the variable are highlighted.
  • Lines where errors have been detected are underlined in red.
The NetBeans for PHP editor window shows a fragment of code with both PHP and HTML code elements highlighted.

To change the settings for highlighting, choose Tools > Options and switch to the Fonts&Colors tab. Specify the settings of your choice.

Go To Declaration

The Go To Declaration function navigates the user from an occurrence of a variable or function to the line where the variable or function is declared or initialized. To use this functionality, position the cursor on the relevant variable or function occurrence and choose Navigate > Go to Declaration from the context menu, or press Ctrl-B/⌘-B, or use Ctrl-click.

Navigator Window

The Navigator window displays code structures as elements of a list that shows the PHP structures of the currently active file. If the file contains any other text sources (for example, HTML) the list displays their structures too. By double-clicking a function or a variable in the list, the cursor points at the declaration of the clicked element.

Caution: The Navigator window only shows PHP code for PHP classes. It cannot show PHP code outside of a class.

The Navigator list does not normally contain any embedded lists, but for complex statements it may contain embedded structures. For example, a PHP class declaration statement can be presented as a tree of declared class members.

The list is dynamically updated while the user types the code.

The Navigator window is shown in the bottom of the left-hand panel.

  1. To open the Navigator window, press Ctrl + 7 or go to Window > Navigating > Navigator. The tree that displays the hierarchy of the HTML and PHP structures appears.
  2. To move to the desired element, double click the relevant node in the list.
    The figure shows an example of using the navigation tool. The figure also shows folded and unfolded classes and functions.

Code Folding

The editor enables the user to selectively hide and display modules, classes or functions of the currently edited file with PHP source code. To fold or display a piece of code, click the - or + icon to the left of the code, or press Ctrl+ or Ctrl-.

Smart Indent

The editor automatically formats the code while the user is typing.

Formatting

To format a piece of code to make it more understandable, perform the following steps:

  1. Select the relevant code passage.
  2. From the right-mouse context menu, choose Format or press Alt + Shift + F

Bracket Completion

The editor automatically adds and removes matching brackets and quotes while the user is typing the code.

  • Paired single ' ' and double quotes "" "", braces (), and brackets [] are added when the user has typed the first symbol.
  • At the end of a line, a semicolon is added in addition to the closing single or double quote.
  • The closing curly brace is added after the user presses Enter, which also activates the Smart Indent function.
  • Deleting the opening single or double quote, brace, or bracket causes automatic removal of the corresponding closing symbol but does not affect the line end semicolon.
  • When the cursor points at a closing brace ), a closing curly brace }, or a closing bracket ], the paired opening symbol is highlighted in yellow.
    When the cursor points at a closing brace or bracket, the paired opening element is highlighted.

Rename Refactoring and Instant Rename

You can rename an element such as a class name across all files in a project. The feature forces you to preview your changes before you can make them. The preview window shows you every location of the element and lets you exclude individual occurrences of the element from being renamed.

Rename Refactoring is contrasted with the older feature, Instant Rename. Instant Rename is still available, but it only works in "non-public" contexts, such as renaming a variable inside a method, or renaming private variables and fields. Instant Rename lets you only rename an element within a file and does not provide a preview window.

To use Instant Rename, place the cursor on a name you want to change and press Ctrl-R. If Instant Rename applies to that variable, all instances of that variable or function name are highlighted.

PHP code editor after Ctrl-R pressed

Change one instance of the name and all other instances in the file are changed simultaneously

PHP code editor showing a refactored variable name

To use Rename Refactoring, select the element you want to rename and either press Ctrl-R or right-click and select Refactor > Rename. A dialog opens for you to rename the element.

Dialog for renaming a variable

Rename the element and press Preview. The Refactoring window opens. In this window, you can find every instance of the element in your project and decide whether or not to rename it.

Refactoring window

For more information about Rename Refactoring, see the screencast Rename Refactoring and Other Editor Improvements in NetBeans IDE for PHP.

Code Completion

Code Completion is a common name for a set of features that speed up the process of coding.

The following types of code completion are distinguished:

Snippets

Snippets enable the user to generate code for various elements automatically.

  1. Choose Tools > Palette > Code Clips. A palette containing various user interface elements appears in the right-hand panel.
  2. Drag the required icon on the palette to the relevant position in the code. A dialog box for specifying the parameters of the corresponding elements appears. Fill in the data.
  3. The code that displays the chosen element is generated and inserted in the chosen location.

Context-Sensitive Proposals

The editor provides context-sensitive proposals for completing any number of starting symbols of:

  • A PHP keyword (for example, if, else, elseif, while, switch, function, and so on)
  • A PHP built-in function ( for example, substr, count, and so on)
  • A pre-defined or user-defined variable

The editor not only suggests expansions but also provides parameter hints. To apply Code Completion:

  1. Type the starting symbols of the required character string.
  2. Press Ctrl + Space. A dropdown list shows the context-sensitive proposals. Each proposal is supplied with a description and parameter hints. The contents of the list change as you continue typing.
  3. To obtain a list of the PHP key words that are available in the current context, press Ctrl + Space without any previous typing.
    A list of context-sensitive proposals. Each proposal is supplied with a description and parameter hints.
  4. To obtain a hint on a variable, just type the dollar symbol "$". A list of all the currently available local and global variables appears.
    A list of variables opens after the user types $. The list contains PHP global variables and variables defined by the user.

Code Templates and Abbreviations

In the current context, the term ""abbreviations" refers to a set of predefined character strings that correspond to the key words used in a programming language. Each abbreviation is associated with an expanded text which contains the full key word and a code template for the key word with parameter hints. To apply this functionality, type an abbreviation and press Tab.

The abbreviation "cls" for the key word "class" is typed

The abbreviation is replaced with the corresponding key word and the code template for the key word is provided.

The full text for the abbreviation is displayed with a code template for class definition

To view the list of defined abbreviation with code templates:

  1. Choose Tools > Options > Editor > Code Templates.
  2. From the Language drop down list, select PHP. The list of PHP abbreviations and code template defined for them is displayed.
  3. To add or remove a definition from the list, use the New or Remove buttons respectively.
  4. To edit a definition, select the relevant row and edit the text in the edit field below the list.
    The list of sbbreviations and code templates defined for them

For more information, please see Code Templates in NetBeans IDE for PHP.

Code Completion for Constructors

After the new keyword, the code completion window is displayed with constructors and parameters for all available classes in the project.

Code completion hints for a constructor

SQL Code Completion

SQL code completion displays when a string begins with the SQL keyword "select." The first step is to select the database connection.

Code completion offering database connection

All database connections registered with the IDE are displayed.

All database connections registered with the IDE

After you select the connection, SQL code completion offers all tables from that database connection.

All tables in the wishlist db connection

If the table has columns, those are displayed as well.

Columns shown for table

SQL code completion also works with table aliases.

SQL code completion showing tables in hotel alias

PHP 5.3 Namespaces

Code completion supports fully qualified, partially qualified, and unqualified namespace names from PHP 5.3. For more information, please see our screencast.

Overridden and Implemented Methods

Code completion between class members offers to override or implement methods.

Code completion offering to override method

Clever Try/Catch Code Completion

Starting in NetBeans IDE 7.1, code completion for catch statements includes only classes that inherit from Exception.

Editor showing clever code completion in catch parameters

Rectangular Selection

NetBeans IDE 7.1 for PHP introduces the Rectangular Selection action. This editing function is useful in cases such as deleting line numbers in pasted code.

To enable rectangular selection, press the Rectangular Selection toggle button or Ctrl-Shift-R.

Editor showing Rectangular Selection toggle button

When Rectangular Selection is enabled, you can make the selection with mouse or keyboard. When you use the keyboard, place the caret on a corner, keep SHIFT pressed down, and select what you need with the arrows keys. 

Editor showing a rectangular selection of pasted line numbers

f you write text while an area is selected, the text is placed on every line in the selected area. This can be useful, for example, for simultaneously changing the access modifiers of multiple fields in a class. 

Editor with an access modifier added to all lines in a rectangular selection

PHPDocumentor Support

Built-in support for PHPDocumentor was added in NetBeans IDE 7.0. For more information, see the screencast Generating PHP Documentation With NetBeans IDE.

Warning: PHPDocumentor does not fully support PHP 5.3. Namespaces and some other 5.3 features are not documented by PHP Documentor.

Code Generators

When you press the combination Alt-Insert (Ctrl-I on Mac), a menu opens with all possible code generators. The list of generators is context sensitive. It depends on the position of the caret in the code when the key combination is pressed. Depending on your position in the code, you can generate a database connection, database tables, lorum ipsum text, and several others. This section describes only the following code generators:

Constructors

You can generate constructors by pressing Alt-Insert (Ctrl-I on Mac) when the caret is inside a class body, but not inside any functions contained in that body. When you select Generate... Constructor, a dialog opens llisting the fields you can initialize by the constructor. The field names are used as parameters of the constructor.

Dialog of fields to initialize with constructor

You can decide not to select any fields. In this case, the IDE generates an empty constructor, with no parameters. If the field is a class with properties, you can either select individual properties, or you can select the class, in which case all the class' properties are selected automatically.

For more information, see the NetBeans PHP blog post.

Getters and Setters

You can generate getters and setters by pressing Alt-Insert (Ctrl-I on Mac) when the caret is inside a class body and selecting Getter, Setter, or Getters and Setters. Only the possible functions are displayed. For example, if you already have setters for the available properties, only the getter option appears.

When you select Generate... Getter/Setter/Getter and Setter, a dialog appears with the properties for which you can generate a getter or setter. The properties are displayed in a tree. If you select a parent class, you automatically select all that class' properties.

You can name a getter or setter according to either the convention getName or the convention get_name.

For more information, see the original NetBeans PHP blog post and the post on improved getter and setter generation.

Overridden and Implemented Methods

You can generate overridden or implemented methods by pressing Alt-Insert (Ctrl-I on Mac) when the caret is inside a class declaration and there are multiple class members. A dialog opens showing the methods you can insert and indicating whether they are overridden or implemented.

Dialog for generating overridden methods

This feature complements the "Implement all abstract methods" hint and code completion for overridden and implemented methods.

For more information, see the NetBeans PHP blog post.

Parameter Hints

The editor prompts the user regarding the formal parameters of a function or a method in the context where the function or method is called.

  1. Type the starting characters of the function you want to call.
  2. Press Ctrl + Space. A dropdown list shows the context-sensitive proposals with the formal parameters for each proposal.
    List of context-sensitive hints
  3. Choose the relevant proposal and press Enter. The name of the chosen function is inserted in the code and a template for entering the parameters is shown in brackets.
    Parameter hints for the chosen context-sensitive proposal.

Defining Variable Type in Comments

You can define a variable and its type in a comment. The comment has to be in the format /* @var $variable type */ . If the comment is written correctly, the var tag is in bold font.

Variables declared in comments

You can use the code template vdoc, followed by Tab, to generate a comment that defines a variable. The variable name is selected, and you can change it. Then press Tab again, and the type is selected.

Variable declaring comment generated by vdoc template

The code template automatically sets the variable name and type. If a variable is used after the place where you insert the template, then that following variable name is suggested by default. If there is not any variable used after the place where you insert the template, but there is a variable used above the template, then that preceeding variable name is suggested as default. If NetBeans IDE is not able locate any variable near where you use the template, then the default name is variable.  The variable type is set automatically according to the same rules.

Variable declaring comment generated by vdoc template, with default variable names and types

Error Messages

The editor analyzes the syntax of the code while you type, and marks syntax errors by underlining the erroneous lines and setting a red bullet next to them. To get an explanation of the error, mouse over the erroneous line or click the red bullet. A tooltip appears with a short explanation of the error.
Error-messaging: a tooltip above the erroneous line.

PHPUnit and Selenium Tests

NetBeans IDE for PHP supports PHPUnit automated tests, including code coverage. Starting in NetBeans IDE 7.1, you can use test groups in your code.

NetBeans IDE also supports the Selenium portable test framework, in combination with PHPUnit. A Selenium plug-in is available from the Update Center. Installing this plugin adds a Selenium server to the IDE's registered servers and adds Selenium test options to the PHP menus.

See Testing with PHPUnit and Selenium for more information.

Spellchecker

A spellchecker is available. In the Options dialog, you can switch spellchecking on or off for different languages.

Options dialog for spellchecker

In the Options dialog, you can add and remove new dictionaries and set the locale.  When you want to add a new dictionary, you have to have a file with the words. The format of the dictionary file is a list of words with every word on a new line. You have to tell NetBeans the encoding of the dictionary file and for which locale the file should be used.

Adding a new dictionary to the spellchecker

When the spellchecker finds a word that is not in its dictionary, it underlines that word in red. The spellchecker also adds a tooltip to that word that says "Misspelled word." Note that HTML text is checked in PHP files.

Errors found in HTML text in PHP file

Symfony and Zend Framework Support

Symfony framework support and Zend framework support are built-in to the PHP editor. It recognizes existing Symfony and Zend frameworks, and you can add the framework to new projects in the last panel of the new PHP project wizard.

In a PHP project with Symfony or Zend support, you can run Symfony or Zend commands from the project's context menu.

Context menu showing Symfony commands

Use the UI for the commands to:

  • Filter the Symfony/Zend commands (1)
  • Specify command parameters (2)
  • Select a command (3)
  • See the command's context help (4)
  • Preview the entire command that will be run (5)
Annotated Symfony command dialog

The list of commands is project specific. This means that if one uses e.g. Doctrine instead of Propel, no Propel commands are listed, just the Doctrine ones. Also, all the commands from the project's Symfony plugins are available.

Code completion includes Symfony variables in Symfony views and Zend variables in Zend views.

Symfony variables in code completion

The IDE also provides navigation shortcuts between Symfony or Zend views and actions. These shortcuts were improved in NetBeans 6.9. In addition, code completion in view templates/files now includes variables that are declared in controller/action files. See the NetBeans PHP blog post for details.

For more about our Symfony framework support, please see the Symfony screencast.

For more about our Zend framework support, please see the Zend screencast.

Smarty Support

NetBeans IDE 7.1 includes a plugin for Smarty framework support. This support includes basic Smarty 3 features, namely Smarty 3 code completion and delimiters.

Editor showing basic Smarty 3 support

Toggle between Smarty 3 and Smarty 2 behavior in the Options window. Go to Tools > Options (NetBeans Preferences on MacOS), select PHP, and open the Smarty tab. The Smarty framework plugin must be installed.

Smarty options

Send Feedback on This Tutorial


To send comments and suggestions, get support, and keep informed on the latest developments on the NetBeans IDE PHP development features, join the mailing list.

Back to the PHP Learning Trail

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo