Руководство по началу работы с Java в среде IDE NetBeans

Добро пожаловать в среду IDE NetBeans!

В этом документе вы познакомитесь с процессом работы в среде IDE NetBeans на примере создания простого консольного приложения "Hello World" на Java. Ознакомление с этим руководством даст общее представление о создании, сборке и выполнении приложений в среде IDE.

Изучение материала, представленного в этом руководстве, занимает приблизительно 10 минут.

После изучения этого руководства можно перейти к другим учебным картам, ссылки на которые приведены на странице Документация, обучение и поддержка. Учебные карты содержат подробные руководства, в которых рассматривается более широкий спектр функций среды IDE и методов программирования разнообразных приложений. Если процедура создания простейшего приложения "Hello World" вам уже знакома, можно пропустить этот документ и перейти сразу к учебным картам.

Содержание

Сведения на этой странице относятся к среде IDE NetBeans 6.9 и более поздним версиям

Для работы с этим учебным курсом требуются программное обеспечение и ресурсы, перечисленные ниже.

Программное обеспечение или ресурс Требуемая версия
Среда IDE NetBeans версия 6.9 и более поздние версии
Комплект для разработчика на языке Java (JDK) версия 6 или 7

Настройка проекта

Для создания проекта IDE выполните следующие действия:

  1. Запустите среду IDE NetBeans.
  2. В среде IDE выберите "Файл" > "Новый проект" (CTRL+SHIFT+N), как показано на рисунке ниже.

    Выбор команды "Файл" > "Новый проект" в меню среды IDE NetBeans

  3. В мастере создания проекта разверните категорию "Java" и выберите "Приложение Java". Нажмите кнопку "Далее".

    Среда IDE NetBeans, мастер "Новый проект", страница "Выбор проекта".

  4. На странице мастера "Имя и местоположение" выполните следующие действия (см. рисунок ниже):
    • введите HelloWorldApp в поле "Имя проекта";
    • не устанавливайте флажок "Использовать отдельную папку для хранения библиотек";
    • в поле "Создать главный класс" введите helloworldapp.HelloWorldApp;
    • оставьте флажок "Установить как главный проект" установленным.

    Среда IDE NetBeans, мастер создания проекта, страница "Имя и местоположение"

  5. Нажмите кнопку "Готово".

Проект будет создан и открыт в среде IDE. На экране должны быть представлены следующие элементы:

  • окно "Проекты", которое содержит дерево элементов проекта, в том числе исходные файлы, библиотеки, от которых зависит код, и т.д.;
  • окно редактора исходного кода с открытым файлом HelloWorldApp;
  • окно "Переходы", которое можно использовать для быстрого перемещения между элементами внутри выбранного класса.
  • окно "Задачи", в котором перечислены ошибки компиляции, а также другие задачи, отмеченные ключевыми словами, например XXX и TODO.

Среда IDE NetBeans с открытым проектом "HelloWorldApp"

Добавление кода к автоматически созданному исходному файлу

Поскольку в мастере создания проекта не был снят флажок "Создать главный класс", средой IDE был создан новый главный класс. К коду этого класса можно добавить, например, сообщение "Hello World!" путем замены строки

            // TODO code application logic here
        
строкой
            System.out.println("Hello World!");
        

Сохраните изменения путем выбора команды "Файл" > "Сохранить".

Файл должен быть похож на следующий пример:

/*
 * Для изменения этого шаблона выберите в меню "Сервис" | "Шаблоны"
 * и откройте шаблон в редакторе.
 */

package helloworldapp;

/**
 *
 * @author <имя>
 */
public class HelloWorldApp {

    /**
     * @param args аргументы командной строки
     */
    public static void main(String[] args) {
            System.out.println("Hello World!");
    }

}

        

Компиляция и выполнение проекта

Благодаря функции среды IDE "Компиляция при сохранении" компилировать проект вручную для выполнения в среде IDE не требуется. При сохранении исходного файла Java в среде IDE выполняется автоматическая компиляция.

Функция компиляции при сохранении отключается в окне "Свойства проекта". Щелкните проект правой кнопкой мыши, выберите "Свойства". В окне "Свойства" перейдите на вкладку "Компиляция". Флажок "Компиляция при сохранении" расположен вверху справа. Обратите внимание, что в окне "Свойства проекта" можно выполнять настройку многочисленных параметров проекта: библиотеки проекта, пакетирование, сборка, выполнение и т. д.

Для запуска программы выполните следующие действия.

  • Выберите команду "Выполнить" > "Выполнить главный проект" (F6).

На экране должны появиться сообщения, подобные приведенным ниже.

Вывод текста "Hello World!" программой в окне "Вывод" (вместе с остальными сообщениями сценария сборки)

Поздравляем! Программа работает!

Если при компиляции возникли ошибки, они отмечаются специальными красными символами в левом и правом полях редактора исходного кода. Символы в левом поле указывают на ошибки в соответствующих строках. Символы в правом поле указывают на все области файла, в которых есть ошибки, в том числе не отображаемые визуально ошибки в строках. Для получения описания ошибки можно навести курсор на метку ошибки. Для перехода к строке с ошибкой щелкните специальный символ в правом поле.

Сборка и развертывание приложения

После сборки и тестирования приложения для подготовки его к развертыванию можно использовать команду "Очистить и собрать". При использовании команды "Очистить и собрать" в среде IDE автоматически запускается сценарий сборки, выполняющий следующие задачи:

  • удаление предварительно скомпилированных файлов и других результатов сборки;
  • повторная компиляция приложения и формирование файла JAR, содержащего скомпилированные файлы.

Для сборки приложения выполните следующие действия

  • Выберите "Выполнение > Очистить и создать главный проект" (SHIFT+F11)

Для просмотра выходных файлов сборки можно открыть окно "Файлы" и развернуть узел HelloWorldApp. Скомпилированный файл байтового кода HelloWorldApp.class находится в подузле build/classes/helloworldapp. Развертываемый архив JAR, содержащий HelloWorldApp.class, находится в узле dist.

В окне "Файлы" показаны узлы для проекта "HelloWorldApp", развернутые для просмотра содержимого подузлов build  и dist.

Для получения дополнительных сведений о методах запуска приложения из командной строки вашей операционной системы ознакомьтесь с уроком "Приложение Hello World" учебных курсов по Java.

 

 

Что дальше?

Итак, теперь вы можете выполнять базовые задачи по программированию в среде IDE.

Дополнительные сведения о разработке приложений Java в среде IDE, включая управление путем к классам, доступны в документе Разработка базовых приложений Java.

Дополнительная информация о развертывании настольных приложений Java доступны в документеПакетирование и распространение настольных приложений Java.

Сведения относительно конкретного вида приложений приведены в учебной карте по среде IDE NetBeans, посвященной этому виду приложений. Каждая учебная карта содержит ряд руководств и указаний различных уровней сложности. Доступны приведенные ниже учебные карты.

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo