Notas de Versão da versão 6.9.1 do NetBeans IDE

O NetBeans IDE é um ambiente de desenvolvimento integrado, modular e baseado em padrões, escrito na linguagem de programação Java. O projeto do NetBeans consiste em um IDE de código-fonte aberto com recursos completos escrito na linguagem de programação Java e em uma plataforma rich client do aplicativo , que pode ser utilizada como uma estrutura genérica para construir qualquer tipo de aplicativo. Para obter mais informações sobre como instalar o software no seu sistema, consulte as Instruções de instalação do NetBeans IDE 6.9.1 . Para saber mais sobre os novos recursos incluídos nessa versão do IDE, consulte a página Informações da versão 6.9.1 do NetBeans IDE.

Conteúdo

O que há de novo na 6.9.1

O NetBeans IDE 6.9.1 é uma pequena atualização do NetBeans IDE 6.9 e inclui as seguintes alterações:

  • Disponibilidade do IDE mais recente incorporado ao JavaFX SDK 1.3.1
  • Aprimoramentos para o depurador JavaFX
  • Problemas de usabilidade importantes consertados no JavaFX Composer and Editor
  • Correções de erros críticos feitos para outros módulos desde a versão final 6.9

As atualizações a seguir da versão incluída na versão 6.8 também é válida na versão 6.9 para 6.9.1:

  • JavaFX Composer para simplificar e visualizar o desenvolvimento JavaFX
  • Suporte a frameworks Equinox e Felix OSGi na plataforma NetBeans
  • Suporte à biblioteca Spring Framework 3.0
  • Java CardTM 3 conectado
  • Suporte ao Rails 3.0 Beta
  • Suporte ao PHP Zend Framework
  • Suporte ao JSR-299, Contexts and Dependency Injection (CDI)
  • As melhorias adicionais estão listadas na página O novo e notável NetBeans IDE 6.9.

Nota: o Java TM SE Development Kit (JDK) 5.0 não é suportado em qualquer plataforma desta versão. É preciso ter o JDK 6.0 em seu sistema para instalar e executar o NetBeans IDE 6.9.1.


Para saber mais sobre esta versão, consulte a página Informações sobre o NetBeans IDE, versão 6.9.1.

Tecnologias compatíveis

O IDE NetBeans 6.9.1. é compatível com as seguintes tecnologias e foi testado com os seguintes servidores de aplicações. Se pretende utilizar outras versões diferentes das que se encontram na lista, observe que o é possível que o IDE se comporte de forma imprevista. Consulte a página Plataformas suportadas do NetBeans IDE 6.9.1 para obter mais detalhes sobre as plataformas testadas e sobre os executáveis desta versão.

Tecnologias compatíveis:
  • Java EE 5, Java EE 6 e J2EE 1.4
  • JavaFX SDK 1.3.1
  • Java ME SDK 3.0
  • Java Card 3.0.2
  • Struts 1.3.8
  • Spring 3.0, 2.5
  • Hibernate 3.2.5
  • Java API para serviços Web RESTful (JAX-RS) 1.1
  • Rastreamento de problemas
    • Bugzilla 3.4 e anterior
    • Jira 3.4 e anterior
  • PHP 5.3, 5.2, 5.1
  • Ruby 1.9, 1.8
  • JRuby 1.5.0
  • Rails 2.3.4, 3.0 Beta
  • Groovy 1.6.4
  • Grails 1.1
  • VCS
    • CVS: 1.11.x, 1.12.x
    • Subversion: 1.5.x, 1.6.x
    • Mercurial: 1.0.x ou posterior
    • ClearCase V7.0
   

Servidores de aplicações testados:
  • GlassFish Server Open Source Edition 3.0.1.
  • GlassFish Enterprise Server v2.1.1
  • Sun Java System Application Server PE 8.2
  • WebLogic 11g (10.3.3.0)
  • Tomcat 6.0.26
  • Tomcat 5.5
  • JBoss 5.0
  • JBoss 4.2.3 (J2EE 1.4)

Requisitos do sistema

O NetBeans IDE é executado em sistemas operacionais que aceitam a Java VM e que foram testados nas plataformas relacionadas abaixo.

Nota: a resolução mínima de tela do IDE é 1024 X 768 pixels.


Sistemas operacionais compatíveis

Configurações mínimas de hardware

  • Microsoft Windows XP Professional SP3/Vista SP1/Windows 7 Professional:
    • Processador: 800 MHz Intel Pentium III ou equivalente
    • Memória: 512 MB
    • Espaço em disco: 750 MB de espaço livre em disco
  • Ubuntu 9.10:
    • Processador: 800 MHz Intel Pentium III ou equivalente
    • Memória: 512 MB
    • Espaço em disco: 650 MB de espaço livre em disco
  • Solaris OS versão 10 (SPARC):
    • Processador: UltraSPARC II 450 MHz
    • Memória: 512 MB
    • Espaço em disco: 650 MB de espaço livre em disco
  • Solaris OS versão 10 (edição plataforma x86/x64):
    • Processador: AMD Opteron 1200 Series 1,8 GHz
    • Memória: 512 MB
    • Espaço em disco: 650 MB de espaço livre em disco
  • Macintosh OS X 10.5 Intel:
    • Processador: Intel Dual Core (32 ou 64 bits)
    • Memória: 512 MB
    • Espaço em disco: 650 MB de espaço livre em disco

Configurações de hardware recomendadas

  • Microsoft Windows XP Professional SP3/Vista SP1/Windows 7 Professional:
    • Processador: 2,6 GHz Intel Premium IV ou equivalente
    • Memória: 2 GB
    • Espaço em disco: 1 GB de espaço livre em disco
  • Ubuntu 9.10:
    • Processador: 2,6 GHz Intel Premium IV ou equivalente
    • Memória: 2 GB
    • Espaço em disco: 850 MB de espaço livre em disco
  • Solaris OS versão 10 (SPARC):
    • Processador: UltraSPARC IIIi 1 GHz
    • Memória: 2 GB
    • Espaço em disco: 850 MB de espaço livre em disco
  • Solaris OS versão 10 (edição plataforma x86/x64):
    • Processador: AMD Opteron 1200 Series 2,8 GHz
    • Memória: 2 GB
    • Espaço em disco: 850 MB de espaço livre em disco
  • OpenSolaris 2010.03 (edição plataforma x86/x64):
    • Processador: AMD Opteron 1200 Series 2,8 GHz
    • Memória: 2 GB
    • Espaço em disco: 650 MB de espaço livre em disco
  • Macintosh OS X 10.6 Intel:
    • Processador: Intel Dual Core (32 ou 64 bits)
    • Memória: 2 GB
    • Espaço em disco: 850 MB de espaço livre em disco


O NetBeans IDE também é executado em diversas outras distribuições do Linux, como o Oracle Enterprise Linux 5, Ubuntu 8.x e 10.04, Red Hat Enterprise Linux e muitas outras.

Nota: o suporte ao NetBeans e Java EE é particularmente exigente com os recursos do sistema, especialmente quando utilizados em combinação com outros servidores de aplicativos. Os requisitos de sistema acima se aplicam à maioria das configurações do IDE e, portanto, para obter os melhores resultados assegure-se de que seu sistema atenda, ao menos, os requisitos de sistema recomendados ao desenvolver aplicativos Web e Java EE.

Software necessário

O NetBeans IDE é executado no Java SE Development Kit (JDK), que compreende o JRE, além das ferramentas do desenvolvedor para os aplicativos de compilação, depuração e execução escritos em linguagem Java.

Os JDKs testados para esta versão são:

  • O JDK 6 Atualização 13 ou posterior é necessário. A versão 6.9.1 do IDE não pode ser instalada ou executada utilizando o JDK 5.0.

Nota: os conjuntos PHP, Ruby e C/C++ NetBeans somente requerem que o Java Runtime Environment ou 6 esteja instalado e executado.


É possível baixar JDK para sua plataforma em um dos sites relacionados abaixo:

início

Suporte ao JavaFX

O JavaFX 1.3.1 SDK está incorporado com o NetBeans IDE Versão 6.9.1. Observe o seguinte:

  • A versão mínima do JDK suportada para o JavaFX 1.3.1 é o JDK 6 Atualização 20 para o Windows e o JDK 5 Atualização 16 para o Mac OS.
  • Observe que o JDK 6.0 é necessário para instalar e executar o NetBeans IDE 6.9.1 no Mac OS, no entanto, o JDK 5.0 pode ser utilizado para o desenvolvimento utilizando o JavaFX 1.3.1 SDK.
  • Consulte a página Documentação da versão do JavaFX para mais informações sobre os requisitos do sistema e recursos suportados no Java FX SDK.

início

Editor SQL e bancos de dados

Foram feitas as seguintes alterações na funcionalidade de banco de dados do NetBeans IDE 6.9.1:

  • Drivers atualizados. Os drivers MySQL, incluídos no NetBeans IDE, foram atualizados para a versão 5.1.6.
  • Drivers testados

    O NetBeans IDE 6.9.1 foi testado com os seguintes bancos de dados e drivers.

    Driver
    Versão
    URL de exemplo
    JavaDB Derby 10.4.1.3 jdbc:derby://localhost:1527/sample (Rede)
    Oracle Oracle Database 11g (11.1.0.7 ) jdbc:oracle:thin:@//localhost:1521:ora9i
    PostgreSQL 8.x jdbc:postgresql://jsmith.mycompany.com:5432/postgres
    MySQL MySQL Connector/J 5.1.6 jdbc:mysql://localhost:3306/sample
  • Outros drivers

    Os seguintes drivers e bancos de dados ainda não foram testados formalmente, mas deverão funcionar com base na experiência.

    Driver
    Versão
    URL de exemplo
    Microsoft Microsoft SQL Server 2005 JDBC Driver 1.2.2828.100 jdbc:sqlserver://localhost:1433;databaseName=viagem;selectMethod=cursor
    IBM Redistributable JDBC Type driver v8 fixpack 13 db2_4_ jdbc:db2://localhost:50002/sample
    jTDS jTDS 1.2.1 jdbc:jtds:sqlserver://test-mycompany.com:1433/travel
    DataDirect DataDirect Connect for JDBC - 3.6 DataDirect Connect for JDBC - 3.6.07 jdbc:datadirect:oracle://localhost;SID=ora9ijdbc:datadirect:sqlserver://localhost:1433;DatabaseName=travel;SelectMethod=cursorjdbc:datadirect:db2://localhost:50002;databaseName=sample
    Pointbase 5.2 ECF compilação 294

     

    jdbc:pointbase://localhost:29092/sample

     

  • Para obter informações adicionais de solução de problemas do banco de dados, consulte FAQ do Usuário Sobre Conectividade de Banco de Dados.

início

Informações de suporte a vários idiomas

O NetBeans IDE está disponível nos seguintes idiomas suportados: português do Brasil (BR), japonês (JP) e chinês simplificado(ZH).

Também há traduções feitas pela comunidade do IDE em vários outros idiomas que podem ser baixadas na seção Contribuição da comunidade no menu suspenso Idioma do IDE.

início

Compatibilidade com versões anteriores

Ao ser executado pela primeira vez depois da instalação, o IDE oferece a opção de importar algumas das configurações utilizadas na instalação anterior. O IDE é aberto utilizando as configurações padrão caso você opte por não importar as configurações da instalação existente. Observe que o IDE somente reconhece as instalações anteriores quando o diretório do usuário estiver na localização padrão. Ele não reconhece as instalações que utilizam --userdir para especificar um diretório padrão. Se desejar importar as configurações de uma localização padrão que o instalador não reconhece, adote o seguinte procedimento:

  1. Inicie o IDE, vá a Ferramentas > Opções no menu principal.
  2. Clique no botão Importar na parte inferior da caixa de diálogo Opções.
  3. Na caixa de diálogo Selecionar opções de importação, clique no botão Procurar e vá até o diretório de usuário que contém as configurações que deseja importar. Para obter mais informações sobre a localização do userdir do NetBeans IDE, consulte a FAQ O que é o userdir e onde posso encontrá-lo?

Nota:se você editar as Propriedades do Projeto no IDE NetBeans IDE 6.9.1, de um projeto criado no IDE NetBeans 4.1 ou anterior, não será mais possível trabalhar com esse projeto em versões anteriores do IDE NetBeans.

início

Módulos e recursos arquivados

Os módulos SOA, UML e Visual Web, assim como o suporte ao jMaki, JAX-RPC e a adição de bibliotecas JavaScript, não mais estão incluídos no instalador do IDE. Para obter mais detalhes sobre os recursos removidos e sobre as alternativas disponíveis, consulte a página Recurso arquivado do NetBeans IDE.

início

Problemas conhecidos: instalador

Os problemas não-resolvidos do instalador desta versão são os seguintes:

  • Problema nº 93568: no Solaris e no Linux, a instalação para quando a conexão de rede é interrompida.

    Descrição: nas plataformas Solaris e Linux, se a conexão de rede é interrompida, a instalação para quando o instalador está buscando um JDK compatível nos diretórios de rede.

    Solução: restabeleça a conexão de rede e prossiga com a instalação.

  • Problema nº 117172: uma janela em branco ao executar o instalador no Ubuntu.

    Descrição: o instalador é exibido como uma caixa de diálogo em branco/cinza ao ser executado no Ubuntu com Beryl/Compiz/Compiz Fusion instalado.

    Solução: execute o comando export AWT_TOOLKIT=MToolkit antes de executar o instalador.

  • Problema nº 123300. No Fedora Core 8, o instalador interrompe a exibição da interface e volta ao console.

    Descrição: no Fedora Core 8, a exibição da interface de instalação é interrompida e o sistema volta ao console.

    Solução: consulte https://netbeans.org/servlets/ReadMsg?list=nbusers&msgNo=98765.

  • O assistente de Instalação do NetBeans IDE 6.9.1 não se inicia corretamente (trava). Depois que o usuário interrompe o processo de instalação manualmente, o programa de instalação informa que outra instância de instalação está em execução.

    Descrição: no Windows, quando o Java6 é utilizado como padrão e grandes arquivos compactados são armazenados na área de trabalho, o assistente de instalação não inicia devidamente (trava). Depois que o usuário interrompe o processo de instalação manualmente, o programa de instalação informa que outra instância de instalação está em execução.

    Solução: antes da instalação, remova todos os grandes arquivos compactados da área de trabalho

  • Problema nº. 177872: no Mac OS X, o complemento e as ferramentas de atualização do GlassFish 3.01 podem não funcionar corretamente

    Descrição: no Mac OS X, o complemento com base no pkg e as ferramentas de atualização não funcionam apropriadamente em contas não da raiz se o GlassFish v3.01 foi instalado na raiz.

    Solução: utilize o comando chown -R para alterar a propriedade da instalação do GlassFish e defina-o para o usuário não da raiz que o necessita. Por exemplo: sudo chown -R <newuser>:admin /Applications/NetBeans/glassfish-3.0.1, onde newuser é o usuário não da raiz. Após este comando ter sido utilizado, o usuário pode executar diretamente as ferramentas bin/updatetool e bin/pkg.

  • Para obter informações adicionais de solução de problemas do instalador, consulte FAQ do Usuário da Instalação do NetBeans.

início

Problemas conhecidos: IDE do núcleo

Os problemas não-solucionados desta versão são os seguintes:

  • Dificuldades para iniciar o IDE (Solaris x86 e Dual-Core Opteron).

    Descrição: em certas configurações do Solaris x86 e do Dual Core Opteron, você poderá encontrar problemas para iniciar o IDE devido a um erro do JDK ao carregar as bibliotecas GTK look&feel.

    Solução: se você enfrentar esse comportamento, especifique a seguinte opção de linha de comando:-laf javax.swing.plaf.metal.MetalLookAndFeel

  • Os caracteres não são exibidos adequadamente em alguns locais asiáticos.

    Descrição: ao se executar o IDE em alguns locais asiáticos no Ubuntu e em algumas outras distribuições de Linux, o texto da tela do IDE pode se tornar ilegível. Em determinadas distribuições do Linux, os caracteres de múltiplos bytes podem ser exibidos em forma de retângulo devido a problemas de configuração de fonte do JDK.

    Solução: consulte as FAQ para obter ajuda na resolução desse problema: http://wiki.netbeans.org/FaqI18nLinuxAsianFonts

  • Problema nº 64840: comunicação de rede interrompida no Linux com IPv6 ativado.

    Descrição: comunicação de rede interrompida no Linux com IPv6 ativado, impedindo a conexão do IDE com servidores empacotados, atualização automática, etc.

    Solução: se isso acontecer, execute o IDE utilizando a chave -J-Djava.net.preferIPv4Stack=true'. Alternativamente, desative o IPv6 (em /etc/modules.conf ou /etc/modprobe.conf).

    Para obter mais informações, consulte:Problema nº 5087907.

  • Problema Nº. 167401: o IDE congela eventualmente em sistemas MacOS X que utilizam o JDK 1.6.0, atualização 13

    Descrição: o IDE pode congelar eventualmente ao navegar pela barra do menu principal devido ao erro nº. 6993269 do JDK da Apple.

    Solução: passe para outra versão do JDK ou modifique as opções de início padrão do arquivo netbeans.conf para -J-Dapple.laf.useScreenMenuBar=false.

  • Problema nº 110074: o editor congela periodicamente no Solaris.

    Descrição: ao executar o IDE no Solaris com JDK 6, 6u1 ou 6u2, os segmentos podem ficar bloqueados por um longo período de tempo e fazer com que o editor não responda.

    Solução: migre sua instalação de JDK 6 para a Atualização 3 ou mais recente.

  • Problema nº 88776: o aplicativo com perfil traçado pode falhar quando a criação de perfil é realizada no modo de conexão dinâmica.

    Descrição:ao executar no JDK 1.6, a criação de perfil em um aplicativo com modo de conexão dinâmica pode levar o aplicativo a falhar.

    Solução: inicie o aplicativo para o qual você deseja criar um perfil com o switch -Xshare:off.

    Consulte também: Problema nº 113847.

  • Problema Nº. 119617: O cursor desaparece no editor e não é possível utilizar o teclado.

    Descrição: às vezes, depois de utilizar uma dica na janela do editor, o ponto de inserção no editor desaparece e o teclado não funciona. Isso foi observado com maior frequência no Mac OS X 10.4, mas houveram alguns relatos em algumas versões do Ubuntu.

    Solução:utilize o mouse para abrir e fechar a caixa de diálogo (por exemplo, uma janela de propriedades). Isso faz com que o foco volte para o editor e o ponto de inserção e o teclado funcione normalmente.

  • Problema Nº. 130357: I18N - o Mac OS não gera o javadoc se o nome ou caminho do projeto contiver caracteres de múltiplos bytes

    Descrição: a tarefa javadoc é escrita em MacRoman, a codificação Mac padrão, ao criar o arquivo de parâmetro temporário. Essa parece ser uma situação do Mac OS, onde as partes BSD e Mach (chamadas do sistema e kernel) aceitam parâmetros em UTF-8, mas o Mac OS e o HFS somente aceitam o MacRoman.

    Solução: evite utilizar caracteres de múltiplos bytes no nome do projeto ou no caminho do projeto.

  • Problema Nº. 152916: dificuldade em iniciar o IDE no Mac OS X 10.5.5 de 64 bits com o JDK 1.6_07

    Descrição: em determinadas configurações do Mac OS X 10.5.5 de 64 bits com o JDK 1.6_07 definido como plataforma Java padrão do sistema, pode haver problemas em iniciar o IDE a partir do localizador e da linha de comando.

    Solução: atualize para uma versão mais recente do JDK 6.0.

  • Problema Nº. 158421: dificuldades em usar o IDE com o G1 Garbage Collector

    Descrição: se estiver utilizando o G1 Garbage Collector (no JDK 6, Atualização 14 ou mais recente e no JDK 7), é possível que exceções sejam lançadas ao utilizar o IDE.

    Solução: não utilize o G1 Garbage Collector (remova -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC do netbeans.conf ou da linha de comando).

  • Para obter informações adicionais de solução de problemas do Core IDE, consulte FAQ do Usuário do NetBeans.

início

Problemas conhecidos: Web e Java EE

Os problemas não-resolvidos da Web e Java EE para essa versão são os seguintes:

  • Problema Nº 183614: o recurso Passar dentro não funciona corretamente com o EJB.

    Descrição: ao depurar um servlet, a chamada Passar dentro de um EJB para no código não-relacionado.

    Solução: defina um ponto de interrupção no código de implementação do EJB e utilize Passar sobre.

  • Problema Nº. 178108: as classes de metamodelo das entidades JPA gerenciadas não são geradas automaticamente

    Descrição: as classes de metamodelo das entidades gerenciadas correspondentes não são geradas. A criação de consultas seguras de construção que utilizam a API Criteria e a classe metamodelo não funciona.

    Solução: consulte a descrição do problema Nº 178108 para obter opções de solução.

  • Para obter informações adicionais de solução de problemas do Web e Java EE, consulte FAQ do Usuário do NetBeans.

início

Problemas conhecidos: Java ME

O NetBeans permite que o desenvolvimento de aplicativos baseados em Java ME para dispositivos MIDP, CLDC e CDC.

Os problemas do Java ME não solucionados nesta versão são os seguintes:

  • Linux Solaris e outros sistemas operacionais não são suportados pelo Java ME SDK 3.0.

    Descrição: o NetBeans 6.9.1 Mobility e Java ME SDK 3.0, incluídos nessa versão, somente suportam os sistemas operacionais Windows e Macintosh.

    Solução: o instalador Linux vem incorporado com o Sun Java Wireless Toolkit 2.5.2.

  • O módulo Java ME não será executado se um nome de diretório, um caminho para o diretório de instalação ou um diretório de usuário contiver caracteres não-ASCII.

    Descrição: o Java ME SDK 3.0 não oferece suporte a caracteres não-ASCII em caminhos de projeto.

    Solução: certifique-se de que o diretório de usuário não contenha caracteres não-ASCII. Se contiver, mude o diretório de usuário padrão do IDE.

  • Problema nº. 139031: o emulador não se inicia no Windows se o binário Java não estiver no caminho do ambiente.

    Descrição: o Java ME SDK e outros emuladores não se iniciam no Windows se o Java.exe não estiver no caminho.

    Solução: instale o JDK utilizando as configurações padrão ou, se estiver realizando uma instalação personalizada, certifique-se de selecionar o JRE público para a instalação. Se o JDK já estiver instalado, é possível adicionar o arquivo Java.exe às configurações de caminho do sistema.

  • Para obter informações adicionais de solução de problemas do Java ME, consulte FAQ do Usuário Sobre Conectividade do Java ME/Mobilidade.

início

Problemas conhecidos: C/C++

O NetBeans C/C++ oferece suporte aos aplicativos C e C++ nos Sistemas Operacionais Microsoft Windows, Macintosh OS X, Linux e SolarisTM. Os desenvolvedores de C/C++ podem trazer os aplicativos existentes para o sistema de projeto NetBeans ou desenvolver novos aplicativos e bibliotecas. O suporte para C/C++ do NetBeans abrange o ciclo de desenvolvimento completo: projetos e modelos, um editor com reconhecimento de linguagem avançado, construções baseadas em makefile e depuração.

Para obter informações sobre a instalação e a configuração dos compiladores e das ferramentas para suporte do NetBeans C/C++, consulte Instalando e configurando o suporte para C/C++.

Os problemas C/C++ não-solucionados nessa versão são os seguintes:

  • Problema nº 148204: nas plataformas Windows, a entrada do usuário não funciona na janela Saída durante a depuração

    Descrição: nas plataformas Windows, quando estiver depurando um aplicativo e o tipo de console do projeto estiver definido como a janela Saída, não é possível digitar a entrada na janela Saída. Esse problema não afeta o desenvolvimento que utiliza uma máquina remota.

    Solução: defina o tipo de console como Terminal externo clicando com o botão direito do mouse no nó do projeto na janela Projetos, selecionando o nó Executar na caixa de diálogo Propriedades do projeto, selecionando Terminal externo na lista suspensa Tipo de console e clicando em OK.

  • Problema Nº. 121775: é necessário o Xcode mais recente para depurar o Tiger (Mac OS X 10.4)

    Descrição: ao depurar no Mac OS Tiger (Mac OS X 10.4), o código gerado pelas versões padrão do compilador gcc e g++, tem informações de linha incorreta e os pontos de interrupção podem ser ignorados.

    Solução: a Apple lançou um pacote Xcode atualizado (versão 2.5) como uma correção para esse problema. As versões corretas de gcc, g++ e gdb são:

    • gcc: 4.0.1: Apple versão 5367
    • g++: 4.0.1: Apple versão 5367
    • gdb: 6.3.50: Apple versão 573 (20/10/2006)

    A versão atualizada do Xcode está disponível em: http://developer.apple.com/tools/download.

  • Para obter informações adicionais de solução de problemas do C/C++, consulte FAQ C/C++ do NetBeans.

início

Mais informações

É possível encontrar notícias, artigos, módulos adicionais e outras informações úteis no site do projeto NetBeans. Já que o NetBeans é um projeto de código-fonte aberto, o site também oferece acesso a código-fonte, banco de dados de erros, informações sobre a criação de módulos do NetBeans e muito mais. Para obter mais informações, visite http://www.netbeans.org.

Documentação

Para aproveitar melhor os recursos no NetBeans IDE 6.9.1, consulte nossos tutoriais e apresentações na tela na Web. Consulte essas páginas frequentemente, pois acrescentamos novos conteúdos o tempo todo.

Os recursos de documentação de referência adicionais incluem:

  • A FAQ do usuário do NetBeans tem muitas soluções e dicas de soluções de problemas que não estão nas Notas de versão.
  • O sistema de Ajuda incorporado no IDE tem informações de suporte detalhadas para os recursos incluídos em todos os módulos do NetBeans IDE.
  • Consulte Utilizando o NetBeans IDE no Mac OS X para obter informações sobre equivalentes de teclado, dicas, truques e outros tópicos específicos do Mac.

Comunidade

Mantenha-se atualizado sobre os últimos desenvolvimentos e interaja com a comunidade NetBeans inscrevendo-se nas listas de distribuição do projeto NetBeans, no endereço https://netbeans.org/community/lists/.

É possível colocar perguntas em http://forums.netbeans.org/ Os fóruns estão sincronizados com a maioria das listas de distribuição do NetBeans mais utilizadas. Observe que é necessária uma inscrição separada para os fóruns.

Visite a página de informações da tradução da comunidade em http://translatedfiles.netbeans.org/ para saber como colaborar na tradução da UI, ajuda e da documentação de usuário do NetBeans para outros idiomas.



início

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo