Notas da versão do NetBeans Mobility Pack para CDC 5.5.1

Bem-vindo ao NetBeans Mobility Pack para CDC, um pacote suplementar que oferece ferramentas para criar aplicativos do Java Micro Edition (Java ME) que dão suporte às tecnologias Java ME, Connected Device Configuration (CDC).

Conteúdo

 

Observação: Se desejar obter informações sobre a instalação do NetBeans Mobility Pack para CDC 5.5.1, consulte Guia de instalação do NetBeans Mobility Pack para CDC 5.5.

início

Requisitos do sistema

Sistemas operacionais suportados

O NetBeans Mobility Pack para CDC 5.5.1 é executado no Java SE JDK, versões 5.0 e 6.0, composto pelo Java Runtime Environment e por ferramentas de desenvolvimento para compilar, depurar e executar aplicativos escritos na linguagem Java.

O NetBeans Mobility Pack para CDC é executado em sistemas do Microsoft Windows que oferecem suporte à máquina virtual Java. Veja uma lista das plataformas nas quais o NetBeans IDE já foi testado.

  • Microsoft Windows XP Professional SP2
  • Windows Vista
  • Ubuntu 6.x
Configuração mínima de hardware

O Mobility Pack para CDC não requer recursos significativos além dos necessários para o NetBeans IDE.

Observação: A resolução de tela mínima para o IDE é de 1.024x768 pixels.

  • Processador: Estação de trabalho Intel Pentium III de 500 MHz ou equivalente
  • Memória: 512 MB
  • Espaço em disco: 850 MB de espaço disponível em disco
Configurações de hardware recomendadas
  • Processador: Estação de trabalho Intel Pentium III de 1,4 GHz ou equivalente
  • Memória: 1 GB
  • Espaço em disco: 1 GB de espaço disponível em disco
Software necessário

O NetBeans IDE é executado no J2SE JDK (Java SE Development Kit), versões 5.0 e 6.0, composto pelo Java Runtime Environment e por ferramentas de desenvolvimento para compilar, depurar e executar aplicativos escritos na linguagem Java.

É possível fazer o download do JDK para sua plataforma em http://java.sun.com/javase/downloads/index.jsp.

Plataformas de emulador

O Sun Java Toolkit para CDC está integrado ao NetBeans Mobility Pack. No entanto, se desejar programar aplicativos para outras plataformas suportadas, é necessário fazer o download de um ou mais dos seguintes SDKs e instalá-los:

  • Ricoh
    • Embedded Software Architecture Emulator (registro necessário para o download)
  • Sony Ericsson
    • UIQ 3 SDK (logon necessário para o download)
    • M600 Extension Package para o UIQ 3 SDK Beta 3 (download)
    • P990 Extension Package para o UIQ 3 SDK Beta 3 (download)
  • Nokia
    • Nokia Series 80 Platform SDK para Symbian OS, para Java, perfil Pessoal (download)
  • Windows Mobile com NSIcom CrEme VM
    • CrEme 4.10 Developer Support (download)
    • Microsoft Device Emulator 1.0 (download)
    • Virtual Machine Network Driver para Microsoft Device Emulator (download)
    • ActiveSync (download)
  • SavaJe
    • A plataforma SavaJe Mobile (não mais disponível)

 

O CDC Pack 5.5.1 dá suporte à implantação em dispositivos do Windows Mobile (com o NSIcom VM) e do SavaJe.

Instruções de instalação para cada emulador estão disponíveis no Guia de instalação do NetBeans Mobility Pack para CDC 5.5.1.

início

Compatibilidade

Ao executar o IDE pela primeira vez com o NetBeans Mobility Pack, é possível importar um subconjunto das configurações usadas no NetBeans Mobility Pack para CDC 5.5. Se escolher não importar as configurações da versão anterior, o IDE irá se abrir usando as configurações padrão.

Observação: O IDE só reconhece instalações anteriores se o diretório de usuário estiver no local padrão. O IDE não reconhece instalações em que o diretório de usuário foi especificado em --userdir. Se quiser importar configurações de um IDE não reconhecido pelo instalador, faça o download de uma versão arquivada do IDE em vez de substituir o instalador.

Embora seja possível importar configurações do NetBeans Mobility Pack para CDC 5.0 para o NetBeans 5.5.1, não é possível importar as configurações do NetBeans Mobility Pack para CDC 5.0.1 para uma versão anterior do IDE.

início

Problemas conhecidos

Os problemas não solucionados desta versão são os seguintes:

  • Problema #77083: icon.small/icon.focused tem caminho absoluto após a implantação

    Descrição: O bundle.jnlp contém um caminho absoluto para icon.small e icon.focused. Isto se dá porque os ícones estão localizados no dispositivo. No campo de texto, você deve inserir o caminho do ícone como ele está definido no dispositivo. O local (caminho) correto deve estar listado na documentação do dispositivo.

  • Problema #86566: Erro ao salvar as configurações da paleta.

    Descrição: As configurações da paleta do GUI Designer não serão salvas, se você alterar a plataforma do emulador do projeto.

  • Problema #88709: A compilação falha ao alternar entre plataformas de emulador.

    Descrição: Se você alterar a plataforma de Nokia para Sony Ericsson, a compilação irá falhar.

    Solução: Altere o UID clicando com o botão direito do mouse no projeto e escolhendo Propriedades do projeto > Geral > Sony Ericsson.

  • Problema #77083: O link do caminho absoluto para ícones em um arquivo bundle.jnlp

    Descrição: icon.small e icon.focused têm caminho absoluto após a implantação.

    Solução: O caminho pode ser especificado para dispositivos de acordo com a documentação do dispositivo.

  • Problema #88913: Não é possível encontrar o erro nbproject/build-impl.xml

    Descrição: A versão internacionalizada do IDE irá receber uma mensagem de erro se você construir, executar e renomear um projeto.

  • Problema #90047: Problemas ao depurar projetos do CDC

    Descrição: java.lang.NoClassDefFoundError é lançado ao se tentar depurar um projeto do CDC

    Solução: A depuração não irá funcionar se você carregar um projeto do CDC Toolkit no Mobility Pack para CDC. É necessário atualizar o projeto para Mobility Pack para CDC indo a Propriedades do projeto, clicando em OK e seguindo as etapas fornecidas pelo IDE.

  • Problema #90647: Não é possível alterar o dispositivo da plataforma Sony Ericsson UIQ dentro do IDE

    Descrição: O dispositivo de destino da plataforma não pode ser alterado no IDE

    Solução: Execute o utilitário SDKConfig.exe, localizado em <install_dir>\UIQ3SDK\epoc32\tools\distrib\, onde <install_dir> é o diretório em que o emulador Sony Ericsson UIQ3 foi instalado no computador.

  • Problema #90654: Projetos construídos com o Mobility Pack para CDC 5.5.1, atualização 1, falham após a atualização para a versão FCS

    Descrição: O problema é causado pelo fato de o método de execução ser incorreto para a versão FCS do pacote CDC

    Solução: Altere as Propriedades do projeto para o método de execução Xlet ao atualizar projetos que usam AGUI criado com o Mobility Pack para CDC 5.5.1, atualização1.

início

Documentação

Além do sistema de ajuda incorporado, o NetBeans Mobility Pack para CDC é documentado em uma série de tutoriais e artigos. Para obter informações sobre Java ME, recursos de desenvolvimento do CDC suportados pelo Mobility Pack para CDC, consulte os seguintes documentos:

início

Mais informações

É possível encontrar notícias, artigos, módulos adicionais e outras informações úteis no site do projeto NetBeans na Web. Visto que o NetBeans e o NetBeans Mobility Pack são um projeto de código aberto, o site também oferece acesso ao código-fonte, a um banco de dados de erros, a informações sobre a criação de módulos do NetBeans e muito mais.

Para obter mais informações, visite http://mobility.netbeans.org/.

Se quiser se manter atualizado sobre o NetBeans IDE e em contato com a comunidade NetBeans, assine a lista de usuários do projeto NetBeans Mobility Pack em https://netbeans.org/community/lists/.

início

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2016, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo