The Issues fixed in the Merak Release (3.4.1)

A total of 107 issues have been resolved in the NetBeans 3.4.1. If you'd like, you may list them all using the IssueZilla query.

Some of them were RFEs (requests for enchancement), but most were bugs, either minor like documentation inconsistencies, or more annoying like inability to browse through compilation errors from Ant script, deadlocks in project switching or numerous uncancellable Nullpointer exceptions.

The issues have been grouped by modules

Module's Name# fixed issues
  
Ant5
ApiSupport1
AutoUpdate2
Beans1
Clazz1
Core16
Diff5
Editor9
Form1
Installer1
JarPackager1
Java5
JavaCvs6
JavaDoc2
NbBuild2
OpenIDE14
Properties1
Tomcatint1
UI7
UsersGuide2
VcsCore11
VcsGeneric9
Web1
Xml1
Mutliple Modules2
  
Total Amount of Fixed Issues107
     #23076: integration of Ant 1.5.1 into NetBeans 3.4.1
When NetBeans 3.4 release came to some final phase, Ant 1.5 was released, but testing uncovered some severe bugs, that forbit to include it into 3.4, some time after Ant 1.5.1 was released with all these bugs fixed, but NetBeans was arleady released. The Ant 1.5.1 integration module was published to NetBeans autoupdate server, thoroughly tested and 3.4.1 contains it by default.
#24474: next/previous error from ant compilation.
This problem happens everytime when the compiler of Ant script is set to "Ant Script Compilation". The problem is that Ant opens own Output tab with its own name and that after the compilation is finished, the Core opens the second output tab with name "Compiler" where the status of compilation (successful or not is shown). The second tab is activated and because all the errors were logged in the first tab, the F12 does not work.
#24506: Executor not notifying on completion.
The task which is returned from TargetExecutor is wrapper task. Unfortunatelly this wrapper task is never started, therefore it cannot report that the wrapped task has already finished.
#25701: Deserialization of AntProjectSupport with new project unreliable
AntProjectSupport deserializes itself by deser'ing a FileObject and a File. The File is fine, I suppose. However the FileObject checks the Repository for mounts. If the mount has not been set up by the time the APS is deserialized, apparently it can become invalid (fo==null, file==null) even though if deser'd later it would be fine.
#29246: Hyperlinking of Ant script errors does not work under 1.5.1
I think this is a regression. Under Ant 1.5.1, error messages referring to build scripts do not hyperlink, as they use URL syntax (e.g. file:) which the Ant module does not recognize. Here is an example: download maven source (jakarta.apache.org) and run top-level build-bootstrap.xml from 3.4.1 with no further configuration and you get:

src/bootstrap/org/apache/maven/BootstrapTask.java
[452] cannot resolve symbol
symbol  : class PatternSet 
location: class org.apache.maven.BootstrapTask
        PatternSet patternSet = new PatternSet();
                                    ^
22 errors
file:/space/src/maven/build-bootstrap.xml:345:
Compile failed; see the compiler error output for
details.
BUILD FAILED
The last error line is not hyperlinked.
    
     #25869: Mnemonics conflict Remove & After Selected item
Components with potential mnemonics conflict:
 - components with mnemonic 'R' :
   Class: javax.swing.JButton {  Remove |  N/A } 
   Class: javax.swing.JRadioButton {   After
Selected Item |  N/A }
    
     #25782: NPE after try to install module from local nbm file
I have vad module nbm file that doesn't contain
Info/info.xml file and do :
- run IDE
- invoke Update Center
- select "Install manually downloaded modules" and
push Next
- add my module (xx.nbm)
- push Next
-> NullPointerException arise (see attachment), I
know that it's impossible use nbm file without
info.xml file by autoupdate, but Exception should
be catched and annotated.
#27600: Module XML file for autoload modules not written correctly.
When an autoload module is installed via
AutoUpdate, the module's XML file will be written
like this:

... prolog ...
<module name="org.brianlsmith.smn.mdr">
...
    <param name="jar">oad/smnmdr.jar</param>
</module>

Notice that the "jar" parameter has an "oad/"
prefix. The problem is that the code is doing this:
   if (jarName.startsWith("autoload")) {
       autoload = true;
       jarName = jarName.substring("eager");  // <<--
    }

To me, this problem causes my autoload module to
be impossible to install, AFAICT. And, it seems
that this code has been in NetBeans since 3.4
release, from looking at the CVS tags.

Another problem is that if your module is an eager
module, then the XML document will look like:
    ...
    <param name="eager">false</param>
    <param name="jar">/smnmdr.jar</param>
    <param name="origin">user/eager</param>
    ...
where the "jar" parameter has an extra slash.

Another problem is that if your module's jarfile
is prefixed with "eager" or "autoload" without a
slash ("eagertoplease.jar", "autoloadtest.jar"),
they will be incorrectly configured: in the first
case, it will be treated as an eager module file
named "toplease.jar" and in the latter case it
will be treated as an autoload module file named
"test.jar". To fix this you need to include the
slash in the test (e.g. jarFile.startsWith("eager/"))
    
     #25957: generated event typenames use FQNs.
Create a New Unicast Event Source. Generate event firing methods and pass event as a parameter. Try it for java.awt.event.ActionListener. It will generate "private void fireActionListenerActionPerformed (ActionEvent event) {" but it is not compilable. Please generate FQN (java.awt.event.ActionEvent) instead of simple name.
    
     #26806: Problem of NPE Gracefully handled
#26726, #27557, #27759 are all marked as duplicate and then would be also resolved by the fix of this issue.
The openide.jar contains file "org/openide/awt/$Toolbar$Patch$.class". The IDE (better said: java module) does not behave correctly when accessing this class.
  1. When you mount openide.jar, automatic complation database update is performed. The first attached exception ("dollar_in_classname_exc_1_update.txt") is thrown on console.
  2. When expanding package with this file (org.openide.awt), the second attached exception is thrown ("dollar_in_classname_exc_2.txt", show in exception dialog).
  3. When an attempt to "open" the class, the third exception is thrown ("dollar_in_classname_exc_3.txt") many times. The MDI frame is not completely re-drawn, when clicking into the IDE, the exception is thrown again. The only thing that stops the exception from throwing is to close the explorer. In sum, probably the only way to completely resume IDE work is to kill the IDE and restart it.
    
#18405: MouseWheel does not work in Output Window
I'm using NB3.3Beta6 on JDK1.3.1. I installed Mouse Wheel Support module into NetBeans and now mousewheel works in all windows in NB apart from OutputWindow. So, I think it is some problem in OW.
#25517: Welcome module should hide "Welcome" node in Options window
no more welcome node in options window
...because it is useless with this module enabled. New welcome doesn't use this option. It is node of old welcome panel. It was discussed that old one will be alive and will be displayed in case some of module puts its entry there. However, when this node is empty and there is no option to put there entries it is is really useless. In each case I think it is work for core because of old welcome panel.
#25589: SplitContainer does not use UIManager to set border colors
I'm doing some work on themes support. When using a dark theme, I noticed that I could not get rid of the bright split borders around components.

The reason is that in code, the colors for this border are hard-coded.

#25622: NullPointerException from "Frame Resides" action
not reproducible
It is triggered when I have a custom CloneableTopComponent sitting in its own, newly created Mode, not residing in the IDE, running MDI. If I go to Windows menu, but don't click anywhere, and then click on the CTC, and back a few times, it will be triggered.
#25679: Maximize buttons in upper-right corner stay after Source Editor resides as a Separate window.
Steps to reproduce:
  • run IDE
  • select Welcome Screen in Editor
  • push from main menu Window | Frame Resides | As Separate Window
-> buttons maximize, minimalize and restore are present in upper-right corner
#25861: MenuItem.acceleratorFont unaffected by -fontsize switch
default acceleratorFont is Dialog Plain 10 whereas default font is Dialog Bold 12. If you consider the base font size in Swing to be 12 by default, and we set -fontsize to e.g. 11, what should acceleratorFont be set to? D.P.10 seems right with -fontsize 11. It seems wrong with -fontsize 18. Should it be some proportion? Rounded how? Etc. Themes (issue #25472) would provide a more coherent solution than -fontsize I think, since you could select particular font sizes for each usage.
#26072: org.openide.filesystems.FSException on startup after deleting jar
#24568, #26088, #26391, #26535, #26623, #27442, #27445, #27464, #28014, #29279, #29343 are all marked as duplicate and then would be also resolved by the fix of this issue.
I am seeing a FSException regarding a jar that was deleted outside of the ide on startup. The full log and exception info are attached. The issue can be resolved by going into the explorer customize dialog and removing the obsolete link. Should this just be done automatically, possibly after a warning dialog?
#26191: ZIPException's during module system startup can cause main thread to halt
The exception is caught and rethrown, but the rethrown exception is missing the module name. A catch clause a bit further down is expecting to know what the module was and when it doesn't find it, it chokes. Easy fix. Improves robustness if some module JARs are corrupted etc.

robustness against ZIPException during ModuleManager.enable.

#26236: core/settings module text strings not localized
This bug makes impossible to localize some of the text coming from core/settings module
#26500: unhelpful "[WinSys] null" messages
With 3.4 RC1, I'm seeing frequent "[WinSys] null" messages printed to the console and I don't know why. org.netbeans.core.windows.PersistenceManager & WorkspaceImpl both implement something like: ErrorManager.getDefault().log(ErrorManager.WARNIN G, "[WinSys] " + ioe.getMessage()); so apparently the exception's message is null. There's no more info in ide.log than this, but I can attach it if you want. --- Now in case there is a null message, it is not dumped. (Will find out later why there are provided such exceptions).
#26517: Missing hyperlinks in output window
the bug appears if (and only if) method name contains class name.
#27776: autoconvert javax.help package deps to core/javahelp module deps.
A bit late, but I think Rochelle was right here - older modules that declared a package dependency on javax.help (e.g. apisupport, apparently TP?) should have been automatically given a dep on org.netbeans.modules.javahelp/1 in 3.4, to let them continue to use the package. org.netbeans.core.modules.NbInstaller permits this kind of thing. Better late than never, right?
#28126: Install-Before not working after new module introduced.
if a new version of a module is released that newly declares that its object type should be above/below some other in the list, the pool should be resorted accordingly. Probably not a very important bug; at least it took this long for it to be reported, though it was probably always broken.

resort after added/removed ordering attrs.

#28307: NPE from DefaultDesktopManager.maximizeFrame
#28358: Endless IndexOutOfBoundsExceptions after unmounting a filesystem that had files open in the editor
  1. Open several files from a filesystem in the editor
  2. Mount another filesystem
  3. Open several files from filesystem #2 in the editor
  4. Unmount the filesystem
EXPECT:
The open windows from filesystem #2 close w/o error

ACTUAL:
I saw an endless loop of IndexOutOfBounds exceptions that forced me to kill NB

#28495: Trouble loading classes from a sealed JAR
Sealed JARs apparently caused problems for modules in pre-4.0 versions; a third-party module developer reported exceptions thrown. Looking at the code, it is clearly wrong (a typo). Does not affect any netbeans.org modules that I know of, but could be a blocker for other module authors.

AIIOBE for sealed module JARs.

     
     #24523: Apply patch doesn't support the unified diff format
apply patch action doesn't support the unified diff format which is produced by the cvs diff -u <name> for example.

Well, it's a missing functionality rather than a bug in existent functionality. But I agree, that from the users point of view this may be considered more like a bug.

#26146: The graphical diff does not handle not reported line differences
When the diff algorithm does not report empty lines as differences, the graphical diff is corrupted. The graphical diff should use a heuristic to detect, that a missing or added empty line was not reported as a difference.
Keep balance of corresponding lines even when there were unreported missing or added lines.
#26427: Apply Patch acttion does'n refresh opened documents
  1. open XML, Java, ... document in the Source Editor
  2. apply some patch on the document
The document's file is changed on the disc but old version remains in the Source Editor. When you edit the document and save it, patch's changes are lost.
Properly close the streams after FileUtil.copy()! Also refresh the FileObject after successfull application of the patch.
#26757: Apply patch doesn't work as expected
It seems, that the only problem is the "*/", that is for some reason added at the end of the merged patch. I'll explore that.
The bug is in the parsing algorithm of the context diff. The same patch in standard UNIX diff format was applied correctly.
#29390: NPE while applying Unified diff
The NPE was caused by the empty line at the end of the patch file.
This NPE was caused by the editing of the diff in an editor (this is apparent from the ^M at the end of the diff). This introduced the last empty line, which does not occur if you redirect cvs diff into a file (this is why I didn't discover the bug earlier).
    
     #21405: Cut on read-only source is sometimes not reverted (was: Unappropriate actions in popup menu)
Steps to reproduce:
  • make diff of two files
  • select part of text
  • invoke popup menu
-> actions : Paste, Cut and Delete should be disabled or should be possible write to this view ?!
#23571: Make abbreviations useful: support and include multiline abbrevs
A much more useful one would be:
tryc ->

    try {
       |
    } catch (Exception e) {
    }
or even
addact ->

     addActionListener(new ActionListener() {
       public void actionPerformed(ActionEvent e) {
          |
       }
     });
#25323: Dispearing code completion
Sometimes, while writting the code, the code completion view just disappears. It is strongly dependent on the timing, but it is possible to simply reproduce it if you know how.
Try these steps:
  1. Clean IDE (new userdir).
  2. Open a java editor (for example ClockFrame in editing mode).
  3. Into a method, try to write "String.err".
  4. Press '.'.
  5. Wait for code completion.
  6. Now, write "println", and try to press keys as fast, as you can. Or, make a delay (~1sec) between key-presses. It sometimes happens, that the code completion just disappears.
  7. This does not happen when you type, remove all you have written (".println") and go back to step 4.
It seems to me, that the problem happens if the key is pressed during code completion re-evaluation. The code completion is closed after that.
#25969:
I was editing a text using code completion. Once, I write quite fast, and IndexOutOfBoundsException/s occured (the second of the exceptions was repeated approx. 4-5 times).
IndexOutOfBoundsException while editing (code completion)
I am marking this bug as RANDOM, because it is unreproducible. I have not seen it from time I reported this, so I suppose the fix was succesfull. Reopen anybody is able to reproduce this problem. Current build is 200210170100.
#26063: Editor should attempt to focus the last activated editor window after Alt+Shift+I
The focus just stays on the main window because it's parent of the FastImport dialog. The Find dialog for example uses Utilities.returnFocus() to attempt to return the focus.
#26430: Import tool doesn't work from XEmacs!
#26480: Javadoc summary does not work for method args with array type
Mount JDK 1.4 sources, type
new DefaultTableModel(
and scroll through the constructors when the popup appears. Javadoc is displayed for most constructors, but not those with one or more Object[] params, though Javadoc comments exist.
#26966: Fast Import (Alt Shift I) should trim selected text
if you select, e.g.: "Remote Exception " with a space as the last char (which will always happen if you use word selection with crtl + right arrow) and use the Fast Import function, it will not work. If you remove the last space all works as expected. I greatly appreciate the Fast Import function and think this small adjustment would improve its "ease of use".
#27213: Two separators in java editor's context menu
Try to invoke a context menu in any java editor. You will see that between "Delete" and "Add" actions are two separators, making it look strange.
    
     #27936: Form Editor loses applet menu on reload
#29749, is marked as duplicate and then would be also resolved by the fix of this issue.
When adding a menu to an applet all works fine and the menu appears. I then compile it and work on it, at this stage the menu is 'hanging' off the JApplet node in the form editor. When I then close it to work on something else and the re-open it, the menu is no longer visible in the form editor (and when the applet is run), at this point the menu is seen to be 'hanging' off the Other Components node.
    
#26049: Installer incorrectly imports modules from userdir.
Installer doesn't import folders like {$userdir}/modules, lib, etc. from 3.3.2 userdir (in contrast to Setting Import Wizard). It is problem of all 3.3.2 XML users because XML wasn't in standard 3.3.2 distribution and is available via AutoUpdate. Steps to reproduce:
  1. run 3.3.2 with empty userdir
  2. install all XML modules via Update Center
  3. exit 3.3.2
  4. run Nb 3.4 installer
  5. slelect Import Settings from: NetBeans IDE v3.3.x
  6. finish instalation
IDE starts and displays 18 Warnind Dialogs and a lot of exceptions (see ide.log) and it will happen at every start.
    
     #25500: While setting empty location, many exceptions are shown in console
How to reproduce:
  1. Open Options
  2. Select "Source Creation and Management|Templates|Jar Archives|Jar Recipe|<Jar Filename>" node
  3. Change Location property to something
  4. Set empty text to Location property
  5. ERROR - Many exception are shown in the console
    
     #26932: ClassPath.getResourceName(FileObject, char, boolean) does not work as documented
The separator character is ignored and '/' is always used.
#27636: NPE exception in V8 parser.
The exception was caused by running Java parser from another Java parser. This is not supported. Fix makes sure that referenced files are saved only for internal compilation and do not saved for the source parsing.
#27827: "Append Environment Variables = True" does not work
Found in 4.0 dev, but also in 3.4. Setting this flag to True has no effect. Code in JavaProcessExecutor simply ignores it. Attaching suggested patch.
#28481Problem with compile all
If I select Compile All from the build menu I get a NullPointerException with a request to report this bug. I had the "Use JavaMake" property set to true. When I reset it back to false Compile All does not throw any exceptions. The problem is reproducable because if I set it back to true I get the same exception. I also tried to delete the entire project and recreate it. Same thing.
#29306: NetBeans does not close all open file descriptors.
When I mounted ten filesystems (in the NetBeans Explorer) and ran command "Update Code Completions..." on some of them, NetBeans became crazy, displayed several exception windows and printed a lot of exceptions to the console and/or to 'ide.log'. It also started installing and uninstalling various sets of modules. Some of the exception messages written into 'ide.log' end with "(Too many open files)".
    
     #22203: After unloading and reloading JavaCVS module, JavaCVS filesystem has local filesystem icon
Re-initialize the cache after addNotify(). This is necessary for the filesystem and cache to work correctly after several calls of removeNotify() and addNotify().
#25844: CVS | DIFF, off-by-one error
If using "Ignore whitespace" and "Ignore blank spaces"; maybe one of those features is broken leading to the spaces we see!

Run the update -p command for each revision compared. This is necessary for the graphical diff to have the correct revision texts. The diff can be given arguments to ignore some changes (spaces, empty lines, etc.) If the cvs diff ignores some changes it's not possible to construct the second file from the first one and the list of differences.

#27271: If isIgnoreLocallyExistingFiles(), pass a null file agrument only to sendEntryAndModifiedRequests().
Well, the problem is in org.netbeans.lib.cvsclient.command.remove.RemoveCommand.sendEntryAndModifiedRequests() method. When isIgnoreLocallyExistingFiles() is true, the file is set to null, which will cause the NPE.
#27274: CVS commands don't save editor buffers first
Please refer to the nbusers discussion thread "Surprising CVS problems (changes lost)" started Mon, 9 Sep 2002 by Mike Cepek, which includes step-by-step reproduction scenarios: Brief summary: CVS command execution, unlike Ant target execution, doesn't save modified files first in NetBeans. A nasty consequence is that a "CVS update" command with unsaved editor buffers can easily result in lost work (yours or someone else's) with no warning.
#28075: DEADLOCK when you mount FS containing WEB module
In versioning filesystem's attributes do NOT look for corresponding FileObject, because this can cause deadlock. In NbJavaCvsFileSystem getVcsAttributes() method added to be able to access attributes directly.
#28943: Default Switches dialog does not allow to cancel the command
When creating a cvs filesystem, the default value for the "User Interface Mode" property is "Only Default Switches".

When first executing a cvs command on that filesystem, a dialog comes up to let you know that more advanced options are available, but does not provide a way to cancel the command.

Why is this bad? If you have been working on a local versions of files, they can get merged when you first do an update from netbeans without any way to stop it short of killing the application before closing the dialog. Bad, bad netbeans.

    
     #22805: No UI for accessing Javadoc except search or editor shortcuts
It's fine that we got rid of the JavaDoc tab in Explorer. But how do I access JavaDoc now? I should be able to browse and possibly open JavaDoc without running a search tool. One idea: When you mount JavaDoc, it should offer to add the main index file to the current project. One issue with that idea (already filed an enhancement on this): You could end up with a bunch of files in your project called "Index." The right solution is to parse out a reasonable name (such as using the <TITLE> tags from the index) and use that for the shortcut that gets added to the project.
#26238: User able to type in the Javadoc Output Window
When a javadoc is created the user is able to type in the output window.
    
     #26431: makenbm target fails with Ant 1.5
#29712: 3.4 instead of 3.4.1 in installer
In the installer for 3.4.1 RC1 build the NetBeans 3.4 is displayed everywhere.

Rudolf Balada:
I've got mixed feeling if it's an error or not, but it's certain, that I'm responsible for that as an idea author and implementator. Installer build *shell* script takes the product key from userdir value specified in runide_defaults.sh I will try to arrange special installer build tomorrow to provide good installers for 3.4.1 RC2 (build #200301032341). I guess 3.4.1 is not going to change userdir so the change is upto me.

    
     #25489: Default action sometimes does not work on TreeTableView
#25590: A number of OpenIDE classes (e.g. SplittedPanel) get colors from java.awt.SystemColor, not UIManager
I've been playing with theme support and noticed a bunch of borders that did not seem to respond to UIDefaults changes. The reason is that they get their colors from java.awt.SystemColor rather than using javax.swing.UIManager.getColor().
#25731: Treat as file doesn't work in jar file
If jar file contains some unrecognized file and user want view that file as text and uses action "Treat as File" from pop-up menu on that file, IOException is thrown and file is not treated as text.
#25884: Wrong title of properties window.
Properties window of filesystems, archive files etc. has wrong caption. It says something like: "Properties of D:\For [Properties of D:\Forte for Java\User\3.4\sampledir]" in case of default local filesystem or "Properties of jemmy. [Properties of jemmy.jar]" in case of JAR file. It looks like only 6 characters are taken into account, doesn't it ? I would love to assing it as P2 but I am sure you would downgrade it immediatelly. However can this remain in FCS ? ;-)
#25963: [Explorer DnD] After cancel drop in Explorer popup menu and short cuts don't work there
#26028: after deleting GUI Editing workspace, editor window blank
I did about the following steps: look at files in editing workspace mount src.zip -- probably unrelated unmount src.zip -- probably unrelated open ImageViewer.java (opens Form Editor on GUI Editing workspace) delete GUI workspace now there is a blank tab in the editor for what should have been the showing file. Other tabs in the editor look OK. Hitting the X on the tab to delete it and opening it again fixes the problem.
#26228: Each time selection of module node in Tools | Options arise new Properties Window
Steps to reproduce:
  • run IDE
  • invoke Options (Tools | Options)
  • try to select some node under IDE Configuration | System | Modules,
if folder is selected -> itself expanded
if module is selected -> new properties window arise
#26311: .settings files are parsed 2+ times
During the IDE startup, each of the .settings files under the Services folder will get parsed at least twice during the FolderLookup initialization.

It is caused by this code in the core:

SerialDataConvertor.java:73
        if (isModuleEnabled()) { 
            instance = createInstance(null); 
            lkpContent.add(instance); 
        }
where in isModuleEnabled->getModuleInfo() is code to create/parse an instance: String module = new SettingsInstance(null).getSettings(true).getCodeNameBase(); and the parsed instance is immediatelly forgotten and created again from above mentioned instance = createInstance(null); and is parsed again later (on demand).

It is possible to keep the parsed instance, which will significantly speed up the FolderLookup initialization.

#26678: I18N - Problems with localized mnemonics
I found a VERY serious bug in localized Netbeans: When I translate, e.g. "&File" menu name into Russian, I have "&<SOME RUSSIAN SYMBOL>...", but then the key combination Alt+<SOME RUSSIAN SYMBOL> doesn't work! All other menus and submenus, buttons, etc. are also affected. And I do not like the way, used by Localizators of Mozilla (which also has the same bug), who just translated the menu name, but left the English key combination. So "&File" menu would look like "<RUSSIAN TRANSLATION> (&F)" - this is not very attractive anyway.
#26887: SystemAction.iconResource upgrade problem
The new semantics of this method are better, but some 3.3- modules with actions might have been harmed by the change. #26887 restores compatibility for them (with a suitable warning to console about how to upgrade).

SystemAction.iconResource relative path compat fix.
#26929: NullPointerException when closing window
I'm running Netbeans 3.4 under the Sun JDK 1.4.0 using the Windows L&F. I had a number of files open in the editor, and closed them all by clicking the "X" button in the menu bar (not the one in the title bar, which would have quit the application). The editor window did close, but I also got a dialog box with the following exception: ...
#27025: Nodes for DataObjects can disappear from the tree even there is no change in the DataObjects
I have noticed issue 26192 and find out that it is caused by fix of issue 20699. Good to know, because I had to workaround this behaviour during implementation of issue 23356, I did not know why, but sometimes nodes that I obtained as children from FolderChildren were not present in the tree when I tried to do ExplorerManager.setSelectedNodes. This is bad behaviour. So it implies that the fix of the bug 20699 is not good. I am creating this bug and I will try to write a test case to show, what is wrong and will attach it here.
#27966: IllegalArgumentException in ExplorerManager when trying to use the Projects module with the Platform
I downloaded the 3.4 platform release dated 9/27/2002, and while in the process of adding the modules I need, I ran into a problem with the Projects module--I tried both versions 1.8 and 1.9, and I get a fatal exception "cannot have null root context". As I understand, it, this is the platform release based on NB3.4, so this projects module should work, because it came from my NB3.4 IDE installation. I'll attach the IDE log.
#29768: NPE when icon for an action is missing
After installing the jindent-integration-module, I get a NullPointerException, when I try to open the Tools-Menu
    
     #29627: NoSuchMethod in PropertiesParser.java under JDK 1.3
The error is raised on startup in PropertiesParser.readNextElem (line 194), full stack trace attached. Priority is P1 because IDE doesn't start at all.
    
     #26570: NullPointerException when starting up
you use a bad zip unpacking SW your SW deletes empty dirs from the IDE_INSTALLATIN.zip check for example, if the "ide_installation_dir\tomcat404 \common\classes" exists (this folder is empty) if not, change or reoption your SW
    
     #25514: Missing descriptions for welcome module
This module does not have a short nor long description in the Setup Wizard's module installation panel.
#25611: Some images (bullets, vertical line) in welcome screen are not transparent
#26011: I18N - "Next" in Tips Panel of Welcome Screen is not localizable
#26022: I18N - "Welcome Screen" in setup wizard module listings not from bundle file
In the modules listing of options and setup wizard, the word Welcome Screen is not localizable due to its value not being in an OpenIDE key in bundle file of welcome.jar. Also, there is not a description in the setup wizard's description field for it.
#27030: I18N - welcome window not fully localizable
In welcome window, not all labels/text come from html or bundle files within welcome.jar Richard mentioned that the third column is from gifs instead, but for ffj localization, this information would need to be in bundle or html files. Also, some of the links under help do not show fully when pseudo translated - that is, their window does not resize to fit; user should not need to resize in other locale if the window shows fully in C locale.
#27630: I18N-Impossible to set different font for "Next" button in Welcome
#29383: Netbeans 3.4.1 Splash is ugly
    
     #29194: linking to ant faq and fixing ant version numbers
Adds a link to the Ant FAQ in the Building With Ant help page
#27498: merging revisions from trunk for 3.4.1 release
    
     #25008: The output tab in Output Window is not made visible when an error ocurrs
The output tab in Output Window should automatically become visible when an error output of a command is being printed into it.

"Versioning" output tab created. It is used for output of VCS commands instead of the standard "Output" tab. Now we're able to make visible this "Versioning" tab when a command fails.

#25364: Netbeans 3.4 Beta 2 CVS External Client does not Refresh correctly
I've set the external CVS properties to make sure that the Refresh occurs when the directory is opened, but the files are not being refreshed properly. If a direcotry is opened that contains sub-directories as well as source files, the source files in that directory don't get refreshed. The refresh occurs if I manually refresh those files, however. Also, the folders themselves always show "Local" instead of the CVS version information unless a checkout is done on that folder.
---
CacheDir.addChildNames() added so that the directory can be initialized from the disk cache when necessary. A new property local added to CacheFile.PersistentData. VcsCache.lookupCacheDir() added to find an already read directory. Ability to read just cache file names from the disk cache added to VcsCacheDir & VcsCacheFile. Exclusive locking for cache files implemented to prevent concurrent access to the file content and mutual rewritings.
#25978: Variables are not expanded in status bar and name of commands.
Runtime variables substitution is not done in status bar of IDE and command names stored in history of ran commands. It concerns commands like "VSS|Set Password" or "CVS|Login".
---
We store the filesystem variables in the VcsCommandWrapper so that they can be easily used for expansion of command display name in reports. Also VcsRuntimeCommands expands the display name with current variables.
#26491: SystemAction does not declare serialVersionUID
After restarting 3.4RC1, I saw the following in the console:
-----------
Serializable class org.openide.util.actions.SystemAction does not declare serialVersionUID field. Encountered while storing: ...
I skimmed that bug and its friends and didn't follow it all, but assume you want this fixed or you wouldn't be printing out the message. Feel free to close this if it's not really a bug.
Please store names of SystemAction classes, not the instances themselves which are not really designed to be serializable.
---
Prevent serialization of VcsActionSupporter with the filesystem. Also do not serialize swing objects in GeneralCommandAction.
#26553: Rare deadlock in VCS cache.
When deciding whether to create backup file or not, check for the importantness at last. Due to a safety change in DefaultAttributes, .nbattrs~ is saved and later renamed .nbattrs~ to .nbattrs. This has caused, that 'isIDESettingsFile()' returns false always and a deadlock could happen when calling isImportant().
#26614, #29295, #29298: Show the VCS revisions instead of the internal used revisions.
Some VCS implementations, (VSS, CMS for OpenVMS, etc.) do not use a ".n" format revision number. That is, revision numbers are positive integers only.
When writing a RevisionListGetter class for a generic VCS module, it is necessary to add a ".0" to the revision if the VCS only uses integers. If this is not done, the Versioning Explorer does not work properly (expanding a node has no effect).
Having a ".0" following all revisions in the Versioning Explorer causes confusion for users of that VCS and doesn't look very good.
#27890: Deadlock in vcs caching, when switching projects
jdk1.4.1 It is not reproducible. It happened to me when switching projects.
---
Construct the cache files outside of the cache file lock when reading from disk.
#28238: ITE & CME (when mouting FSs)
I took todays build and started it with clear userdir. I mounted 1 JavaCVSFS, invoked Update Wizard and updating few modelus.... during this I executed one class which automaticaly mounts various FSs to set my CLASSPATH, etc. After it and also Update Wizards finished I found in console stacktraces of InvocationTargetException and ConcurrentModificationException which are attached in one file
---
The access to the list of CacheHandlerEvent listeners is synchronized.
#29296: Patch for OpenVMS to work around protection issue
We need to make 2 changes to ChooseDirDialog() in vcscore to work around a file protection problem with Java on OpenVMS. The changes are as follows: ...
    
     #25175: CVS, PVCS: Can't see new basic variable.
Description:
This is quite interesting bug. Users can't create basic variables to CVS or PVCS filesystems or at least they are not visible in the customizer. The most strange is that it seems like VSS was not affected. Looks like regression ?

Steps to reproduce:

  1. Invoke "Versioning|Mount Version Control|Generic VCS".
  2. Select CVS profile and push "Next >" button.
  3. Click "Edit Variables..." and right click "Basic" node.
  4. Choose "Add Variable", type "Name" and click "OK".
  5. Push "Finish" and invoke the customizer after the filesystem is mounted into explorer.
  6. There is no "Name:" textfield in it.

---
Construct the configuration input descriptor only if the descriptor string representation is non-empty. This prevents from creating and empty panel from the empty input descripor.
#25959: Lazy enabling of "Save" profile button.
It's quite annoying that "Save" button gets enabled on lost focus event instead of its non-empty value. I mean the button when saving own profile.
#26034: PVCS: Filesystem unusable after specific workflow.
Description:
There is a special workflow that gets PVCS filesystem into unusable state because of never ending loop of exceptions. The only workaround is to restart IDE. Take a look at the attachment for details or read below.

Steps to reproduce:

  1. Mount PVCS filesystem and invoke its customizer.
  2. Switch to "Environment" tab and push "Insert" button.
  3. Type "AHOJ" as name and push "OK" button.
  4. Switch to "Advanced" tab, push "Edit Variables" and "OK".
  5. Repeat steps 2 and 3 with "CD" as name of new variable.
  6. Exceptions will be thrown.

Filter out all variables with null values after the autofill process.

#26176: Text diff empty after switch from graphical diff
I tried to run graphical diff (directly from context menu) an then I switched to to text diff using combo on top of the form. The textual diff contained just information about lines where the change was made. Text diff from context menu is OK, so the problem occurs only when switching from graphical diff to text diff.
Add the text of the differences also into the data output of this command. This is necessary for the parser so that the text will be included in the Difference objects.
#26188: CVS: It would be good to chain "Remove" command with "Commit"
It would be nice to have also "CVS|Remove" command chained with "Commit" so that it can be done in one step as with "Add" command. I mean the checkbox like "Proceed With Commit If Remove Succeeds".
---
There is a possibility now to do commit right after remove command.
#26413: "Refresh Time" is reset to default in every IDE session.
"Refresh Time For Local Files [ms]" filesystem property is reset to its default value (15000) when IDE is restarted. User must always set it manually, if new IDE session is started.
The new refresh time property defined (PROP_VCS_REFRESH_TIME). This property is fired when the refresh time is changed.
#27353: PVCS: No way how to setup Unix shell interpreter.
Description:
There is no way how to setup Unix shell interpreter in PVCS profiles. Although, there is a lot of workarounds they are not easy to find. This is serious regression in functionality and I would recommend it for 3.4.1.

Steps to reproduce:

  1. Invoke "Versioning|Mount Version Control|Generic VCS".
  2. Uncheck "Only Show Profiles Compatible With ...".
  3. Select "PVCS (Windows 95/98/ME)" profile.
  4. There will be no "Unix Shell" field in the dialog.

---
Unix Shell variable added to the configuration input descriptor for Win95/98/ME PVCS profiles.
#28157: Generic VCS NullPointerException
Here is the NPE stack trace - I'm having a hell of a time trying to get NetBeans integrated with PVCS. I either get constant NP exceptions or the PCLI commands fail.
---
Initialize the refresher after FS deserialization. Optimalize the class loader retrieval when loading action classes for commands. Check for null variable values to be more robust.
#29297: Empty Working Dir text box on OpenVMS doesn't work correctly
We need to make a permanent change to VcsCustomizer.java in vcsgeneric to properly handle an empty "Working Dir" text box on the Generic VCS Mount Wizard on OpenVMS. This change is as follows: ...
    
     #26620: NB3.4 does not recognize JSP files if the freestyle browser is installed
1. Created a new web module. 2. Added three JSPs to the web module. 3. From the Update Center, installed the Free Style Browser module (it's either Alpha or Beta, don't remember which). 4. After the IDE restarted, my JSPs had null icons. 5. From the Options window, I disabled the Free Style Browser module. 6. After either restarting the IDE or remounting the web module, the JSP nodes are back to normal.
    
     #29024: minor docs fixes
    
     #26097, #26099: Can't select $USERDIR/hidden dirs in JFileChoser
setFileHidingEnabled(false) was set for all JFileChoosers, so that users can browse hidden folders and select hidden files.
    
Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo