NetBeans.org Community News

Back to the community news list

NetBeans IDE Development Builds Now Require JDK 7

By: tinu, 16 Apr 2013

As of March 25, the NetBeans IDE development builds require JDK 7. Please note that this does not apply to NetBeans 7.3 or any other previous release.

The reasons for this are: JDK 6 has already stopped public updates, so if NetBeans users encounter a bug that originates in the JDK, we have no way to fix it in JDK 6. Also, we are forging ahead with tooling for JDK 8, which requires the JDK 7 compiler and tools. And most important of all, we are excited about using JDK 7 language constructs in NetBeans itself. We think that there are some real improvements we can give our users, especially in the area of performance, by using JDK 7.

As always, you can register JDK 6 or earlier versions of the JDK and build programs that runs against those platforms.

Special note to Mac users: We are aware that NetBeans IDE (or Java in general) has some rendering problems on Retina displays. We are hard at work with the JDK team to resolve those issues in time for our next major release.

Thank you,
The NetBeans Team

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo