Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 99978 - Inspect Hierarchy is not dockable
Inspect Hierarchy is not dockable
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Navigation
6.x
All All
: P3 (vote)
: 7.3
Assigned To: Tomas Zezula
issues@java
:
: 131715 (view as bug list)
Depends on: 211784
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-04 13:52 UTC by Tomas Mysik
Modified: 2012-11-28 17:27 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2007-04-04 13:52:00 UTC
NetBeans IDE Dev (Build 20070403-1341)
1.6.0; Java HotSpot(TM) Server VM 1.6.0-b105
Linux version 2.6.20-gentoo-r4 running on i386
cs_CZ (nb); UTF-8

Inspect Hierarchy is not dockable so the window is closed after you open any 
class from it which is wrong because it should stay opened to have possibility 
to open all implementations of an interface etc. (now you have to open 
Hierarchy window, e.g. change filter type, open class; open the Hierarchy 
window *again*, change filter type *again*, open class and so on)

I also noticed that the window is automatically closed when you switch to 
another program and back (using ALT+TAB).
Comment 1 _ sandipchitale 2007-04-05 04:57:43 UTC
The Inspect Members and Hierarchy windows are meant to be pop up only 
transient windows.
Comment 2 Tomas Mysik 2007-04-05 11:00:05 UTC
I don't agree because it's annoying e.g. to open several implementations of an 
interface - shall I write here all the steps one has to do?

Another improvement could be to open hierarchy for class under the caret and 
not only for open document - so I suggest to reopen this issue and change it 
to enhancement.
(please, try eclipse, press F4 on *any* class name under the caret in the 
opened file and you'll see the difference [btw eclipse shows both super- and 
subtypes as default and it remembers the last state] - i'm not saying that 
eclipse is correct but i'm saying that eclipse is much better)
Comment 3 _ sandipchitale 2007-04-05 15:19:51 UTC
The Inpsect commands in the Go to menu in the Menu bar show the hierarchy of 
the class of file that is open or a .java file that is selected in the 
Project/Files window.

There are Inspect commands in the editor pop up menu that show the information 
about the type under caret.

HIE is going to provide separate key bindings for these. I need to ping Jano 
about it. Also there was some discussion about using distinct display labels 
for the actions in Go to menu and the editor pop up menu so that it is clear 
what they do.
Comment 4 Vladimir Kvashin 2012-09-04 15:02:42 UTC
To me, it's close to impossible to use it because it isn't docked - each time I  need to traverse the three and look more than one class of the hierarchy. So each time I need to open it again and again.

Please see how it is done in C/C++: by default it is transient, but it has "dock" button. The way it was done in C/C++ isn't our fantasy, that's NetBeans HIE who worked on this first, and they spent quite a bit on that.
Comment 5 markiewb 2012-10-14 00:18:12 UTC
In 7.3 the hierarchy window and inspect members are now topcomponents and are dockable (docked by default).
* http://netbeans.org/bugzilla/show_bug.cgi?id=211784 (starting branch "java_hierarchy")
* http://wiki.netbeans.org/UEXInspectMembersAndHierarchies
Comment 6 Tomas Mysik 2012-10-15 05:24:17 UTC
You are right, this issue is fixed for NB 7.3.
Comment 7 Petr Somol 2012-11-28 17:26:19 UTC
*** Bug 131715 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo