Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 99975 - The Use Case name is badly visible after Extension Point insertion
The Use Case name is badly visible after Extension Point insertion
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: Diagram Usecase
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Thuy.d Nguyen
issues@uml
HOL, release55_fixes_fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-04 13:49 UTC by Alexandr Scherbatiy
Modified: 2007-05-11 15:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Use Case Name (12.37 KB, image/png)
2007-04-04 13:59 UTC, Alexandr Scherbatiy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2007-04-04 13:49:50 UTC
Steps to reproduce:

- Create a Use Case diagram
- Put a Use Case element on the diagram, name it 'Add Personal Information'
- Insert 'Add Birth Date' extension point to the Use Case

  The extension point places on the center the element
  The name of element is not clear visible because of it is nearly above
  the element.
Comment 1 Alexandr Scherbatiy 2007-04-04 13:51:33 UTC
The issue affects Advanced UML Modeling with NetBeans HOL
Comment 2 Alexandr Scherbatiy 2007-04-04 13:59:53 UTC
Created attachment 40437 [details]
Use Case Name
Comment 3 Thuy.d Nguyen 2007-04-09 23:14:55 UTC
Re-calculated the size of the name and the extension point compartments  of a
usecase node such that the height of the name compartment does not get pushed to
the top of the node. 
Fixed and integrated to trunk.
Comment 4 Andrew Korostelev 2007-04-17 13:57:29 UTC
current fix is enough for HOL.
mark as verified in all-nbms-griffin_fixes-070416_1-ml

But will file new issue to add Vertical alignment.
Comment 5 Andrew Korostelev 2007-04-17 14:24:27 UTC
issue 101366 was filed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo