Bug 99888 - EQ frozen for long periods while opening "nbbuild" + all dependencies
EQ frozen for long periods while opening "nbbuild" + all dependencies
Status: RESOLVED WORKSFORME
Product: apisupport
Classification: Unclassified
Component: Project
6.x
Sun Solaris
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@apisupport
: PERFORMANCE, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-03 21:55 UTC by _ pcw
Modified: 2008-06-19 22:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Deadlock thread stack dump. (17.56 KB, text/plain)
2007-04-03 21:55 UTC, _ pcw
Details
New threaddump showing CVS activity on AWT thread. (29.04 KB, text/plain)
2007-04-06 20:33 UTC, _ pcw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ pcw 2007-04-03 21:55:26 UTC
I'm running an IDE built from the latest trunk sources.  I tried to open project
'nbbuild' of said source tree along with all dependent projects and the IDE
deadlocked.

According to the UI, it's stuck opening the Struts project, but that probably
doesn't matter.

This was with JDK 1.6.0_00, thread dump attached.
Comment 1 _ pcw 2007-04-03 21:55:58 UTC
Created attachment 40375 [details]
Deadlock thread stack dump.
Comment 2 _ pcw 2007-04-03 22:02:07 UTC
As an aside, I suspect (but am by no means certain) that this can be easily
reproduced by selecting "nbbuild" in the project chooser, checking "open
required projects" and hitting OK *before* the system is able to compute what
the list of required projects is.

Also, I think you can consistently work around it by waiting until the required
list is fully computed before hitting OK.

I've seen this deadlock a few times now, always on dual core or dual CPU
machines.  May not be reproducible on single threaded hardware.
Comment 3 novakm 2007-04-05 10:52:57 UTC
Reassigning to Java for evaluation.
Comment 4 Jesse Glick 2007-04-05 19:40:24 UTC
I don't see any deadlock in this thread dump. Nor do I see anything that
specifically indicates a problem in apisupport - the IDE looks to be happily
opening the projects (which is slow for NBM projects but should terminate).
Comment 5 _ pcw 2007-04-06 20:31:32 UTC
This issue is either invalid, or a red herring.  It seems that the opening
process is just unexpectedly slow sometimes, even on really fast machines.

At the point where I thought it was deadlocked, the entire UI (including the
progress bar monitoring the java parsing) froze for a very long time.  I'm able
to reproduce this delay, but it's not very long today (30 seconds to a minute at
most).

The cause of the UI freeze may be CVS processing on the AWT thread, see attached
dump.
Comment 6 _ pcw 2007-04-06 20:33:27 UTC
Created attachment 40577 [details]
New threaddump showing CVS activity on AWT thread.
Comment 7 Jesse Glick 2007-04-06 20:58:25 UTC
Hmm, shouldn't block EQ this way.
Comment 8 Jesse Glick 2008-06-19 22:28:21 UTC
ide/allmodules is now the "main" project to open.

Using a dev build (Basic IDE) on Ubuntu / JDK 6, does not freeze GUI; "Opening Projects" dialog opens and lists the
projects one by one as they are opened. The background compiler can also be seen working in the process area. Of course
there are hundreds of projects and it takes a long time.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo