Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 99686 - Add components from all packs to Exc. DB
Add components from all packs to Exc. DB
Status: CLOSED FIXED
Product: ide
Classification: Unclassified
Component: Exceptions Reporter
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jindrich Sedek
logger-issues@ide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-02 13:49 UTC by Marian Mirilovic
Modified: 2007-05-29 14:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2007-04-02 13:49:45 UTC
For now I see a lot of exceptions are reported against Core, those should be
reported against :
uml, visualweb, wsdl, ....

But I don't see these components in query page, so i assume if you don't find
appropriate component in your DB (means there aren't all these components), you
select Core as default, don't you ?

Because all packs are build on the top of the IDE, it would be much better to
all of these components to DB.
Comment 1 Jindrich Sedek 2007-04-12 11:24:15 UTC
we are goint to use a jar file suggestion with pseudo components more info is
writen in 

http://www.netbeans.org/issues/show_bug.cgi?id=96565

it should solve this problem

as default "unknowm" is going to be used to say we have no suggestion

*** This issue has been marked as a duplicate of 96565 ***
Comment 2 Marian Mirilovic 2007-04-12 12:15:58 UTC
Jindra, 
do you think it will solve the problem with missing modules in query page ?
Comment 3 Jindrich Sedek 2007-04-12 12:31:37 UTC
In query page there are just modules with existing error in our DB, I don't see
the reason to fill it with no more used components in issuezilla or something
like that. The number of components is going to rise while finding errors from
new components. Why do you want to have a query for components if there is no
issue assigned to them. I feel it as useless data. After fixing #96565 we will
be able to set correct components by web site for unknown components and since
that we can generate also new components from pacs in query page.

*** This issue has been marked as a duplicate of 96565 ***
Comment 4 Marian Mirilovic 2007-04-12 12:43:06 UTC
>  Why do you want to have a query for components if there is no
issue assigned to them. 

first 3 lines of this report said :
------------
For now I see a lot of exceptions are reported against Core, those should be
reported against :
uml, visualweb, wsdl, ....
------------

so that's the reason. If we want to people use this tool, we need a way to
reassign issues to the right component, for now a lot off them simply don't
exist in DB. So my previous question was:
Do you plan to go through all already reported exceptions and assign each of
them once again - just to use algorithm you described in issue 96565 ?
Comment 5 Jindrich Sedek 2007-04-12 13:04:21 UTC
Yes we are going to recalculate all the components by new algorithm and we are
going to keep information if the component was assigned by algorithm or by hand
not to change user's decision. 

Web console is going to be done to add new components not just to reassign to
existing components. We have no fixed table of existing components. As I said
the number of components is going to rise with new suggestions and
reassignements made by users.  

I'll close this issue after having regenerated components if you find it better.
Comment 6 Marian Mirilovic 2007-04-12 13:06:37 UTC
Ok Jindra, thanks for explanation. 
Comment 7 Jindrich Sedek 2007-05-09 17:17:24 UTC
I've regenerated components and there as a possibility to change the component
to all existing in issuezilla.
Comment 8 Marian Mirilovic 2007-05-29 14:09:16 UTC
v/c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo