Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 99555 - Obsolete pages are created for VWP JSF project
Obsolete pages are created for VWP JSF project
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: _ potingwu
issues@javaee
:
: 73352 (view as bug list)
Depends on:
Blocks: 72091
  Show dependency treegraph
 
Reported: 2007-03-30 15:13 UTC by Petr Blaha
Modified: 2008-11-10 11:49 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Blaha 2007-03-30 15:13:56 UTC
Steps:
1) create Web project with VWp JSF framework
ERROR: pages laik index.jsp and welcomeJSF.jsp pages are created. Why? These
pages should be created only in NetBeans JSF framework was selected.
Comment 1 _ potingwu 2007-03-30 19:43:15 UTC
I don't see welcomeJSF.jsp. index.jsp is expected by web project.

Comment 2 Petr Blaha 2007-04-02 08:43:42 UTC
OK, maybe these pages are expected but for these pages JSF visual editor doesn't
work. For me it seems that users would be confused why visual editor works for
some pages and for doesn't. Therefore, we should remove these pages for visual
JSF web project development.
Comment 3 _ potingwu 2007-04-02 17:24:00 UTC
> but for these pages JSF visual editor doesn't work.

What do you mean "doesn't work"? VWP is not just VWP, it's a plugin of NetBeans
Web Project. VWP is extending the web project functionality. These pages are
still normal NetBeans Web project stuffs that can use non-visual JSP editor to edit.

Remember that all plugin 'should not' remove the or disable the parent platform,
only extending it.
Comment 4 Petr Blaha 2007-04-02 17:29:02 UTC
There are two different behavior for JSP pages: visual editor is opened for one
and for other text JSP editor is opened. I think that users will be confused
from this. 
Comment 5 _ potingwu 2007-04-02 17:43:07 UTC
Since NetBeans 5.5 + Visual Web Pack, VWP can add any non-visual JSP pages. And
these pages can ONLY be opened by non-visual JSP editor. JSF is not equal to
Visual. VWP is helping to add Visual page, but not remove or even make all
non-visual stuffs become visual.

Please remember that Visual Web framework is an extra, not a replacement of
NetBeans web project. This concept was starting from NetBeans 5.5. (This concept
was only for Creator)

You can see how non-visual and visual stuffs work together by looking into how
'index.jsp' has a link to the visual page 'Page1.jsp'. Not all pages in users'
web application must be JSF, and not all JSF page should be only edited by
Visual editor.
Comment 6 Petr Blaha 2007-04-02 18:29:06 UTC
Petre, can you comment this? Thanks P
Comment 7 _ potingwu 2007-04-02 18:50:44 UTC
Petr Blaha wrote:
> Current situation is very strange for me. When user installs Visual JSF
> support he expects that IDE will provide capability for visual editing of JSP
> pages, config files, ....
> 
> Now, we have some visual editing feature for some pages but not for all.
> Maybe, it's better to ask somebody from HIE or architects.
> 
> What's about to enable Visual JSF editing for all JSP pages when the VWP JSF
> framework is selected and user can switch to text mode via JSP button in
> multiview editor. 

This is not the intended feature for Visual Web. This is too much for at least
NetBeans 6 integration.

Pavel may have something to say too.
Comment 8 Pavel Buzek 2007-04-02 19:29:16 UTC
Visual editing of plain JSP pages is not planned to be supported in 6.0. When
you create a page using the visual page template you can edit it visually, if
you use the JSP page template you will only be able to use JPS code editor. This
is similar to Mattise which can only edit classes with form files, not any .java
file.

I agree that when you create web project with visual JSF framework the index.jsp
should NOT be created. I just wanted to file the bug for that myself :)

IMO creation of these initial pages should be delegate to frameworks. I can see
2 options, but Petr Pisl owns the decision on this. My choices:
1. If no framework gets selected we should populate the project with default
content (i.e. index.jsp). If the user selects a framework the framework is
responsible for creating the initial content.
2. (possible but I do NOT like this as it is a hack, although it is a simple and
quick fix) framework can delete the default content (index.jsp) and create its
own (Page1.jsp)
Comment 9 Petr Pisl 2007-04-02 22:08:43 UTC
I think the first solution, which is suggested by Pavel, can be taken as a hotfix.

I was thinking about this more complex. The index.jsp is set up as a welcome
file for the application. I think the right solution should contain appropriate
api for changing the setting of welcome files as well. The question still is
here, what happen, when more frameworks is selected? Which file will be the
welcome file for the application? Will be the last framework,  which was added.

Now it can be solved as Pavel suggest and the welcome file can be changed
through the deployment descriptor API. If there will be time it can be solved
through spacial api in web project.
Comment 10 Pavel Buzek 2007-04-03 07:52:00 UTC
Enhancement? You are kidding? The project framework is only partly finished and
IMO should not have been integrated in this state. Now it should definitely be
fixed for M9!
Comment 11 _ potingwu 2007-04-03 16:57:16 UTC
This bug is now becoming confused because another features have been added and
discussed. I changed it to 'Enhancement' because of the last request 'All JSP
editors should be Visual after adding Visual Web framework!'.

Now back to the 'Obsolete Pages', since it's a general web project scheme, I
will reassign it to web project.
Comment 12 _ potingwu 2007-04-05 23:20:51 UTC
*** Issue 73352 has been marked as a duplicate of this issue. ***
Comment 13 _ potingwu 2007-04-05 23:22:08 UTC
Increase to P2 requested by the management. Please decrease if not possible for M9.
Comment 14 Pavel Buzek 2007-04-07 19:47:50 UTC
I have it almost done, will integrate when I get to it...
Comment 15 Pavel Buzek 2007-04-09 23:36:28 UTC
fixed: index.jsp is not registered in web.xml template, index.jsp is created and
set as a welcome file in web project only if none of the frameworks set any
welcome files. Struts, jsf and visual jsf fixed to register their files a
welcome files (in Struts there is a small index.jsp with redirect as Struts
action cannot be set as a welcome file, in jsf it is welcomeJSF.jsp, in VW it is
Page1.jsp). If the framework is added into an existing web project and the
project has an unmodified index.jsp then a link is added into index.jsp (same as
it was). I also fixed Struts and JSF to open their welcome page after project
creation (index.jsp in Struts is no open). In VW opening Page1.jsp is done
differently because it requires insync to be initialized.

C:\nb_all\web>cvs -q com -m "99555 create welcome pages based on the selected
framework"
Checking in jsf/nbproject/project.xml;
/cvs/web/jsf/nbproject/project.xml,v  <--  project.xml
new revision: 1.18; previous revision: 1.17
done
Checking in jsf/src/org/netbeans/modules/web/jsf/JSFFrameworkProvider.java;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/JSFFrameworkProvider.java,v  <-- 
JSFFrameworkProvider.java
new revision: 1.16; previous revision: 1.15
done
Checking in jsf/src/org/netbeans/modules/web/jsf/api/ConfigurationUtils.java;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/api/ConfigurationUtils.java,v  <--
 ConfigurationUtils.java
new revision: 1.4; previous revision: 1.3
done
Checking in project/src/org/netbeans/modules/web/project/WebProject.java;
/cvs/web/project/src/org/netbeans/modules/web/project/WebProject.java,v  <-- 
WebProject.java
new revision: 1.112; previous revision: 1.111
done
Checking in
project/src/org/netbeans/modules/web/project/api/WebProjectUtilities.java;
/cvs/web/project/src/org/netbeans/modules/web/project/api/WebProjectUtilities.java,v
 <--  WebProjectUtilities.java
new revision: 1.12; previous revision: 1.11
done
Checking in project/src/org/netbeans/modules/web/project/ui/resources/web-2.3.xml;
/cvs/web/project/src/org/netbeans/modules/web/project/ui/resources/web-2.3.xml,v
 <--  web-2.3.xml
new revision: 1.3; previous revision: 1.2
done
Checking in project/src/org/netbeans/modules/web/project/ui/resources/web-2.4.xml;
/cvs/web/project/src/org/netbeans/modules/web/project/ui/resources/web-2.4.xml,v
 <--  web-2.4.xml
new revision: 1.5; previous revision: 1.4
done
Checking in project/src/org/netbeans/modules/web/project/ui/resources/web-2.5.xml;
/cvs/web/project/src/org/netbeans/modules/web/project/ui/resources/web-2.5.xml,v
 <--  web-2.5.xml
new revision: 1.3; previous revision: 1.2
done
Checking in
project/src/org/netbeans/modules/web/project/ui/wizards/NewWebProjectWizardIterator.java;
/cvs/web/project/src/org/netbeans/modules/web/project/ui/wizards/NewWebProjectWizardIterator.java,v
 <--  NewWebProjectWizardIterator.java
new revision: 1.27; previous revision: 1.26
done
Checking in
project/src/org/netbeans/modules/web/project/ui/wizards/PanelOptionsVisual.form;
/cvs/web/project/src/org/netbeans/modules/web/project/ui/wizards/PanelOptionsVisual.form,v
 <--  PanelOptionsVisual.form
new revision: 1.26; previous revision: 1.25
done
Checking in
project/src/org/netbeans/modules/web/project/ui/wizards/PanelOptionsVisual.java;
/cvs/web/project/src/org/netbeans/modules/web/project/ui/wizards/PanelOptionsVisual.java,v
 <--  PanelOptionsVisual.java
new revision: 1.35; previous revision: 1.34
done
Checking in struts/src/org/netbeans/modules/web/struts/StrutsConfigUtilities.java;
/cvs/web/struts/src/org/netbeans/modules/web/struts/StrutsConfigUtilities.java,v
 <--  StrutsConfigUtilities.java
new revision: 1.16; previous revision: 1.15
done
Checking in struts/src/org/netbeans/modules/web/struts/StrutsFrameworkProvider.java;
/cvs/web/struts/src/org/netbeans/modules/web/struts/StrutsFrameworkProvider.java,v
 <--  StrutsFrameworkProvider.java
new revision: 1.11; previous revision: 1.10
done
Checking in struts/src/org/netbeans/modules/web/struts/resources/layer.xml;
/cvs/web/struts/src/org/netbeans/modules/web/struts/resources/layer.xml,v  <-- 
layer.xml
new revision: 1.11; previous revision: 1.10
done

Checking in project/jsf/nbproject/project.xml;
/cvs/visualweb/project/jsf/nbproject/project.xml,v  <--  project.xml
new revision: 1.9; previous revision: 1.8
done
Checking in
project/jsf/src/org/netbeans/modules/visualweb/project/jsf/api/JsfProjectUtils.java;
/cvs/visualweb/project/jsf/src/org/netbeans/modules/visualweb/project/jsf/api/JsfProjectUtils.java,v
 <--  JsfProjectUtils.java
new revision: 1.22; previous revision: 1.21
done
Checking in
project/jsf/src/org/netbeans/modules/visualweb/project/jsf/framework/JSFFrameworkProvider.java;
/cvs/visualweb/project/jsf/src/org/netbeans/modules/visualweb/project/jsf/framework/JSFFrameworkProvider.java,v
 <--  JSFFrameworkProvider.java
new revision: 1.28; previous revision: 1.27
done

Checking in golden/friend-packages.txt;
/cvs/ide/golden/friend-packages.txt,v  <--  friend-packages.txt
new revision: 1.146; previous revision: 1.145
done
Checking in golden/group-friend-packages.txt;
/cvs/ide/golden/group-friend-packages.txt,v  <--  group-friend-packages.txt
new revision: 1.71; previous revision: 1.70
done
Comment 16 Pavel Buzek 2007-04-10 01:06:29 UTC
cvs com -m "reverting fix of 99555 because it makes internal VW build which uses
old netbeans binaries fail"

Checking in nbproject/project.xml;
/cvs/visualweb/project/jsf/nbproject/project.xml,v  <--  project.xml
new revision: 1.10; previous revision: 1.9
done
Checking in src/org/netbeans/modules/visualweb/project/jsf/api/JsfProjectUtils.java;
/cvs/visualweb/project/jsf/src/org/netbeans/modules/visualweb/project/jsf/api/JsfProjectUtils.java,v
 <--  JsfProjectUtils.java
new revision: 1.23; previous revision: 1.22
done
Checking in
src/org/netbeans/modules/visualweb/project/jsf/framework/JSFFrameworkProvider.java;
/cvs/visualweb/project/jsf/src/org/netbeans/modules/visualweb/project/jsf/framework/JSFFrameworkProvider.java,v
 <--  JSFFrameworkProvider.java
new revision: 1.29; previous revision: 1.28
done

Comment 17 Pavel Buzek 2007-04-10 01:08:15 UTC
the web/* part is done, apply the visualweb part when VW updates to current
NetBeans build
Comment 18 Pavel Buzek 2007-04-11 14:14:55 UTC
Consider this fixed. The user visible part is done.

I copied one method from
visualweb/project/jsf/src/org/netbeans/modules/visualweb/project/jsf/api/JsfProjectUtils.java
into
web/jsf/src/org/netbeans/modules/web/jsf/api/ConfigurationUtils.java
It would be nice to remove the method from visualweb and add a project
dependency on web/jsf (it is already added as a friend).

Comment 19 martin_zmrhal 2008-11-10 11:49:30 UTC
verified

Product Version: NetBeans IDE 6.5 (Build 200811100001)
Java: 1.6.0_10; Java HotSpot(TM) Client VM 11.0-b15
System: Linux version 2.6.27-7-generic running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo