Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 99231 - I18N - Properties File Editor doesn't support UTF-8 encoding
I18N - Properties File Editor doesn't support UTF-8 encoding
Status: RESOLVED DUPLICATE of bug 75906
Product: utilities
Classification: Unclassified
Component: Properties
5.x
PC Windows XP
: P4 (vote)
: TBD
Assigned To: Marian Petras
issues@utilities
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-28 12:22 UTC by ksupakorn
Modified: 2007-08-29 16:46 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Properties file editor doesn't support charactor encoding UTF-8!!! (1.52 MB, application/octet-stream)
2007-03-28 12:29 UTC, ksupakorn
Details
a utf-8 file which still not works in netbeans (2.14 KB, application/octet-stream)
2007-08-21 03:56 UTC, windli
Details
the expected look of autopager.properties (282.04 KB, image/png)
2007-08-21 04:00 UTC, windli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ksupakorn 2007-03-28 12:22:51 UTC
From IDE menu goto Tools -> Options -> Editor -> Advance Options -> Default 
Charator Encoding only support in JavaSource only!!! so how to edit properties 
file in UTF-8 or in JSP
Comment 1 ksupakorn 2007-03-28 12:29:05 UTC
Created attachment 40083 [details]
Properties file editor doesn't support charactor encoding UTF-8!!!
Comment 2 windli 2007-05-12 14:24:37 UTC
Hope we can have this feature.
Thanks
Comment 3 windli 2007-05-12 14:25:20 UTC
Hope we can have this feature.
Thanks
Comment 4 windli 2007-05-12 14:59:42 UTC
I just find a walk through for this. In Tools -> Options -> Editor -> Advance
Options -> IDE Setting -> System -> Object Type -> DTD Objects, add properties
to the extensions and MIME Types. Then I can edit the UTF-8 encoding properties
files . But I will lose the menu assigned to properties.
I know there is a netbeans addon which add a menu to let open a file as other
type. But I don't remember what's it's name.
Comment 5 Ken Frank 2007-07-20 04:25:28 UTC
nb6 has concept of project  encoding property

is this issue about jsp files or property files ?

ken.frank@sun.com
Comment 6 Ken Frank 2007-07-20 04:27:06 UTC
nb6 has concept of project  encoding property; the java property mentioned will not be present and wont be needed.

is this issue about jsp files or property files ?

ken.frank@sun.com
Comment 7 Peter Pis 2007-08-17 07:07:09 UTC
ksupakorn, windli: Can you please check the latest builds of 6.0? There is "Encoding" property of the project that is
used for entire sources of it. Does that work for you? Thanks.
Comment 8 ksupakorn 2007-08-20 16:17:15 UTC
As of nb6.0 that is work for me. How can I close the issue?
Comment 9 windli 2007-08-21 03:56:50 UTC
Created attachment 46940 [details]
a utf-8 file which still not works in netbeans
Comment 10 windli 2007-08-21 04:00:31 UTC
Created attachment 46941 [details]
the expected look of autopager.properties
Comment 11 windli 2007-08-21 04:05:36 UTC
Hi ppis
  It's still not work for me. See the two new attached files. When I open the attached utf-8 file in netbeans, it will
not show the content correctly. And after I modify it, it will be convert to \uxxxx format. I hope the utf-8 files can
be opened and saved in utf-8 format also. Not convert the content to \uxxxx.
Is this possible in the last build?

Thanks
Wind
Comment 12 Peter Pis 2007-08-28 16:46:46 UTC
Mariane, could you please have a look at it? Thanks.
Comment 13 Marian Petras 2007-08-29 16:46:29 UTC
Properties files are always loaded/saved using encoding ISO-8859-1, with non-ASCII characters decoded/encoded from/to
\uxxxx sequences (where 'xxxx' is a sequence of four hexadecimal numbers). There is currently no way (from the user's
point of view) to specify another encoding to be used.

There is a request for enhancement named "Add support for other encodings (other than ISO-8859-1)" already filed - see
issue #75906. I have also described the current mechanism of encoding/decoding in one comment of issue #75906 (comment
filed on Apr 27 06:57:17 +0000 2007).

Marked as a duplicate of issue #75906.

*** This issue has been marked as a duplicate of 75906 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo