Bug 98955 - Progress dialog window is not closing sometimes
Progress dialog window is not closing sometimes
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
5.x
PC All
: P3 (vote)
: 6.x
Assigned To: issues@profiler
issues@profiler
: THREAD
: 60031 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-26 12:31 UTC by Alexander Kouznetsov
Modified: 2007-08-20 13:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2007-03-26 12:31:29 UTC
NB 5.5.1 RC1 200703220600

There are no exact steps to reproduce this issue (i. e. definite configuration
of packs to install). However I was able to reproduce it several times in
different configurations.

Steps to reproduce:
- Install NB 5.5.1 with Profiler and some other packs: C/C++ and Visual Web
Pack. When I experienced this behavior, I had one of the following configurations:
  - Profiler was installed on top of Visual Web Pack
  - Visual Web Pack was installed on top of Profiler installed on top of C/C++ Pack
  - C/C++ Pack was installed on top of Visual Web Pack installed on top of Profiler
- Create or open Anagram Game project
- Click Profile Application
- Select Analyze Code Fragment Performance
- Click Select Code Fragment
- Select com.toy.anagrams.ui.Anagrams class
- Select nextTrialActinoPerformed method
- Confirm Specify Code Fragment dialog
- Click Run
- RESULT: Profiling is started but empty Progress window is shown until IDE is
shut down. It seems that there are no other ways to close it.
Comment 1 Kenneth Ganfield 2007-05-21 21:35:24 UTC
I am not sure if this is related, but I am also seeing this strange behaviour
and it is affecting the Help window and other windows.

system:
NetBeans IDE 6.0 Preview (M9, build 070502)
1.5.0_07; Java HotSpot(TM) Client VM 1.5.0_07-87
Mac OS X version 10.4.9 running on i386
en_US (nb); MacRoman

Steps:
1. I open the Profile Application dialog
2. I open JavaHelp from the Help menu
The JavaHelp opens and also the mystery Progress box which says "Performing
instrumentation, please wait". There is no way to close the dialog.

But...

If I minimize the IDE, all 3 windows [javahelp, progress, IDE] "minimize".
If I now "maximize" the IDE, the IDE window opens, but the other two windows do
not appear.
If I try to open JavaHelp from the menu, nothing happens. The window does not
appear. F1 also does not work.

But...

If I open some IDE window, ie dialog, or Profile Application dialog, the dialog
opens and ALSO the JavaHelp window. If I close the Profile Application dialog,
the JavaHelp also disappears.

The JavaHelp window then seems to return to the expected behaviour 



Comment 2 J Bachorik 2007-06-21 14:24:29 UTC
*** Issue 60031 has been marked as a duplicate of this issue. ***
Comment 3 J Bachorik 2007-06-21 14:27:16 UTC
the issue was caused by synchronization problems in opening and closing asynchronous modal dialogs
it applies to the version 6.0 as well
this is fixed together with the issue #107374


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo