Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 98871 - Move method to different Type
Move method to different Type
Status: RESOLVED DUPLICATE of bug 57767
Product: editor
Classification: Unclassified
Component: Refactoring
5.x
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: issues@java
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-24 07:02 UTC by belur_1d
Modified: 2008-10-16 18:29 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description belur_1d 2007-03-24 07:02:13 UTC
Hi


How do i do this?

1> Choose a method
2> Say move to different Class 
3>Apply and Nbs then updates the references to that method

I want this feature badly and cud not figure out how to do it.


-swaroop belur
Comment 1 gglazer 2008-06-03 16:35:42 UTC
I agree that this is an important feature and much more common event than some of the more obscure refactoring choices
already in NetBeans, such as abstracting to a superclass.  A typical example involves moving a method from a worker
object to a service after it becomes known that multiple types of workers will require the same type of processing. 
Here, the method is being generalized in usage, but not with respect to inheritance, so refactoring tools like pull up,
push down, extract and so on are not useful. 
Comment 2 Jan Pokorsky 2008-10-16 18:29:32 UTC

*** This issue has been marked as a duplicate of 57767 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo