Bug 98836 - Adding network JAR file/folder fails
Adding network JAR file/folder fails
Status: RESOLVED DUPLICATE of bug 46813
Product: java
Classification: Unclassified
Component: Project
5.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-23 18:32 UTC by issawif
Modified: 2007-10-29 15:53 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description issawif 2007-03-23 18:32:42 UTC
Hello,

When adding a JAR file/folder from a network drive, I get a 
NullPointerException. Adding the same JAR file/folder from my local disk works 
fine. I have read access to the network drive.

Below is my log file output.

Thank you,
Fatima




*********** Exception occurred ************ at 1:11 PM on Mar 23, 2007
java.io.IOException
	at 
org.netbeans.modules.java.j2seproject.classpath.J2SEProjectClassPathExtender.ad
dArchiveFile(J2SEProjectClassPathExtender.java:138)
[catch] at 
org.netbeans.modules.java.j2seproject.ui.LibrariesNode$AddFolderAction.addJarFi
les(LibrariesNode.java:661)
	at 
org.netbeans.modules.java.j2seproject.ui.LibrariesNode$AddFolderAction.actionPe
rformed(LibrariesNode.java:645)
	at javax.swing.AbstractButton.fireActionPerformed
(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed
(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed
(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed
(DefaultButtonModel.java:242)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick
(BasicMenuItemUI.java:1170)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased
(BasicMenuItemUI.java:1211)
	at java.awt.Component.processMouseEvent(Component.java:6038)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3260)
	at java.awt.Component.processEvent(Component.java:5803)
	at java.awt.Container.processEvent(Container.java:2058)
	at java.awt.Component.dispatchEventImpl(Component.java:4410)
	at java.awt.Container.dispatchEventImpl(Container.java:2116)
	at java.awt.Component.dispatchEvent(Component.java:4240)
	at java.awt.LightweightDispatcher.retargetMouseEvent
(Container.java:4322)
	at java.awt.LightweightDispatcher.processMouseEvent
(Container.java:3986)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3916)
	at java.awt.Container.dispatchEventImpl(Container.java:2102)
	at java.awt.Window.dispatchEventImpl(Window.java:2429)
	at java.awt.Component.dispatchEvent(Component.java:4240)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters
(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter
(EventDispatchThread.java:183)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy
(EventDispatchThread.java:173)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:168)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:160)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
==>
java.lang.NullPointerException
	at org.openide.filesystems.FileUtil.toFile(FileUtil.java:381)
	at 
org.netbeans.modules.java.j2seproject.classpath.J2SEProjectClassPathExtender$2.
run(J2SEProjectClassPathExtender.java:114)
	at org.openide.util.Mutex.writeAccess(Mutex.java:356)
	at 
org.netbeans.modules.java.j2seproject.classpath.J2SEProjectClassPathExtender.ad
dArchiveFile(J2SEProjectClassPathExtender.java:108)
[catch] at 
org.netbeans.modules.java.j2seproject.ui.LibrariesNode$AddFolderAction.addJarFi
les(LibrariesNode.java:661)
	at 
org.netbeans.modules.java.j2seproject.ui.LibrariesNode$AddFolderAction.actionPe
rformed(LibrariesNode.java:645)
	at javax.swing.AbstractButton.fireActionPerformed
(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed
(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed
(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed
(DefaultButtonModel.java:242)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick
(BasicMenuItemUI.java:1170)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased
(BasicMenuItemUI.java:1211)
	at java.awt.Component.processMouseEvent(Component.java:6038)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3260)
	at java.awt.Component.processEvent(Component.java:5803)
	at java.awt.Container.processEvent(Container.java:2058)
	at java.awt.Component.dispatchEventImpl(Component.java:4410)
	at java.awt.Container.dispatchEventImpl(Container.java:2116)
	at java.awt.Component.dispatchEvent(Component.java:4240)
	at java.awt.LightweightDispatcher.retargetMouseEvent
(Container.java:4322)
	at java.awt.LightweightDispatcher.processMouseEvent
(Container.java:3986)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3916)
	at java.awt.Container.dispatchEventImpl(Container.java:2102)
	at java.awt.Window.dispatchEventImpl(Window.java:2429)
	at java.awt.Component.dispatchEvent(Component.java:4240)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters
(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter
(EventDispatchThread.java:183)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy
(EventDispatchThread.java:173)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:168)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:160)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
Comment 1 Jiri Prox 2007-03-27 18:28:21 UTC
What is your version/build number? 
Comment 2 issawif 2007-03-27 18:31:30 UTC
I am using the latest version of netbeans (5.5). I downloaded it last week.
Comment 3 issawif 2007-03-27 19:39:53 UTC
Version 5.5 Build 200612070100
Comment 4 Tomas Zezula 2007-06-22 09:02:11 UTC
The NetBeans doesn't support windows network drives (UNC paths).
Comment 5 Tomas Zezula 2007-10-29 15:53:10 UTC

*** This issue has been marked as a duplicate of 46813 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo