Bug 98577 - Cannot add/edit beans' property using GUI.
Cannot add/edit beans' property using GUI.
Status: RESOLVED DUPLICATE of bug 94193
Product: obsolete
Classification: Unclassified
Component: visualweb
6.x
All All
: P2 with 1 vote (vote)
: TBD
Assigned To: _ sandipchitale
issues@obsolete
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-22 00:03 UTC by _ hlu
Modified: 2007-03-22 22:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ hlu 2007-03-22 00:03:29 UTC
With NB VWP 5.5, user can edit beans', e.g. SessionBean1, ApplicationBean1
property in outline window or through source packages in project window.

With NB6 build, the add menu item is disabled in Navigator window and there is
no to edit property through source packages either.

The only way seems to edit java file.
Comment 1 _ potingwu 2007-03-22 00:08:06 UTC
Sandip should know the bean properties better.
Comment 2 _ sandipchitale 2007-03-22 22:36:09 UTC
There are multiple issues here.

1. The functionality available in the Project windows was removed by the 
NetBeans Java project support. There are several bugs related to that:

See:

http://www.netbeans.org/issues/show_bug.cgi?id=98133
http://www.netbeans.org/issues/show_bug.cgi?id=98134

2. The functionality in the Outline window was simply delegating to the 
functionality available in NetBeans java file nodes. For the same rason as 1 
now the functionality is not available.

3. IMHO this does not qualify a P1 issue as there is, albeit, long winded way 
to add properties in the Java source editor. Making it P2. This could be 
considered as a regression though from NetBeans 5.5 as well as VWP point of 
view.

*** This issue has been marked as a duplicate of 94193 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo