Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 98555 - Table component design time enhancements to support non-data provider data source
Table component design time enhancements to support non-data provider data so...
Status: VERIFIED FIXED
Product: obsolete
Classification: Unclassified
Component: visualweb
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Winston Prakash
issues@obsolete
plan60
:
: 94190 (view as bug list)
Depends on: 98864
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-21 19:34 UTC by Winston Prakash
Modified: 2007-06-21 23:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Winston Prakash 2007-03-21 19:34:08 UTC
Currently only way to bind to table component using design time binding dialog
is via Data Provider.  However, table component design time must support other
data source such as Java Collections directly with out Data Provider.
Comment 1 Winston Prakash 2007-03-24 00:03:21 UTC
Implemented the necessary infrastructure in the Table Design Time. The Table
Layout is able to get the List and Array properties in the Managed Beans, Page
where the Table is places, Session and application bean.

Still there is a a caveat. The List type must be of Type "java.util.ArrayList"
(can not be interface List). 

To solve the above need support from insync to support generic Type properties
ex. List<String>

http://www.netbeans.org/issues/show_bug.cgi?id=98864 

Comment 2 Winston Prakash 2007-05-01 03:28:22 UTC
*** Issue 94190 has been marked as a duplicate of this issue. ***
Comment 3 Winston Prakash 2007-05-18 03:22:54 UTC
Fixed
Comment 4 _ hlu 2007-06-21 23:01:19 UTC
Verified in nbi build200706201200: table layout is able to get the List and Array properties in the Managed Beans.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo