Bug 98478 - script cannot be ran when switched to native ruby interpreter
script cannot be ran when switched to native ruby interpreter
Status: VERIFIED FIXED
Product: ruby
Classification: Unclassified
Component: Code
6.x
PC Linux
: P1 (vote)
: 6.x
Assigned To: Torbjorn Norbye
issues@ruby
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-21 14:39 UTC by Tomas Danek
Modified: 2007-07-03 14:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2007-03-21 14:39:02 UTC
NetBeans IDE Dev (Build 200703201900)
1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105
Linux version 2.6.17-10-generic running on i386
cs_CZ (nb); UTF-8
------------------------
- downloaded 0.39.0 ruby from UC
- created new app (only helloworld)- ran it by F6 - OK
- switched in Tools|Options interpreter to /usr/bin/ruby
- ran F6 - /usr/bin/ruby: no such file to load -- /tmp/ud/sync-stdio.rb (LoadError)

Seem like LOAD_PATH is not set correctly?! This scenario used to work some time
ago..
Comment 1 Torbjorn Norbye 2007-03-21 16:06:19 UTC
There is an new file being installed into the userdir, but it was missing from the nbm file so this broke 
when installed via Auto Update as opposed to a kit build.

Fixed in 0.42.
Comment 2 Tomas Danek 2007-05-24 11:25:49 UTC
verified in 070523
Comment 3 Jiri Kovalsky 2007-07-03 14:14:35 UTC
Reassigning this issue to newly created 'ruby' component.
Comment 4 Jiri Kovalsky 2007-07-03 14:45:01 UTC
Changing target milestone of all resolved Ruby issues from TBD to 6.0 Beta 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo