Bug 98437 - Lookups.metaInfServices(String prefix)
Lookups.metaInfServices(String prefix)
Status: RESOLVED DUPLICATE of bug 98426
Product: platform
Classification: Unclassified
Component: Lookup
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
: API_REVIEW_FAST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-21 10:49 UTC by Jaroslav Tulach
Modified: 2008-12-22 10:58 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Contains implementation of metaInfServices(prefix) lookup (21.61 KB, patch)
2007-03-21 10:52 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2007-03-21 10:49:43 UTC
metaInfServices is nice and low cost concept - it allows registrations just by 
putting JAR files on classpath. No need for org-openide-fs or 
org-openide-loaders, etc.

However for purposes of issue 98426 it would need a bit of generalization - an 
ability to search not only META-INF/services, but do the search for any other 
prefix.

I'll attach a simple patch that does that.
Comment 1 Jaroslav Tulach 2007-03-21 10:52:15 UTC
Created attachment 39744 [details]
Contains implementation of metaInfServices(prefix) lookup
Comment 2 Jaroslav Tulach 2007-03-21 12:10:52 UTC
The previous patch contains implementation of Lookups.metaInfServices(prefix), 
plus some additional stuff that can be ignored. Are there any objections 
against the new metaInfServices method?
Comment 3 Jesse Glick 2007-03-21 22:19:06 UTC
I don't see what the intended purpose of this is. We already have too many
registration mechanisms in NB, IMHO - this would just add one more.
Comment 4 Jaroslav Tulach 2007-04-16 21:48:13 UTC

*** This issue has been marked as a duplicate of 98426 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo