Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 98212 - Catalog fails on Mac/Linux from root folder '/'
Catalog fails on Mac/Linux from root folder '/'
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Catalog
6.x
Macintosh Mac OS X
: P1 (vote)
: 6.x
Assigned To: Samaresh Panda
issues@xml
: PERFORMANCE, THREAD
Depends on:
Blocks: 111875 113345 113450
  Show dependency treegraph
 
Reported: 2007-03-19 14:57 UTC by Martin Grebac
Modified: 2008-04-02 08:54 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Catalog (500 bytes, text/xml)
2007-03-19 14:59 UTC, Martin Grebac
Details
NB log file (214.50 KB, text/plain)
2007-03-19 15:00 UTC, Martin Grebac
Details
Test Project (20.45 KB, application/octet-stream)
2007-03-19 15:09 UTC, Martin Grebac
Details
WSIT Configuration Image (147.87 KB, application/octet-stream)
2007-03-20 23:42 UTC, Samaresh Panda
Details
Ubuntu Screenshot (149.24 KB, application/octet-stream)
2007-03-21 00:35 UTC, tonybeckham
Details
wsit-config.png (23.78 KB, image/png)
2007-03-21 09:07 UTC, ritzmann
Details
new resolver jar (82.12 KB, application/octet-stream)
2007-08-16 19:21 UTC, Samaresh Panda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Grebac 2007-03-19 14:57:20 UTC
With NB 5.5.1 and WSIT plugins or EPack, open attached project and:
- Open Web Service References node
- Right-click on TestService
- Choose Edit Web Service Attributes
- Select WSIT Configuration
-> The WSIT Configuration window is empty

There is a atack trace from catalog resolver, which works on other systems.

The project, catalog file and messages.log are attached
Comment 1 Martin Grebac 2007-03-19 14:59:23 UTC
Created attachment 39624 [details]
Catalog
Comment 2 Martin Grebac 2007-03-19 15:00:25 UTC
Created attachment 39625 [details]
NB log file
Comment 3 Martin Grebac 2007-03-19 15:09:37 UTC
Created attachment 39626 [details]
Test Project
Comment 4 Samaresh Panda 2007-03-19 22:38:39 UTC
AFAIK, we are not going to have a 5.5.1 release, so IMO you should try this on
6.0 instead.

Please let us know if this fix is indeed needed in 5.5.1 branch? If not, please
update the issue with your observation in 6.0 and we'll be very happy to work on it.
Comment 5 Martin Grebac 2007-03-20 07:30:36 UTC
Yes, it's needed. There will be NetBeans IDE 5.5.1 release and WSIT modules will
be provided on Update Center independently on EPack.
Comment 6 Samaresh Panda 2007-03-20 23:42:01 UTC
Created attachment 39725 [details]
WSIT Configuration Image
Comment 7 Samaresh Panda 2007-03-20 23:49:43 UTC
I Installed latest EntPack build from http://www.netbeans.info/downloads/dev.php
(Select 5.5.1 and Daily) that is, build 200703130600 for IDE and 20070312_7 for
EntPack. I'm unable to reproduce the same, nor do I see any exception in log
file. See attached image.

I'm CC'ing mikhail and tony so that they can also try.

Comment 8 Samaresh Panda 2007-03-20 23:54:30 UTC
How did you install EntPack and which build are you using? Have you tried this
on a fresh userdir?
Comment 9 tonybeckham 2007-03-21 00:35:09 UTC
I did a fresh install of EP 5.5.1 on Mac Intel.  I see the same thing as the
screen shot.  I guess that you are saying that the fields under Secure Token
Services node should be filled in?  They definitely are not.  I also did a clean
install on Ubuntu Linux and get the same results.  I am going to attach
screenshot for Ubuntu, no use doing another Mac one since it is the same.
Comment 10 tonybeckham 2007-03-21 00:35:59 UTC
Created attachment 39726 [details]
Ubuntu Screenshot
Comment 11 ritzmann 2007-03-21 09:07:29 UTC
Created attachment 39740 [details]
wsit-config.png
Comment 12 ritzmann 2007-03-21 09:08:07 UTC
Steps to reproduce on a Powerbook G4 with Mac OS X 10.4.9:

1. Download NB 5.5.1 IDE daily build for Mac OS X:
http://www.netbeans.info/downloads/all.php?b_id=2902&src=1

2. Download WSIT plugin:
http://websvc.netbeans.org/servlets/ProjectDocumentList?folderID=123&expandFolder=123&folderID=115

3. Unpack NetBeans and in etc/netbeans.conf set
netbeans_default_userdir="${HOME}/.netbeans/5.5.1test"

4. Start NetBeans

5. Install WSIT plugins, select "restart IDE"

6. After IDE was restarted, close IDE and start once more so that WSIT plugins
actually get installed. BTW, sounds like another bug to me.

7. Open client project. Ignore warning about missing server. (I configured a
server later, doesn't make a difference.)

8. Wait forever (2+ minutes) until classpaths are scanned. (I guess you don't
need to wait, just wanted to mention how long it takes.)

9. Open Web Service References / TestService node, right click and select Edit
Web Service Attributes.

Result is attached:
http://www.netbeans.org/nonav/issues/showattachment.cgi/39740/wsit-config.png
Comment 13 tonybeckham 2007-03-21 17:39:46 UTC
I know the wait for scanning can take some time, I had a PowerBook G4 for a few
years.  Performance was so slow it wasn't worth using for work anymore.  I
recently got a MackBook Pro and can say that scanning only takes a few seconds
instead of a few minutes.
Comment 14 tonybeckham 2007-03-21 18:03:05 UTC
I get NPE when trying the latest steps. With build 200703210600, Intel Mac, and
WSIT nbms from the link.

java.lang.NullPointerException
	at org.netbeans.modules.websvc.wsitconf.util.Util.isWsitSupported(Util.java:355)
	at
org.netbeans.modules.websvc.wsitconf.WSITEditor.createWSEditorComponent(WSITEditor.java:104)
	at
org.netbeans.modules.websvc.core.wseditor.support.EditWSAttributesTopComponent.addTabs(EditWSAttributesTopComponent.java:48)
[catch] at
org.netbeans.modules.websvc.core.wseditor.support.EditWSAttributesCookieImpl$1.run(EditWSAttributesCookieImpl.java:83)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 15 tonybeckham 2007-03-21 18:39:43 UTC
Okay, I registered an instance of glassfish and was able to get the same result
as ritzmann's screen shot, a blank WSIT tab.
Comment 16 Samaresh Panda 2007-03-21 23:36:15 UTC
I did try exactly as you said and I do not see any problems. Also I checked out
5.5.1 source, built it locally and tried to reproduce, but no luck. I do not see
a blank WSIT configuration tab.

What JDK are you using?

Comment 17 ritzmann 2007-03-22 07:18:49 UTC
> What JDK are you using?

The one that is delivered and supported with OS X 10.4.9. See the log file:

http://www.netbeans.org/nonav/issues/showattachment.cgi/39625/messages.log
Comment 18 Samaresh Panda 2007-03-26 21:41:04 UTC
Its very hard to fix it if I'm unable to reproduce. I saw the problem in Tony's
Mac as well, but the bits he used cannot be used for debugging purposes. I gave
him locally built bits and we were not able to reproduce it again. And I cannot
reproduce this in my Mac even with the downloaded bits from site.
Comment 19 ritzmann 2007-03-27 16:30:12 UTC
Unfortunately, it's 100% reproducible for me. :/ I just tried out the enterprise
pack and that works for me, so at least I am not completely stuck.
Comment 20 ritzmann 2007-03-27 17:22:57 UTC
Following the steps I posted earlier, it is 100% reproducible. If I install the
enterprise pack instead of the WSIT plugin, the problem does not occur.
Comment 21 tonybeckham 2007-03-27 17:32:39 UTC
The problem you are having is that the daily builds have not made a new
iteration since 3/20.  The bits that Sam mentioned that he built locally where
the problem was fixed even for me have not been pushed out as a daily build. 
There is an RC1 available but that didn't even get whatever changes made Sam's
build work.  I'm still waiting for some new bits to come down the pipe and
verify that this is no longer an issue.
Comment 22 tonybeckham 2007-04-03 00:36:42 UTC
Looks like there are new WSIT modules available at
http://websvc.netbeans.org/servlets/ProjectDocumentList?folderID=123&expandFolder=123&folderID=115

There still is the problem that without EnterprisePack, Base NB and the WSIT
NBMs still have the blank tab.  With the latest Gavotte daily or a Hula build
this doesn't happen.

Sam, I think we need to look at this again.
Comment 23 tonybeckham 2007-04-03 20:32:37 UTC
We decided to look at this again later. Reducing priority to P3.
Comment 24 Martin Grebac 2007-04-06 08:05:55 UTC
If you look at nbentpack alias (response to announce of Netbeans6.0 pack), there
seem to be more people running into this issue, so I'm raising priority again.
Comment 25 Martin Grebac 2007-04-06 08:10:26 UTC
This is the post from forum:

OK, I dowloaded the Mac OS X X86 version.

I had to download the installer manually -- the auto-download was pushing
the package to the Safari main window.

Then I had to fix the permissions on the .command file itself.

The installer worked.

I opened 2 WSIT projects I had from my Netbeans 5.5.1 beta work -- the
Calculator server application and the Calculator servlet client. I made this
following the WSIT tutorial instructions.

I was able to deploy the server application.

Trying to open the WSIT configuration dialog for the web service reference
for the client throws a null pointer exception.

I tried to report the bug using the Issuezilla dialog but nothing appears to
happen when I click the submit button.

The start of the exception trace looks like:

INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found
in ProxySelector[Type: 1] for uri ftp://basename/./xcatalog. 
java.net.UnknownHostException: basename
java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
java.net.Socket.connect(Socket.java:516)
java.net.Socket.connect(Socket.java:466)
sun.net.NetworkClient.doConnect(NetworkClient.java:157)
sun.net.NetworkClient.openServer(NetworkClient.java:118)
sun.net.ftp.FtpClient.openServer(FtpClient.java:488)
sun.net.ftp.FtpClient.openServer(FtpClient.java:475)
sun.net.www.protocol.ftp.FtpURLConnection.connect(FtpURLConnection.java:270)
sun.net.www.protocol.ftp.FtpURLConnection.getInputStream(FtpURLConnection.java:352)
java.net.URL.openStream(URL.java:1007)
org.apache.xml.resolver.Catalog.parseCatalogFile(Catalog.java:875)
org.apache.xml.resolver.Catalog.parsePendingCatalogs(Catalog.java:779)
org.apache.xml.resolver.Catalog.parseCatalog(Catalog.java:627)
org.apache.xml.resolver.Catalog.loadSystemCatalogs(Catalog.java:602)
org.apache.xml.resolver.CatalogManager.getPrivateCatalog(CatalogManager.java:727)
org.apache.xml.resolver.CatalogManager.getCatalog(CatalogManager.java:754)
org.apache.xml.resolver.tools.CatalogResolver.initializeCatalogs(CatalogResolver.java:124)
org.apache.xml.resolver.tools.CatalogResolver.<init>(CatalogResolver.java:119)
org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.resolveUsingApacheCatalog(CatalogModelImpl.java:413)
org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.resolveUsingApacheCatalog(CatalogModelImpl.java:393)
org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.resolveUsingPublicCatalog(CatalogModelImpl.java:343)
org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.resolveUsingCatalog(CatalogModelImpl.java:291)
org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.getModelSource(CatalogModelImpl.java:127)
org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.getModelSource(CatalogModelImpl.java:206)
org.netbeans.modules.websvc.wsitconf.wsdlmodelext.WSITModelSupport.getModelForClient(WSITModelSupport.java:157)
org.netbeans.modules.websvc.wsitconf.wsdlmodelext.WSITModelSupport.getModel(WSITModelSupport.java:103)
org.netbeans.modules.websvc.wsitconf.WSITEditor.createWSEditorComponent(WSITEditor.java:158)
org.netbeans.modules.websvc.core.wseditor.support.EditWSAttributesTopComponent.addTabs(EditWSAttributesTopComponent.java:48)
org.netbeans.modules.websvc.core.wseditor.support.EditWSAttributesCookieImpl$1.run(EditWSAttributesCookieImpl.java:83)
java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found
in ProxySelector[Type: 1] for uri
ftp://basename/Users/jjs/CalculatorServletClient/catalog.xml.
Comment 26 tonybeckham 2007-04-23 20:25:27 UTC
This issue seams to be fixed now.  All WSIT tabs are populated.  I noticed this
is working in the following System:
NetBeans IDE Dev (Build 070423)
1.5.0_07; Java HotSpot(TM) Client VM 1.5.0_07-87
Mac OS X version 10.4.9 running on i386
en_US (nb); MacRoman

Comment 27 tonybeckham 2007-04-23 20:27:54 UTC
Forget about my last comment.
I realized as I submitted that this issue is for 5.5.1 w/ WSIT plugins and I am
using 6.0 w/ SOA pack.
Comment 28 Samaresh Panda 2007-07-18 01:37:22 UTC
I was not able to reproduce this on 5.5.1, now I do not have a Mac. Has anyone tried this on 6.0?
Comment 29 tonybeckham 2007-07-18 17:38:40 UTC
Product Version: NetBeans IDE Dev (Build 200707171200) 
Java: 1.5.0_07; Java HotSpot(TM) Client VM 1.5.0_07-87 
System: Mac OS X version 10.4.10 running on i386; MacRoman; en_US (nb)

This problem has become obsolete because now Web Service security dialog has been completely redesigned for 6.0 and can
no longer be reproduced.

I recommend closing this bug at this time.
Comment 30 tonybeckham 2007-07-18 18:33:26 UTC
Spoke with Sam on this and he agrees we should close this as works for me and set target milestone to 6.0
See above comment for more clarificatoin.
Comment 31 Vladimir Yaroslavskiy 2007-08-09 14:43:35 UTC
I can reproduce it: build 200708081200 on Mac OS X Intel with JDK 1.5.0_07

1. *IMPORTANT*: Run IDE from root path "/" or clicking on icon
   on desktop (it runs IDE from "/" too)
2. Open attached project
3. Right-click on TestService
4. Choose Edit Web Service Attributes
5. Select WSIT Configuration

=> The WSIT Configuration window is empty.

The same situation on Linux too.
Comment 32 Vladimir Yaroslavskiy 2007-08-09 14:52:49 UTC
The problem is that IDE runs from root folder "/"
you can reproduce it from command lime/terminal:
$ cd /
$ /Users/<user>/netbeans/bin/netbeans

if you run from another folder, it works fine.
Comment 33 Vladimir Yaroslavskiy 2007-08-09 14:59:08 UTC
Increasing priority because it blocks P1 issue 111875.

You can see the root of problem in another way:

1. Start IDE from root folder "/"
2. Create Samples | SOA | SynchronousSample project
3. Open SynchronousSample.bpel from SynchronousSample

=> exception on console and bpel has validation error (can't
resolve SynchronousSample.wsdl file).

java.io.IOException: Server returned HTTP response code: 504 for URL: ftp://basename/./xcatalog
   at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1152)
   at sun.net.www.protocol.ftp.FtpURLConnection.getInputStream(FtpURLConnection.java:356)
   at java.net.URL.openStream(URL.java:1007)
   at org.apache.xml.resolver.Catalog.parseCatalogFile(Catalog.java:875)
   at org.apache.xml.resolver.Catalog.parsePendingCatalogs(Catalog.java:779)
   at org.apache.xml.resolver.Catalog.parseCatalog(Catalog.java:627)
   at org.apache.xml.resolver.Catalog.loadSystemCatalogs(Catalog.java:602)
   at org.apache.xml.resolver.CatalogManager.getPrivateCatalog(CatalogManager.java:727)
   at org.apache.xml.resolver.CatalogManager.getCatalog(CatalogManager.java:754)
   at org.apache.xml.resolver.tools.CatalogResolver.initializeCatalogs(CatalogResolver.java:124)
   at org.apache.xml.resolver.tools.CatalogResolver.<init>(CatalogResolver.java:119)
   at org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.resolveUsingApacheCatalog(CatalogModelImpl.java:440)
   at org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.resolveUsingApacheCatalog(CatalogModelImpl.java:420)
   at org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.resolveUsingPublicCatalog(CatalogModelImpl.java:364)
   at org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.resolveUsingCatalog(CatalogModelImpl.java:312)
   at org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.getModelSource(CatalogModelImpl.java:139)
   at org.netbeans.modules.bpel.model.api.support.ImportHelper.getWsdlModel(ImportHelper.java:85)
   at org.netbeans.modules.bpel.model.api.support.ImportHelper.getWsdlModel(ImportHelper.java:118)
   at org.netbeans.modules.bpel.model.api.support.ImportHelper.getWsdlModel(ImportHelper.java:109)
   at
org.netbeans.modules.bpel.model.impl.references.ExternalModelRetrieverImpl.collectWsdlModelsViaImports(ExternalModelRetrieverImpl.java:117)
   at
org.netbeans.modules.bpel.model.impl.references.ExternalModelRetrieverImpl.getWSDLModels(ExternalModelRetrieverImpl.java:60)
   at org.netbeans.modules.bpel.model.impl.references.WSDLReferenceBuilder.getModels(WSDLReferenceBuilder.java:185)
   at org.netbeans.modules.bpel.model.impl.references.WSDLReferenceBuilder.getWSDLModels(WSDLReferenceBuilder.java:178)
   at org.netbeans.modules.bpel.model.impl.references.WSDLReferenceBuilder.getWSDLModels(WSDLReferenceBuilder.java:167)
   at org.netbeans.modules.bpel.model.impl.references.PartnerLinkTypeResolver.resolve(WSDLReferenceBuilder.java:629)
   at org.netbeans.modules.bpel.model.impl.references.GlobalWSDLReferenceImpl.get(GlobalWSDLReferenceImpl.java:58)
   at org.netbeans.modules.bpel.model.impl.references.GlobalWSDLReferenceImpl.get(GlobalWSDLReferenceImpl.java:34)
   at org.netbeans.modules.bpel.model.impl.references.RoleResolver.resolve(WSDLReferenceBuilder.java:751)
   at org.netbeans.modules.bpel.model.impl.references.WSDLReferenceImpl.get(WSDLReferenceImpl.java:53)
   at org.netbeans.modules.bpel.model.impl.references.WSDLReferenceImpl.get(WSDLReferenceImpl.java:36)
   at org.netbeans.modules.bpel.properties.props.editors.ModelReferenceEditor.getValue(ModelReferenceEditor.java:69)
   at org.openide.explorer.propertysheet.PropUtils.updateEdFromProp(PropUtils.java:863)
   at org.openide.explorer.propertysheet.PropUtils.getPropertyEditor(PropUtils.java:826)
   at org.openide.explorer.propertysheet.ReusablePropertyModel.getPropertyEditor(ReusablePropertyModel.java:79)
   at org.openide.explorer.propertysheet.RendererFactory.preparePropertyEditor(RendererFactory.java:237)
   at org.openide.explorer.propertysheet.RendererFactory.getRenderer(RendererFactory.java:145)
   at org.openide.explorer.propertysheet.SheetCellRenderer.getTableCellRendererComponent(SheetCellRenderer.java:129)
   at org.openide.explorer.propertysheet.BaseTable.prepareRenderer(BaseTable.java:586)
   at org.openide.explorer.propertysheet.SheetTable.prepareRenderer(SheetTable.java:515)
   at javax.swing.plaf.basic.BasicTableUI.paintCell(BasicTableUI.java:2070)
   at javax.swing.plaf.basic.BasicTableUI.paintCells(BasicTableUI.java:1972)
   at javax.swing.plaf.basic.BasicTableUI.paint(BasicTableUI.java:1895)
   at javax.swing.plaf.ComponentUI.update(ComponentUI.java:154)
   at javax.swing.JComponent.paintComponent(JComponent.java:742)
   at org.openide.explorer.propertysheet.BaseTable.paintComponent(BaseTable.java:950)
   at org.openide.explorer.propertysheet.SheetTable.paintComponent(SheetTable.java:421)
   at javax.swing.JComponent.paint(JComponent.java:1005)
   at org.openide.explorer.propertysheet.BaseTable.paint(BaseTable.java:636)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JViewport.paint(JViewport.java:726)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1021)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at org.netbeans.core.windows.view.ui.MultiSplitPane.paint(MultiSplitPane.java:294)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JLayeredPane.paint(JLayeredPane.java:559)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JLayeredPane.paint(JLayeredPane.java:559)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at java.awt.GraphicsCallback$PaintCallback.run(GraphicsCallback.java:34)
   at sun.awt.SunGraphicsCallback.runOneComponent(SunGraphicsCallback.java:60)
   at sun.awt.SunGraphicsCallback.runComponents(SunGraphicsCallback.java:97)
   at java.awt.Container.paint(Container.java:1722)
   at org.netbeans.core.windows.view.ui.MainWindow.paint(MainWindow.java:509)
   at sun.awt.RepaintArea.paintComponent(RepaintArea.java:276)
   at sun.awt.RepaintArea.paint(RepaintArea.java:241)
   at apple.awt.ComponentModel.handleEvent(ComponentModel.java:251)
   at apple.awt.CWindow.handleEvent(CWindow.java:175)
   at java.awt.Component.dispatchEventImpl(Component.java:4097)
   at java.awt.Container.dispatchEventImpl(Container.java:2068)
   at java.awt.Window.dispatchEventImpl(Window.java:1774)
   at java.awt.Component.dispatchEvent(Component.java:3869)
   at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
   at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
   at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
   at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 34 Samaresh Panda 2007-08-09 16:22:02 UTC
Tony, I do not have a Mac. Would you please try the same and update the issue with your observation?
Comment 35 tonybeckham 2007-08-09 18:19:19 UTC
I can confirm this as described on Mac OS X.  When starting from "/" WSIT tab is blank, and also the BPEL Synchronous
Sample project  SynchronousSample.bpel issue is confirmed.  I will try on linux too.  
Comment 36 tonybeckham 2007-08-09 18:27:37 UTC
Product Version: NetBeans IDE Dev (Build 200708080000) 
Java: 1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105 System: 
Linux version 2.6.20-16-generic running on i386; UTF-8; en_US (nb)

I can also reproduce bpel file problem and blank tab problem when starting the IDE from "/" on linux.
Comment 37 tonybeckham 2007-08-09 21:06:35 UTC
I should have added to my earlier comments that the same results occur when launching the IDE from the icon on Mac OS X
as described.  However,on linux, launching the IDE from the icon does not have the same results.  On linux it only
happens when you explicitly start the IDE from "/".
Comment 38 Samaresh Panda 2007-08-11 01:11:25 UTC
I'm able to reproduce the problem, however, I do not have a solution for this yet. As you can see, the traces are coming
from org.apache.xml.resolver. I didn't find any problem with the retriever code so far.
Comment 39 Samaresh Panda 2007-08-16 16:07:48 UTC
One more issue: 112679, same traces are seen in the log file, possibly the same remedy, if there is one.
Comment 40 _ rkubacki 2007-08-16 18:47:12 UTC
Connecting to network from EDT and waiting for timeouts? Isn't this apparently wrong? Can someone clarify how API in
XML/retriever is designed wrt threading? Either it must document that it can take a long time to complete the request
and then all usages has to be reviewed (including one in issue #111875) or it has to perform well and probably do its
work asynchronously.
Comment 41 Samaresh Panda 2007-08-16 19:17:49 UTC
Radim, I totally agree with you. I'm not the original author of this module, nor do I know a lot of history behind this.
Please add your comments on retriever on issue: 107752. I'll try to fix as much as I can.
Comment 42 Samaresh Panda 2007-08-16 19:20:01 UTC
We use a third party jar from Apache. I have a new resolver jar (see attachment) that fixes the problem. I've verified
this locally on my linux box. However I would like you and hong to verify the same. Here is what you need to do:

Copy the attached jar to <NB_INSTALL_DIR>/netbeans/ide8/modules/ext and restart the IDE.

You may see a lot of INFO exceptions in console, but thats OK, do not panic. I just want you to verify if the issues get
resolved or not? Once you guys verify the same, I'll see how the console messages can be suppressed.

Comment 43 Samaresh Panda 2007-08-16 19:21:10 UTC
Created attachment 46762 [details]
new resolver jar
Comment 44 Vladimir Yaroslavskiy 2007-08-17 09:37:45 UTC
I tried with patch on SunOS version 5.10 running on x86, it works fine.
Comment 45 tonybeckham 2007-08-17 16:54:14 UTC
The patch works for Mac OS.
Comment 46 Samaresh Panda 2007-08-21 00:46:25 UTC
I've couple of questions w.r.t. the naming/patching/licensing of this jar and as soon as I have the right answer I'll
commit the jar. Please stay tuned.
Comment 47 Samaresh Panda 2007-08-22 19:29:35 UTC
Added:
/cvs/libs/resolver/external/resolver.jar,
initial revision: 1.1
/cvs/libs/resolver/external/resolver.patch,v  <--  resolver.patch
initial revision: 1.1
/cvs/libs/resolver/external/resolver-license.txt,v  <--  resolver-license.txt
initial revision: 1.1
/cvs/libs/resolver/external/readme.txt,v  <--  readme.txt
initial revision: 1.1

Removed:
/cvs/libs/resolver/external/resolver-1_1_nb.jar
/cvs/libs/resolver/external/resolver-1_1_nb.patch
/cvs/libs/resolver/external/resolver-1_1_nb-license.txt

Updated:
/cvs/libs/resolver/nbproject/project.properties,
new revision: 1.4; previous revision: 1.3
/cvs/libs/resolver/nbproject/project.xml
new revision: 1.4; previous revision: 1.3
/cvs/libs/resolver/manifest.mf,
new revision: 1.4; previous revision: 1.3
/cvs/libs/resolver/src/org/apache/xml/resolver/Bundle.properties,
new revision: 1.3; previous revision: 1.2
Comment 48 tonybeckham 2007-11-01 18:59:22 UTC
Fix Verified

Product Version: NetBeans IDE Dev (Build 200710310000)
Java: 1.5.0_13; Java HotSpot(TM) Client VM 1.5.0_13-119
System: Mac OS X version 10.5 running on i386; MacRoman; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo