Bug 98150 - Provide SPI for Ruby Debugger implementation
Provide SPI for Ruby Debugger implementation
Status: RESOLVED FIXED
Product: ruby
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Martin Krauskopf
issues@ruby
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-18 08:28 UTC by Martin Krauskopf
Modified: 2007-07-03 14:46 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Krauskopf 2007-03-18 08:28:25 UTC
I would start with minimalistic:

 org.netbeans.modules.ruby.rubyproject.spi.RubyDebuggerImplementation

which I will implement in the debugger. I'll do it.
Comment 1 Martin Krauskopf 2007-03-18 10:03:27 UTC
Checking in
projects/src/org/netbeans/modules/ruby/rubyproject/spi/RubyDebuggerImplementation.java;
initial revision: 1.1
Checking in projects/nbproject/project.xml;
new revision: 1.9; previous revision: 1.8
Checking in
projects/src/org/netbeans/modules/ruby/rubyproject/RubyActionProvider.java;
new revision: 1.8; previous revision: 1.7
Comment 2 Jiri Kovalsky 2007-07-03 14:07:20 UTC
Reassigning this issue to newly created 'ruby' component.
Comment 3 Jiri Kovalsky 2007-07-03 14:46:48 UTC
Changing target milestone of all resolved Ruby issues from TBD to 6.0 Beta 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo