Bug 98071 - focus lost in ide
focus lost in ide
Status: CLOSED DUPLICATE of bug 97249
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
: FOCUS, JDK_SPECIFIC
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-16 11:30 UTC by Radim Roska
Modified: 2011-06-09 09:56 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Radim Roska 2007-03-16 11:30:15 UTC
NetBeans IDE Dev (Build 200703151900)
1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105
Linux version 2.6.17-11-generic running on i386
en_US (nb); UTF-8

ubuntu edgy
gnome 2.6.1 running on 7.1 X server with aiglx extensions, but its not depend on
wm..i have tried fluxbox as well


I lost focus almost immediately when start working in ide..like 
1. ctrl+shift+n -> new project
2. close wizard
3. no matter what i press on keyboard, nb doesnt care. But if i open any menu
with mouse( like new project again )..in wizard keyboard is working. But after
that...again i cannot write code or use keyboard shortcuts.

but when using nb with 1.5 jdk...focus lost doesnt happen.
Comment 1 Jana Maleckova 2007-03-16 17:04:00 UTC
It could cause jdk version, I'll send it for evaluationg
There is similar bug, see, this could be duplicate of this issue
http://www.netbeans.org/issues/show_bug.cgi?id=73960
Comment 2 Radim Roska 2007-04-13 10:41:59 UTC
I already know what cause this problem at my computer.

this env. variable has to be set, if you wanna use java app in beryl
(compositing window manager)

export AWT_TOOLKIT=MToolkit

and also this is the cause of focus lost 
Comment 3 David Simonek 2007-09-10 16:27:13 UTC
Very similar bug to 97249, I'm making duplicate as it contains more info. Unfortunately it's JDK, not directly Netbeans
related it looks like. Please write any further findings, reproducible set of steps into 97249.

*** This issue has been marked as a duplicate of 97249 ***
Comment 4 Marian Mirilovic 2011-06-09 09:56:13 UTC
v/c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo