Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 97533 - Go To is missing in Source view
Go To is missing in Source view
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: WSDL Tools
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Shivanand Kini
issues@xml
:
: 100889 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-09 01:52 UTC by htt
Modified: 2007-06-20 23:39 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description htt 2007-03-09 01:52:45 UTC
Open a sample .wsdl file.
In WSDL or Partner view, right-click an element : Go To is avaliable.
In Source view, right-click an element : Go To is not available.
Comment 1 Shivanand Kini 2007-06-09 02:09:56 UTC
*** Issue 100889 has been marked as a duplicate of this issue. ***
Comment 2 Shivanand Kini 2007-06-09 02:49:55 UTC
Added this feature.

Also selection in source, updates property sheet and navigator content.

For components that are visible in partner view, go to partner is also shown.
Comment 3 jlautz 2007-06-20 23:39:32 UTC
Verified in 
Product Version: NetBeans IDE Dev (Build 200706190000, C/C++ Pack 20070619) Java: 1.6.0_01; Java HotSpot(TM) Client VM
1.6.0_01-b06 System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb) Userdir: C:\Documents and
Settings\lautz\.netbeans\dev

"Go To -> WSDL" or "Go To -> Partner" are available on WSDL elements as appropriate (partner is only available when an
element would be displayed in the partner view.

However, I noticed that if I choose "Go To -> Partner" and the element is inside a collapsed widget in the Partner view,
the element is not displayed as highlighted in the Partner view. This behavior is inconsistent with the "Go To -> WSDL"
behavior, where the WSDL tree is expanded as needed to show the selected element. This has been logged as issue 107542.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo