Bug 97366 - Deadlock while opening nbbuild/ project
Deadlock while opening nbbuild/ project
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Freeform
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Milan Kubec
issues@java
: THREAD
: 97443 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-07 11:43 UTC by David Strupl
Modified: 2007-03-09 11:07 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Build info + thread dump. (49.55 KB, text/plain)
2007-03-07 11:43 UTC, David Strupl
Details
patch file (1.53 KB, patch)
2007-03-08 08:19 UTC, Milan Kubec
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Strupl 2007-03-07 11:43:07 UTC
Will attach the relevant dump.
Comment 1 David Strupl 2007-03-07 11:43:53 UTC
Created attachment 39249 [details]
Build info + thread dump.
Comment 2 Milan Kubec 2007-03-07 13:24:35 UTC
Not reproducible for me.
Comment 3 David Strupl 2007-03-07 13:56:05 UTC
100% reproducible in my setup. Steps:

1. Take a fresh build with a fresh user dir
2. As a first project try to open project nbbuild (in NB sources)
3. Freeze is while scanning "antsrc" ...

This is in no way random here.
Comment 4 David Strupl 2007-03-07 13:57:19 UTC
The trick here is not to have any other projects opened ...
Comment 5 Milan Kubec 2007-03-07 14:31:49 UTC
Yes, with provided info it seems reproducible, I got a bit different thread dump
though. Removing RANDOM, leaving as P2, since there is workaround. Do you agree?
Comment 6 David Strupl 2007-03-07 15:03:54 UTC
I don't care whether it is P1 or P2 as long as someone fixes it promptly ;-)

Please attach also your thread dump so we can see how different it is (and
whether the same change will fix both).
Comment 7 Milan Kubec 2007-03-07 15:28:28 UTC
After careful reading both dumps I realized they both show the same problem.
Comment 8 Jan Lahoda 2007-03-08 06:44:44 UTC
*** Issue 97443 has been marked as a duplicate of this issue. ***
Comment 9 Jesse Glick 2007-03-08 07:07:25 UTC
Also happening to me. Cannot seem to open nbbuild at all. Note that I had other
projects open.
Comment 10 Milan Kubec 2007-03-08 08:19:18 UTC
Created attachment 39292 [details]
patch file
Comment 11 Milan Kubec 2007-03-08 08:21:36 UTC
Patch file is attached. Honzo please could take a look at it. Thanks.
Comment 12 Milan Kubec 2007-03-09 11:07:33 UTC
Done. Taking read access to prevent deadlock during opening project.

Checking in Classpaths.java;
/cvs/java/freeform/src/org/netbeans/modules/java/freeform/Classpaths.java,v  <--
 Classpaths.java
new revision: 1.12; previous revision: 1.11
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo