Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 97300 - Black diagram images in report on mac
Black diagram images in report on mac
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: Reporting
5.x
All Mac OS X
: P2 (vote)
: 6.x
Assigned To: Yang Su
issues@uml
release55_fixes_fixed
:
Depends on: 82394
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-06 16:38 UTC by Sergey Petrov
Modified: 2007-08-03 13:06 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Petrov 2007-03-06 16:38:09 UTC
reproducible with 070304
java 1.5.07

steps:
1. create diagram
2. add several elements
3. generate report
4. open diagram in the report
it's a black rectangle for all sizes (zoom, full image etc)

it may be a regression
Comment 1 Sergey Petrov 2007-03-06 17:11:17 UTC
the same for export as image
Comment 2 Sergey Petrov 2007-03-06 17:16:56 UTC
can't reproduce with 1.6
Comment 3 Sergey Petrov 2007-03-06 17:28:18 UTC
works on 1.5 with flag from  Issue 78346 (initially suggested as flag for
performance improvement)
Comment 4 Peter Lam 2007-03-07 05:21:22 UTC
Actually using jdk 1.6, the 2nd size (press the minus size once to zoom out) of
the image is also black. The largest and smallest images are ok. It's really
just background color that is very very dark.
Comment 5 Peter Lam 2007-03-20 20:05:49 UTC
low use case not currently impacting our installed user base.
Comment 6 Yang Su 2007-06-01 02:25:33 UTC
It's fixed as a result of fix to issue 82394
Comment 7 Peter Lam 2007-06-07 00:21:40 UTC
verified in build netbeans-hudson-trunk-346-full.zip (20070606)
Comment 8 Peter Lam 2007-07-13 08:52:16 UTC
for the record. verified for backport to NB5.5/5.5.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo