Bug 97283 - Statically held resources in profiler modules
Statically held resources in profiler modules
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P3 (vote)
: 7.0
Assigned To: issues@profiler
issues@profiler
: PERFORMANCE, VISUALVM
: 158649 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-06 14:10 UTC by _ rkubacki
Modified: 2010-10-09 15:27 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ rkubacki 2007-03-06 14:10:29 UTC
Classes in profiler modules commonly hold references to icons and/or bundles in
statis variables. This means that their classloading can be slower than
necessary (so it can contribute to #96897) and these cannot be GCed.

As I do not see sources at this moment I can only look at results from 

ant -f core/test/build.xml -Dxtest.attribs=performance
Comment 1 Tomas Hurka 2007-11-07 10:35:53 UTC
Changing target milestone to dev, since NetBeans 6.0 is in high resistance mode.
Comment 2 J Bachorik 2008-03-28 16:28:00 UTC
changing milestone
Comment 3 Jiri Sedlacek 2009-04-14 15:06:08 UTC
*** Issue 158649 has been marked as a duplicate of this issue. ***
Comment 4 J Bachorik 2010-10-06 08:12:42 UTC
fixed

changeset:   178855:6b385efca54b
tag:         tip
user:        Jaroslav Bachorik <yardus@netbeans.org>
date:        Wed Oct 06 10:11:05 2010 +0200
summary:     #97283 - removing certain statically held references to ResourceBundles
Comment 5 Quality Engineering 2010-10-09 15:27:03 UTC
Integrated into 'main-golden', will be available in build *201010090000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/6b385efca54b
User: Jaroslav Bachorik <yardus@netbeans.org>
Log: #97283 - removing certain statically held references to ResourceBundles


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo