Bug 97072 - Safe delete not available for packages.
Safe delete not available for packages.
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Refactoring
6.x
All All
: P3 (vote)
: 6.x
Assigned To: _ bharathch
issues@java
plan61
: PLAN
: 119623 119624 124869 (view as bug list)
Depends on: 92443
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-02 11:33 UTC by Radim Roska
Modified: 2008-03-16 14:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Radim Roska 2007-03-02 11:33:06 UTC
i guess that after deleting servlet file in project, its informations in web.xml
should be deleted too. While opposite way is working( when create servlet, its
definitions are written in web.xml)
Comment 1 Erno Mononen 2007-03-02 11:55:49 UTC
Yes, it should work the way you described. Currently it doesn't work since the 
j2ee/refactoring module is not re-enabled yet due to migration to the new java 
infrastructure.
Comment 2 Erno Mononen 2007-08-02 13:24:34 UTC
Should be fixed already.
Comment 3 Radim Roska 2007-08-07 13:36:48 UTC
It is really fixed for case when user delete servlet. In case user delete whole package(with servlet) web.xml is not
updated.
Comment 4 Erno Mononen 2007-08-08 15:22:11 UTC
The web refactoring plugin is not invoked in this case, the delete package action doesn't seem to be integrated with 
safe delete. Reassigning to refactoring for further evaluation.
Comment 5 Jan Becicka 2007-08-13 12:52:48 UTC
Package delete is not integrated with safe delete.
Comment 6 Jan Becicka 2007-10-22 14:21:36 UTC
*** Issue 119623 has been marked as a duplicate of this issue. ***
Comment 7 Jan Becicka 2007-10-22 15:36:07 UTC
*** Issue 119624 has been marked as a duplicate of this issue. ***
Comment 8 Jan Becicka 2008-02-27 10:59:07 UTC
Safe delete is now available for packages.
Comment 9 Radim Roska 2008-02-27 12:49:11 UTC
VERIFIED
Comment 10 _ bharathch 2008-02-27 13:28:08 UTC
Package delete in its current state does not meet the stated requirements completely. I have (locally) made additional
changes that fully address the requirement. I intend to commit them this weekend. Until then, the issue must remain open.
Comment 11 _ bharathch 2008-03-16 14:20:52 UTC
Fixed.

Files modified:
        refactoring.java/src/org/netbeans/modules/refactoring/java/plugins/JavaRefactoringsFactory.java
        refactoring.java/src/org/netbeans/modules/refactoring/java/plugins/SafeDeleteRefactoringPlugin.java
        refactoring.java/src/org/netbeans/modules/refactoring/java/ui/SafeDeleteUI.java
        refactoring.java/src/org/netbeans/modules/refactoring/java/ui/RefactoringActionsProvider.java
        refactoring.api/src/org/netbeans/modules/refactoring/plugins/FileDeletePlugin.java
        refactoring.api/src/org/netbeans/modules/refactoring/plugins/Bundle.properties
        refactoring.api/src/org/netbeans/modules/refactoring/plugins/PackageDeleteRefactoringPlugin.java
        refactoring.java/src/org/netbeans/modules/refactoring/java/ui/Bundle.properties
        refactoring.java/src/org/netbeans/modules/refactoring/java/ui/SafeDeletePanel.java

Files added:
        PackageDeleteRefactoringPlugin.java
Comment 12 _ bharathch 2008-03-16 14:22:01 UTC
*** Issue 124869 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo