Bug 96948 - Page is not reset to 1 on category/sorting change
Page is not reset to 1 on category/sorting change
Status: RESOLVED FIXED
Product: updatecenters
Classification: Unclassified
Component: Pluginportal
6.x
All Windows XP
: P1 (vote)
: TBD
Assigned To: David Botterill
issues@updatecenters
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-01 14:43 UTC by Jiri Kovalsky
Modified: 2009-10-03 12:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2007-03-01 14:43:17 UTC
Description:
============
Switching between categories by clicking tag clouds or changing sorting does not
reset page to 1 but leaves the last value. I consider this strange behavior.

Steps to reproduce:
===================
1. Click "Task List" tag cloud in the right pane.
2. Change "Page:" number to 2 and hit Enter.
3. Once the view is refreshed click "Tools" tag cloud.
4. Scroll down the page to find out that you see plugins from the 2nd page of
Tools category instead of the 1st page.
Comment 1 Todd Fast 2007-03-13 05:04:24 UTC
Raising priority to P1 because it is not apparent to the user when clicking
between categories that he is seeing a partial list. I made this mistake several
times myself until I revisited a category I'd been looking at before and noticed
there were fewer items. Having pagination be sticky when clicking between
different categories is completely unexpected; there is no precedent for it (in
fact, the precedent is exactly the opposite).
Comment 2 David Botterill 2007-03-19 06:20:52 UTC
This was a nasty side affect of using a dataprovider at the sessionbean level. 
I had to reset the tablerowgroup.page each time the category changes.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo