Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 9676 - ExecSupport "reconfigure" logic ignores ErrorManager
ExecSupport "reconfigure" logic ignores ErrorManager
Status: CLOSED DUPLICATE of bug 15487
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
PC Linux
: P3 (vote)
: 3.x
Assigned To: rmatous
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-18 22:31 UTC by Jesse Glick
Modified: 2008-12-22 17:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2001-02-18 22:31:33 UTC
ExecSupport, when showing an exception and prompting to
reconfigure, does not take into account ErrorManager localized
annotations. Ditto CloneableEditorSupport.notifyModified.

Affects anyone who throws ErrorManager-localized IOException from
Executor.execute(); nothing useful is shown in the dialog box. I think use of
ErrorManager annotations now supercedes the interim hack of checking whether the
localized message differs from the base message.

Ideally only getAnnotation would be needed in code like this, and NbErrorManager
would actually autocreate localized-message annotations from exceptions whose
localized message was in fact distinct.
Comment 1 Jan Chalupa 2001-03-12 12:07:50 UTC
Version: 'Dev' -> 3.2
Comment 2 Jan Chalupa 2001-05-06 08:12:30 UTC
Target milestone -> 3.3
Comment 3 rmatous 2001-11-21 15:58:33 UTC
I think this is duplicate of #15847. 

*** This issue has been marked as a duplicate of 15847 ***
Comment 4 rmatous 2001-11-22 09:11:36 UTC
Sorry, I did not want to mark it as duplicate #15847.
Comment 5 rmatous 2001-11-22 09:13:11 UTC
Marked as duplicate to #15487.

*** This issue has been marked as a duplicate of 15487 ***
Comment 6 Quality Engineering 2003-07-01 15:53:46 UTC
Resolved for 3.4.x or earlier, no new info since then -> verified
Comment 7 Quality Engineering 2003-07-01 16:13:59 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo