Bug 96700 - [RAILS] WEBrick does not start, rails project is not generated
[RAILS] WEBrick does not start, rails project is not generated
Status: VERIFIED DUPLICATE of bug 95128
Product: ruby
Classification: Unclassified
Component: Code
6.x
PC Linux
: P1 (vote)
: 6.x
Assigned To: Torbjorn Norbye
issues@ruby
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-27 15:15 UTC by Tomas Danek
Modified: 2007-07-03 14:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
webrick exc. (12.71 KB, text/plain)
2007-02-27 15:31 UTC, Tomas Danek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2007-02-27 15:15:03 UTC
NetBeans IDE Dev (Build 200702261900)
1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105
Linux version 2.6.17-10-generic running on i386
cs_CZ (nb); UTF-8
------------------------------------------------
- downloaded ruby umbrella module from UC, ide restarted 
- created rails application
- WEBrick Web server output tab contains:
 STARTING
Error opening script file: script/server (No such file or directory)
RUN COMPLETED

- generate rails project output is 
STARTING
/tmp/ud/jruby-0.9.2/bin/rails:17:Warning: require_gem is obsolete.  Use gem instead.
/tmp/ud/jruby-0.9.2/lib/ruby/site_ruby/1.8/rubygems.rb:301:in
`report_activate_error': Could not find RubyGem activesupport (= 1.3.1)
(Gem::LoadError)

        from /tmp/ud/jruby-0.9.2/lib/ruby/site_ruby/1.8/rubygems.rb:239:in
`activate'
        from /tmp/ud/jruby-0.9.2/lib/ruby/site_ruby/1.8/rubygems.rb:264:in
`activate'
        from /tmp/ud/jruby-0.9.2/lib/ruby/site_ruby/1.8/rubygems.rb:76:in `each'
        from /tmp/ud/jruby-0.9.2/lib/ruby/site_ruby/1.8/rubygems.rb:265:in
`activate'
        from /tmp/ud/jruby-0.9.2/lib/ruby/site_ruby/1.8/rubygems.rb:76:in
`active_gem_with_options'
        from /tmp/ud/jruby-0.9.2/lib/ruby/site_ruby/1.8/rubygems.rb:61:in
`require_gem'
        from /tmp/ud/jruby-0.9.2/bin/rails:17
RUN COMPLETED

- project has no subnodes, server does not start
Comment 1 Tomas Danek 2007-02-27 15:24:53 UTC
it seems like rails stuff on autoupdate is out of sync with hudson?!
i've removed userdir (i.e. ruby modules), downloaded  #256 from hudoson,
unpacked, and put extra cluster to netbeans and tried to create rails app:
- first i noticed that there is "Create rails app with custom sources" in new
project wizard - that was not there when i used ruby from UC
- now rails project seems to be generated ok, there is a bunch of subnodes under
project node
- WEBrick server output tab contains exception (attached), server does not start.
Comment 2 Tomas Danek 2007-02-27 15:31:23 UTC
Created attachment 38950 [details]
webrick exc.
Comment 3 Torbjorn Norbye 2007-02-27 16:29:36 UTC
The observation that this works with deadlock.netbeans.org bits and not with the
update center was very helpful.  I tracked it down and it turns out there was a
problem with the build scripts which assembles files for the nbm.

Basically, two .gemspec files ended up missing in the Ruby installation when
installed from the update center!

I've checked in a fix; when rails version 1601 hits the update center (or
Feature umbrella module version 0.23) it will hopefully work.
Comment 4 Tomas Danek 2007-03-01 13:26:04 UTC
yes, semi-working now, project generation works, but still there's en exception
from WEBrick..
Comment 5 Torbjorn Norbye 2007-03-13 23:21:51 UTC
The original issue is fixed. Is the new webrick exception you are seeing still there? (Since this bug was 
created, JRuby has changed quite a bit and I'm now bundling JRuby 0.9.8 which is supposed to work with 
Rails).
Comment 6 mcmics 2007-03-15 20:17:15 UTC
the stop button for webrick doesn't work. Webrick is running still on the port
Comment 7 Torbjorn Norbye 2007-03-15 21:34:19 UTC
Are you on Windows? I think this is fixed on Unix but maybe not on Windows. See this JRuby thread: 
http://www.nabble.com/Killing-jruby...-tf3367512.html
Comment 8 Torbjorn Norbye 2007-03-19 22:24:05 UTC
I think this is a duplicate of another issue - there are a couple of issues related to killing processes and 
JRuby.

I've just checked in a fix which I believe will address this - launching JRuby's VM directly rather than going 
through the .bat launcher file. However, it's untested code since I don't have Windows - please let me 
know whether this works (you need to have Ruby Feature 0.39 or later - e.g. build #513 or later from 
http://wiki.netbeans.org/wiki/view/RubyInstallation).
Comment 9 Torbjorn Norbye 2007-03-19 22:25:58 UTC
The other issue is #95128.

*** This issue has been marked as a duplicate of 95128 ***
Comment 10 Tomas Danek 2007-05-24 11:20:32 UTC
the original issue is fixed, and the second one is duplicate. verified.
Comment 11 Jiri Kovalsky 2007-07-03 14:08:05 UTC
Reassigning this issue to newly created 'ruby' component.
Comment 12 Jiri Kovalsky 2007-07-03 14:47:20 UTC
Changing target milestone of all resolved Ruby issues from TBD to 6.0 Beta 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo