Bug 96613 - Can't see the tables in my database
Can't see the tables in my database
Status: RESOLVED DUPLICATE of bug 84654
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Andrei Badea
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-26 19:05 UTC by twolf2919
Modified: 2007-02-27 09:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description twolf2919 2007-02-26 19:05:13 UTC
This used to work sometime before October last year.  Since I can't see any
tables at all, I'm filing this as a P1 now.

I go to Runtime->Databases->Drivers and add my odbc14.jar driver.  After that, I
establish a connection as I usually do:
               jdbc:oracle:thin:@neptune.netforensics.com:1521:nfdb
And NB seems content with everything:  I see a DB connection tree that expands
to have "Tables", "Views", and "Procedures".  If I expand "Views" or
"Procedures", I indeed see the views and stored procedures on my database
server.  But when I select "Tables", I get the error:
               Unable to read the database structure, connection error;
Unsupported feature

Colleagues using DBVisualizer with the same ojdbc14.jar have no problem
accessing the tables in the DB.

I'm running FC5.0 Linux with NB 6.0M7 (but it's been a problem since October
last year!) using JDK1.6.  Before filing this bug, I checked the 'net and found
a reference to the same problem in a Sun Bug DB and the evaluation of the bug
stated that it's a bug in dbExplorer - so I'm filing it here.  Here's the
reference to the Sun Bug entry:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6480113
Comment 1 Andrei Badea 2007-02-27 09:20:43 UTC
Please use a 10.x driver, see details in issue 84654.

*** This issue has been marked as a duplicate of 84654 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo