Bug 96516 - Validation of WSDL broken
Validation of WSDL broken
Status: VERIFIED WORKSFORME
Product: xml
Classification: Unclassified
Component: WSDL Model
5.x
All All
: P1 (vote)
: 5.x
Assigned To: Ritesh Adval
issues@xml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-25 09:52 UTC by johaneltes
Modified: 2007-03-08 16:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description johaneltes 2007-02-25 09:52:26 UTC
1. Create a wsdl.
2. Enter source view
3. Trigger Validate WSDl through context menue

Result:

java.lang.AbstractMethodError: 
org.netbeans.modules.xml.wsdl.validator.spi.ValidatorSchemaFactory.getSchemaSource()Ljavax/xml/
transform/Source;
	at org.netbeans.modules.xml.wsdl.validator.WSDLSchemaValidator.getSchema
(WSDLSchemaValidator.java:71)
	at org.netbeans.modules.xml.xam.spi.XsdBasedValidator.validate(XsdBasedValidator.java:90)
	at org.netbeans.modules.xml.xam.spi.Validation.validate(Validation.java:78)
	at org.netbeans.modules.xml.validation.ValidationOutputWindowController.validate
(ValidationOutputWindowController.java:64)
	at org.netbeans.modules.xml.validation.ValidateXMLCookieImpl.validateXML
(ValidateXMLCookieImpl.java:48)
	at org.netbeans.modules.xml.tools.actions.ValidateAction$RunAction.run(ValidateAction.java:95)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:499)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:932)
Comment 1 Alexei Mokeev 2007-02-26 15:33:07 UTC
Looks like a Beta stopper for me.
What build are you using ?
Comment 2 Alexei Mokeev 2007-02-26 16:37:58 UTC
Since it is MacOS specific it looks like Java 6 issue.
Is it reproducible with latest Java 5 ?

We have a lot of problems with current version of Java 6 for MacOS, since no
final version is released yet.

Marking as INCOMPLETE until submitter's feedback.
Comment 3 johaneltes 2007-02-26 17:56:58 UTC
java version "1.5.0_07"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-164)
Java HotSpot(TM) Client VM (build 1.5.0_07-87, mixed mode, sharing)
Comment 4 Alexei Mokeev 2007-02-26 23:53:19 UTC
OK, at least now we are sure that it is not a Java 6 issue.
Still need evaluation from development team.
Comment 5 Nam Nguyen 2007-02-27 00:14:12 UTC
Johaneltes:
Is this behaviour observed on a development build or official build?

Can QE make sure this is reproducible on a release551 build?
Comment 6 johaneltes 2007-02-27 09:02:28 UTC
This is observed on Windows version as well as Mac OS version. Bill of material: NetBeans IDE 5.5.1 (Build 
200702190600). Enterprise Pack:  QBuild milestone 6a - 02/09/2007.
Comment 7 Nam Nguyen 2007-02-27 15:25:23 UTC
This AbstractMethodError is due to downloaded build mismatched.  
This is not beta show stopper.  However the introduced incompatible API method
still needs to be corrected to be compatible.  

Ritesh, please make sure the introduced method getSchemaSource() has reasonable
default implementation.
Comment 8 Alexei Mokeev 2007-02-27 19:49:13 UTC
Waiver since it is not a Beta stopper per evaluation
Comment 9 Ritesh Adval 2007-02-27 21:47:58 UTC
We do not want add a default implementation of this api.
We know which modules were using the old api and made changes to make sure they
use the new api.

This breakage was one time due to mismatch in net beans base version and
enterprise pack.

This should be fixed if you are using the 551 beta official build or in
release551. Seems like there is a problem in the version you are using which
does not have the latest netbeans? 

Can you try with next build.

Comment 10 johaneltes 2007-02-27 22:36:02 UTC
Please provide either the process or the links, that would bring me the proper bill-of-material  and I'm 
more than happy to give it a try.  I'm not sure what you understand with "the next build". I need the 
documented process of obtaining the Netbeans 5.5.1 version as well as the Enterprise Pack version your 
after.
Comment 11 johaneltes 2007-02-27 23:30:23 UTC
With the following version of ID and EP, the problem is gone:
netbeans-5_5_1-daily-bin-200702230600-windows-ml_ja_zh_CN_pt_BR-23_Feb_2007_0600.exe
netbeans-ent_pack-5_5_1-daily-070225_2-windows.exe. Thanks to the patient and terrific team behind 
these products!
Comment 12 Ritesh Adval 2007-02-28 02:19:33 UTC
As johaneltes agreed that this was build mismatch between netbeans and entpack and 
fixed. I am closing this bug.
Comment 13 Alexei Mokeev 2007-03-06 11:50:07 UTC
Removed EP551_WAIVER_APPROVED
Comment 14 jlautz 2007-03-08 16:01:35 UTC
Accepting the reporter's comments as verification.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo