Bug 96331 - Need ability to mark/define a TopComponent as undockable
Need ability to mark/define a TopComponent as undockable
Status: RESOLVED DUPLICATE of bug 156693
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P1 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-22 16:20 UTC by _ wadechandler
Modified: 2009-05-11 14:07 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ wadechandler 2007-02-22 16:20:40 UTC
We need the ability to mark/define a TopComponent as undockable.  In different
cases or categories of applications such as something used in early childhood
development agencies or day cares where children are tested or analyzed it makes
sense not to allow users to move certain things around.  It is simply an issue
of poor computer skills and usability.  Sometimes it is important to not let the
user have more than a certain amount of flexibility.  One can always define a
TopComponent to always open up in the same place, however, this isn't good
sometimes because some users will accidentally drag a running instances
components around on the screen then call a tech support line because they have
no clue what just happened.  The system needs to support the developer not
allowing specific TopComponents to be undocked at all.

I set this up as a P1 as the release of the undocking features will be with
Netbeans 6.0.  We can better support the developer with simple abilities such as
this.
Comment 1 Antonin Nebuzelsky 2009-05-11 14:07:03 UTC
This one seems like a forgotten duplicate of issue 156693 fixed in 6.7M2.

*** This issue has been marked as a duplicate of 156693 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo